Subject: [Tools-discuss] Tiny URLs (was: 4646bis-00 review by John Cowan)

From: Frank Ellermann <[email-masked]>
Date: Wed, 13 Sep 2006 19:27:02 +0200

Addison Phillips wrote on tge LTRU list:
 
> I note that TinyURL has decided that tools.ietf.org is a
> "frequently spammed" site. I'm going to have to switch to
> del.icio.us or Y!Scuttle for my short URLs....

Sigh, forwarded to the "tools" list, could we get a default
url1= if only url2= is specifified ?  The algorithm would be:

1: strip and note any extension like ".txt" at the last dot
2: split version after last hyphen-minus like 03 for "...-03"
3: concatenate the rest plus version -1 (02) plus extension
   to get a default url1.

And maybe let &difftype=--hwdiff be the default, instead of
the side-by-side diff (?)

It's okay if the tinyurl folks are paranoid, they were or are
blacklisted by wikipedia after some abuse.  For redirectors
SURBL offers a way to fight abuse:
<http://www.surbl.org/redirect.html>

Frank

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/tools-discuss

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 13 Sep 2006 21:41:19 +0200

Hi Frank,

>> del.icio.us or Y!Scuttle for my short URLs....

Hmm - tried to use it just now for a tinyurl to a  tools.ietf.org URL,
and didn't see any problems...  Is it a matter both of target domain
and requesting domain?

> 3: concatenate the rest plus version -1 (02) plus extension

Done.  I've also added a symlink so instead of

  http://www1.tools.ietf.org/tools/rfcdiff/rfcdiff.pyht?url2=http://...

you can now also use the somewhat shorter

  http://www1.tools.ietf.org/tools/rfcdiff.pyht?url2=http://...

The changes are available on www1.tools.ietf.org now, should be on all
servers within an hour.

> the side-by-side diff (?)

This is less obvious to me... I personally always want the side-by-side
diff, but if most people want --hwdiff, we could change.  Either way,
I've considered adding links to other diff formats at the top of the
diff generated, but haven't gone there yet.

> <http://www.surbl.org/redirect.html>

Mmm.  Thanks.  I didn't know about this.

	Henrik

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 13 Sep 2006 22:25:34 +0200

Henrik Levkowetz wrote:

 [default url1= derived from url2=]
> Done.  I've also added a symlink
[...]
> http://www1.tools.ietf.org/tools/rfcdiff.pyht?url2=http://...

Great, thanks, test URL:

http://www1.tools.ietf.org/tools/rfcdiff.pyht?url2=http://www.inter-locale.com/ID/draft-ietf-ltru-4646bis-01.txt&difftype=--hwdiff

Frank

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 13 Sep 2006 22:43:40 +0200

Hi Frank,

> http://www1.tools.ietf.org/tools/rfcdiff.pyht?url2=http://www.inter-locale.com/ID/draft-ietf-ltru-4646bis-01.txt&difftype=--hwdiff

I actually shortened it a little bit further just after I sent off the previous :

  http://tools.ietf.org/rfcdiff?url2=http://www.inter-locale.com/ID/draft-ietf-ltru-4646bis-01.txt&difftype=--hwdiff

Regards,

	Henrik

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 13 Sep 2006 22:56:11 +0200

Henrik Levkowetz wrote:

  [minus LTRU for that part]
>> maybe let &difftype=--hwdiff be the default
> This is less obvious to me... I personally always want the
> side-by-side diff, but if most people want --hwdiff, we
> could change.

I can't tell what most want, but with narrow browser windows,
one open for the diff, another to compose a review based on
the diff, this didn't work too well for me.  Last year I used
xml2rfc unpaginated output for a plain text diff, and posted
that (USEFOR or LTRU).

This year I checked the source of your Web form, because the
URL diff (unlike the upload form) works, and a combination of
the second form with the &difftype=--hwdiff of the first form
is less trouble than xml2rfc-unpaginated diff.

Two authors (Ken in USEFOR and Addison in LTRU) loved it, they
said --hwdiff or similar is the format used by the Rfc-editor.
With my browser all difftypes excluding side-by-side are nice.  

> I've considered adding links to other diff formats at the top
> of the diff generated, but haven't gone there yet.

Yes, it's an idea.  Now after I know the keywords changing the
location directly is no issue: --abdiff / --chbars / --hwdiff,
or --html for side-by-side.

Frank

---

From: Tony Hansen <[email-masked]>
Date: Wed, 13 Sep 2006 17:18:37 -0400

I'd say to add other formats, but don't change the default.

	Tony Hansen
	[email-masked]