Subject: [Tools-discuss] IDST: cancelled messages

From: "Dan Wing" <[email-masked]>
Date: Fri, 21 Mar 2008 09:20:06 -0700

I am puzzled why cancelling an IDST post causes notification to be sent to all
of the document authors, rather than just the author that submitted (and
cancelled) the IDST post.  Could someone educate me on this?

-d

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 21 Mar 2008 17:47:29 +0100

Hi Dan,

> cancelled) the IDST post.  Could someone educate me on this?

I am equally puzzled.  The spec (RFC 4228) certainly does not specify this.

I think this 'just happened to be implemented that way' and once we have the
Django rewrite of the tool up and running, I'd like this to be changed.

	Henrik

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 26 Mar 2008 17:36:19 -0700

> -----Original Message-----
> From: Henrik Levkowetz [mailto:[email-masked]] 
> Sent: Friday, March 21, 2008 9:47 AM
> To: Dan Wing
> Cc: [email-masked]
> Subject: Re: [Tools-discuss] IDST: cancelled messages
> 
> Hi Dan,
> 

Today I found a reason it might be implemented this way.  If you
submit your draft and it gets stuck (due to unparsable meta-
data, for example), it sits in the staging area.  At this moment,
the following draft is stuck there:

http://www3.ietf.org/proceedings/staging/draft-kaplan-behave-twist-00.txt

While it is stuck there, anyone could click on the link and cancel
the post.  

I suppose the intent of the email to all of the authors is to make them
aware of this event.

I guess this makes sense.  

However, it is only necessary to inform all of the authors _after_
the "post now" button is pressed on the
https://datatracker.ietf.org/idst/validate.cgi?submission_id=NNNNN
page; currently, pressing Cancel on that page causes the email to
all of the authors to be sent.

-d

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 27 Mar 2008 10:12:14 +0100

Hi Dan,

> I guess this makes sense.  

Yes, but as you say below, only at that stage.

> all of the authors to be sent.

Which we agree is less than perfect :-)