Subject: [Tools-discuss] Stats of citations inside RFC series

From: Pekka Savola <[email-masked]>
Date: Wed, 12 Mar 2008 14:37:12 +0200 (EET)

Hi,

It just occurred to me that it might be interesting to see which of 
our RFCs are most cited within the RFC series (RFC2119 no doubt being 
the highest).  For more fine-grained stats, you could look how many of 
the citations are between documents from the same WG and the same area 
(cross-pollination aspects).  You could possibly see the stats on 
per-WG basis (e.g., on the tools.ietf.org/wg/foo page) or per 
author-basis (e.g., extension to Jari's authorstats tools)

While in many cases the primary consumers of RFCs are vendors, not 
other IETF WGs, this might shed some light on the latter.

Has anyone worked on something like this?

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: "Frank Ellermann" <[email-masked]>
Date: Thu, 13 Mar 2008 08:53:48 +0100

> Has anyone worked on something like this?

Dunno, but I'm aware of a list with RFCs using
MD5:  <http://www.garlic.com/~lynn/rfcmd5.htm>

A list of the "most popular" RFCs by normative
or just any reference in other RFCs could help
to identify RFCs ready for promotion. 

 Frank

---

From: "Bill Fenner" <[email-masked]>
Date: Fri, 14 Mar 2008 09:41:55 -0400

On 3/12/08, Pekka Savola <[email-masked]> wrote:
>  the highest).

The database behind http://www.fenron.com/~fenner/ietf/deps/ can do
some of this:

mysql> select dep,count(*) as refs from dep where doc like 'rfc%' and
dep like 'rfc%' group by dep order by refs desc limit 20;
+---------+------+
| dep     | refs |
+---------+------+
| rfc2119 | 1812 |
| rfc822  |  442 |
| rfc791  |  339 |
| rfc2434 |  326 |
| rfc1157 |  254 |
| rfc793  |  233 |
| rfc2578 |  229 |
| rfc2579 |  225 |
| rfc2026 |  223 |
| rfc1035 |  222 |
| rfc1034 |  221 |
| rfc2580 |  210 |
| rfc3261 |  203 |
| rfc1213 |  196 |
| rfc2401 |  194 |
| rfc2045 |  182 |
| rfc1155 |  182 |
| rfc2234 |  169 |
| rfc768  |  167 |
| rfc1700 |  166 |
+---------+------+

>  Has anyone worked on something like this?

The more fine-grained data would be pretty easily available to
correlate, I think.

  Bill