Subject: Re: [Tools-discuss] draft name changes

From: "Spencer Dawkins" <[email-masked]>
Date: Mon, 1 Sep 2008 07:24:45 -0500

>> IMO, the internet-drafts upload tool should be capturing this 
>> information.
>>
>
> Yes.
>
>> If you put in a name that ends in -00 and it's a draft-ietf name, it
>> should practically require the name of the I-D that is being replaced.
>> It's fairly probable that a WG document will have starte as a personal 
>> doc.
>>
>
> Right.

I'm bridling because of "practically require", and I'll grant that 
"practically require" could reasonably be:

   "Enter the name of the individual draft(s) being replaced:
      (or "none" if this working group draft has no predecessor drafts)"

But - individual draft NAMES -> working group draft NAMES is certainly most 
common practice, but please DON'T require a name of the I-D that's being 
replaced, because our WG BCPs do not require WG documents to start as a 
personal doc, and I have seen WG documents that sprang fully formed from 
thin air.

Another case where ALMOST everyone does something, but our WG BCPs don't 
require it - a lot of people are surprised that WGLC is not required by WG 
BCPs, either...

My views of how badly most of our process BCPs need to be updated is no 
secret, but evolving our processes via tool design is not the way we should 
be going.

Thanks,

Spencer 

_______________________________________________
Tools-discuss mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 01 Sep 2008 15:01:08 +0200

>       (or "none" if this working group draft has no predecessor drafts)"

...

> secret, but evolving our processes via tool design is not the way we should 

I agree.  If there are obvious ways for tools to make it easy to 'do the
right thing', that's fine, but they shouldn't pre-empt the decision process
and institute policy which hasn't been agreed and decided upon (by whichever
process we have).

	Henrik

---

From: Thomas Morin <[email-masked]>
Date: Mon, 01 Sep 2008 16:00:13 +0200

In the same line of thinking (making it easy to do the right thing
without enforcing any new processes), it seems to me that it would make
sense to allow a WG draft to have *more than one* precursor individual
drafts. 

Indeed, there are cases where a WG draft results from the "merger" of
individual drafts aiming at solving the same issue, or proposing very
similar solutions.  Forcing to state zero or one precursor would force
author to settle for zero (loss of information) or to arbitrarily choose
one of the precursors (the latter being possibly difficult if the merger
resulted from a non obvious consensus).

-Thomas

---

From: Thomas Morin <[email-masked]>
Date: Mon, 01 Sep 2008 16:11:34 +0200

Henrik Levkowetz :
> Hi Julian,
> 
> On 2008-08-31 22:02 Julian Reschke said the following:
> >
> > Would it be useful if the xml2rfc format captured that information somehow?

I would support this.

> Mmm.  I'm not sure.
> 
> The intention has been that when we have Bill's rewrite of the draft
> submission tool deployed, we should consider adding fields in the form
> to capture information like this.  
> 
> Capturing it in the xml2rfc format would mostly be appropriate if xml2rfc
> also had an option to render it in a standard way in the draft itself.
> For drafts which are submitted with an accompanying xml file it would be
> possible to pre-populate the replaced-by field in the submission meta-data
> verification page based on a replaced-by indication in the xml file, but
> it would never be a complete solution which could do away with the form
> field.  So once the metadata verification page of the submission tool has
> a field for 'replaced-by', having it also in the .xml file would make
> things a bit easier for xml2rfc users.  Before then I think it would not
> make a big difference, I think.

If, at some point, it makes it easier for xml2rfc users, then wouldn't
it be nice to work on a such new field today ?

Also, independently of the submission tool, adding this type of
precursor information to the XML2RFC format could be applicable to the
RFC editor, as a way to store the name of the draft before it became an
RFC, couldn't it ?

-Thomas

> 
> (Detour...:)
> 
> The question made me start to wonder how large a percentage of drafts are
> now being submitted with an accompanying .xml file, and a quick check gave
> a figure of about 28% for 2008 to date.  The distribution of .xml, .txt
> and .pdf drafts over the years were as follows a moment ago, according to
> the archive on one of the tools servers:
> 
> 
> 23:46 /www/tools.ietf.org/id
> henrik@merlot $ ls -l | grep draft-.*\.xml$ | field 6 | cut -c 1-4 | sort -n | uniq -c | bargraph
>      16 2006   1% 
>     445 2007  30% ***************************
>     979 2008  67% ************************************************************
> 
>    1440 Tota 
>   480.0 Aver  33% =============================
> 
> 23:47 /www/tools.ietf.org/id
> henrik@merlot $ ls -l | grep draft-.*\.txt$ | field 6 | cut -c 1-4 | sort -n | uniq -c | bargraph
>     140 1992   0% *
>       8 1993   0% 
>     203 1994   0% **
>     704 1995   1% ********
>    1401 1996   2% ****************
>    1688 1997   3% *******************
>    2891 1998   5% **********************************
>    2688 1999   5% *******************************
>    3402 2000   6% ****************************************
>    4527 2001   8% *****************************************************
>    4835 2002   9% *********************************************************
>    4861 2003   9% *********************************************************
>    4755 2004   9% ********************************************************
>    4932 2005   9% **********************************************************
>    5069 2006  10% ************************************************************
>    4953 2007   9% **********************************************************
>    3421 2008   6% ****************************************
> 
>   50478 Tota 
>  2969.3 Aver   5% ===================================
> 
> 23:48 /www/tools.ietf.org/id
> henrik@merlot $ ls -l | grep draft-.*\.pdf$ | field 6 | cut -c 1-4 | sort -n | uniq -c | bargraph
>      25 2002   8% **********************
>      48 2003  15% ******************************************
>      31 2004   9% ***************************
>      28 2005   9% *************************
>      67 2006  21% ************************************************************
>      67 2007  21% ************************************************************
>      45 2008  14% ****************************************
> 
>     311 Tota 
>    44.4 Aver  14% =======================================
> 
> 
> Regards,
> 
> 	Henrik

---

From: Thomas Morin <[email-masked]>
Date: Mon, 01 Sep 2008 16:18:18 +0200

Henrik Levkowetz :
> So once the metadata verification page of the submission tool has
> a field for 'replaced-by'.

By the way the submission tool field has to be named in terms of "draft
being replaced: " rather than "replaced by", or that will certainly
cause some confusion (usability nitpicking).

Cheers,

-Thomas

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 01 Sep 2008 16:56:37 +0200

> cause some confusion (usability nitpicking).

Quite so.

	Henrik

---

From: Jari Arkko <[email-masked]>
Date: Mon, 01 Sep 2008 18:07:18 +0300

I did not mean to imply that you have to give an individual draft name 
as the predecessor of the wg-00 draft. But I do want that question to be 
asked upon submission time.

Jari (who has sent in countless mails to the secretary to add a history 
link between drafts)

---

From: Tony Hansen <[email-masked]>
Date: Mon, 01 Sep 2008 13:40:31 -0400

>       (or "none" if this working group draft has no predecessor drafts)"

Spencer, this is exactly the sort of thing I was thinking of. It
requires you to think about the question and provide an answer one way
or another.

> personal doc, and I have seen WG documents that sprang fully formed from 

Exactly why it can't be "require". There's *always* an exception and
whatever we put in to place *must* allow for such exceptions.

	Tony Hansen
	[email-masked]

---

From: Tony Hansen <[email-masked]>
Date: Mon, 01 Sep 2008 13:47:34 -0400

> sense to allow a WG draft to have *more than one* precursor individual

+1

Note: it's not just WG drafts, but also individual drafts that can have
more than one precursor individual draft.

There's also the case of individual drafts starting as WG drafts and
turning individual when a WG decides (or is forced) to disband.

Another twist that could be captured is when a draft is split apart into
multiple drafts.

The taxonomy progresses in many ways.

	Tony Hansen
	[email-masked]

---

From: "Frank Ellermann" <[email-masked]>
Date: Wed, 3 Sep 2008 08:02:41 +0200

Henrik Levkowetz wrote:

> The question made me start to wonder how large a percentage
> of drafts are now being submitted with an accompanying .xml
> file, and a quick check gave a figure of about 28% for 2008
> to date.  The distribution of .xml, .txt and .pdf drafts
> over the years were as follows a moment ago, according to

[...]
[xml] 
>   480.0 Aver  33% =============================

[...]
[txt]
>  2969.3 Aver   5% ===================================

[...]
[pdf]
>    44.4 Aver  14% =======================================

Lies, damned lies, statistics.  I'm mystified, what does
this mean ?  95% of all users somehow managed to submit
Internet-Drafts without the required TXT (5%) versions ?
And for what purpose do they submit PDF (14%) versions ?

 Frank

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 03 Sep 2008 11:00:14 +0200

Hi Frank,

> Internet-Drafts without the required TXT (5%) versions ?

The utility I use to produce bargraphs gratuitously calculates
average figures, but you should ignore them if it's not obvious
what they mean.  They are always the average bar length calculated
over the slots corresponding to the bars above, and in this case
you can even calculate the percentages from the number of years
displayed: 3 years => the average submissions per year were 33%
of the total submissions -- impressive, no? ,,;-)

> And for what purpose do they submit PDF (14%) versions ?

Ignore the 14% -- it just means that there were 7 years in the
input.

	Henrik

---

From: "Frank Ellermann" <[email-masked]>
Date: Sun, 7 Sep 2008 04:04:31 +0200

Henrik Levkowetz wrote:

 [33- 5 - 14] 
> Ignore the 14% -- it just means that there were 
> 7 years in the input.

LOL, I completely missed the point, thanks for info.

 Frank