Subject: [Tools-discuss] IRTF site question: group ordering

From: Aaron Falk <[email-masked]>
Date: Mon, 08 Mar 2010 09:22:13 -0500

Hi Henrik-

In the attached file (found at http://www.irtf.org/groups) lists active
research groups.  Is it possible to control the order?  My preference
would be to have them alphabetical.

Thanks,

--aaron

---

From: Henrik Levkowetz <[email-masked]>
Date: Mon, 08 Mar 2010 16:52:11 +0100

Hi Aaron,

> would be to have them alphabetical.

I believe the following change to the inc/helpers.php file should make the
order alphabetical (by acronym):

henrik@shiraz $ diff -u inc/helpers.php,1 inc/helpers.php
--- inc/helpers.php,1	2007-01-09 03:09:29.000000000 +0100
+++ inc/helpers.php	2010-03-08 16:48:47.000000000 +0100
@@ -34,6 +34,7 @@
   }
   function showgroupnames($dirname) {
       $groups=listgroups($dirname);
+      natcasesort($groups);
       $names=getnames($dirname, $groups);
       echo "		<ul>\n";
       foreach ($groups as $group) {

Best,

	Henrik

---

From: Aaron Falk <[email-masked]>
Date: Mon, 08 Mar 2010 11:32:26 -0500

Excellent.  Thanks! 

--aaron