Subject: [Tools-discuss] I-D mail aliases

From: Brian E Carpenter <[email-masked]>
Date: Tue, 02 Nov 2010 10:19:05 +1300

Hi,

It seems that mail to [email-masked]
reaches two of the authors, but not [email-masked]

By the same token, I should get messages sent to
[email-masked], but that doesn't
seem to work either.

Is there a wider problem with data extraction here?

   Brian

-------- Original Message --------
Subject: Test for Ben
Date: Tue, 02 Nov 2010 08:42:30 +1300
From: Brian E Carpenter <[email-masked]>
Organization: University of Auckland
To: [email-masked]

Did this reach [email-masked]?

-- 
Regards
   Brian Carpenter

---

From: Tony Hansen <[email-masked]>
Date: Mon, 01 Nov 2010 22:10:44 -0400

Is there any way for someone to find out the addresses to which a 
message to [email-masked] alias will be sent?

Either a web form or a -request version of the email address in question 
would be viable mechanisms IMO. Do either of those exist?

If this doesn't exist, this could be a small project for Saturday's sprint?

     Tony

On 11/1/2010 5:19 PM, Brian E Carpenter wrote:
> From: Brian E Carpenter<[email-masked]>

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 02 Nov 2010 14:34:51 +0100

Hi Tony,

> would be viable mechanisms IMO. Do either of those exist?

The full alias list is available (but requires login).  There's a link
at http://tools.ietf.org/ , under 'Email aliases to draft authors and chairs'.

> If this doesn't exist, this could be a small project for Saturday's sprint?

A better project would be a cron-script to generate the equivalent alias lists
from the author information in the database, so that we could deploy these on
www.ietf.org instead of on tools.ietf.org.  Currently, the author information
on tools.ietf.org is better than the one on www.ietf.org, but that will change
(for new drafts) when the rewritten submission tool gets deployed, and will
change again to match that of tools.ietf.org when we do the database conversion.

Brian, I'll have a look at the specific aliases you mention and reply separately.

Best,

	Henrik

> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 2 Nov 2010 15:21:38 -0500

Related - see <http://trac.tools.ietf.org/tools/ietfdb/ticket/402>, which has been
on my personal wishlist for some time. Hopefully, I'll get to work on it at this sprint.

RjS

---

From: "Dan Wing" <[email-masked]>
Date: Tue, 2 Nov 2010 17:10:56 -0700

> at http://tools.ietf.org/ , under 'Email aliases to draft authors and

After challenging me for my IETF userid/password, my attempt to
access http://tools.ietf.org/draft/aliases fails with an authorization
error:

  "Access forbidden

   You don't have permission to access the requested object.  It is 
   either read-protected or not readable by the server."

-d

---

From: Tony Hansen <[email-masked]>
Date: Wed, 03 Nov 2010 00:09:05 -0400

ditto for me

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 03 Nov 2010 16:23:07 +0100

Hi Dan,

>    either read-protected or not readable by the server."

Right.  Bad permissions on one of the servers, possibly caused by me when
poking at this.  Sorry.  Fixed now.

	Henrik

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 04 Nov 2010 09:10:40 +1300

I had no trouble, but then I was using a superior protocol (IPv6)  :-)

Regards
   Brian Carpenter

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 3 Nov 2010 13:28:41 -0700

Ok, thanks.

-d

> -----Original Message-----
> From: Henrik Levkowetz [mailto:[email-masked]]
> Sent: Wednesday, November 03, 2010 8:23 AM
> To: Dan Wing
> Cc: 'Tony Hansen'; 'Tools Team Discussion'
> Subject: Re: [Tools-discuss] I-D mail aliases
> 
> Hi Dan,
> 
> >> at http://tools.ietf.org/ , under 'Email aliases to draft authors
> and
> >> chairs'.
> >