Subject: Re: [Tools-discuss] Audio from IETF-79?

From: Tony Hansen <[email-masked]>
Date: Wed, 24 Nov 2010 11:44:58 -0500

I'm thinking that after the time for a meeting is past, the speaker icon 
in the agenda could point to the archive location, possibly with a 
change to the icon to indicate that it's now pointing at the archive 
instead of the stream.

Henrik, thoughts?

     Tony Hansen
     [email-masked]

On 11/24/2010 7:21 AM, David Harrington wrote:
> Hi,
> The little speaker next to the agenda is the link to the live 
> streaming. You need the archive.
> From http://www.ietf.org/ select Audio Archives (under previous meeting)
> which leads to http://www.ietf.org/audio/ietf79/
> Then look for the entry with ch4 for wed am.
> Unfortunately, I don't see such a listing, which makes me think it 
> might not have been recorded.
> dbh
>
>     ------------------------------------------------------------------------
>     *From:* [email-masked]
>     [mailto:[email-masked]] *On Behalf Of *Benoit Claise
>     *Sent:* Wednesday, November 24, 2010 4:31 AM
>     *To:* Vijay K. Gurbani
>     *Cc:* [email-masked]
>     *Subject:* Re: Audio from IETF-79?
>
>     Hi,
>
>     Historically, finding the audio has always been a source of
>     frustration for me.
>     Once I found the web site (thanks Vijay), then what is the right
>     channel?
>     Simple example: I want to listen to IPFIX, which was on Wed
>     morning in Jade 1.
>     I guess that the right channel is the number 4 because I see 4 in
>     the URL next to Jade1 at
>     http://www.ietf.org/meeting/79/remote-participation.html
>
>
>           Audio Streaming
>
>     Room 	Audio
>     Emerald 	http://videolab.uoregon.edu/events/ietf/ietf791.m3u
>     Garden Ballroom 1
>     http://videolab.uoregon.edu/events/ietf/ietf792.m3u
>     Garden Ballroom 3
>     http://videolab.uoregon.edu/events/ietf/ietf793.m3u
>     Jade 1 	http://videolab.uoregon.edu/events/ietf/ietf794.m3u
>     Pearl 	http://videolab.uoregon.edu/events/ietf/ietf795.m3u
>     Valley Ballroom A
>     http://videolab.uoregon.edu/events/ietf/ietf796.m3u
>     Valley Ballroom B
>     http://videolab.uoregon.edu/events/ietf/ietf797.m3u
>     Valley Ballroom C
>     http://videolab.uoregon.edu/events/ietf/ietf798.m3u
>
>
>     So looking for channel 4 wed morning at
>     http://videolab.uoregon.edu/events/ietf doesn't return anything...
>     Note: on http://tools.ietf.org/agenda/79/, the little speaker next
>     to the WG doesn't produced anything for me.
>
>     I should be missing something obvious, but I would not like to die
>     stupid ;-)
>
>     Regards, Benoit.
>
>>     On 11/16/2010 12:24 PM, David A. Bryan wrote:
>>>     Thanks!
>>>
>>>     At risk of really looking stupid (but I'll risk it since there
>>>     are so
>>>     many other reasons I look stupid all the time ;) )...how did you
>>>     know
>>>     this/find it on the IETF page?
>>
>>     Navigate to the main IETF 79 page
>>        (http://www.ietf.org/meeting/79/index.html).
>>
>>     From there, click on "Remote Participation (Audio, Jabber, WebEx)
>>     link.
>>
>>     From there, cut any of the streaming audio links ---
>>     http://videolab.uoregon.edu/events/ietf/ietf791.m3u will do. 
>>     Strip the
>>     tail end of the resource to get to
>>     http://videolab.uoregon.edu/events/ietf and from there you have
>>     a link to the raw archives (all the way at the bottom.)
>>
>>     I agree ... not intuitive.
>>
>>     Ciao,
>>
>>     - vijay
>

---

From: Joel Jaeggli <[email-masked]>
Date: Sat, 27 Nov 2010 23:21:08 -0800

> change to the icon to indicate that it's now pointing at the archive

the general thought was the existing name scheme is not sufficiently
normalized to support that, it could potentially be however up to a
point. the recorders postpend .# in ordering to keep from overwriting
prexisting recordings, which happens if the recording is start and
stopped, the recorder crashes or environmental hazards (like someone
unplugging it occur).

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 30 Nov 2010 15:15:08 +0100

> stopped, the recorder crashes or environmental hazards (like someone

It is as Joel says.  The naming scheme for the recordings is insufficiently
consistent over time and insufficiently well mapped to the meeting slots
to easily (automatically) point to the right recording.  I've tried to scratch
this itch several times, but every time I've balked at the amount of manual
work needed to normalize the naming scheme to something useful.

Best,

	Henrik

---

From: Tony Hansen <[email-masked]>
Date: Tue, 30 Nov 2010 11:39:14 -0500

Seems like an interstitial page or popup would be useful then. We know 
the channel, and we know the time of the WG meeting -- what we don't 
know is what files this maps into. For example, the meetings on 
Wednesday morning in the Garden Ballroom 1 map in to this set of files:

http://www.ietf.org/audio/ietf79/
     ietf79-ch2-wed-am.mp3
     ietf79-ch2-wed-am.mp3.1
     ietf79-ch2-wed-am.mp3.2

Being able to click on an icon in the agenda that somehow displayed 
those three links would be useful.

Whether this is shown on a separate page, or done via a popup box from 
the agenda page, is a matter of taste.

     Tony Hansen

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 30 Nov 2010 17:51:35 +0100

Hi Marshall,

On 2010-11-30 15:35 Marshall Eubanks said:
> 
> On Nov 30, 2010, at 9:15 AM, Henrik Levkowetz wrote:
> 
>>
> Would it be a reasonable amount of work to set something up something like this going forward (i.e., only
> for future meetings, and not worrying about ease of use of the past) ? 
> 
> The need for audio recordings peaks about 1 month after the meeting, so starting in Prague  
> would capture most of the need for the future. 

Looking at it from the viewpoint of connecting up a recording with a WG
name, but keeping in mind that the audio people wouldn't want to keep
track of the actual WG names, I'd propose a naming following the agenda's
timeslot names.  These are 'Morning Session I', 'Morning Session II',
'Afternoon Session I', 'Afternoon Session II' and 'Afternoon Session III'.

Abbreviating this and merging with the current naming for meeting number
and day, we would have for instance:

  ietf80-ch1-mon-morning-i.mp3
  ietf80-ch1-mon-afternoon-i.mp3
  ietf80-ch1-mon-afternoon-ii.mp3
  ietf80-ch1-mon-afternoon-iii.mp3
  ietf80-ch1-tue-morning-i.mp3
  
or alternatively, shorter:

  ietf80-ch1-mon-am-i.mp3
  ietf80-ch1-mon-pm-i.mp3
  ietf80-ch1-mon-pm-ii.mp3
  ietf80-ch1-mon-pm-iii.mp3
  ietf80-ch1-tue-am-i.mp3

etc.

The automatic appending of sequence numbers for re-started recordings
should work as it is with the schemes above.

The naming schema above seems to be close to what's currently in use,
but I'm not sure the current schema is quite as regular as the proposed.
Also, in the current schema I always get a bit confused by seeing 'noon',
which I guess is an abbreviation for afternoon, but it makes me think
of something related to 12 o'clock -- maybe the extra Thursday lectures...

However, it is still the people who manage the audio recordings who will
have to split and name the recordings to match the above; and they should
have the last word on whether this is feasible and makes sense.

Best,

	Henrik

---

From: Tony Hansen <[email-masked]>
Date: Tue, 30 Nov 2010 12:30:35 -0500

On 11/30/2010 11:51 AM, Henrik Levkowetz wrote:
> ... or alternatively, shorter:
>
>    ietf80-ch1-mon-am-i.mp3
>    ietf80-ch1-mon-pm-i.mp3
>    ietf80-ch1-mon-pm-ii.mp3

The current names also use afnoon, plenary, plenary-iab-technical, 
noon2, noon3 and a plethora of other variations that seemed to be at the 
whim of the person in the audio lab.

Regularizing the name scheme would be useful.

     Tony Hansen

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 30 Nov 2010 21:29:35 +0100

Hi Marshall,

...
> I would propose a add on - 
> 
> a - for the first segment of the session 
> b - for the second, etc.
> 
> So, it might be
> 
>  ietf80-ch1-mon-morning-i-a.mp3
>  ietf80-ch1-mon-morning-i-b.mp3
>  ietf80-ch1-mon-morning-i-c.mp3
>  ietf80-ch1-mon-afternoon-i-a.mp3

Or -1 -2 -3, or whatever.  I wouldn't mind, but also wouldn't require it
if it means that some script will have to be rewritten, with the outcome
that we won't get the essential changes in place for Prague...

Best,

	Henrik

> That way, if the audio has a break or restart, it doesn't also break the naming convention. 
> 
> Regards
> Marshall
> 
>

---

From: Joel Jaeggli <[email-masked]>
Date: Tue, 30 Nov 2010 14:35:22 -0800

So long as it's feasible whomever does it Prague will attempt to hew to a selected convention.

From my vantage point it would be cool if it resulted in a days worth of sessions be in same temporal and alphabetical sort order. 

Note that one general issues is that. Sessions that are stacked on top of each other like in the afternoon tend to run together.  The alternative is rigidly enforcing the breaks in the recording.

Joel's widget number 2

---

From: Joel Jaeggli <[email-masked]>
Date: Tue, 30 Nov 2010 14:45:52 -0800

Joel's widget number 2

On Nov 30, 2010, at 9:30, Tony Hansen <[email-masked]> wrote:

> The current names also use afnoon, plenary, plenary-iab-technical, noon2, noon3 and a plethora of other variations that seemed to be at the whim of the person in the audio lab.

That would mostly be me, and yes, I'm assuredly mad.

---

From: Tony Hansen <[email-masked]>
Date: Tue, 30 Nov 2010 19:28:27 -0500

> That would mostly be me, and yes, I'm assuredly mad.
But still loved and appreciated by all!

     Tony Hansen