Subject: [Tools-discuss] Two issues on [email-masked] aliases

From: Thomas Morin <[email-masked]>
Date: Wed, 01 Dec 2010 11:54:10 +0100

Hi,

Here is a mailer-daemon I had when writing to 
[email-masked].

There are two issues appearing :

1) this mail was re-sent by the tools server re-using my address as 
sender, and among the receivers are some colleagues from my company; but 
the mail server of my company seems to reject mail coming into it with a 
sender address of somebody inside the company ; this seems like an issue 
that mailing list engine resolve properly (possibly thanks to the 
"Sender" SMTP header?) -- could such a fix, or another relevant one, be 
applied to draft aliases ?

2) the email address for one of the authors is the old address that was 
present in a early version of the dratf ([email-masked] ); the new 
address for this co-author ([email-masked]) is not used by the 
tools.ietf.org engine even though it's been present in the recent 
version of the draft (since March 2007)  ; is this a known issue ? a 
design limitation ?

Thanks,

-Thomas

-------- Message original --------
Sujet: 	Mail delivery failed: returning message to sender
Date : 	Wed, 01 Dec 2010 02:43:20 -0800
De : 	Mail Delivery System <[email-masked]>
Pour : 	[email-masked]

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

   [email-masked]
     (generated from [email-masked])
     SMTP error from remote mail server after MAIL FROM:<[email-masked]>  SIZE=3943:
     host relais-ias89.francetelecom.com [193.251.215.89]:
     554 5.7.1<[email-masked]>: Sender address rejected:
     domain use is reserved
   [email-masked]
     (generated from [email-masked])
     SMTP error from remote mail server after MAIL FROM:<[email-masked]>  SIZE=3943:
     host relais-ias89.francetelecom.com [193.251.215.89]:
     554 5.7.1<[email-masked]>: Sender address rejected:
     domain use is reserved
   [email-masked]
     (generated from [email-masked])
     SMTP error from remote mail server after MAIL FROM:<[email-masked]>  SIZE=3943:
     host relais-ias89.francetelecom.com [193.251.215.89]:
     554 5.7.1<[email-masked]>: Sender address rejected:
     domain use is reserved
   [email-masked]
     (generated from [email-masked])
     SMTP error from remote mail server after RCPT
TO:<[email-masked]>:
     host cluster7.us.messagelabs.com [216.82.253.179]:
     550 Invalid recipient<[email-masked]>  (#5.1.1)

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 09 Dec 2010 15:16:44 +0100

Hi Thomas,

> applied to draft aliases ?

I don't know what the right thing to do here is.  If somebody can describe
the proper solution to this, I'll implement it.

> version of the draft (since March 2007)  ; is this a known issue ? a 

This was a bug, and it was resolved shortly after you sent the message.

Sorry for the delay in responding.

Regards,

	Henrik

> _______________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss