Subject: [Tools-discuss] N00b question - getting list of documents an AD is responsible for.

From: Warren Kumari <[email-masked]>
Date: Fri, 7 Sep 2018 11:21:51 -0400

Hi there,

I'm trying to get the list of documents that I'm responsible for.

https://datatracker.ietf.org/doc/ad/warren.kumari/ contains this, but I'd
like to be able to parse it with tools (to add stuff to my calendar, keep
state, etc).

I've spent some time poking around with https://datatracker.ietf.org/api/,
(the above page seems to be generated by
ietfdb/trunk/ietf/doc/views_search.py : docs_for_ad) but seem to be missing
something fundamental; I'd like it in JSON / XML / something.

The closest I've been able to accomplish is:
curl 'https://datatracker.ietf.org/api/v1/person/email/[email-masked]/'
then
curl 'https://datatracker.ietf.org/api/v1/doc/document/?limit=0&ad=111656'

but this feels very clumsy / unfriendly to the database.

Is there something cleaner? Like (not working):
https://datatracker.ietf.org/doc/ad/warren.kumari/?format=json

W

--
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 7 Sep 2018 15:35:35 +0000

Everything in the database is a level of indirection, except in DB-world they call it normalization :)

Are you bothered that you have to do two GET’s, or that you’re still not getting what you want.

---

From: Robert Sparks <[email-masked]>
Date: Fri, 7 Sep 2018 10:42:56 -0500

Hi Warren -

> I'm trying to get the list of documents that I'm responsible for.
I suspect you're only wanting the ones that are still in flight? Or are 
you wanting things that have been RFCed already too?
>
> https://datatracker.ietf.org/doc/ad/warren.kumari/ 
> <https://datatracker.ietf..org/doc/ad/warren.kumari/> contains this, 
> but I'd like to be able to parse it with tools (to add stuff to my 
> calendar, keep state, etc).
>
> I've spent some time poking around with 
> https://datatracker.ietf.org/api/, (the above page seems to be 
> generated by ietfdb/trunk/ietf/doc/views_search.py : docs_for_ad) but 
> seem to be missing something fundamental; I'd like it in JSON / XML / 
> something.
>
Have you tried 
https://datatracker.ietf.org/api/v1/doc/document/?limit=0&ad=111656&format=json 
?

> https://datatracker.ietf.org/doc/ad/warren.kumari/?format=json
So the link I sent above is essentially that (and the cost to the 
database is roughly the same).

Let me know what you're really hoping to do, and I'll try to help you 
get closer to it.
>
> W
>
>
> --
> I don't think the execution is relevant when it was obviously a bad 
> idea in the first place.
> regret at having chosen those particular rabid weasels and that pair 
> of pants.
>    ---maf
>
>
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
>
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Warren Kumari <[email-masked]>
Date: Fri, 7 Sep 2018 11:44:24 -0400

> Are you bothered that you have to do two GET’s, or that you’re still not

It's not so much bothered as feeling like I might be missing something.

"regular" interface:
time curl 'https://datatracker.ietf.org/doc/ad/warren.kumari'
real 0m2.835s

API:
time curl '
https://datatracker.ietf.org/api/v1/doc/document/?limit=0&ad=111656'
real 0m12.323s

For the Agenda I can append 'agenda.json' to '
https://datatracker.ietf.org/iesg/agenda/' and get a JSON version, wasn't
sure if there was something similar for the /doc/ad/ view.
I'm fine to continue doing
https://datatracker.ietf.org/api/v1/doc/document/?limit=0&ad=111656 -- I
really don't care about the speed (I'll run it once or twice a day), I just
didn't want to be doing something stupid if there is a more elegant way....

W

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 7 Sep 2018 15:51:41 +0000

*   It's not so much bothered as feeling like I might be missing something.

I don’t understand.  Missing a more efficient way to do it?  I wonder if the webpage does the filtering at the query (SQL WHERE) and the fetch does post-query filtering?

  *   curl 'https://datatracker.ietf.org/api/v1/doc/document/?limit=0&ad=111656<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_api_v1_doc_document_-3Flimit-3D0-26ad-3D111656&d=DwMFaQ&c=96ZbZZcaMF4w0F4jpN6LZg&r=4LM0GbR0h9Fvx86FtsKI-w&m=Ua0GgcE0sOg0bjJ99ZGRcuqKEVOGCTeSy_67uwxYKg4&s=mCbAMFmatsR2KUv_Uql5yOm53T-QtN6DilKZu8CO9nk&e=>'

You can append “&format=json” BTW

---

From: Warren Kumari <[email-masked]>
Date: Fri, 7 Sep 2018 12:02:04 -0400

On Fri, Sep 7, 2018 at 11:43 AM Robert Sparks <[email-masked]> wrote:

> <https://datatracker.ietf..org/doc/ad/warren.kumari/> contains this, but
> I'd like to be able to parse it with tools (to add stuff to my calendar,
> keep state, etc).
>
> So the link I sent above is essentially that (and the cost to the database
> is roughly the same).
>
>
Ok, cool.

> Let me know what you're really hoping to do, and I'll try to help you get
> closer to it.
>
>
>
It looks like what I'm doing / the link you provided above is the "right"
way to do it - mainly I was wanting to be sure I wasn't being anti-social
to the database, or just doing something silly.

I'm trying to collect metrics and stats about how I'm doing (useful to
justify my time to management people, and also just for my own knowledge),
make a much simpler dashboard so I can have a widget to remind me what to
do next, etc.

W

> W
>
>
> --
> I don't think the execution is relevant when it was obviously a bad idea
> in the first place.
> Tools-discuss mailing [email-masked]://www.ietf.org/mailman/listinfo/tools-discuss
>
> Please report tools.ietf.org bugs athttp://tools.ietf.org/tools/issues