Subject: [Tools-discuss] A "fetch" API for things off datatracker?

From: "Salz, Rich" <[email-masked]>
Date: Thu, 6 Sep 2018 17:25:26 +0000

I looked through the summary at https://tools.ietf.org and skimmed some of the archives and couldn’t find anything.

I assume that most of the pages on datatracker are templates, populated at fetch time from a database.  Is there an API to fetch those data items?  I am working on some scripts (https://github.com/richsalz/ietf-gh-scripts) that could really benefit from such a thing.  I am willing to spend time, now and at the IETF hackathon, to help develop this.

Thanks for any input.

                /r$

---

From: Henrik Levkowetz <[email-masked]>
Date: Thu, 6 Sep 2018 19:36:36 +0200

Hi Rich,

There exists one generic API through which all table data can be fetched,
and some additional special-purpose API endpoints.  There are notes on
the API here:

  https://datatracker.ietf.org/api/

Best regards,

	Henrik

On 2018-09-06 19:25, Salz, Rich wrote:
> I looked through the summary at https://tools.ietf.org and skimmed
> some of the archives and couldn’t find anything.
>
> I assume that most of the pages on datatracker are templates,
> populated at fetch time from a database.  Is there an API to fetch
> those data items?  I am working on some scripts
> (https://github.com/richsalz/ietf-gh-scripts) that could really
> benefit from such a thing.  I am willing to spend time, now and at
> the IETF hackathon, to help develop this.
>
> Thanks for any input.
>
> /r$

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 6 Sep 2018 13:44:32 -0400

I use this API for the IETFers iPhone/iPad app. Everything I needed is available. I found that I needed to make too many requests to rebuild the links between objects which was slow and asked Henrik/Robert for a meeting API that collected the info I needed for quicker access. They were very helpful and fulfilled this request. So now I use a combination of the tastypie API and a custom one for meeting info. I can provide assistance with the API if you get stuck.

Thanks,
Tom

> On Sep 6, 2018, at 1:36 PM, Henrik Levkowetz <[email-masked]> wrote:
> 
> Hi Rich,
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]