Subject: Re: [Tools-discuss] Strange IDnits behavior (or is it something else?)

From: Lars Eggert <[email-masked]>
Date: Tue, 22 Sep 2020 11:04:21 +0300

Hi,
On 2020-7-30, at 6:37, Carsten Bormann <[email-masked]> wrote:
> On 2020-07-30, at 04:44, Spencer Dawkins at IETF <[email-masked]> wrote:
>> In IDnits, I'm getting
>> 
>>  -- The document date (January 2021) is 170 days in the future.  Is this
>>     intentional?
>> 
>> and that seems to be the Expiration date in the draft (so, I'm confused).
> 
> Yes, I am seeing this behavior for my v3 drafts.

same here.

>> I'm also getting
>> 
>>  -- Unexpected draft version: The latest known version of
>>     draft-irtf-panrg-questions is -04, but you're referring to -05.
>> 
>> but the datatracker DOES have https://tools.ietf.org/id/draft-irtf-panrg-questions-05.txt

Same here.

And when running it locally, it fails to download most of the status files it needs, which causes other errors.

> It seems the idnits downloading and caching approach is somewhat brittle…
> Idnits is an amazing script held together by spit and scotch tape.
> I think it is waiting for a full rewrite…
> Until then, it will stay a little quirky.

Given how central idnits is to the review process, I'm not sure living with the quirks is the right approach here.

Lars

---

From: Julian Reschke <[email-masked]>
Date: Tue, 22 Sep 2020 10:29:24 +0200

Am 30.07.2020 um 04:44 schrieb Spencer Dawkins at IETF:
> I'm working on a draft and getting some weird behavior when running
> IDnits and trying to submit the draft.
>
> In IDnits, I'm getting
>

...maybe caused by xml2rfc v3's change in date format in the boilerplate?

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 22 Sep 2020 10:47:10 +0200

Most likely; it seems to think the expiry date is the document date. 

Sent from mobile, sorry for terse

> On 22. Sep 2020, at 10:29, Julian Reschke <[email-masked]> wrote:
> 
> ___________________________________________________________
> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

---

From: Lars Eggert <[email-masked]>
Date: Tue, 22 Sep 2020 13:32:54 +0300

> ...maybe caused by xml2rfc v3's change in date format in the boilerplate?

Yep. I have a fix in https://github.com/larseggert/idnits/pull/1/files, but since I have no idea what the sources for the actual repo are, I don't know what to do with that patch...

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 22 Sep 2020 17:45:09 +0200

Hi Lars,

> Yep. I have a fix in https://github.com/larseggert/idnits/pull/1/files, but since I have no idea what the sources for the actual repo are, I don't know what to do with that patch...

The old idnits doesn't have a repository.  I'll grab your patch from the
link.

Best regards,

	Henrik

---

From: Lars Eggert <[email-masked]>
Date: Tue, 22 Sep 2020 19:01:14 +0300

> The old idnits doesn't have a repository.  I'll grab your patch from the

ACK.

(Is there a new idnits?!)

Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 22 Sep 2020 23:26:36 +0200

> (Is there a new idnits?!)

Being worked at; complete rewrite.  Not ready for primetime; will be within
months.

	Henrik

---

From: Lars Eggert <[email-masked]>
Date: Wed, 30 Sep 2020 10:33:15 +0300

Hi,

> Being worked at; complete rewrite.  Not ready for primetime; will be within

is this development happening in the open, e.g., is there a GitHub repo?

The current idnits is basically broken (mostly because the state files seem to have gone AWOL), and I'd be happy to try a development version of whatever is next rather than live with the current defunct one.

Thanks,
Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 30 Sep 2020 15:15:57 +0200

Hi Lars,

> is this development happening in the open, e.g., is there a GitHub repo?

There's a repo, but it's currently private.  Will be open when the code
settles.

> The current idnits is basically broken (mostly because the state
> files seem to have gone AWOL), and I'd be happy to try a development
> version of whatever is next rather than live with the current defunct
> one.

Glad to have you test the new version when I get to that point.

The bad state file is a bug and will need to be fixed, irrespective of
testing of the new version.  I'm looking into that right now (looks to
be a matter of missing UTF-8 support in a processing script).

	Henrik

---

From: Henrik Levkowetz <[email-masked]>
Date: Wed, 30 Sep 2020 20:41:08 +0200

Hi Lars,

> be a matter of missing UTF-8 support in a processing script).

The state files should be OK now.

	Henrik