Subject: [Tools-discuss] Update to DMARC issue tracker workflow?

From: Tim Wicinski <[email-masked]>
Date: Fri, 8 Jan 2021 14:21:47 -0500

Hi

We're looking to change the ticket workflow for the dmarc project in
tracker.

Based on the documentation at
https://trac.edgewall.org/wiki/TracWorkflow#AdditionalTicketWorkflows
we believe
this requires an update to the trac.ini file associated with the dmarc
project.

Based on our reading of the documentation, can we change the
[ticket-workflow] section of the trac.ini file, with the current contents
of that section removed and replaced with the contents of the
opensource-workflow.ini template included with the source tree and found
online here -
https://trac.edgewall.org/browser/branches/1.4-stable/contrib/workflow/opensource-workflow.ini

thanks
tim

---

From: Glen <[email-masked]>
Date: Fri, 8 Jan 2021 12:14:41 -0800

On 1/8/2021 11:21, Tim Wicinski wrote:
> [ticket-workflow] section of the trac.ini file, with the current 
> contents of that section removed and replaced with the contents of the 
> <https://trac.edgewall.org/browser/branches/1.4-stable/contrib/workflow/opensource-workflow.ini>

Hi Tim -

This is done.  As a point of order, the Trac setup on the IETF is highly 
customized, and strongly linked to the Datatracker.  As a result, I 
cannot guarantee that these changes will work properly (or at all), nor 
that they will "stick" (and not at some point be overwritten by an 
automated custom process I don't know about.)  But I've updated the 
file, so give it a shot and let me know (at [email-masked] please) 
if there are any problems.

All -

Just a reminder that operational change requests should be directed to 
[email-masked] .  I sometimes see messages on this list, but not 
always.  To reach the IT team and get things done, ietf-action is the 
address to contact.

Thanks!
Glen
--
Glen Barney
IT Director
AMS (IETF Secretariat)

---

From: tjw ietf <[email-masked]>
Date: Fri, 8 Jan 2021 15:18:27 -0500

Thanks Glen we’ll try them out 

Should we change the footer for the tools-discuss list?

Tim

Sent from my iPhone

> On Jan 8, 2021, at 15:14, Glen <[email-masked]> wrote:
> 
>> Based on our reading of the documentation, can we change the [ticket-workflow] section of the trac.ini file, with the current contents of that section removed and replaced with the contents of the opensource-workflow.ini template included with the source tree and found online here - https://trac.edgewall.org/browser/branches/1.4-stable/contrib/workflow/opensource-workflow.ini <https://trac.edgewall.org/browser/branches/1.4-stable/contrib/workflow/opensource-workflow.ini>
> 
> Hi Tim -
> 
> This is done.  As a point of order, the Trac setup on the IETF is highly customized, and strongly linked to the Datatracker.  As a result, I cannot guarantee that these changes will work properly (or at all), nor that they will "stick" (and not at some point be overwritten by an automated custom process I don't know about.)  But I've updated the file, so give it a shot and let me know (at [email-masked] please) if there are any problems.
> 
> All -
> 
> Just a reminder that operational change requests should be directed to [email-masked] .  I sometimes see messages on this list, but not always.  To reach the IT team and get things done, ietf-action is the address to contact.
> 
> Thanks!
> Glen
> --
> Glen Barney
> IT Director
> AMS (IETF Secretariat)
>

---

From: Glen <[email-masked]>
Date: Fri, 8 Jan 2021 12:45:16 -0800

> Should we change the footer for the tools-discuss list?

Well, I'm not sure what you mean, and it's not my list, but my personal 
opinion is that it probably does need some updating.  Right now it says:

> Tools-discuss mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> Please report datatracker.ietf.org and mailarchive.ietf.org
> bugs at http://tools.ietf.org/tools/ietfdb
> or send email to [email-masked]
> 
> Please report tools.ietf.org bugs at
> http://tools.ietf.org/tools/issues
> or send email to [email-masked]

which is long even by my own very-long-winded-email standards.  :-)

I could see tightening it up a little, perhaps to something like:

--snip--

Tools-discuss mailing list - [email-masked]
This list is for discussion, not for action requests or bug reports.
* Report Datatracker bugs to: [email-masked]
* Report tools.ietf.org bugs to: [email-masked]
* Report all other bugs or issues to: [email-masked]
Unsubscribe at: https://www.ietf.org/mailman/listinfo/tools-discuss

--snip--

but that is up to Russ and Robert, the list owners, so they should weigh 
in on your question.

Glen

---

From: Bob Hinden <[email-masked]>
Date: Fri, 8 Jan 2021 17:20:53 -0800

Glen,

> On Jan 8, 2021, at 12:45 PM, Glen <[email-masked]> wrote:
> 
> Well, I'm not sure what you mean, and it's not my list, but my personal opinion is that it probably does need some updating.  Right now it says:
> 

I like that!

Bob

---

From: Tim Wicinski <[email-masked]>
Date: Fri, 8 Jan 2021 23:43:19 -0500

I agree with Bob, especially since I search my mail to 'tools' and start
from there.

tim

---

From: Robert Sparks <[email-masked]>
Date: Sun, 10 Jan 2021 11:54:48 -0600

I've made a change similar to what's suggested. We can incrementally 
improve it as we move forward.

RjS

On 1/8/21 7:20 PM, Bob Hinden wrote:
> ___________________________________________________________

---

From: Robert Sparks <[email-masked]>
Date: Sun, 10 Jan 2021 11:56:17 -0600

Sigh - no, I didn't make the change _stick_ yet. Mailman is such a 
wonderful thing. I lost a race on form lifetime expiration. Will reapply.

RjS

On 1/10/21 11:54 AM, Robert Sparks wrote:
>>> On Jan 8, 2021, at 12:45 PM, Glen<[email-masked]>  wrote:
>>>
>>>> bugs athttp://tools.ietf.org/tools/ietfdb
>>>> or send email [email-masked]
>>>> or send email [email-masked]
>>> Tools-discuss mailing list [email-masked]
>>> * Report Datatracker bugs to:[email-masked]
>>> * Report tools.ietf.org bugs to:[email-masked]
>>> * Report all other bugs or issues to:[email-masked]
>>> Unsubscribe at:https://www.ietf.org/mailman/listinfo/tools-discuss
>> I like that!
>>
>> Bob
>>
>>
>>
>> bugs athttp://tools.ietf.org/tools/ietfdb
>> or send email [email-masked]
>>
>> or send email [email-masked]
>

---

From: Robert Sparks <[email-masked]>
Date: Sun, 10 Jan 2021 11:59:10 -0600

This might be better.

>>>> Unsubscribe at:https://www.ietf.org/mailman/listinfo/tools-discuss
<trim/>

---

From: Bob Hinden <[email-masked]>
Date: Sun, 10 Jan 2021 10:07:49 -0800

> On Jan 10, 2021, at 9:59 AM, Robert Sparks <[email-masked]> wrote:
> 
> This might be better.
…..
> Tools-discuss mailing list - [email-masked]
> * Report datatracker and mailarchive bugs to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

Thanks, Looks good.

Bob

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 10 Jan 2021 20:13:40 +0100

On 2021-01-10, at 18:59, Robert Sparks <[email-masked]> wrote:
> 
>> Sigh - no, I didn't make the change _stick_ yet. Mailman is such a wonderful thing. I lost a race on form lifetime expiration. Will reapply.

I repeatedly ran into the exceedingly low CSRF lifetimes of mailman as well.
Can this be configured slightly more leniently?

Grüße, Carsten