Subject: Re: [Tools-discuss] [rfc-i] Citing drafts

From: "Salz, Rich" <[email-masked]>
Date: Fri, 26 Feb 2021 17:46:41 +0000

Moved from rfc-interest (BCC) to tools-discuss.

>    My pet hate is that I have to scroll to the bottom before I can tell the 
    system that I want the lot.

(Are hates what peeves become when fully grown? :)
 
One the one hand, I get it.  I find it annoying too.  On the other hand, you're presumably already down at the bottom of the page at the time you see it. On the third hand, it's annoying to have to tweak the link if you already started sharing it. On the fourth hand, it could be an easy change.

When would you want to get the full document?  When you click on a document from the WG page?  (e.g., https://datatracker.ietf.org/wg/acme/documents/ )

---

From: Robert Sparks <[email-masked]>
Date: Fri, 26 Feb 2021 12:02:47 -0600

So, I _think_ the way the main document page behaves now was intended to 
protect people on low bandwidth or expensive bandwidth connections from 
very large documents.

Is that still something we should consider important? Or would it be 
better if the main page served the whole document all the time?

RjS

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 26 Feb 2021 10:04:31 -0800

> better if the main page served the whole document all the time?

I think that's largely unnecessary at this time, especially given that a
lot of people currently go to tools which serves the whole thing

-Ekr

> > One the one hand, I get it.  I find it annoying too.  On the other hand,
> you're presumably already down at the bottom of the page at the time you
> see it. On the third hand, it's annoying to have to tweak the link if you
> already started sharing it. On the fourth hand, it could be an easy change.
> >
> > When would you want to get the full document?  When you click on a
> document from the WG page?  (e.g.,
> https://datatracker.ietf.org/wg/acme/documents/ )
> >
> >
>
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: "Paul Hoffman" <[email-masked]>
Date: Fri, 26 Feb 2021 10:07:33 -0800

> lot of people currently go to tools which serves the whole thing

+1 to Robert's memory, and +1 to Ekr's proposal and reasoning.

--Paul Hoffman

---

From: Bob Hinden <[email-masked]>
Date: Fri, 26 Feb 2021 10:38:29 -0800

> On Feb 26, 2021, at 10:07 AM, Paul Hoffman <[email-masked]> wrote:
> 

Agreed.

Bob

> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 26 Feb 2021 19:40:39 +0000

I agree it makes sense to serve the full document now, but I also think having a link for just the ‘document status’ would be useful.  I don’t care how fast your link is, you don’t want to keep refreshing some honkin’ long draft just to see if the SECDIR person finished their review, especially if it’s your draft.

From: Eric Rescorla <[email-masked]>
Date: Friday, February 26, 2021 at 1:05 PM
To: Robert Sparks <[email-masked]>
Cc: Rich Salz <[email-masked]>, tom petch <[email-masked]>, tools-discuss <[email-masked]>
Subject: Re: [Tools-discuss] Serving a partial documents (was Re: [rfc-i] Citing drafts)

On Fri, Feb 26, 2021 at 10:03 AM Robert Sparks <[email-masked]<mailto:[email-masked]>> wrote:
So, I _think_ the way the main document page behaves now was intended to
protect people on low bandwidth or expensive bandwidth connections from
very large documents.

I think that's largely unnecessary at this time, especially given that a lot of people currently go to tools which serves the whole thing

-Ekr

RjS

On 2/26/21 11:46 AM, Salz, Rich wrote:
> When would you want to get the full document?  When you click on a document from the WG page?  (e.g., https://datatracker.ietf.org/wg/acme/documents/<https://urldefense.com/v3/__https:/datatracker.ietf.org/wg/acme/documents/__;!!GjvTz_vk!AhV4Mz4gH8GRqZgNs7WT5KGI8bDZvJMGwkMcVbnqIooDl7GQlpoHEyxKlo-1$> )
>
>

___________________________________________________________
Tools-discuss mailing list - [email-masked]<mailto:[email-masked]>
This list is for discussion, not for action requests or bug reports.
* Report datatracker and mailarchive bugs to: [email-masked]<mailto:[email-masked]>
* Report tools.ietf.org<https://urldefense.com/v3/__http:/tools.ietf.org__;!!GjvTz_vk!AhV4Mz4gH8GRqZgNs7WT5KGI8bDZvJMGwkMcVbnqIooDl7GQlpoHE_w3E_fr$> bugs to: [email-masked]<mailto:[email-masked]>
* Report all other bugs or issues to: [email-masked]<mailto:[email-masked]>
List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/tools-discuss__;!!GjvTz_vk!AhV4Mz4gH8GRqZgNs7WT5KGI8bDZvJMGwkMcVbnqIooDl7GQlpoHE0tOzf5Z$>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 26 Feb 2021 20:58:19 +0100

> I agree it makes sense to serve the full document now, but I also think having a link for just the ‘document status’ would be useful.  I don’t care how fast your link is, you don’t want to keep ref…

+1.

There should be separate landing and status pages (and archive access pages, for getting a verbatim copy of the submission).

Grüße, Carsten

---

From: Tom Pusateri <[email-masked]>
Date: Fri, 26 Feb 2021 16:07:10 -0500

> On Feb 26, 2021, at 2:58 PM, Carsten Bormann <[email-masked]> wrote:
> 

The number of “users” that want document meta-data << the number of “users” who want to read the document.

IMO, we should work to remove the tools server duality of documents and have an archive of documents that is served how people want to read them in a single place on the datatracker and a place for meta data WITHOUT the document so that there is only place to read the document.

Tom

---

From: "HANSEN, TONY L" <[email-masked]>
Date: Sat, 27 Feb 2021 00:29:07 +0000

Agreed.

    Bob

If you're logged in, you already have control over whether the full document is shown be default or not. Preferences -> "Show full document text by default?" controls that. I turned it on ages and ages ago.

However, the default has always been Off. Perhaps the default needs to become On?

	Tony

---

From: Bob Hinden <[email-masked]>
Date: Fri, 26 Feb 2021 16:56:21 -0800

> On Feb 26, 2021, at 4:29 PM, HANSEN, TONY L <[email-masked]> wrote:
> 

I didn’t know that was there :-(

Bob

---

From: tom petch <[email-masked]>
Date: Sat, 27 Feb 2021 12:33:26 +0000

> better if the main page served the whole document all the time?

Keep something like the current behaviour.
e-mail used to be user-friendly but now I get 20Mbyte e-mails containing 
home-movies and I do not want them!  Ever!  They take time to download, 
blocking access, they take up space and are slow, or impossible, to 
process.  The senders are unaware, or do not care, about the impact of 
what they are doing.  Keep them to social media.

Currently, I see plain text I-D in the hundreds of kbyte, some I seem to 
recall are over 500 kbyte, one I think was 2Mbyte (although that may 
have been a .pdf), and I expect that the maximum will go on getting 
larger and larger.
Up to 50kbyte, perhaps 100kbyte, is ok with current technology but I 
think there should be a limit beyond which the user is warned about the 
size and should not have it just dumped on them.

There may also be format issues, as when no plain text is available, 
which could again warrant a warning before inflicting it on the user.

Tom Petch

>> One the one hand, I get it.  I find it annoying too.  On the other
>> hand, you're presumably already down at the bottom of the page at the
>> time you see it. On the third hand, it's annoying to have to tweak the
>> link if you already started sharing it. On the fourth hand, it could
>> be an easy change.
>>

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 27 Feb 2021 19:28:55 +0000

Holy cow!

I still think a link for just the metadata will be useful.