Subject: [Tools-discuss] Setting replaced-by

From: Carsten Bormann <[email-masked]>
Date: Tue, 23 Feb 2021 14:39:52 +0100

One of the great features of the datatracker is that it tells you which document has been replaced by which.

As an author, I’m really interested to be able to mark my documents as replaced-by something bigger and greater.  But it seems the replaced-by arrow goes the other direction, so I can’t set it up from the replaced document.  Should I be able to mark my documents replaced?

(From a discussion over at int-area.)

Grüße, Carsten

---

From: Russ Housley <[email-masked]>
Date: Tue, 23 Feb 2021 09:40:41 -0500

Carsten:

The Datatracker has both replaces and replaced-by pointers.

Russ

> On Feb 23, 2021, at 8:39 AM, Carsten Bormann <[email-masked]> wrote:
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Robert Sparks <[email-masked]>
Date: Tue, 23 Feb 2021 09:29:57 -0600

> The Datatracker has both replaces and replaced-by pointers.

The datatracker only stores replaces pointers - it computes replaced-by.

Editing the relationship is only currently possible at the document that 
does the replacing. And I think that's right. Carsten, for the use case 
you're talking about, you will almost certainly be able to operate on 
the document that is doing the replacing or know someone who can.

Replaces is many-to-many. A document can replace several other 
documents. A document can be replaced by several other documents. 
Keeping a clear understanding of authority for replaces requires careful 
attention.

RjS

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 23 Feb 2021 18:19:15 +0100

On 2021-02-23, at 16:29, Robert Sparks <[email-masked]> wrote:
> Editing the relationship is only currently possible at the document that does the replacing. And I think that's right. Carsten, for the use case you're talking about, you will almost certainly be able to operate on the document that is doing the replacing or know someone who can.

My use case actually was as an author of the replaced document.
So I’ll have to talk to the author of the replacing document, and it’s still somehow hard for them to get this status in there (for good reasons!).
Gets the whole thing in the “not worth the effort” category too easily.

> Replaces is many-to-many. A document can replace several other documents. A document can be replaced by several other documents. Keeping a clear understanding of authority for replaces requires careful attention.

I agree.  
I was just trying to make it easier for the author of a replaced document to acknowledge that their work has been superseded.

(If we need a rendezvous here to make the relationship happen, that’s fine too.)

Grüße, Carsten

---

From: Robert Sparks <[email-masked]>
Date: Tue, 23 Feb 2021 11:29:03 -0600

> (If we need a rendezvous here to make the relationship happen, that’s fine too.)
How about "suggests has been replaced by" that sends a note to the 
secretariat?

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 23 Feb 2021 18:47:52 +0100

On 2021-02-23, at 18:29, Robert Sparks <[email-masked]> wrote:
> 
> How about "suggests has been replaced by" that sends a note to the secretariat?

Works for me.

(I could have thought about sending a note to the secretariat, but while I still was Working Group chair, I noted a strong hesitance by WG members to contact the secretariat on anything, which probably now afflicts me as well :-)

Grüße, Carsten

---

From: Cindy Morgan <[email-masked]>
Date: Tue, 23 Feb 2021 11:37:23 -0800

> On Feb 23, 2021, at 9:47 AM, Carsten Bormann <[email-masked]> wrote:
> 

Speaking as a member of the Secretariat team, we are here to help! If there is something you think we can be of assistance on, please don't hesitate to contact us.

Thanks,
Cindy

---

From: Glen <[email-masked]>
Date: Tue, 23 Feb 2021 11:38:59 -0800

> (I could have thought about sending a note to the secretariat, but while I still was Working Group chair, I noted a strong hesitance by WG members to contact the secretariat on anything, which prob…

I hope that affliction passes quickly.  The secretariat (of which I'm a 
part) would not want anyone thinking that contact was unwelcome.  They - 
and I - are all here to help, and if anyone has something to talk to us 
about, please do not hesitate so to do.

Glen
--
Glen Barney
IT Director
AMS (IETF Secretariat)