Subject: [Tools-discuss] Login timeouts on the various trac instances

From: Lars Eggert <[email-masked]>
Date: Tue, 2 Feb 2021 12:39:27 +0200

Hi,

not sure if this is the right list, but:

The various trac instances we have seem to all time out user logins pretty aggressively, after something that feels like 24-48h.

That's pretty annoying, since one needs to constantly re-login. Doubly so, because trac uses HTTP authentication that doesn't integrate with my password manager (1Password), so I need to manually copy&paste my password.

Could we lengthen the timout and/or switch to forms-based authentication?

Thanks,
Lars

---

From: Henrik Levkowetz <[email-masked]>
Date: Tue, 2 Feb 2021 17:47:33 +0100

Hi Lars,

> Could we lengthen the timout and/or switch to forms-based authentication?

I've set this to 30 days for the datatracker and xml2rfc issue trackers.

Will email Glen with instructions for how to do this for the ietf-hosted
Trac instances.

Best,

	Henrik

---

From: Glen <[email-masked]>
Date: Tue, 2 Feb 2021 10:40:30 -0800

> Will email Glen with instructions for how to do this for the ietf-hosted

All -

I have received the instructions from Henrik, and implemented them.

Thank you!

Glen

---

From: Lars Eggert <[email-masked]>
Date: Tue, 2 Feb 2021 21:12:10 +0200

> I have received the instructions from Henrik, and implemented them.

Thanks Henrik, thanks Glen.

Lars