Subject: [Tools-discuss] Could not resolve host: tools.ietf.org

From: Lars Eggert <[email-masked]>
Date: Mon, 15 Feb 2021 09:43:19 +0200

Hi,

I'm downloading idnits from https://tools.ietf.org/tools/idnits/idnits-2.16.05.tgz as part of a CI run. Every so often, that download fails, because:

> curl: (6) Could not resolve host: tools.ietf.org
> 
> The command '/bin/sh -c curl -L -o idnits.tgz https://tools.ietf.org/tools/idnits/idnits-2.16.05.tgz' returned a non-zero code: 6

For example, https://github.com/larseggert/i-d-toolchain/runs/1893387974?check_suite_focus=true#step:3:2165 or https://github.com/larseggert/i-d-toolchain/runs/1894464855?check_suite_focus=true#step:3:2303

Is one of the tools servers out of sync?

Thanks,
Lars

---

From: Lars Eggert <[email-masked]>
Date: Mon, 15 Feb 2021 09:45:20 +0200

>> The command '/bin/sh -c curl -L -o idnits.tgz https://tools.ietf.org/tools/idnits/idnits-2.16.05.tgz' returned a non-zero code: 6

Sorry, need more coffee. Of course this a DNS resolution issue, not a content retrieval issue. Which means I have no theory for what is wrong.

Thanks,
Lars