Subject: [Tools-discuss] People outside IETF only finds old draft versions - makes people believe EAP-TLS 1.3 was abandoned 2.5 years ago

From: John Mattsson <[email-masked]>
Date: Wed, 24 Feb 2021 07:49:11 +0000

Hi,

First, thanks for all the great tools.

For at least the third time in just a few months I have been received mails from persons from other SDOs, operating systems, and network equipment that is interested in implementing EAP-TLS 1.3 but for some reason find version -03 on tools.ietf.org and thinks it has been abandoned 2.5 years ago. 

I don't know why they find -03, but a Google search for "eap tls 1.3 tools" seems to give that as the first result.

https://tools.ietf.org/html/draft-ietf-emu-eap-tls13-03

There seems to be some bug in tools so that no newer versions that -04 show up when you look at -03. (Actually clicking on -04 makes all versions pop up, but obviously many people do not realize that...)

If adoption of IETF standards into product and other SDOs get delayed that is quite a big problem.

It there anything more than just fixing the bug that can be done? Could tools somehow warn the reader that there is a newer version available? Maybe with a stylish <blink> tag ;)

Cheers,
John

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 24 Feb 2021 09:31:57 +0100

On 24. Feb 2021, at 08:49, John Mattsson <john.mattsson=[email-masked]> wrote:
> 
> There seems to be some bug in tools so that no newer versions that -04 show up when you look at -03. (Actually clicking on -04 makes all versions pop up, but obviously many people do not realize that…)

The swallowing of some updates is a long-standing bug with the tools.ietf.org presentation of documents that really, really, really needs to be fixed.

What we are not going to be able to fix is that google favours older over newer documents.
So the landing pages for older documents always need the links to the newer ones (or, more generally, status information).
The attempt to have static information (this document expires in…) inside the archived document is misdirected.
(That information is nearly always wrong and misleading.)

I know that there is some aversion to JavaScript, but the metadata.js approach for the 8650+ RFCs looks exactly right to me; we could do the same for I-Ds to emulate the usefulness that the tools.ietf.org pages gave us (when updated right).

Grüße, Carsten

---

From: Jeffrey Yasskin <[email-masked]>
Date: Thu, 25 Feb 2021 14:22:35 -0800

I used to see this a lot with versioned technical documentation, and I
realize I haven't noticed it in a while outside of the IETF. Python
documentation used to do it, but now pages like
https://docs.python.org/3.6/library/subprocess.html include a <link
rel="canonical" href="https://docs.python.org/3/library/subprocess.html">
that points search engines toward the latest version. This is something of
a mis-use of <link rel=canonical>, since a new version's documentation
isn't a complete replacement for the old version's, but it seems to mostly
work in practice.

Would it make sense for versioned pages like
https://tools.ietf.org/html/draft-ietf-emu-eap-tls13-03 to include a <link
rel=canonical href="https://tools.ietf.org/html/draft-ietf-emu-eap-tls13">
pointing at the unversioned URL? This still wouldn't help when I-Ds change
names or are published as RFCs, but it would fix the most common instances
of the problem.

Jeffrey

On Tue, Feb 23, 2021 at 11:49 PM John Mattsson <john.mattsson=
[email-masked]> wrote:

> For at least the third time in just a few months I have been received
> mails from persons from other SDOs, operating systems, and network
> equipment that is interested in implementing EAP-TLS 1.3 but for some
> reason find version -03 on tools.ietf.org and thinks it has been
> abandoned 2.5 years ago.
>
> I don't know why they find -03, but a Google search for "eap tls 1.3
> tools" seems to give that as the first result.
>
> There seems to be some bug in tools so that no newer versions that -04
> show up when you look at -03. (Actually clicking on -04 makes all versions
> pop up, but obviously many people do not realize that...)
>
> It there anything more than just fixing the bug that can be done? Could
> tools somehow warn the reader that there is a newer version available?
> Maybe with a stylish <blink> tag ;)
>
> Cheers,
> John
>
>
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>