Subject: [Tools-discuss] Rfcdiff Tool: too much right margin

From: Paul Kyzivat <[email-masked]>
Date: Sat, 6 Feb 2021 14:49:17 -0500

When diffing (side by side) some drafts I find that there is extra right 
margin in the left panel. This skews things so I can't see both panels 
simultaneously.

I don't think this always happens, but I can't characterize when it does 
and doesn't. An example of this can be seen diffing 
draft-ietf-rum-rue-03/draft-ietf-rum-rue-04.

Any idea why this is happening and if I can do anything to fix it?

	Thanks,
	Paul

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 7 Feb 2021 05:14:24 +0100

draft-ietf-rum-rue-04.txt hasn’t made it to tools.ietf.org yet, so I can only speculate: draft-ietf-rum-rue-03.txt has some very long lines, which expand the left side of that comparison.

Grüße, Carsten

> On 2021-02-06, at 20:49, Paul Kyzivat <[email-masked]> wrote:
> 
> When diffing (side by side) some drafts I find that there is extra right margin in the left panel. This skews things so I can't see both panels simultaneously.
> 
> I don't think this always happens, but I can't characterize when it does and doesn't. An example of this can be seen diffing draft-ietf-rum-rue-03/draft-ietf-rum-rue-04.
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Paul Kyzivat <[email-masked]>
Date: Sun, 7 Feb 2021 11:48:07 -0500

> draft-ietf-rum-rue-04.txt hasn’t made it to tools.ietf.org yet, so I can only speculate: draft-ietf-rum-rue-03.txt has some very long lines, which expand the left side of that comparison.

Weird stuff going on here, but your hint above does suggest the answer.

I can do the diff between -03 and-04 by simply typing the names into the 
rfcdiff tool web page without any actual url information. So it is 
finding the files on the ietf site somehow.

When I go to the tracker, the -04 version has a full complement of 
formats available, but -03 is lacking a plaintext format. There is 
however a htmlized(tools) format for it. When I look at that, I do find 
that there are some long lines, so that explains my problem.

	Thanks,
	Paul