Subject: [Tools-discuss] Alternate bibxml servers

From: Carsten Bormann <[email-masked]>
Date: Sat, 13 Feb 2021 00:28:39 +0100

I just patched kramdown-rfc to use rfc-editor/datatracker for RFC/I-D bibxml; this emergency patch will be in 1.3.30.

Comparing the output (- is tools, + is rfc-editor/datatracker):

@@ -88,11 +88,11 @@
 3.1.  Normative References
 
    [I-D.ietf-core-coap]
-              Shelby, Z., Hartke, K., and C. Bormann, "Constrained
+              Shelby, Z., Hartke, K., and C. Bormann, "The Constrained
               Application Protocol (CoAP)", Work in Progress, Internet-
               Draft, draft-ietf-core-coap-18, 28 June 2013,
-              <http://www.ietf.org/internet-drafts/draft-ietf-core-coap-
-              18.txt>.
+              <https://www.ietf.org/internet-drafts/draft-ietf-core-
+              coap-18.txt>.
 
    [RFC2119]  Bradner, S., "Key words for use in RFCs to Indicate
               Requirement Levels", BCP 14, RFC 2119,
@@ -127,12 +127,12 @@
    [I-D.ietf-ace-aif]
               Bormann, C., "An Authorization Information Format (AIF)
               for ACE", Work in Progress, Internet-Draft, draft-ietf-
-              ace-aif-00, 29 July 2020, <http://www.ietf.org/internet-
-              drafts/draft-ietf-ace-aif-00.txt>.
+              ace-aif-01, 11 February 2021, <https://www.ietf.org/
+              internet-drafts/draft-ietf-ace-aif-01.txt>.
 
    [old]      Bormann, C., "An Authorization Information Format (AIF)
               for ACE", Work in Progress, Internet-Draft, draft-ietf-
-              ace-aif-00, 29 July 2020, <http://www.ietf.org/internet-
+              ace-aif-00, 29 July 2020, <https://www.ietf.org/internet-
               drafts/draft-ietf-ace-aif-00.txt>.
 
 Acknowledgements

Diff finished.  Sat Feb 13 00:13:46 2021

Wow.  

(1) The title of draft-ietf-core-coap-18.txt is “Constrained…”, not “The Constrained…” (the RFC editor made this change later on the way to RFC 7252).  Could datatracker be replacing the RFC title for the title of the final draft?  The date is right.

(2) xml2rfc.tools.ietf.org is serving up URLs with “http://”.  That was changed a while ago; this seems to be a regression.  (I *think* I got dechaunac, 4.31.198.62.)  

(3) It also thinks draft-ietf-ace-aif-00 is the current draft-ietf-ace-aif, while it has been draft-ietf-ace-aif-01 for a couple days.

I’ll take slightly revisionist over outdated data, so in goes 1.3.30.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 13 Feb 2021 00:39:07 +0100

> (3) It also thinks draft-ietf-ace-aif-00 is the current draft-ietf-ace-aif, while it has been draft-ietf-ace-aif-01 for a couple days.

(4) … and the link given there, http://www.ietf.org/internet-drafts/draft-ietf-ace-aif-00.txt, is 404 (that would need to be the archive/id link now).

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Sat, 13 Feb 2021 13:17:30 -0500

Carsten Bormann <[email-masked]> wrote:
    > (4) … and the link given there,
    > http://www.ietf.org/internet-drafts/draft-ietf-ace-aif-00.txt, is 404
    > (that would need to be the archive/id link now).

Based upon the policy for IDs, and the lack of a redirect, and that, in my
draft, I can't predict when you'll update your draft, I think that all such
links in IDs need to point to archive/id by default.
{That's too bad from a SEO point of view, but effectively the result
is that google is never gonna pick www.ietf.org/internet-draft/foo.}

I recognize that you are just rendering what's in the reference.I-D.foo.xml file.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 13 Feb 2021 20:18:05 +0100

On 2021-02-13, at 19:17, Michael Richardson <[email-masked]> wrote:
> Signed PGP part

… which I thought already was the case (with an https URL).
Apparently it is not with the datatracker-generated links.

Let’s try that with a superseded draft:

$ curl -s https://datatracker.ietf.org/doc/bibxml3/draft-ietf-ace-aif-00/xml | tail -2
   <format type="TXT" target="https://www.ietf.org/internet-drafts/draft-ietf-ace-aif-00.txt" />
</reference>

Fine reference bibxml.
Let’s dereference the target in that:

$ curl -s https://www.ietf.org/internet-drafts/draft-ietf-ace-aif-00.txt | tail -2
<p>The document has moved <a href="https://www.ietf.org/id/draft-ietf-ace-aif-00.txt">here</a>.</p>
</body></html>

OK, thank you for the hint, let’s get *that*:

$ curl -I https://www.ietf.org/id/draft-ietf-ace-aif-00.txt
HTTP/2 404
[…]

Do I now have to pile on another emergency patch to fix the datatracker links?
🤦‍♂️.

> is that google is never gonna pick www.ietf.org/internet-draft/foo.}

archive/id is the stable URL [1].  The temporary ones should never be used.

Grüße, Carsten

[1]: https://www.w3.org/Provider/Style/URI.html
"Cool URIs don't change"

---

From: Robert Sparks <[email-masked]>
Date: Sat, 13 Feb 2021 13:27:30 -0600

On 2/13/21 1:18 PM, Carsten Bormann wrote:

<trimming>
> Do I now have to pile on another emergency patch to fix the datatracker links?
I'll add a ticket to make sure this points to the archive.
> archive/id is the stable URL [1].  The temporary ones should never be used.

I mostly agree. But there are still people who want the set of active 
drafts distinguished from the set of all drafts, and things do disappear 
from the set of active drafts.

> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 13 Feb 2021 21:39:09 +0100

On 2021-02-13, at 20:27, Robert Sparks <[email-masked]> wrote:
> 
> I mostly agree. But there are still people who want the set of active drafts distinguished from the set of all drafts, and things do disappear from the set of active drafts.

/internet-drafts/
or
/id/

…could point to a tombstone page that points to (or transcludes!)

/archive/id/

…if you want to keep up this distinction.

Grüße, Carsten