Subject: [Tools-discuss] Inexplicable differences in datatracker bibxml files

From: Carsten Bormann <[email-masked]>
Date: Sat, 20 Feb 2021 17:30:23 +0100

The files coming from
"https://datatracker.ietf.org/doc/bibxml3/draft-#{namepart}/xml”
(newest version) and
"https://datatracker.ietf.org/doc/bibxml3/draft-#{namepart}-#{version}/xml"
(specific version), when #{version} is the most recent one, are almost the same, except:

--- reference.I-D.arkko-farrell-arch-model-t-7258-additions.xml	2021-02-20 17:10:23.000000000 +0100
+++ reference.I-D.draft-arkko-farrell-arch-model-t-7258-additions-01.xml	2021-02-20 17:10:23.000000000 +0100
@@ -2,10 +2,10 @@
 <reference anchor="I-D.arkko-farrell-arch-model-t-7258-additions">
    <front>
       <title>RFC 7258 additions due to evolving Internet thread model</title>
-      <author fullname="Jari Arkko">
+      <author initials="J." surname="Arkko" fullname="Jari Arkko">
 	 <organization>Ericsson</organization>
       </author>
-      <author fullname="Stephen Farrell">
+      <author initials="S." surname="Farrell" fullname="Stephen Farrell">
 	 <organization>Trinity College Dublin</organization>
       </author>
       <date month="August" day="20" year="2020" />

This is a `diff -ub`, because the other inexplicable difference is that draft-…-nn has more of its pretty-XML indentation replaced by HTAB characters, while draft-… (without version number) is somewhat cleaner, but not entirely clean.

(If the files were the same, I could use hardlinks and would need half as many fetches.)

Grüße, Carsten

---

From: Robert Sparks <[email-masked]>
Date: Sat, 20 Feb 2021 12:13:51 -0600

Might be a good sprint project.

What's happening can be seen from line 77 here:

https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/ietf/doc/urls.py#L77

(though you might also look through what happens with line 76)

lines 875-907 here:

https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/ietf/doc/views_doc.py#L875

and this template:

https://trac.tools.ietf.org/tools/ietfdb/browser/trunk/ietf/templates/doc/bibxml.xml

The crux is that the view using the DocHistory record if a rev is 
present rather than the Document object.

It should either look at the most recent DocHistory (matching current 
rev) if a rev is not present, or stick with the Document object if rev 
is present. (I lean towards the latter).

The difference in rendering is a consequence of there being a link from 
the Document object to its Submission object, but not from the 
DocumentHistory object. If the template can get to a submission object, 
it renders the author records from that. It would probably be worth it 
to go try to find the Submission object matching the DocumentHistory 
object if it exists and make that available to the template.

This is related to the long-standing tension we have with older 
documents DocumentAuthor set being extracted from .txt by heuristics. 
The Submission objects have a bit of (or at least the potential for a 
bit of) manual grooming at submission time, and keeps some details like 
affiliation at time of submission that is not as easy to calculate from 
the DocumentAuthor set. When we have the Submission objects, we should 
use that data. Only when we don't should we fall back to the 
DocumentAuthor set.

Also - it would be worth the template to avoid the whitespace 
differences on the different branches that you noted when possible

RjS

On 2/20/21 10:30 AM, Carsten Bormann wrote:
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss