Subject: [Tools-discuss] Gathering requirements for a new wiki

From: Jay Daley <[email-masked]>
Date: Wed, 31 Mar 2021 14:06:39 +1300

I’m helping out the Tools Team PM (Robert) with the migration of functionality from tools.ietf.org and one area that needs addressing is wikis.  We currently use Trac to provide wikis though Trac itself has a broader applicability for software project management.  The Secretariat maintains a Trac installation at https://trac.ietf.org with separate instances for each current Working Group (WG), Directorate, Team, and most concluded WGs.  Some of the wiki instances only point to other resources, others are reasonably detailed, while the majority appear to be unused or broken (cannot be started). 

The full usage stats are:

	• Total			364
	• Unused			157
	• Broken			28
	• In use - wiki		140
	• In use - issues	39

We are proposing to replace Trac with a new wiki product and instead of having multiple public instances, have a single community wiki, with the existing pages copied over.  This will be a true community wiki with any member of the community able to add/change pages and reorganise as needed, moderated by other members of the community and the secretariat, and provided they have a datatracker login to authenticate with.  Private pages will be allowed, but their creation controlled by the admins.

In multiple small discussions with the community, the following requirements have emerged for new wiki software:

• Strategic

	• Must be available at reasonable cost (to the IETF LLC) for possibly thousands of users.

	• Must be widely used, well documented, actively developed and actively supported to ensure that we do not end up with a dead-end product.  This includes any required plugins.

	• Must be a specific wiki product and not a larger product that includes a wiki as one part of its functionality, to prevent complications and overlaps with other tools.

	• Must be scalable to support tens of thousands of users to support the full IETF community and reasonable future growth.

• Content

	• Must support a text based input language.

	• Must support code snippets, maths expressions and diagrams to enable the full representation of the same kind of content as found in I-Ds and RFCs.

	• Must provide an excellent mobile experience.

	• Must provide content backup, change visibility, and the ability to revert changes

	• Should support Markdown by default for page content.

	• Should support git for content backup and change visibility.

	• Should provide a WYSIWYG editor for Markdown that can be used interchangeably with direct Markdown editing.

	• Should have a themable interface to enable the wiki to be given a look and feel consistent with www.ietf.org.

• Integration

	• Must support OIDC for authentication and role permissions.

	• Must support custom module development.

	• Should support Matomo for web analytics so that these can be integrated with our website statistics.

• Local management (if self-hosted)

	• Must support either MySql/MariaDB or PostgreSQL as those are the database products supported by the IT operations team.

	• Must run on Linux and should run in a Docker container to fit with the management processes of the IT operations team.

We would like your views on these requirements so that we can move to assessing products.

thanks
Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 31 Mar 2021 09:14:03 +0200

> 	• Must support a text based input language.

Given that content often flows back and forth between I-Ds and Wikis, that language SHOULD be markdown.

Grüße, Carsten