Subject: [Tools-discuss] Links from HTML I-Ds to datatracker/latest versions

From: Jeffrey Yasskin <[email-masked]>
Date: Wed, 10 Mar 2021 12:02:01 -0800

I've noticed that the native-HTML version of internet drafts, like
https://www.ietf.org/archive/id/draft-yasskin-wpack-bundled-exchanges-03.html

1) Don't link back to the datatracker's description of the draft:
https://datatracker.ietf.org/doc/draft-yasskin-wpack-bundled-exchanges/
2) Don't link to any later versions of the draft:
https://www.ietf.org/archive/id/draft-yasskin-wpack-bundled-exchanges-04.html
3) Don't have an easy way to find a version-independent URL, like the
htmlized version provides at
https://datatracker.ietf.org/doc/html/draft-yasskin-wpack-bundled-exchanges.

This makes it dangerous to link to native-HTML versions of I-Ds because
readers don't have any way to realize that they're reading an old version.

I haven't dug into which tools would need to change to provide such links.
Probably both xml2rfc and the datatracker itself? Are there issues with the
/archive/ path segment that might imply these files can never change to
incorporate the fact that the latest available version does change?

Jeffrey

---

From: Julian Reschke <[email-masked]>
Date: Wed, 10 Mar 2021 21:18:05 +0100

Am 10.03.2021 um 21:02 schrieb Jeffrey Yasskin:
> ...
> I haven't dug into which tools would need to change to provide such
> links. Probably both xml2rfc and the datatracker itself? Are there
> issues with the /archive/ path segment that might imply these files can
> never change to incorporate the fact that the latest available version
> does change?
> ...

I don't think there's a requirement not to re-render Internet Drafts, so
yes, this could be done.

An alternative is to do this at displaytime using JS, I started to do
that in rfc2629.xslt recently. Example:

<https://greenbytes.de/tech/webdav/draft-ietf-httpbis-semantics-13.html#rfc.meta>

(and yes, that currently only notifies readers that the version is
obsolete and doesn't provide links beyond that)

Best regards, Julian

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 11 Mar 2021 11:15:06 +1300

On 11-Mar-21 09:02, Jeffrey Yasskin wrote:
> I've noticed that the native-HTML version of internet drafts, like https://www.ietf.org/archive/id/draft-yasskin-wpack-bundled-exchanges-03.html
> 
> 1) Don't link back to the datatracker's description of the draft: https://datatracker.ietf.org/doc/draft-yasskin-wpack-bundled-exchanges/
> 2) Don't link to any later versions of the draft: https://www.ietf.org/archive/id/draft-yasskin-wpack-bundled-exchanges-04.html
> 3) Don't have an easy way to find a version-independent URL, like the htmlized version provides at https://datatracker.ietf.org/doc/html/draft-yasskin-wpack-bundled-exchanges.
> 
> This makes it dangerous to link to native-HTML versions of I-Ds because readers don't have any way to realize that they're reading an old version.

Really? When I tried with your draft -03, the links to updated drafts gave 404 errors.
 
> I haven't dug into which tools would need to change to provide such links. Probably both xml2rfc and the datatracker itself? Are there issues with the /archive/ path segment that might imply these files can never change to incorporate the fact that the latest available version does change?

afaik, if your xml (v3) looks like this:

<xi:include href="https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.foo-bar.xml"/>

the html rendering will point to the current version at the time the xml file is converted, but via the tools server. The top bar there gives you the versions up to date. There's also a link to the tracker.

(That will have to be changed of course when tools.ietf.org goes away.)

Looking at your -04 draft, that's exactly how it is, so whatever caused the wrong links in the -03 draft seems to have been fixed already.

Regards
   Brian Carpenter

---

From: Jeffrey Yasskin <[email-masked]>
Date: Wed, 10 Mar 2021 15:29:41 -0800

On Wed, Mar 10, 2021 at 2:15 PM Brian E Carpenter <
[email-masked]> wrote:

> links. Probably both xml2rfc and the datatracker itself? Are there issues
> with the /archive/ path segment that might imply these files can never
> change to incorporate the fact that the latest available version does
> change?
>
> <xi:include href="
> https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.foo-bar.xml
> "/>
>
> the html rendering will point to the current version at the time the xml
> file is converted, but via the tools server. The top bar there gives you
> the versions up to date. There's also a link to the tracker.
>
> Looking at your -04 draft, that's exactly how it is, so whatever caused
> the wrong links in the -03 draft seems to have been fixed already.
>

I think you might have confused the htmlized version (
https://datatracker.ietf.org/doc/html/draft-yasskin-wpack-bundled-exchanges-04),
which has the cross-links I want, with the native-HTML version (
https://www.ietf.org/archive/id/draft-yasskin-wpack-bundled-exchanges-04.html)
that has better typesetting and table of contents, but is missing the
cross-links I mentioned above. I'm not sure where the mention of
<xi:include> came from, as it's not in my XML version at all (
https://www.ietf.org/archive/id/draft-yasskin-wpack-bundled-exchanges-04.xml
).

Jeffrey

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 11 Mar 2021 14:14:23 +1300

On 11-Mar-21 12:29, Jeffrey Yasskin wrote:
> On Wed, Mar 10, 2021 at 2:15 PM Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     (That will have to be changed of course when tools.ietf.org <http://tools.ietf.org> goes away.)
> 
> I think you might have confused the htmlized version (https://datatracker.ietf.org/doc/html/draft-yasskin-wpack-bundled-exchanges-04), which has the cross-links I want, with the native-HTML version (https://www.ietf.org/archive/id/draft-yasskin-wpack-bundled-exchanges-04.html) that has better typesetting and table of contents, but is missing the cross-links I mentioned above.

I still don't understand what you want. The htmlized version has links to
   https://datatracker.ietf.org/doc/html/draft-yasskin-wpack-use-cases-01
and
   https://tools.ietf.org/html/draft-yasskin-wpack-use-cases-01

which are essentially identical. The native HTML version links only to the second one, but I'm at a loss to see what's missing.

> I'm not sure where the mention of <xi:include> came from, as it's not in my XML version at all (https://www.ietf.org/archive/id/draft-yasskin-wpack-bundled-exchanges-04.xml).

Well, that's just the short way to encode I-D references in xml2rfcv3. It looks as if kramdown does it a more noisy way. I guess it's irrelevant.

Regards
   Brian

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 11 Mar 2021 06:54:56 +0100

I think this discussion is currently confused about the links that are in a document to different documents vs. the desire for links that point to a document with links to its status and current versions.

It is the latter that need to be fixed, and then it will be easy to include these links to get the former.

Grüße, Carsten