Subject: [Tools-discuss] https://tools.ietf.org/agenda/110/calendar borked?

From: Julian Reschke <[email-masked]>
Date: Tue, 2 Mar 2021 14:07:14 +0100

Hi there,

it seems the calendars served over here do not have any actual dates in
them?

(for instance, try
<"https://tools.ietf.org/agenda/110/ics/ietf-110-webtrans.ics">).

Best regards, Julian

---

From: Robert Sparks <[email-masked]>
Date: Tue, 2 Mar 2021 09:42:16 -0600

Hi Julian -

Are the ics available from the datatracker not filling a need?

RjS

On 3/2/21 7:07 AM, Julian Reschke wrote:
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: 
> [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): 
> https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Julian Reschke <[email-masked]>
Date: Tue, 2 Mar 2021 16:45:30 +0100

> Are the ics available from the datatracker not filling a need?

I can and will try.

Is tools variant known to be broken?

Best regards, Julian

---

From: Robert Sparks <[email-masked]>
Date: Tue, 2 Mar 2021 09:51:26 -0600

>> Are the ics available from the datatracker not filling a need?

If it's helpful, consider

https://datatracker.ietf.org/meeting/110/agenda?show=webtrans

Use the "Customize agenda view" panel to tune what you want and don't 
want to appear in the calendar, then subscribe to (or download) the 
Customized schedule link.

> Is tools variant known to be broken?

It is supported by Henrik at best effort - I'll forward a note to him 
letting him know you've seen an issue.

---

From: Julian Reschke <[email-masked]>
Date: Tue, 2 Mar 2021 17:05:41 +0100

> Customized schedule link.

Tried and works for me.

FWIW, downloading the ICS usually is the wrong thing. We should
encourage users to *subscribe* to the ICS file (that is, in Thunderbird,
configure this as a calendar on the network).

> letting him know you've seen an issue.

Thanks, Julian

---

From: Robert Sparks <[email-masked]>
Date: Tue, 2 Mar 2021 10:10:02 -0600

> configure this as a calendar on the network).

Yes - we have webcal: links on several other pages to promote that 
behavior, and should make a similar change to this one.

But when we started discussing that, there were people that noted they 
required download as corporate security policies made subscription 
impossible.

RjS

---

From: Bob Hinden <[email-masked]>
Date: Tue, 2 Mar 2021 08:16:58 -0800

Robert,

> On Mar 2, 2021, at 7:51 AM, Robert Sparks <[email-masked]> wrote:
> 
> 
> 
>> 
> It is supported by Henrik at best effort - I'll forward a note to him letting him know you've seen an issue.

I have subscribed to

https://tools.ietf.org/agenda/110/ics/ietf-110-hrpc+rfcefdp+spring+iabopen+v6ops+6man+tsvarea+tsvwg+shmoo+gendispatch+homenet+IETF-Plenary+intarea.ics

with a refresh every day.   This morning it was gone, after a few manual refreshes it reappeared.   I reported this to Henrik last week.

Bob

> * Report datatracker and mailarchive bugs to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Julian Reschke <[email-masked]>
Date: Tue, 2 Mar 2021 17:21:01 +0100

> behavior, and should make a similar change to this one.

Uh, ugly. "webcal" is only provisionally registered without a spec link.
(and it's really not a different protocol, just an "intent" connected to
the handling of an http(s) resource).

I would prefer a "copy ICS link to clipboard" option, or at least a
statement next to the download button that "copy link target" will get
you something you can subscribe to...

 > ...

Best regards, Julian

---

From: Robert Sparks <[email-masked]>
Date: Tue, 2 Mar 2021 10:24:10 -0600

> with a refresh every day.   This morning it was gone, after a few manual refreshes it reappeared.   I reported this to Henrik last week.

Consider

https://datatracker.ietf.org/meeting/110/agenda?show=hrpc,rfcefdp,spring,iabopen,v6ops,6man,tsvarea,tsvwg,shmoo,gendispatch,homenet,plenary,intarea

and the corresponding .ics at

https://datatracker.ietf.org/meeting/110/agenda.ics?show=hrpc,rfcefdp,spring,iabopen,v6ops,6man,tsvarea,tsvwg,shmoo,gendispatch,homenet,plenary,intarea

---

From: Michael Richardson <[email-masked]>
Date: Tue, 02 Mar 2021 12:35:37 -0500

I'll just mention that I use this bit of indirect script:

#!/bin/sh

mkdir -p /ssw/docs/SSW/ietf/meeting/ietf110
cd /ssw/docs/SSW/ietf/meeting/ietf110
GROUPS=show=6lo
GROUPS=$GROUPS,6man
GROUPS=$GROUPS,danish
GROUPS=$GROUPS,madinas
GROUPS=$GROUPS,ace
...
curl -s >agenda.ics "https://datatracker.ietf.org/meeting/110/agenda.ics?$GROUPS"

and I subscribe to that (plus cron). ("/ssw/docs" is a live NFS mount of my web server)
I do this because I realized that I had to unsubscribe/subscribe if I wanted
to change the list of groups, since it's in the URL.  Solved by a layer of indirection...

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide