Subject: Re: [Tools-discuss] Meetecho on Android

From: Robert Sparks <[email-masked]>
Date: Wed, 10 Mar 2021 09:10:34 -0600

Hi Kyle -

I'm moving this to tools-discuss.

On 3/10/21 8:45 AM, Kyle Rose wrote:
> Is there any way to make Meetecho usable on Android? I encounter two 
> main problems with the browser interface:
>
> * The UI is unusable in both portrait and landscape mode: elements 
> overlap, controls are either too big or too small, etc.
> * When the screen sleeps, audio stops shortly thereafter, requiring me 
> to unlock.
>
> Considering that Android-on-phones is the world's most widely deployed 
> user platform, this seems like a significant barrier to participation.
>
> https://www.dropbox.com/s/ux3t5zuk5qjwpa0/2021-03-10%2009.44.17.png?dl=0 
> <https://www.dropbox.com/s/ux3t5zuk5qjwpa0/2021-03-10%2009.44.17.png?dl=0>
> https://www.dropbox.com/s/kgcm0jvduq5slma/2021-03-10%2009.44.05.png?dl=0 
> <https://www.dropbox.com/s/kgcm0jvduq5slma/2021-03-10%2009.44.05.png?dl=0>
>
> Kyle

---

From: Hoi lam Poon <[email-masked]>
Date: Wed, 10 Mar 2021 23:16:02 +0800

不會，因為世上只有我可以寫copyright law 他沒有權去說人大權力，而是他一直犯罪，
金匙傳給另一人，是要脅法律奕力，而且人品性格也要計算在內，不可隨便複制，所有也有證明，而且本來認鎖匙不認人（在網路）

在 2021年3月10日 週三 23:11，Robert Sparks <[email-masked]> 寫道：

> Is there any way to make Meetecho usable on Android? I encounter two main
> problems with the browser interface:
>
> * When the screen sleeps, audio stops shortly thereafter, requiring me to
> unlock.
>
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Kyle Rose <[email-masked]>
Date: Wed, 10 Mar 2021 10:21:21 -0500

-ietf@

Thanks.

Is there something I'm missing? I looked for a thick client and couldn't
find one, so I assume the browser client is what's available.

I do note that the sound doesn't drop* if I keep the screen on, but this is
wasteful of battery when I'm only interested in the audio.

*Usually. Sound drops and requires me to manually recycle it whenever my
connectivity changes, e.g., from wifi to LTE or vice versa.

Kyle

---

From: Robert Sparks <[email-masked]>
Date: Wed, 10 Mar 2021 09:26:58 -0600

For the immediate problem, if you are ok only being able to listen, 
consider using the live audio stream linked from the agenda.

RjS

On 3/10/21 9:21 AM, Kyle Rose wrote:
> -ietf@
>
> Thanks.
>
> Is there something I'm missing? I looked for a thick client and 
> couldn't find one, so I assume the browser client is what's available.
>
> I do note that the sound doesn't drop* if I keep the screen on, but 
> this is wasteful of battery when I'm only interested in the audio.
>
> *Usually. Sound drops and requires me to manually recycle it whenever 
> my connectivity changes, e.g., from wifi to LTE or vice versa.
>
> Kyle
>
> On Wed, Mar 10, 2021 at 10:10 AM Robert Sparks <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi Kyle -
>
>>     Is there any way to make Meetecho usable on Android? I encounter
>>     two main problems with the browser interface:
>>
>>     * The UI is unusable in both portrait and landscape mode:
>>     elements overlap, controls are either too big or too small, etc.
>>     * When the screen sleeps, audio stops shortly thereafter,
>>     requiring me to unlock.
>>
>>     Considering that Android-on-phones is the world's most widely
>>     deployed user platform, this seems like a significant barrier to
>>     participation.
>>
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: "John R. Levine" <[email-masked]>
Date: 10 Mar 2021 11:35:41 -0500

> wasteful of battery when I'm only interested in the audio.

FYI, I'm using Meetecho on a 2015 vintage Galaxy Tab A and it works fine. 
It's not a performance issue, looks like it needs some tuning to recognize 
when it's on a phone and recognize things like you'd want to leave the 
audio on and the video off.

> connectivity changes, e.g., from wifi to LTE or vice versa.

I'm amazed it can keep the session up at all across connectivity changes 
since your IP address changes too.

Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly

---

From: "Valery Smyslov" <[email-masked]>
Date: Fri, 12 Mar 2021 10:26:39 +0300

Hi,

last time I tried Meetecho on Android I had the same experience.

Unfortunately, it was not possible to use it at all, since

UI didn’t take phone screen specifics into considerations

and some controls were inaccessible.

Regards,

Valery.

Hi Kyle -

Is there any way to make Meetecho usable on Android? I encounter two main problems with the browser interface:

* The UI is unusable in both portrait and landscape mode: elements overlap, controls are either too big or too small, etc.

* When the screen sleeps, audio stops shortly thereafter, requiring me to unlock.

Considering that Android-on-phones is the world's most widely deployed user platform, this seems like a significant barrier to participation.

Kyle