Subject: [Tools-discuss] Deletion of unused and broken trac instances

From: Jay Daley <[email-masked]>
Date: Mon, 15 Mar 2021 10:34:58 +1300

To support Robert as The Tools Team PM, I am working on an RFP to move all the wiki pages in existing trac instances to a new wiki product and all the issues to GitHb repositories.  In preparation for this work, I propose to have all broken and unused Trac instances deleted so that we do not waste resources having those migrated.  

- Broken instances are ones that cannot be started by the Trac software.  They may well contain data but as no support calls have been raised since they broke some years ago, I am assuming they are no longer needed. 

- Unused instances are those with no edits made and no issues raised.

The following lists have been circulated to the IESG and WG Chairs and one instance moved from one list to another.  Please note: there are multiple examples where a specific WG/Team uses a set of wiki pages underneath inside another wiki, not actual wiki set aside for that purpose, which remains unused.  e.g. genart pages are under the gen wiki not the specific genart wiki, which is unused.

This is just a final check to make sure there are no concerns with this deletion.  Please let us know in the next few days if you do have a concern.

PS There will be a follow up this week about what Wiki product I propose we switch to.

thanks
Jay

1.  List of the broken instances along with an estimated date for when they broke.  24 in total.

Jun 10  2019	ITU-T-CITS
Oct 22  2014	aaadoctors
Jun 11  2019	add
Jul 10  2015	appsdir
Oct 22  2014	genart
Jun 26  2019	iepg
Oct 22  2014	intdir
Oct 22  2014	iotdir
Jun 11  2019	lake
Jun 11  2019	loops
Jun 26  2019	mentor
Oct 22  2014	mibdoctors
Jun 11  2019	mops
Oct 22  2014	opsdir
Oct 22  2014	perfmetrdir
Oct 22  2014	raiart
Oct 22  2014	rsvpdir
Oct 22  2014	rtgdir
Oct 22  2014	sdpdir
Oct 22  2014	secdir
Oct 22  2014	smartpower
Jun 27  2019	tdd
Oct 22  2014	tsvdir
Oct 22  2014	yangdoctors

2.  List of unused Trac instances.  159 in total

16ng
6renum
acme
ancp
apparea
aqm
arcmedia
armd
artarea
artart
atoca
autoconf
avtext
babel
banana
bcause
bfcpbis
bimi
bmwg
cacao
calext
capport
capwap
cbor
cdni
cellar
cfrg
coinrg
coms
cose
csi
curdle
cuss
dart
dcrouting
dcrup
detnet
doh
drip
driu
emodir
enum
eppext
extra
fecframe
genarea
gendispatch
geojson
ghost
git
grow
hackathon
hotrfc
hrpc
i18ndir
i18nrp
ianaplan
iasa2
iasa20
iccrg
ice
icnrg
ideas
ietf
ila
imapapnd
insipid
ipfix
ipwave
irtfopen
isis
jmap
jsonbis
justfont
karp
keyprov
kitten
ksk
l2sm
l2tpext
l2vpn
lamps
ledbat
lmap
lsr
lsvr
maprg
marf
masque
mboned
mip6
mipshop
mls
modern
monami6
morg
netrqmts
netslicing
netvc
nfsv4
nfvrg
nwcrg
openpgp
opsarea
opsawg
opsec
p2psip
pals
panrg
paw
paws
pcn
pearg
perc
privacypass
qirg
qresync
quic
raiarea
rats
rfcplusplus
ript
rsoc
rtgarea
rtgyangcoord
rum
saag
sasl
savi
sdnrg
secevent
sidrops
sip
sipbrandy
splices
storm
straw
supa
t2trg
taps
tcpinc
teep
tmrid
tokbind
tools-arch
trill
tsvarea
tsvart
txauth
v6ops
vcarddav
vipr
vnrg
webpush
webtrans
wgtlgo
wpack
wugh
xrblock

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "John Levine" <[email-masked]>
Date: 14 Mar 2021 18:22:56 -0400

It appears that Jay Daley  <[email-masked]> said:
>To support Robert as The Tools Team PM, I am working on an RFP to move all the wiki pages in existing trac instances to a new wiki
>product and all the issues to GitHb repositories.  In preparation for this work, I propose to have all broken and unused Trac
>instances deleted so that we do not waste resources having those migrated.  

Do we plan to keep backups of the broken instances in case someone in
the future thinks there was something of interest in them? I don't
propose offering a recovery service, just "here's a copy of the files,
good luck and let us know if you find anything."

R's,
John

>
>- Broken instances are ones that cannot be started by the Trac software.  They may well contain data but as no support calls have
>been raised since they broke some years ago, I am assuming they are no longer needed. 
>
>The following lists have been circulated to the IESG and WG Chairs and one instance moved from one list to another.  Please note:
>there are multiple examples where a specific WG/Team uses a set of wiki pages underneath inside another wiki, not actual wiki set
>aside for that purpose, which remains unused.  e.g. genart pages are under the gen wiki not the specific genart wiki, which is
>unused.
>

---

From: Jay Daley <[email-masked]>
Date: Mon, 15 Mar 2021 11:44:25 +1300

> On 15/03/2021, at 11:22 AM, John Levine <[email-masked]> wrote:
> 

Yes we do.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "Jim Fenton" <[email-masked]>
Date: Sun, 14 Mar 2021 15:50:53 -0700

Jay,

On 14 Mar 2021, at 14:34, Jay Daley wrote:

> To support Robert as The Tools Team PM, I am working on an RFP to move 
> all the wiki pages in existing trac instances to a new wiki product 
> and all the issues to GitHb repositories.  In preparation for this 
> work, I propose to have all broken and unused Trac instances deleted 
> so that we do not waste resources having those migrated.

Does “all the issues” include the Datatracker issues? The current 
issue tracking system is hooked to subversion, where the datatracker 
code is managed, and I suspect we would lose that if the issues were 
migrated to GitHub. Unless there is also a plan to move the code to 
GitHub as well, of course.

-Jim

---

From: Jay Daley <[email-masked]>
Date: Mon, 15 Mar 2021 12:02:23 +1300

> On 15/03/2021, at 11:50 AM, Jim Fenton <[email-masked]> wrote:
> 
> Jay,
> 
> Does “all the issues” include the Datatracker issues? The current issue tracking system is hooked to subversion, where the datatracker code is managed, and I suspect we would lose that if the issues were migrated to GitHub. Unless there is also a plan to move the code to GitHub as well, of course.

Sorry, I should have explained that Datatracker and xml2rfc sit outside of this project as they are much larger code/issue bases. And yes, as noted in Robert’s email [1], these are being moved to GitHub as complete migrations.

Jay

[1]  https://mailarchive.ietf.org/arch/msg/tools-discuss/oYrAxb3KayPzZ4SNB1DVZTDPPNo/

-- 
Jay Daley
IETF Executive Director
[email-masked]