Subject: [Tools-discuss] RFC and I-D publication feature matrix

From: Jay Daley <[email-masked]>
Date: Tue, 16 Mar 2021 10:52:47 +1300

As we all know, RFCs are published on three sites: RFC Editor site, Datatracker and tools.ietf.org; and I-Ds on a different three: www.ietf.org, Datatracker and tools.ietf.org.  These documents are published in TXT, HTMLised TXT, native HTML, PDF and XML, with different sites publishing different combinations, different metadata, different features, different URL structures and different combinations of links to each other.

To understand this and to help the various groups/people think about what changes are needed to declutter this, I’ve been through each of the three site and drawn up a comprehensive feature matrix:

	https://docs.google.com/spreadsheets/d/1Ljj4QV6YmvQo4F8MtydZH9owvwH-dMOJcwSaz5CW4E0/edit?usp=sharing

I so far have not looked at this through the lens of sub-series (e.g BCP)

Please let me know if you see any errors or omissions.

Jay

PS the switch between RFC 8179 and RFC 8719 for examples is deliberate not a typo.

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Michael Richardson <[email-masked]>
Date: Mon, 15 Mar 2021 21:39:55 -0400

Jay Daley <[email-masked]> wrote:
    > As we all know, RFCs are published on three sites: RFC Editor site,
    > Datatracker and tools.ietf.org; and I-Ds on a different three:
    > www.ietf.org, Datatracker and tools.ietf.org.  These documents are
    > published in TXT, HTMLised TXT, native HTML, PDF and XML, with
    > different sites publishing different combinations, different metadata,
    > different features, different URL structures and different combinations
    > of links to each other.

Yes. That's quite a list and feature matrix.
What have we done :-)

    > Please let me know if you see any errors or omissions.

Information density is too high for me to see anything, but gosh I think you
must have gotten it all there.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide