Subject: [Tools-discuss] BCP links to multiple RFCs broken (in inconsistent ways)

From: Samuel Weiler <[email-masked]>
Date: Mon, 15 Mar 2021 16:53:38 -0400 (EDT)

When one BCP number points at two docs, e.g. BCP14, the tools site 
shows a concatenation of the RFCs:

https://tools.ietf.org/html/bcp14

The datatracker does inconsistent things.  For BCP14, it only shows 
2119, not 8174:

https://datatracker.ietf.org/doc/html/bcp14

For others, the datatracker misses all of the RFCs, instead pointing 
at an earlier i-d:

https://datatracker.ietf.org/doc/html/bcp6
https://datatracker.ietf.org/doc/html/bcp9
https://datatracker.ietf.org/doc/html/bcp13

-- Sam

---

From: Robert Sparks <[email-masked]>
Date: Tue, 16 Mar 2021 09:44:21 -0500

Thanks Sam - Adding that to a ticket that had noted part of that problem 
already.

See https://trac.tools.ietf.org/tools/ietfdb/ticket/3233

RjS

On 3/15/21 3:53 PM, Samuel Weiler wrote:
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: 
> [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): 
> https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Russ Housley <[email-masked]>
Date: Tue, 16 Mar 2021 11:51:16 -0400

Why doesn't the datatracker serve the .html file for the BCP from the RFC Editor?

Russ

> On Mar 16, 2021, at 10:44 AM, Robert Sparks <[email-masked]> wrote:
> 
> Thanks Sam - Adding that to a ticket that had noted part of that problem already.
> 
>> When one BCP number points at two docs, e.g. BCP14, the tools site shows a concatenation of the RFCs:
>> 
>> The datatracker does inconsistent things.  For BCP14, it only shows 2119, not 8174:
>> 
>> For others, the datatracker misses all of the RFCs, instead pointing at an earlier i-d:
>> 
>> * Report datatracker and mailarchive bugs to: [email-masked]
>> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss
> 
> * Report datatracker and mailarchive bugs to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Michael Richardson <[email-masked]>
Date: Tue, 16 Mar 2021 17:27:03 -0400

> Why doesn't the datatracker serve the .html file for the BCP from the RFC Editor?

That's a good question!

I think that aside from reducing duplication, it would also raise the SEO of
that copy, and I think that we want to point more to rfc-editor.org, where errata,
etc. are best available.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide