Subject: [Tools-discuss] Unicode decode error for RFCs

From: "Paul Hoffman" <[email-masked]>
Date: Sat, 03 Apr 2021 19:23:11 -0700

See https://tools.ietf.org/html/rfc9007

(Hat tip to https://twitter.com/elithebearded/status/1378520379229044736 
for pointing it out, and the @FakeUnicode Twitter user for reposting.)

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 4 Apr 2021 15:41:21 +1200

Paul,

https://datatracker.ietf.org/doc/html/rfc9007 is OK. And the tools repository is going away anyway. Maybe the Twitterland needs to be told.

https://www.rfc-editor.org/rfc/rfc9007.html is even more OK. I mean, who cares about the htmlized versions of HTML RFCs?

Regards
   Brian Carpenter

On 04-Apr-21 14:23, Paul Hoffman wrote:
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 4 Apr 2021 09:36:41 +0200

On 4. Apr 2021, at 05:41, Brian E Carpenter <[email-masked]> wrote:
> 
> Maybe the Twitterland needs to be told.

Did.

https://twitter.com/c4bo/status/1378611991212875779

Grüße, Carsten

---

From: "Paul Hoffman" <[email-masked]>
Date: Sun, 04 Apr 2021 09:14:28 -0700

On 3 Apr 2021, at 20:41, Brian E Carpenter wrote:

> https://datatracker.ietf.org/doc/html/rfc9007 is OK.

Of course. If it didn't, I would have reported that as well.

> And the tools repository is going away anyway.

"going to" does not help current programs that generate URLs to the site 
that has worked for a very long time.

> Maybe the Twitterland needs to be told.

That will be as useful as telling them that they should all be using 
IPv6 addressing. I'm not saying you shouldn't try, but I am saying that 
us doing so absolves us from the responsibility to maintain the current 
infrastructure.

> https://www.rfc-editor.org/rfc/rfc9007.html is even more OK. I mean, 
> who cares about the htmlized versions of HTML RFCs?

Everyone with tools that generates URLs to them.

--Paul Hoffman

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 4 Apr 2021 18:19:24 +0200

> Everyone with tools that generates URLs to them.

Cool URIs are stable [1].
Those URIs are not going away.
Google still prioritizes them.
Thousands of RFC, I-Ds, papers, articles, blog entries reference them.
(And the above tools still generate them.)

I genuinely hate to say this, but at some point we’ll need to find a way to take control of what is behind these URIs.

Grüße, Carsten

[1]: https://www.w3.org/Provider/Style/URI.html

---

From: Julian Reschke <[email-masked]>
Date: Sun, 4 Apr 2021 19:55:42 +0200

Am 04.04.2021 um 18:19 schrieb Carsten Bormann:
> ...

True. Maybe just redirect?

Best regards, Julian

---

From: "Paul Hoffman" <[email-masked]>
Date: Sun, 04 Apr 2021 11:36:38 -0700

On 4 Apr 2021, at 10:55, Julian Reschke wrote:

>> I genuinely hate to say this, but at some point we’ll need to find 
>> a way to take control of what is behind these URIs.
>> ...
>

That would be the easiest solution to implement and, at the same time, 
the most flexible for the future.

--Paul Hoffman

---

From: Hoi lam Poon <[email-masked]>
Date: Mon, 5 Apr 2021 03:25:22 +0800

不用說了，你們working group, 跟world press,
tools一樣，跟github一起跟特朗普合作，我不會再相信你們，而且你們只是因為有他們做保護傘，我會改變到，你們連被害的鎖匙也沒有回收，一直用，我看到是在中國支付寶，保安公司及一個人用我女朋友被搶的iphone8手機轉移金錢，你們全部已不可相信，別讓我有機會，我已開始找一個人協助我，而且就算那人不協助，我，永遠也不會再用鎖匙做任何事，我鎖匙是複製不到的，你們搶走是錢，用不完？用不完就不用再找我吧，好笑，一群無知的人，我會把你們封鎖，全部人，也別想用測試去騙我把程式讓你們更新，所有平台我也不會上去，我不會讓你們得到，死心吧，你們只是貪心的人，過去，做了多少年，也沒作用，因為你們全已背叛她一家人，去死吧，別再打擾我，終有一天我會追究你們全部人，癈物

在 2021年4月5日 週一 01:56，Julian Reschke <[email-masked]> 寫道：

> > I genuinely hate to say this, but at some point we’ll need to find a way
> to take control of what is behind these URIs.
> > ...
>
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 5 Apr 2021 08:39:02 +1200

> the most flexible for the future.

My understanding from a recent message from Robert Sparks is that this
is already the plan.

By the way, I apologise that my original reply to Paul could be read
as dismissive. That wasn't at all my intention.

    Brian

---

From: Nico Williams <[email-masked]>
Date: Sun, 4 Apr 2021 16:06:29 -0500

On Sun, Apr 04, 2021 at 03:41:21PM +1200, Brian E Carpenter wrote:
> I mean, who cares about the htmlized versions of HTML RFCs?

I do.  I like them better.

---

From: Michael Richardson <[email-masked]>
Date: Sun, 04 Apr 2021 18:15:39 -0400

Paul Hoffman <[email-masked]> wrote:
    >>> Cool URIs are stable [1].  Those URIs are not going away.  Google
    >>> still prioritizes them.  Thousands of RFC, I-Ds, papers, articles,
    >>> blog entries reference them.  (And the above tools still generate
    >>> them.)
    >>>
    >>> I genuinely hate to say this, but at some point we’ll need to find a
    >>> way to take control of what is behind these URIs.  ...
    >>

    > the most flexible for the future.

I wonder if putting a robots.txt on tools.ietf.org would also be helpful to
direct search engines away from it.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Nico Williams <[email-masked]>
Date: Sun, 4 Apr 2021 18:02:21 -0500

> direct search engines away from it.

It would, but it wouldn't guarantee good results.

---

From: "Salz, Rich" <[email-masked]>
Date: Mon, 5 Apr 2021 15:53:08 +0000

> I mean, who cares about the htmlized versions of HTML RFCs?

I also like them better.  I can also read them on any device (yeah, responsive design).

If we're writing for the Internet, text/html is way more important and useful than text/plain.

---

From: Nico Williams <[email-masked]>
Date: Mon, 5 Apr 2021 14:24:16 -0500

> I also like them better.  I can also read them on any device (yeah,

But I mean specifically the htmlized versions versus HTML produced by
xml2rfc or any XSLT conversion.

I like the pagination (yes, yes, I know, we as a community want to stop
paginating).  I like the way footers and headers are rendered.  I like
the metadata header at the top with the version history, alternative
formats links, and datatracker/nits/IPR/diffs links.

I accept that we'll eventually lose the pagination, but a) the
tools.ietf.org URIs are kinda useful now just because they are so
recognized, b) we should really not lose the metadata header.

> If we're writing for the Internet, text/html is way more important and

I read these things in $PAGER as much as in $BROWSER.  I don't mind the
text.  I just don't want to lose all the value provided by the htmlize
tool right now.

---

From: "Paul Hoffman" <[email-masked]>
Date: Mon, 05 Apr 2021 12:29:08 -0700

PLEASE, PEOPLE!

Every mail thread that involves RFCs does not have to turn into "text 
versus HTML" or "paginated versus unpaginated". I sincerely believe 
everything that can be said about those topics has already been said and 
heard by whomever is going to update the v3 specification.

Don't make me create an update to Godwin's Law about this.

--Paul Hoffman

---

From: Nico Williams <[email-masked]>
Date: Mon, 5 Apr 2021 14:33:28 -0500

On Mon, Apr 05, 2021 at 12:29:08PM -0700, Paul Hoffman wrote:
> [...]

Yes, but please please lets not lose the metadata at the top.  It is
much too useful.

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 6 Apr 2021 08:21:10 +1200

> Yes, but please please lets not lose the metadata at the top.  It is

It's not lost, e.g.:
https://datatracker.ietf.org/doc/html/draft-ietf-anima-grasp-api-10

   Brian

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 5 Apr 2021 16:22:20 -0400

Nico,

The tools functionality has been replicated in the datatracker.

See, for example.
https://datatracker.ietf.org/doc/html/draft-ietf-mpls-mldp-yang-08 .

Cheers,
Andy

---

From: Robert Sparks <[email-masked]>
Date: Mon, 5 Apr 2021 16:57:34 -0500

Replying to this, even though the thread has mostly moved on, to point 
at a detail that we need to remember.

> https://www.rfc-editor.org/rfc/rfc9007.html is even more OK. I mean, who cares about the htmlized versions of HTML RFCs?

Other systems (software, SDOs) need to be able to point at the 
appropriate thing for both old and new RFCs. There's been a strong 
preference in the past to point to the HTMLized versions for many reasons.

For pre-v3 era RFCs, the htmlized versions is what we have - we do not 
have the xml2rfc v3 html output, and it is not currently on any plan to 
try to retroactively create any such thing.

Asking software and other SDOs to learn to use two different URL 
patterns (one before and one after the v3 switch) is not likely to be heard.

RjS

---

From: Jay Daley <[email-masked]>
Date: Tue, 6 Apr 2021 10:04:38 +1200

Just a reminder to all - there is a detailed RFC and I-D publication feature matrix

	https://docs.google.com/spreadsheets/d/1Ljj4QV6YmvQo4F8MtydZH9owvwH-dMOJcwSaz5CW4E0/edit?usp=sharing

Jay

> On 6/04/2021, at 8:22 AM, Andrew G. Malis <[email-masked]> wrote:
> 
> Nico,
> 
> See, for example. https://datatracker.ietf.org/doc/html/draft-ietf-mpls-mldp-yang-08 <https://datatracker.ietf.org/doc/html/draft-ietf-mpls-mldp-yang-08> .
> 
> Cheers,
> Andy
> 
> 
> On Mon, Apr 5, 2021 at 3:33 PM Nico Williams <[email-masked] <mailto:[email-masked]>> wrote:
> Tools-discuss mailing list - [email-masked] <mailto:[email-masked]>
> * Report datatracker and mailarchive bugs to: [email-masked] <mailto:[email-masked]>
> * Report tools.ietf.org <http://tools.ietf.org/> bugs to: [email-masked] <mailto:[email-masked]>
> * Report all other bugs or issues to: [email-masked] <mailto:[email-masked]>
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss>

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 6 Apr 2021 10:05:04 +1200

> patterns (one before and one after the v3 switch) is not likely to be heard.

Indeed. I believe the RFC Editor would prefer us to use their landing pages like
https://www.rfc-editor.org/info/rfc9007 or https://www.rfc-editor.org/info/rfc1,
but I'm not sure that will catch on.

    Brian

---

From: Nico Williams <[email-masked]>
Date: Mon, 5 Apr 2021 21:34:09 -0500

> https://datatracker.ietf.org/doc/html/draft-ietf-anima-grasp-api-10

I should have completed my thought: don't lose ... when you switch to
non-paginated HTML rendering.

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Tue, 6 Apr 2021 16:18:56 +0000

> https://www.rfc-editor.org/info/rfc9007 or https://www.rfc-editor.org/info/rfc1 ,

As someone who has perpetrated numerous egregious xrefs to RFCs using the tools 
url (mostly from BBF docs), I have a few comments.
 - This conversation has been very educational. Thx.
 - I did point to the tools html version because it was historically by far the most readable on-line rendition
 - I now recognize the error of my ways. What I find at "https://www.rfc-editor.org/info/rfc<nnnn>"
does look like what I should be using. I also see the "Cite" links there are very helpful, and both
point to this rfc-editor.org/info url. That's good and makes it a useful permalink for citations.
 - The fact that I have to click once more (from the info page) to get an actual rendering of the RFC
is ameliorated by the fact I have a choice of renderings. So that's ok. And I really like the new rfc-editor
html rendering with pinned ToC on the right. That's much better than the tools rendering.
 - I'll be using the rfc-editor info link from here on out and will work to change existing docs when the
opportunity arise. I shall be evangelizing this wherever I go.
 - The datatracker bibtex data provides an url of rfc-editor.org/rfc/rfc9006.txt (note the ".txt" at the end).
This is a much less useful url than the info url. Any chance of getting that changed?

Thx,
Barbara