Subject: [Tools-discuss] Bizarre error in bibxml3

From: Brian E Carpenter <[email-masked]>
Date: Tue, 27 Apr 2021 08:48:46 +1200

Hi,

One of the authors of draft-ietf-anima-asa-guidelines-00 is Pierre Peloso. In the XML source, he is correctly identified as <author fullname="Pierre Peloso" initials="P." surname="Peloso">. However, in  https://xml2rfc.tools.ietf.org/public/rfc/bibxml3/reference.I-D.ietf-anima-asa-guidelines.xml he is identified as <author initials="P" surname="Pierre" fullname="Peloso Pierre"></author> .

How on earth could such an inversion occur? (The other authors of the same draft are OK.)

Is it possible that this bug would occur for any author with the same initial letter for both components? Would we see <author initials="M" surname="Mickey" fullname="Mouse Mickey"></author> ?

Regards
   Brian Carpenter

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 26 Apr 2021 22:58:28 +0200

$ curl https://datatracker.ietf.org/doc/bibxml3/draft-ietf-anima-asa-guidelines/xml
<?xml version="1.0" encoding="UTF-8"?>
<reference anchor="I-D.ietf-anima-asa-guidelines">
   <front>
      <title>Guidelines for Autonomic Service Agents</title>
      <author fullname="Brian Carpenter">
	 </author>
      <author fullname="Laurent Ciavaglia">
	 <organization>Nokia</organization>
      </author>
      <author fullname="Sheng Jiang">
	 <organization>Huawei Technologies Co., Ltd</organization>
      </author>
      <author fullname="Pierre Peloso">
	 <organization>Nokia</organization>
      </author>
      <date month="November" day="14" year="2020" />
      <abstract>
	 <t>   This document proposes guidelines for the design of Autonomic Service
   Agents for autonomic networks, as a contribution to describing an
   autonomic ecosystem.  It is based on the Autonomic Network
   Infrastructure outlined in the ANIMA reference model, using the
   Autonomic Control Plane and the Generic Autonomic Signaling Protocol.

	 </t>
      </abstract>
   </front>
   <seriesInfo name="Internet-Draft" value="draft-ietf-anima-asa-guidelines-00" />
   <format type="TXT" target="https://www.ietf.org/archive/id/draft-ietf-anima-asa-guidelines-00.txt" />
</reference>

Datatracker doesn’t try to parse the name.
It seems the advice to switch to datatracker for bibxml3 still stands.

Grüße, Carsten

> On 26. Apr 2021, at 22:48, Brian E Carpenter <[email-masked]> wrote:
> 
> Hi,
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Julian Reschke <[email-masked]>
Date: Tue, 27 Apr 2021 05:55:01 +0200

Am 26.04.2021 um 22:58 schrieb Carsten Bormann:
> ...

Yes, but then it means that *xml2rfc* needs to parse the name. I'm
pretty sure that there will be edge cases where it doesn't get it right,
so it really would be good when datatracker would keep that information,
and used that for the generated reference files.

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 27 Apr 2021 08:25:39 +0200

> and used that for the generated reference files.

Indeed.  I think people with Spanish names now know better than to use their full names in fullname=“”, but maybe there is an example we can find…

Grüße, Carsten

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 27 Apr 2021 14:07:23 +0000

>    Indeed.  I think people with Spanish names now know better than to use their full names in fullname=“”, but maybe there is an example we can find…

How would they know this, especially someone knew to the IETF?  Is that common?

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 27 Apr 2021 17:32:05 +0200

> How would they know this, especially someone knew to the IETF?  Is that common?

I think most people with Spanish names that run around in English-speaking circles do know that Gringos (*) don’t grok their names.

When it actually comes to filling in fullname attributes of author elements, most people will actually look at the result (in particular if they know that their names are not well understood in other parts of the world) and adapt.

Grüße, Carsten

(*) grin·go| ˈɡrɪŋɡoʊ | 
noun (plural gringos) derogatory or humorous 

Please apply the humorous sense today.

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 27 Apr 2021 15:36:21 +0000

>   I think most people with Spanish names that run around in English-speaking circles do know that Gringos (*) don’t grok their names.

Gracias.  Such muy gringo.

(And that's about the extent of what I remember from high school Spanish.)

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 27 Apr 2021 17:45:18 +0200

On 2021-04-27, at 05:55, Julian Reschke <[email-masked]> wrote:
> 
> it really would be good when datatracker would keep that information,

It seems to do that at least in some cases where it is important (e.g., Peter Van der Stok), but not in others (input was <author fullname="Alberto Gonzalez Prieto" initials="A.” surname="Gonzalez Prieto”>).  Hmm.

Note that tools.ietf.org has

<author initials='A' surname='Prieto' fullname='Alberto Prieto'>
    <organization />
</author>

for the latter case, which is just slightly wronger.

(No comment about the spurious &qout;s.)

Grüße, Carsten

$ curl https://datatracker.ietf.org/doc/bibxml3/draft-anima-constrained-join-proxy-00.xml
<?xml version="1.0" encoding="UTF-8"?>
<reference anchor="I-D.anima-constrained-join-proxy">
   <front>
      <title>Constrained Join Proxy for Bootstrapping Protocols</title>
      <author initials="M." surname="Richardson" fullname="Michael Richardson">
         <organization>Sandelman Software Works</organization>
      </author>
      <author initials="P." surname="Van der Stok" fullname="Peter Van der Stok">
         <organization>vanderstok consultancy</organization>
      </author>
      <author initials="P." surname="Kampanakis" fullname="Panos Kampanakis">
         <organization>Cisco Systems</organization>
      </author>
      <date month="November" day="26" year="2020" />
      <abstract>
	 <t>   This document defines a protocol to securely assign a pledge to a
   domain, represented by an EST server, using an intermediary node
   between pledge and EST server.  This intermediary node is known as a
   &quot;constrained Join Proxy&quot;.

   This document extends the work of
   [I-D.ietf-anima-bootstrapping-keyinfra] by replacing the Circuit-
   proxy by a stateless/stateful constrained (CoAP) Join Proxy.  It
   transports join traffic from the pledge to the Registrar without
   requiring per-client state.

	 </t>
      </abstract>
   </front>
   <seriesInfo name="Internet-Draft" value="draft-anima-constrained-join-proxy-00" />
   <format type="TXT" target="https://www.ietf.org/archive/id/draft-anima-constrained-join-proxy-00.txt" />
</reference>

$ curl https://datatracker.ietf.org/doc/bibxml3/draft-ietf-netconf-yang-push-00.xml
<?xml version="1.0" encoding="UTF-8"?>
<reference anchor="I-D.ietf-netconf-yang-push">
   <front>
      <title>Subscribing to YANG datastore push updates</title>
      <author initials="A." surname="Clemm" fullname="Alexander Clemm">
         </author>
      <author initials="A. G." surname="Prieto" fullname="Alberto Gonzalez Prieto">
         </author>
      <author initials="E." surname="Voit" fullname="Eric Voit">
         </author>
      <date month="October" day="15" year="2015" />
      <abstract>
	 <t>   This document defines a subscription and push mechanism for YANG
   datastores.  This mechanism allows client applications to request
   updates from a YANG datastore, which are then pushed by the server to
   the client per a subscription policy, without requiring additional
   client requests.

	 </t>
      </abstract>
   </front>
   <seriesInfo name="Internet-Draft" value="draft-ietf-netconf-yang-push-00" />
   <format type="TXT" target="https://www.ietf.org/archive/id/draft-ietf-netconf-yang-push-00.txt" />
</reference>

---

From: "Paul Hoffman" <[email-masked]>
Date: Tue, 27 Apr 2021 09:33:54 -0700

During the discussions that led to XMLv3, I proposed that we get rid of 
the "initials" field altogether and only use full names or surnames. 
Using initials is a historic academic format created by people who 
didn't care about names that don't easily have clear initials.

My proposal failed, and yet we still have the same problems. I would be 
happy to again suggest that Internet Drafts and RFCs refer to authors by 
their actual names, not forced into a construct that is trivially shown 
to hamper both understanding while reading and searchability of our 
documents.

--Paul Hoffman