Subject: [Tools-discuss] Recommended new wiki product

From: Jay Daley <[email-masked]>
Date: Wed, 14 Apr 2021 09:41:56 +1200

Hi All

The requirements for a new wiki have been consulted on [1] and it has been confirmed on today’s call that there are no further changes.  Based on that we can now move to a recommendation for a new wiki product.

There are over a hundred wiki products available and an exhaustive requirements assessment has not been conducted.  Based on the agreed requirements, the following products have been evaluated and rejected:

	• MediaWiki
		• Markdown only supported by an unmaintained extension
		• Limited interface customization
		• Limited WYSIWYG editor
	• Confluence
		• Too costly.  It might be possible to get a free license but no guarantee that would always be available.
	• Dokuwiki
		• Uses the file system and not a database.
		• Markdown by default is experimental feature
	• TWiki
		• Will not support Markdown
		• Much more than just a wiki
	• Trac
		• Much more than a wiki product
		• Markdown plugin is unmaintained
		• Significant community hostility

The proposed product, that meets all the agreed requirements and meets them well is:

	• Wiki.js
		• Core Markdown with optional WYSIWYG
		• Core OIDC support
		• Very actively developed and supported with excellent documentation
		• Designed for containers
		• Core support for code snippets, maths expressions and diagrams
		• Core support for Git
		• Supports Matomo
		• Themes are weak in comparison to other products requiring a developer familiar with the NodeJS vue framework.
		• Runs on multiple databases including MySQL and PostgreSQL though may move to solely support PostgreSQL in the future.

Please let me know if you think there is a mistake in the assessment or there is another product that meets the requirements [1] better.

thanks
Jay

[1]  https://mailarchive.ietf.org/arch/msg/tools-discuss/OKPzIqdz79FAdrKcx9SNDGysUww/

-- 
Jay Daley
IETF Executive Director
[email-masked].

---

From: Jay Daley <[email-masked]>
Date: Wed, 21 Apr 2021 08:53:30 +1200

Just a reminder about this in case anyone was planning to comment but it got pushed down their stack.  Once this is settled we will be moving ahead with planning the migration.

Jay

> On 14/04/2021, at 9:41 AM, Jay Daley <[email-masked]> wrote:
> 
> Hi All
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Tom Pusateri <[email-masked]>
Date: Tue, 20 Apr 2021 16:59:34 -0400

> On Apr 13, 2021, at 5:41 PM, Jay Daley <[email-masked]> wrote:
> 
> Hi All
> 

Wiki.js looks like a nice product. The main problem I’ve had with products like this in the past is getting data out of them when you switch because you want to replace it or the project has been abandoned.

This product uses PostgreSQL in the long term and while the data will be there, it will likely require some custom programming to get it out for a migration.

My preference has been to use tools that store their data in flat files to reduce migration problems but as long as we understand this going in and are prepared to do what is needed to migrate the data or abandon it, I’m ok with it because I realize we can’t have all the features we want.

Tom