Subject: Re: [Tools-discuss] Gathering requirements for a new wiki

From: Jay Daley <[email-masked]>
Date: Fri, 9 Apr 2021 10:25:06 +1200

Just a reminder about this before we move to assess and recommend a new wiki platform based on the proposed features below.

Jay

> On 31/03/2021, at 2:06 PM, Jay Daley <[email-masked]> wrote:
> 
> I’m helping out the Tools Team PM (Robert) with the migration of functionality from tools.ietf.org and one area that needs addressing is wikis.  We currently use Trac to provide wikis though Trac itself has a broader applicability for software project management.  The Secretariat maintains a Trac installation at https://trac.ietf.org with separate instances for each current Working Group (WG), Directorate, Team, and most concluded WGs.  Some of the wiki instances only point to other resources, others are reasonably detailed, while the majority appear to be unused or broken (cannot be started). 
> 
> The full usage stats are:
> 
> 	• Total			364
> 	• Unused			157
> 	• Broken			28
> 	• In use - wiki		140
> 	• In use - issues	39
> 
> 
> We are proposing to replace Trac with a new wiki product and instead of having multiple public instances, have a single community wiki, with the existing pages copied over.  This will be a true community wiki with any member of the community able to add/change pages and reorganise as needed, moderated by other members of the community and the secretariat, and provided they have a datatracker login to authenticate with.  Private pages will be allowed, but their creation controlled by the admins.
> 
> In multiple small discussions with the community, the following requirements have emerged for new wiki software:
> 
> • Strategic
> 
> 	• Must be available at reasonable cost (to the IETF LLC) for possibly thousands of users.
> 
> 	• Must be widely used, well documented, actively developed and actively supported to ensure that we do not end up with a dead-end product.  This includes any required plugins.
> 
> 	• Must be a specific wiki product and not a larger product that includes a wiki as one part of its functionality, to prevent complications and overlaps with other tools.
> 
> 	• Must be scalable to support tens of thousands of users to support the full IETF community and reasonable future growth.
> 
> • Content
> 
> 	• Must support a text based input language.
> 
> 	• Must support code snippets, maths expressions and diagrams to enable the full representation of the same kind of content as found in I-Ds and RFCs.
> 
> 	• Must provide an excellent mobile experience.
> 
> 	• Must provide content backup, change visibility, and the ability to revert changes
> 
> 	• Should support Markdown by default for page content.
> 
> 	• Should support git for content backup and change visibility.
> 
> 	• Should provide a WYSIWYG editor for Markdown that can be used interchangeably with direct Markdown editing.
> 
> 	• Should have a themable interface to enable the wiki to be given a look and feel consistent with www.ietf.org.
> 
> • Integration
> 
> 	• Must support OIDC for authentication and role permissions.
> 
> 	• Must support custom module development.
> 
> 	• Should support Matomo for web analytics so that these can be integrated with our website statistics.
> 
> • Local management (if self-hosted)
> 
> 	• Must support either MySql/MariaDB or PostgreSQL as those are the database products supported by the IT operations team.
> 
> 	• Must run on Linux and should run in a Docker container to fit with the management processes of the IT operations team.
> 
> 
> We would like your views on these requirements so that we can move to assessing products.
> 
> 
> thanks
> Jay
> 
> -- 
> Jay Daley
> IETF Executive Director
> [email-masked]
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Fri, 9 Apr 2021 12:48:24 +0000

Thx Jay. One additional requirement occurred to me. It's one I've seen supported on all the platforms I'm familiar with, but it's probably best not to assume...

  *   Support for file attachments (via upload) on wiki pages

Barbara

Jay

On 31/03/2021, at 2:06 PM, Jay Daley <[email-masked]<mailto:[email-masked]>> wrote:

I'm helping out the Tools Team PM (Robert) with the migration of functionality from tools.ietf.org<https://urldefense.com/v3/__http:/tools.ietf.org__;!!BhdT!wNiWdlhm35XJVFSpBip00DgvnFLuOD2hmSN_FHgMqQB_i7UMV6WX3cQf8qj_qA$> and one area that needs addressing is wikis.  We currently use Trac to provide wikis though Trac itself has a broader applicability for software project management.  The Secretariat maintains a Trac installation at https://trac.ietf.org<https://urldefense.com/v3/__https:/trac.ietf.org__;!!BhdT!wNiWdlhm35XJVFSpBip00DgvnFLuOD2hmSN_FHgMqQB_i7UMV6WX3cSc4rxBfg$> with separate instances for each current Working Group (WG), Directorate, Team, and most concluded WGs.  Some of the wiki instances only point to other resources, others are reasonably detailed, while the majority appear to be unused or broken (cannot be started).

             * Total                                364
             * Unused                                           157
             * Broken                                            28
             * In use - wiki                    140
             * In use - issues 39

* Strategic

             * Must be available at reasonable cost (to the IETF LLC) for possibly thousands of users.

             * Must be widely used, well documented, actively developed and actively supported to ensure that we do not end up with a dead-end product.  This includes any required plugins.

             * Must be a specific wiki product and not a larger product that includes a wiki as one part of its functionality, to prevent complications and overlaps with other tools.

             * Must be scalable to support tens of thousands of users to support the full IETF community and reasonable future growth.

* Content

             * Must support a text based input language.

             * Must support code snippets, maths expressions and diagrams to enable the full representation of the same kind of content as found in I-Ds and RFCs.

             * Must provide an excellent mobile experience.

             * Must provide content backup, change visibility, and the ability to revert changes

             * Should support Markdown by default for page content.

             * Should support git for content backup and change visibility.

             * Should provide a WYSIWYG editor for Markdown that can be used interchangeably with direct Markdown editing.

             * Should have a themable interface to enable the wiki to be given a look and feel consistent with www.ietf.org<https://urldefense.com/v3/__http:/www.ietf.org__;!!BhdT!wNiWdlhm35XJVFSpBip00DgvnFLuOD2hmSN_FHgMqQB_i7UMV6WX3cSixktpMQ$>.

* Integration

             * Must support OIDC for authentication and role permissions.

             * Must support custom module development.

             * Should support Matomo for web analytics so that these can be integrated with our website statistics.

* Local management (if self-hosted)

             * Must support either MySql/MariaDB or PostgreSQL as those are the database products supported by the IT operations team.

             * Must run on Linux and should run in a Docker container to fit with the management processes of the IT operations team.

thanks
Jay

--
Jay Daley
IETF Executive Director
[email-masked]<mailto:[email-masked]>

___________________________________________________________
Tools-discuss mailing list - [email-masked]<mailto:[email-masked]>
This list is for discussion, not for action requests or bug reports.
* Report datatracker and mailarchive bugs to: [email-masked]<mailto:[email-masked]>
* Report tools.ietf.org bugs to: [email-masked]<mailto:[email-masked]>
* Report all other bugs or issues to: [email-masked]<mailto:[email-masked]>
List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss<https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/tools-discuss__;!!BhdT!wNiWdlhm35XJVFSpBip00DgvnFLuOD2hmSN_FHgMqQB_i7UMV6WX3cRoTvDkCA$>

--
Jay Daley
IETF Executive Director
[email-masked]<mailto:[email-masked]>

---

From: Jay Daley <[email-masked]>
Date: Tue, 13 Apr 2021 09:31:37 +1200

> On 10/04/2021, at 12:48 AM, STARK, BARBARA H <[email-masked]> wrote:
> 
> Thx Jay. One additional requirement occurred to me. It’s one I’ve seen supported on all the platforms I’m familiar with, but it’s probably best not to assume...
> Support for file attachments (via upload) on wiki pages

I will ensure that is included.

Jay

> On 31/03/2021, at 2:06 PM, Jay Daley <[email-masked] <mailto:[email-masked]>> wrote:
>  
> I’m helping out the Tools Team PM (Robert) with the migration of functionality from tools.ietf.org <https://urldefense.com/v3/__http:/tools.ietf.org__;!!BhdT!wNiWdlhm35XJVFSpBip00DgvnFLuOD2hmSN_FHgMqQB_i7UMV6WX3cQf8qj_qA$> and one area that needs addressing is wikis.  We currently use Trac to provide wikis though Trac itself has a broader applicability for software project management.  The Secretariat maintains a Trac installation at https://trac.ietf.org <https://urldefense.com/v3/__https:/trac.ietf.org__;!!BhdT!wNiWdlhm35XJVFSpBip00DgvnFLuOD2hmSN_FHgMqQB_i7UMV6WX3cSc4rxBfg$> with separate instances for each current Working Group (WG), Directorate, Team, and most concluded WGs.  Some of the wiki instances only point to other resources, others are reasonably detailed, while the majority appear to be unused or broken (cannot be started). 
> 
>              • Should have a themable interface to enable the wiki to be given a look and feel consistent with www.ietf.org <https://urldefense.com/v3/__http:/www.ietf.org__;!!BhdT!wNiWdlhm35XJVFSpBip00DgvnFLuOD2hmSN_FHgMqQB_i7UMV6WX3cSixktpMQ$>.
> 
> • Integration
> 
> [email-masked] <mailto:[email-masked]>
> 
> Tools-discuss mailing list - [email-masked] <mailto:[email-masked]>
> * Report datatracker and mailarchive bugs to: [email-masked] <mailto:[email-masked]>
> * Report tools.ietf.org bugs to: [email-masked] <mailto:[email-masked]>
> * Report all other bugs or issues to: [email-masked] <mailto:[email-masked]>
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss <https://urldefense.com/v3/__https:/www.ietf.org/mailman/listinfo/tools-discuss__;!!BhdT!wNiWdlhm35XJVFSpBip00DgvnFLuOD2hmSN_FHgMqQB_i7UMV6WX3cRoTvDkCA$>
>  
> -- 
> Jay Daley
> IETF Executive Director
> [email-masked] <mailto:[email-masked]>
-- 
Jay Daley
IETF Executive Director
[email-masked]