Subject: [Tools-discuss] XML2RFC version used by https://datatracker.ietf.org/submit/?

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 8 Jun 2021 18:22:41 -0500

I apologize for asking here, but I always get correct answers quickly. Have
you people thought about your incentive structure?

On https://datatracker.ietf.org/doc/draft-ietf-mops-streaming-opcons/, I,
and one co-author, are using this format of author with only a country
attribute specified for <postal>..

    <author initials="S." surname="Dawkins" fullname="Spencer Dawkins">
      <organization>Tencent America LLC</organization>
      <address>
        <postal>
          <country>United States of America</country>
        </postal>
        <email>[email-masked]</email>
      </address>
    </author>

That processes just fine with XML2RFC 3.8.0, but errors out when I try to
submit the XML file, which I try to provide so that it's available for
anyone doing updates in the future without conversion.

I remember seeing the same error before I updated to a newer version of
xml2rfc.

Is the submit tool using this version of XML2RFC on purpose?

I can still upload the TXT file, but since that's like the third preferred
input format out of three, I thought I should ask while my workaround still
works!

Best,

Spencer

---

From: Robert Sparks <[email-masked]>
Date: Wed, 9 Jun 2021 10:44:28 -0500

Hi Spencer -

The datatracker is using 3.8.0.

Could you send me your source xml (create a ticket and upload it if you 
have no other way) and/or send me the error you're seeing?

RjS

On 6/8/21 6:22 PM, Spencer Dawkins at IETF wrote:
> I apologize for asking here, but I always get correct answers quickly. 
> Have you people thought about your incentive structure?
>
> On https://datatracker.ietf.org/doc/draft-ietf-mops-streaming-opcons/ 
> <https://datatracker.ietf.org/doc/draft-ietf-mops-streaming-opcons/>, 
> I, and one co-author, are using this format of author with only a 
> country attribute specified for <postal>..
>
>         <email>[email-masked] 
> <mailto:[email-masked]></email>
>       </address>
>     </author>
>
> That processes just fine with XML2RFC 3.8.0, but errors out when I try 
> to submit the XML file, which I try to provide so that it's available 
> for anyone doing updates in the future without conversion.
>
> I remember seeing the same error before I updated to a newer version 
> of xml2rfc.
>
> I can still upload the TXT file, but since that's like the third 
> preferred input format out of three, I thought I should ask while my 
> workaround still works!
>
> Best,
>
> Spencer
>
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Mon, 14 Jun 2021 08:52:06 -0500

Hi, Robert,

> have no other way) and/or send me the error you're seeing?
I was getting this error from
https://github.com/ietf-wg-mops/draft-ietf-mops-streaming-opcons/blob/main/draft-ietf-mops-streaming-opcons.md,
converted to XML using kramdown-rfc2629 1.4.15 and kramdown 2.3.1.

I cleverly didn't record the error (sigh), but it was something very close
to "expecting (street:, city:, country:), got (country:).

I'd seen that before, on my system which was outdated, like a year ago, so
thought to ask.

I opened https://trac.ietf.org/trac/ietfdb/ticket/3305 about this, but
don't see a place to upload my XML file. Am I missing something? I am
logged in ...

I hope this helps!

Best,

Spencer

---

From: Robert Sparks <[email-masked]>
Date: Mon, 14 Jun 2021 08:59:36 -0500

Hi Spencer - look at the ticket again now for the ability to upload 
attachments (I added you to the set of people that can modify trac 
tickets, so your options should have changed).

RjS

On 6/14/21 8:52 AM, Spencer Dawkins at IETF wrote:
> Hi, Robert,
>
> On Wed, Jun 9, 2021 at 10:44 AM Robert Sparks <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi Spencer -
>
>     Could you send me your source xml (create a ticket and upload it
>     if you have no other way) and/or send me the error you're seeing?
>
> https://github.com/ietf-wg-mops/draft-ietf-mops-streaming-opcons/blob/main/draft-ietf-mops-streaming-opcons.md 
> <https://github.com/ietf-wg-mops/draft-ietf-mops-streaming-opcons/blob/main/draft-ietf-mops-streaming-opcons.md>, 
> I cleverly didn't record the error (sigh), but it was something very 
> close to "expecting (street:, city:, country:), got (country:).
>
> I'd seen that before, on my system which was outdated, like a year 
> ago, so thought to ask.
>
> I opened https://trac.ietf.org/trac/ietfdb/ticket/3305 
> <https://trac.ietf.org/trac/ietfdb/ticket/3305> about this, but don't 
> see a place to upload my XML file. Am I missing something? I am logged 
> in ...
>
> I hope this helps!
>
> Best,
>
> Spencer
>
>     RjS
>
>>     I apologize for asking here, but I always get correct answers
>>     quickly. Have you people thought about your incentive structure?
>>
>>     On
>>     https://datatracker.ietf.org/doc/draft-ietf-mops-streaming-opcons/
>>     That processes just fine with XML2RFC 3.8.0, but errors out when
>>     I try to submit the XML file, which I try to provide so that it's
>>     available for anyone doing updates in the future without conversion.
>>
>>     I remember seeing the same error before I updated to a newer
>>     version of xml2rfc.
>>
>>     preferred input format out of three, I thought I should ask while
>>     my workaround still works!
>>
>>     Best,
>>
>>     Spencer
>>
>>     Tools-discuss mailing list [email-masked]  <mailto:[email-masked]>
>>     * Report datatracker and mailarchive bugs to:[email-masked]  <mailto:[email-masked]>
>>     * Reporttools.ietf.org  <http://tools.ietf.org>  bugs to:[email-masked]  <mailto:[email-masked]>
>>     * Report all other bugs or issues to:[email-masked]  <mailto:[email-masked]>
>>     List info (including how to Unsubscribe):https://www.ietf.org/mailman/listinfo/tools-discuss  <https://www.ietf.org/mailman/listinfo/tools-discuss>
>