Subject: [Tools-discuss] Source repo for xml2rfc

From: Marc Petit-Huguenin <[email-masked]>
Date: Sat, 12 Jun 2021 08:30:22 -0700

Hi,

I got this messgae this morning when rebasing my local tree with the SVN repo for xml2rfc:

Can't create session: Unable to connect to a repository at URL 'https://svn.tools.ietf.org/svn/tools/xml2
rfc/trunk': The server at 'https://svn.tools.ietf.org/svn/tools/xml2rfc/trunk' does not support the HTTP/
DAV protocol at /usr/share/perl5/Git/SVN.pm line 717.

Was the SVN repo moved, and if that's the case where?

Thanks.

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug

---

From: Julian Reschke <[email-masked]>
Date: Sat, 12 Jun 2021 18:05:30 +0200

Am 12.06.2021 um 17:30 schrieb Marc Petit-Huguenin:
> Can't create session: Unable to connect to a repository at URL
> 'https://svn.tools.ietf.org/svn/tools/xml2
> rfc/trunk': The server at
> 'https://svn.tools.ietf.org/svn/tools/xml2rfc/trunk' does not support
> the HTTP/

It was indeed moved, but I don't know where exaclty either.

See also <https://trac.ietf.org/trac/xml2rfc/ticket/643>.

Best regards, Julian

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 12 Jun 2021 18:07:45 +0200

On 2021-06-12, at 18:05, Julian Reschke <[email-masked]> wrote:
> 
>> https://svn.tools.ietf.org/svn/tools/xml2rfc/trunk

The department of educated guessing produced:

https://svn.ietf.org/svn/tools/xml2rfc/trunk/

Grüße, Carsten

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sat, 12 Jun 2021 09:30:05 -0700

Thanks Julian and Carsteen, that works.

Looking at the history I see that it was updated with version 3.8.0, but I cannot find an announce at the usual places for that new version.  Is that accidental, our should I stop counting on a new version announce to rebase my copy?

Thanks.

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 12 Jun 2021 18:32:59 +0200

> Looking at the history I see that it was updated with version 3.8.0, but I cannot find an announce at the usual places for that new version.  Is that accidental, our should I stop counting on a new…

Indeed, I can’t find the announcement at the usual places (roc-markdown, xml2rfc, xml2rfc-dev).  I’d assume that was an omission.

Grüße, Carsten

---

From: Robert Sparks <[email-masked]>
Date: Mon, 14 Jun 2021 10:07:51 -0500

It certainly wasn't an intentional omission, but was a place that broke 
in the transition to releasing from the new repository location

I believe I found the spot that caused that to fail to go out, and will 
watch to make sure that the next release succeeds in sending those messages.

RjS

On 6/12/21 11:32 AM, Carsten Bormann wrote:
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Robert Sparks <[email-masked]>
Date: Mon, 14 Jun 2021 10:47:27 -0500

I also just reran the part of the script that sent that mail, so the 
message is in the archives, even if a bit late.

On 6/14/21 10:07 AM, Robert Sparks wrote:
> It certainly wasn't an intentional omission, but was a place that 
> broke in the transition to releasing from the new repository location
>
> I believe I found the spot that caused that to fail to go out, and 
> will watch to make sure that the next release succeeds in sending 
> those messages.
>
> RjS
>
>
>>> Looking at the history I see that it was updated with version 3.8.0, 
>>> but I cannot find an announce at the usual places for that new 
>>> version.  Is that accidental, our should I stop counting on a new 
>>> version announce to rebase my copy?
>> Indeed, I can’t find the announcement at the usual places 
>> (roc-markdown, xml2rfc, xml2rfc-dev).  I’d assume that was an omission.
>>
>> Grüße, Carsten
>>
>> List info (including how to Unsubscribe): 
>> https://www.ietf.org/mailman/listinfo/tools-discuss
>