Subject: [Tools-discuss] Rfcdiff v 0.12 feedback

From: Donald Eastlake <[email-masked]>
Date: Tue, 1 Jun 2021 13:46:35 -0400

Hi,

Some change seems to have been made to stop people from saving Diffs
from the Rfcdiff Web Service, https://tools.ietf.org/rfcdiff.

A very common scenario for me is that I am the pen holder on a draft
so I edit my source and produce a candidate new text file. I then want
to send it to co-authors or maybe a WG chair or whoever AND I would
like to send along a Diff from the currently posted. It used to work
just fine to use the Rfcdiff Tool to create a two column web page with
nice color coded differences that I could save as an html file and
ship along with the candidate new text file. Admittedly, recipients
could save the text attachment to my email and do the diff themselves
but I want to make it as easy as possible for them to see what's going
on so they can send me comments or an OK.

Now, if I do a save-as in Chrome while looking at the nice two column
color coded diff, it saves some html which just gets you back to the
Rfcdiff tool :-(  And if I print the web page to PDF, all the color
coding goes way :-(

Can this be fixed so there is some way to produce a file to share the
Rfcdiff output? Note: my candidate new text file is not web accessible
so I can't just send them a URL to do the diff...

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 1 Jun 2021 20:19:59 +0200

Weird, this form used to do a GET, which led to a reusable URL in the browser address line (see the bottom half of the page for how that is used).

(You can still have that after using this useful little bookmark on this form, which I have stored as “frmget”:

javascript:(function()%7Bvar%20x,i;%20x%20=%20document.forms;%20for%20(i%20=%200;%20i%20%3C%20x.length;%20++i)%20x%5Bi%5D.method=%22get%22;%20alert(%22Changed%20%22%20+%20x.length%20+%20%22%20forms%20to%20use%20the%20GET%20method.%20%20After%20submitting%20a%20form%20from%20this%20page,%20you%20should%20be%20able%20to%20bookmark%20the%20result.%22);%20%7D)();

.)

The form page now uses POST, which doesn’t make sense to me.

I can still save the resulting page and look at it in its full glory (both in Chrome and Safari, but of course the formats are different), so I cannot reproduce that part of the report.

But I want my GET back!
(Without needing to use the frmget hack, please.)

By the way, the rfcdiff is 1.48, only the form page seems to have a separate version number.
(Brew’s rfcdiff is still 1.46, which I have pinned now...)

Grüße, Carsten

> On 2021-06-01, at 19:46, Donald Eastlake <[email-masked]> wrote:
>

---

From: Robert Sparks <[email-masked]>
Date: Tue, 1 Jun 2021 14:22:44 -0500

What do you see at https://www.ietf.org/rfcdiff?

(That's the webservice that will have support going forward - the page 
at tools.ietf.org will likely start redirecting soon).

RjS

On 6/1/21 1:19 PM, Carsten Bormann wrote:
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Jay Daley <[email-masked]>
Date: Wed, 2 Jun 2021 07:26:59 +1200

> On 2/06/2021, at 6:19 AM, Carsten Bormann <[email-masked]> wrote:
> 

So that I’m clear - do you want to bookmark the GET in order to repeat the same diff?  In other words, if the result was stored indefinitely and a bookmarkable URL returned then would that be sufficient for you?  (not designing things here, just trying to understand the use case).

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Donald Eastlake <[email-masked]>
Date: Tue, 1 Jun 2021 17:01:30 -0400

If I do an Html wdiff and then a save-as, I get a .mht file which may
be adequate for my purposes.

However, poking around further, when I do a side-by-side Diff and
save-as in Chrome, there actually an option of one of three types of
Formats:
"Webpage, HTML only"
"Webpage, Single File" and
"Webpage, Complete"

The last of these produces a .html file that seems to do what I want!
The middle option produces a .mht file that gets an error if I try to
open it in Chrome. The first one produces a .html file that just takes
you to the Rfcdiff page in some odd mode. The problems I was
experiencing before were with the first choice of Format "Webpage,
HTML only"...

Thanks,
Donald

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 2 Jun 2021 09:33:32 +1200

Robert,

The behaviour of https://tools.ietf.org/rfcdiff definitely seems to have changed recently. For whatever reason, to save the actual html file of the side-by-side diffs, you now need to select the "Web page, complete" option in Firefox, which was unnecessary before. No problem once you know. As Donald says, saving this format can be very useful when working with co-authors.

I couldn't actually tell whether www.ietf.org/rfcdiff has changed. My browser seems to have decided that I want the "Web page, complete" option by 
default now ;-).

Regards
   Brian

On 02-Jun-21 07:22, Robert Sparks wrote:
>> I can still save the resulting page and look at it in its full glory (both in Chrome and Safari, but of course the formats are different), so I 
cannot reproduce that part of the report.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 1 Jun 2021 23:59:12 +0200

> So that I’m clear - do you want to bookmark the GET in order to repeat the same diff?  In other words, if the result was stored indefinitely and a bookmarkable URL returned then would that be suffi…

Not quite, because the file at one of the URLs might change.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 2 Jun 2021 00:01:43 +0200

> Not quite, because the file at one of the URLs might change.

… as in

https://tools.ietf.org/rfcdiff?url1=draft-ietf-asdf-sdf-05.txt&url2=https://raw.githack.com/ietf-wg-asdf/SDF/master/sdf.txt

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 2 Jun 2021 00:03:53 +0200

> https://tools.ietf.org/rfcdiff?url1=draft-ietf-asdf-sdf-05.txt&url2=https://raw.githack.com/ietf-wg-asdf/SDF/master/sdf.txt

… and that is even true for local files, e.g.

https://tools.ietf.org/rfcdiff?url1=draft-ietf-asdf-sdf&url2=https://raw.githack.com/ietf-wg-asdf/SDF/master/sdf.txt

(Note that there is no version number on url1, so it is the most recent one.)

Grüße, Carsten

---

From: Jay Daley <[email-masked]>
Date: Wed, 2 Jun 2021 10:34:05 +1200

> On 2/06/2021, at 9:59 AM, Carsten Bormann <[email-masked]> wrote:
> 

I see.  Some more questions:

- I’m guessing, though I don’t know, that the reason for a POST is so that a local file can be provided in the form body, which a GET cannot do.  Is that a use case you use? Of course it could switch from a GET to a POST in that situation but I don’t know what the impact of that is.

- Would a bookmarkable stored result with a 'refresh' button do the same thing?

- Is this just a time saver or is there another reason not to use the web form each time?  I ask because there are time saving techniques that can be adopted on web forms - 'recent diffs', 'favourites' etc.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 2 Jun 2021 00:53:59 +0200

On 2. Jun 2021, at 00:34, Jay Daley <[email-masked]> wrote:
> 
> 
> 
>> On 2/06/2021, at 9:59 AM, Carsten Bormann <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> On 2021-06-01, at 21:26, Jay Daley <[email-masked] <mailto:[email-masked]>> wrote:
>>> 
> - I’m guessing, though I don’t know, that the reason for a POST is so that a local file can be provided in the form body, which a GET cannot do.  Is that a use case you use?

I don’t (I have local copies of all IETF documents + a local installation of rfcdiff).

I use the web page:

— when I get a new draft mail — there is a convenient diff link in there, and I’d need to rsync first otherwise (*).
— to send the URL to other people (via mail, via GitHub README.md, telegram, …).

> Of course it could switch from a GET to a POST in that situation but I don’t know what the impact of that is.
> 

I’d need these other people to press the refresh button.

> - Is this just a time saver or is there another reason not to use the web form each time?  

See above.

> I ask because there are time saving techniques that can be adopted on web forms - 'recent diffs', 'favourites' etc.

I have no control over other people’s favorites…

Grüße, Carsten

(*) which can be slow, because the RFC editor tends to update files that didn’t change, so rsync needs to check all these files each time.
I don’t know who I need to talk to about how to update a file offered for rsync (i.e., don’t, unless it changed).

---

From: Jay Daley <[email-masked]>
Date: Wed, 2 Jun 2021 11:16:52 +1200

> On 2/06/2021, at 10:53 AM, Carsten Bormann <[email-masked]> wrote:
> 
> On 2. Jun 2021, at 00:34, Jay Daley <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> 
>> 

Got it - thank you. So

1.  If this functionality was only for files accessible over the web then a GET could be used each time.

2.  If a local file needs to be uploaded then that has to use a POST to send it.  It could possibly redirect to a GET using a stored copy of the uploaded file to provide this functionality

3.  Any storing/caching of the output would probably complicate matters considerably as we then need to take into account versioning, change detection and so on.

Sound about right?

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]