Subject: Re: [Tools-discuss] Hyperlinks to sections/subsections in current RFC HTML format

From: Toerless Eckert <[email-masked]>
Date: Wed, 16 Jun 2021 16:31:33 +0200

Thanks, Julian

Alas, the answer makes me wonder even more:

Where would i find an example of such an IETF draft/RFC rendered with CSS
page media attributes ? AFAIK, the older drafts/RFC do not do that,
instead they render page breaks explicitly. And the post-reform ones
do no contain those media attributes, right ?

Even if i had an appropriate attributed html file, i would still not
be able to persuade a normal browser to render the html with pagination ??

Cheers
    Toerless

On Tue, Jun 15, 2021 at 04:14:06AM +0200, Julian Reschke wrote:
> Am 15.06.2021 um 03:12 schrieb Toerless Eckert:
> > ...
> > But then again, afaik, css could by itself not take the current html and paginate it, so it too has its limits.
> > ...
> 
> HTML does support pagination. You just need to use the proper CSS paged
> media attributes (such as done by rfc2629.xslt=, and use a tools that
> takes advantage of them (such as PrinceXml or WeasyPrint).
> 
> Best regards, Julian
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Julian Reschke <[email-masked]>
Date: Wed, 16 Jun 2021 16:39:57 +0200

> do no contain those media attributes, right ?

xml2rfc inserts some of these, but not all.

rfc2629.xslt does, however. Example HTML output:
<https://greenbytes.de/tech/webdav/rfc7991.html>

> be able to persuade a normal browser to render the html with pagination ??

You could switch to "print preview"; but then, most browsers do ignore
most of the "paged media" related CSS.

You really need a tool designed for printing/pdfing HTML, such as
PrinceXML or WeasyPrint.

(you may want to read
<https://greenbytes.de/tech/webdav/rfc2629xslt/rfc2629xslt.html#output.pdf.html>)

Best regards, Julian