Subject: [Tools-discuss] Source for txt RFC htmlizer?

From: "John Levine" <[email-masked]>
Date: 25 Jun 2021 14:52:26 -0400

Apropos of all of the grousing about wrong section references in HTML-ized RFCs,
where's the source code for the tool?  I've looked in some obvious places and haven't found it.

R's,
John

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 25 Jun 2021 21:07:07 +0200

https://tools.ietf.org/tools/rfcmarkup/code

I think this is the current version

Sent from mobile, sorry for terse

> On 25. Jun 2021, at 20:52, John Levine <[email-masked]> wrote:
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: "John R Levine" <[email-masked]>
Date: 25 Jun 2021 15:48:32 -0400

> I think this is the current version

Thanks.  The displayed code says version 1.120 but the changelog says the 
latest version is 1.129.  I wonder where the code archive is.

>> where's the source code for the tool?  I've looked in some obvious places and haven't found it.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Robert Sparks <[email-masked]>
Date: Fri, 25 Jun 2021 15:16:52 -0500

Hi John, Carsten -

The thing you _really_ want to be looking at is rfc2html (that is what 
the datatracker is using - see https://pypi.org/project/rfc2html/), and 
the source for it is currently at 
http://svn.tools.ietf.org/svn/src/rfc2html/.

I expect to be moving it soon.

RjS

On 6/25/21 2:48 PM, John R Levine wrote:
> Thanks.  The displayed code says version 1.120 but the changelog says 
> the latest version is 1.129.  I wonder where the code archive is.
>
>
>>
>>> List info (including how to Unsubscribe): 
>>> https://www.ietf.org/mailman/listinfo/tools-discuss
>>
>
> Regards,

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 25 Jun 2021 22:26:50 +0200

On 25. Jun 2021, at 21:48, John R Levine <[email-masked]> wrote:
> 
> Thanks.  The displayed code says version 1.120 but the changelog says the latest version is 1.129.  I wonder where the code archive is.

Robert has the real answer to your original question, but the answer to this question is:

https://tools.ietf.org/tools/rfcmarkup/rfcmarkup-1.129.tgz

Grüße, Carsten

---

From: "John R Levine" <[email-masked]>
Date: 26 Jun 2021 12:17:32 -0400

> https://tools.ietf.org/tools/rfcmarkup/rfcmarkup-1.129.tgz

Thanks.

Since we evidently plan to keep using this, someone should adopt it and at 
least turn it from python2 into python3.

Regards,

---

From: "John Levine" <[email-masked]>
Date: 26 Jun 2021 12:42:30 -0400

>least turn it from python2 into python3.

Never mind, saw Robert's note.

R's,
John