Subject: [Tools-discuss] Robert: opening bug against rfcmarkup (was: Re: Hyperlinks to sections/subsections in current RFC HTML format)

From: Toerless Eckert <[email-masked]>
Date: Wed, 16 Jun 2021 03:02:47 +0200

Hi Robert

How do i open a bug against RFC rendering ? Julian thinks it is in the rfcmarkup tool,
but unlike other tools such as xml2rfc, i can not find a bug-trac under
https://tools.ietf.org/tools/rfcmarkup/

Problem:

  pre-reform html'ized RFC, example:  https://datatracker.ietf.org/doc/html/rfc7994
     The section numbers in the TOC are hotlinks to the sections.

  post-reform html'ized RFC, example: https://datatracker.ietf.org/doc/html/rfc8994
     The section numbers in the TOC are not hotlinks anymore, making it 
     impossible to click through from TOC to a particular section.
     This seems to be a bug, for example "Appendi A" is still a hotlink.
     All the sections still have their tags for hotlinks and in the
     section titles themselves these hotlinks are still used, just not in the TOC.

Thanks!
    Toerless

On Tue, Jun 15, 2021 at 11:56:09PM +0200, Julian Reschke wrote:
> Am 15.06.2021 um 23:14 schrieb Toerless Eckert:
> > Julian,
> > 
> > On Tue, Jun 15, 2021 at 04:17:01AM +0200, Julian Reschke wrote:
> > > Am 14.06.2021 um 22:33 schrieb Toerless Eckert:
> > > > Just don't know these days anymore where/how to submit a bugfix
> > > > request... whats the "tool" in question here ?
> > > 
> > > <https://tools.ietf.org/tools/rfcmarkup/> (unless datatracker runs
> > > something else; Robert Sparks would know).
> > 
> > Thanks!
> > 
> > > > > To fix this, the "htmlize" tool would need to be updated.
> > > > 
> > > > I think this is not an update, but a fix for a regression bug.
> > > 
> > > The tool is not broken; i't doing what it has been doing all the time.
> > > It's the *input* on what is runs that changed.
> > 
> > Please explain, so that the bug report i would write is as correct
> > as possible. AFAIK, the input did have section numbers before and past
> > the new rfc changes. Likewise do the htmlized output have section
> > heading tags before and after. Just after those section heading tags
> > have no hotlinks to them in the toc anymore.
> 
> After the format switch, the plain text version ceased to have page numbers.
> 
> Looking at this some more, I really do not understand yet why linking
> the section number string in the TOC entry does not work anymore. Might
> be a tiny change in the formatting that causes the regexp used for that
> not to work anymore.
> 
> Best regards, Julian

-- 
---
[email-masked]

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 16 Jun 2021 07:13:36 +0200

The bug is that we are still using rfcmarkup to generate the htmlized versions.
That was needed in the age of nroff, but since RFC 8650 it is really weird to throw away all the information that the XML has during rendering and then try to guess it back into existence in rfcmarkup.

xml2rfc should have an “htmlized” writer, which generates the same layout in the output as the text writer, just in the way that rfcmarkup has been doing it, but with information from the horse’s mouth.

Grüße, Carsten