Subject: Re: [Tools-discuss] IETF Administration LLC staffing update

From: Adam Roach <[email-masked]>
Date: Mon, 7 Jun 2021 21:04:26 -0700

[cc'ing the IESG for their awareness, since authority over the @ietf.org 
domain has historically been in their remit]

On 6/7/21 19:40, IETF Executive Director wrote:
> Lee-Berkeley is an experienced fundraiser, most recently with the Center for Democracy and Technology (CDT).  She is based in the United States and can be reached at [email-masked].

I'm surprised to see new personal addresses being provisioned under 
"@ietf.org". My recollection is that we had a discussion between the 
IESG and the LLC some while back (when I was still a member of the IESG) 
where we concluded that this is a confusing practice that might lead to 
conflicts in the future. The last I recall seeing on the topic was over 
a year ago, at which point it sounded like there was an active plan to 
move ahead with "@llc.ietf.org" email addresses:

https://mailarchive.ietf.org/arch/msg/tools-development/kxQjVyVdJtXeX6RWX2BTN-GMvTA/

Where do we stand on that plan, and what is the current thinking about 
how we might unwind in-use personal addresses under "@ietf.org"?

/a

---

From: Jay Daley <[email-masked]>
Date: Tue, 8 Jun 2021 16:59:33 +1200

Hi Adam

> On 8/06/2021, at 4:04 PM, Adam Roach <[email-masked]> wrote:
> 
> [cc'ing the IESG for their awareness, since authority over the @ietf.org domain has historically been in their remit]
> I'm surprised to see new personal addresses being provisioned under "@ietf.org". My recollection is that we had a discussion between the IESG and the LLC some while back (when I was still a member of the IESG) where we concluded that this is a confusing practice that might lead to conflicts in the future. 

I’ll leave the IESG to speak for themselves but I will note that this new email address was created with the permission of the IESG. The previous email for our Senior SDE did not have prior permission because I thought there was an agreement to use a specific naming scheme - [email-masked] - to avoid any possible future conflicts, but my recollection was off the mark and so this time I specifically sought permission. 

> The last I recall seeing on the topic was over a year ago, at which point it sounded like there was an active plan to move ahead with "@llc.ietf.org" email addresses:
> 
> Where do we stand on that plan, and what is the current thinking about how we might unwind in-use personal addresses under "@ietf.org"?

That email was not setting out a plan, only noting a number of possibilities. 

As I understand it, “conflicts in the future“ could mean either a naming conflict or a conflict of representation. The former can be addressed by a naming scheme such as initial.lastname if initialslastname is not sufficient. The latter is more complex as the LLC does represent the IETF but only in the limited areas of finance, meetings, legal compliance and contracts.  Any issue with confusion would come from someone in the LLC overstepping that in the content of their emails, no matter the form of their address. 

However, and in case there is any doubt, this is solely within the purview of the IESG to decide and not the LLC. 

Jay

-- 
Jay Daley
IETF Executive Director

---

From: Adam Roach <[email-masked]>
Date: Mon, 7 Jun 2021 22:21:28 -0700

On 6/7/21 23:59, Jay Daley wrote:
> I’ll leave the IESG to speak for themselves but I will note that this 
> new email address was created with the permission of the IESG. The 
> previous email for our Senior SDE did not have prior permission 
> because I thought there was an agreement to use a specific naming 
> scheme - [email-masked] - to avoid any possible future 
> conflicts, but my recollection was off the mark and so this time I 
> specifically sought permission. 

Okay -- this approach of continuing to grant exceptions differs 
materially and importantly from the conclusion that the IESG seated at 
IETF 104 reached. I can see how the current situation would be both 
frustrating for you and tenuous in general: an ad-hoc system of one-off 
approvals seems capricious and unsustainable, especially in the face of 
a steering group that changes composition every year.

As we all seem to be in agreement that the IESG has authority in this 
matter, I would implore this IESG to develop a formal position on the 
topic and write it down, both so that future IESGs have a point of 
reference for future decisions, and so that the community can be 
informed of decisions regarding stewardship of the ietf.org domain.

/a

---

From: Lars Eggert <[email-masked]>
Date: Tue, 8 Jun 2021 11:09:33 +0300

Hi,

On 2021-6-8, at 8:21, Adam Roach <[email-masked]> wrote:
> Okay -- this approach of continuing to grant exceptions differs materially and importantly from the conclusion that the IESG seated at IETF 104 reached.

that conclusion doesn't seem to have been minuted - we searched, but couldn't find anything. (I wish it had been.)

> I can see how the current situation would be both frustrating for you and tenuous in general: an ad-hoc system of one-off approvals seems capricious and unsustainable, especially in the face of a steering group that changes composition every year.
> 
> As we all seem to be in agreement that the IESG has authority in this matter, I would implore this IESG to develop a formal position on the topic and write it down, both so that future IESGs have a point of reference for future decisions, and so that the community can be informed of decisions regarding stewardship of the ietf.org domain.

Actually, the current IESG is currently finalizing a policy together with the LLC Board that should go for public comment soon.

Since Lee-Berkeley started before that could happen, we decided to approve [email-masked] as her personal email address. This is because she will almost exclusively interact with external individuals who may not have much familiarity with the IETF, and so an @ietf.org email address is therefore very helpful.

Thanks,
Lars

---

From: "Livingood, Jason" <[email-masked]>
Date: Tue, 8 Jun 2021 14:13:14 +0000

> Actually, the current IESG is currently finalizing a policy together with the LLC Board that should go for public comment soon.

Redirecting discussion away from email address formatting to this big news of hiring a fundraiser... :-)

I'd like to ask each of you (Adam, IESG, Tools Team) a personal favor -- please consider sending Lee-Berkeley a personal email warmly welcoming her to the IETF and maybe offering to setup a few minutes for a video chat. As well, please think of your personal/professional connections when you meet her - as perhaps you may in the future be able to make introductions to potential organizations or individuals that might be open to supporting the IETF financially. You all have amazing personal networks and can probably play a big supporting role in helping her (and the IETF) succeed in this effort!

Thanks!
Jason