Subject: [Tools-discuss] Fwd: Datatracker State Update Notice: <draft-ietf-dnsop-shared-root-server-01.txt>

From: Tim Wicinski <[email-masked]>
Date: Sat, 19 Jun 2021 14:47:47 -0400

I have a silly question.   In these emails, the state change is

State changed to None from WG Document

Which feels very counter intuitive, and always causes a double take.
Why does it not read

State changed from WG Document to None

Also, quotes around the state names make things more obvious.

Will gladly file said bug, though it is a nit.

tim

---------- Forwarded message ---------
From: IETF Secretariat <[email-masked]>
Date: Sat, Jun 19, 2021 at 2:38 PM
Subject: Datatracker State Update Notice:
<draft-ietf-dnsop-shared-root-server-01.txt>
To: <[email-masked]>, <[email-masked]>,
<[email-masked]>

State changed to None from WG Document

Datatracker URL:
https://datatracker.ietf.org/doc/draft-ietf-dnsop-shared-root-server/

---

From: Robert Sparks <[email-masked]>
Date: Tue, 22 Jun 2021 10:07:01 -0500

Hi Tim -

This one is frustrating - whichever way we state it (old to new, or new 
from old), several people chime in and want it the other way.

The last time we went through this, several IESG members pushed for the 
current form since it puts the most important bit of information (the 
state _now_) first.

We even with through iterations where we split the information onto 
multiple lines, and tried to emphasize (in plain-text) the new state, 
but pushback landed us where we are.

(Note that the new state is bolded on this history page for the document).

We can add quotes, and it would be nice to get other suggestions for how 
to make the message more useful - for instance, would it be helpful for 
the email message to say _who_ changed the state?

RjS

On 6/19/21 1:47 PM, Tim Wicinski wrote:
> From: *IETF Secretariat* <[email-masked] 
> <mailto:[email-masked]>>
> To: <[email-masked] <mailto:[email-masked]>>, 
> <[email-masked] 
> <mailto:[email-masked]>>, 
> <[email-masked] <mailto:[email-masked]>>
>
>
> <https://datatracker.ietf.org/doc/draft-ietf-dnsop-shared-root-server/>
>
>
>
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 22 Jun 2021 19:49:59 +0200

On Tue, Jun 22, 2021 at 10:07:01AM -0500, Robert Sparks wrote:
> Hi Tim -
> 
> This one is frustrating - whichever way we state it (old to new, or new from
> old), several people chime in and want it the other way.
> 
> current form since it puts the most important bit of information (the state
> _now_) first.

*Rotfl*

  State changed to None from WG Document
  You must unlearn what you have learned
  Named must be your fear before banish it you can

Kidding aside:

I think it is appropriate to let those who have to work with
Datatracker the most have the first pass at it's interface, but if there is
a conflict, maybe a compromise would be to change it slightly to something
that looks more like maybe router CLI instead of english yoda.

   State now: "None", prior: "WG Document"

Cheers
    Toerless

> We even with through iterations where we split the information onto multiple
> lines, and tried to emphasize (in plain-text) the new state, but pushback
> landed us where we are.
> 
> We can add quotes, and it would be nice to get other suggestions for how to
> make the message more useful - for instance, would it be helpful for the
> email message to say _who_ changed the state?
> 
> RjS
> 
> 

-- 
---
[email-masked]

---

From: Tim Wicinski <[email-masked]>
Date: Tue, 22 Jun 2021 16:24:51 -0400

Robert

Thanks for the explanation.  I am not shocked by what you described, which
means I've been involved in the IETF long enough.
I'm wondering if the Subject line could contain the new state?

Subject:  New Datatracker state Waiting for AD Go-Ahead <draft-ietf-....>

I went back and was looking in my email for datatracker update emails, and
they are not consistent.
Here are a few examples:

----
IESG state changed:
New State: Waiting for AD Go-Ahead::Revised I-D Needed

(The previous state was Waiting for AD Go-Ahead)
----
IANA action state changed to "In Progress"
----
The IETF WG state of draft-salgado-dnsop-rrserial has been changed to
"Adopted by a WG" from "Call For Adoption By WG Issued" by Tim Wicinski:
----
The DNSOP WG has placed draft-sury-toorop-dnsop-server-cookies in state
Candidate for WG Adoption (entered by Tim Wicinski)
----

Robert, I will be the first to say I should be ignored because my OCD can
drive
myself mad, let alone anyone else.  I also don't have any claims to what
makes the
most sense.

Feel free to ignore me now, as you more important things to worry about.

tim

On Tue, Jun 22, 2021 at 11:07 AM Robert Sparks <[email-masked]> wrote:

> multiple lines, and tried to emphasize (in plain-text) the new state, but
> pushback landed us where we are.
>
> to make the message more useful - for instance, would it be helpful for the