Subject: [Tools-discuss] FW: RFC 4301 - TOC links to appendices not working

From: "Salz, Rich" <[email-masked]>
Date: Tue, 1 Jun 2021 17:52:58 +0000

Forwarding for a friend.  We have realistic expectations about anything getting fixed. :)

From: "Matthias St. Pierre" <[email-masked]>
Date: Tuesday, June 1, 2021 at 9:17 AM
To: Rich Salz <[email-masked]>
Subject: RFC 4301 - TOC links to appendices not working

Hi Rich,

I noticed that the links to the appendices in the TOC of RFC 4301 are not working properly, only the links to subsections of the appendices. This does not seem to be a general problem, as the link for Appendix A of RFC 7296 below shows.

I’m on vacation and viewing with Safari on  my iPad, so I wasn’t able to view the page source to figure out whether the anchor is missing or misspelled. Also, I wouldn’t know how and where exactly to report this issue. So I thought, I’ll just drop you a short note and hope you’ll forward it to the right location.

Regards, Matthias

RFC 4301

https://datatracker.ietf.org/doc/html/rfc4301#appendix-B<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/rfc4301*appendix-B__;Iw!!GjvTz_vk!AZ7D25ujmwNS4VBFKMz-5QQgQdBEL-h0TUKrVjnyQXetCWUGj8TzjhDleV4q$>  (not ok)

https://datatracker.ietf.org/doc/html/rfc4301#appendix-B.1<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/rfc4301*appendix-B.1__;Iw!!GjvTz_vk!AZ7D25ujmwNS4VBFKMz-5QQgQdBEL-h0TUKrVjnyQXetCWUGj8TzjvxDnS7c$>  (ok)

RFC 7296

https://datatracker.ietf.org/doc/html/rfc7296#appendix-A<https://urldefense.com/v3/__https:/datatracker.ietf.org/doc/html/rfc7296*appendix-A__;Iw!!GjvTz_vk!AZ7D25ujmwNS4VBFKMz-5QQgQdBEL-h0TUKrVjnyQXetCWUGj8TzjtiA5OGl$> (ok)

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 1 Jun 2021 20:28:56 +0200

On 2021-06-01, at 19:52, Salz, Rich <rsalz=[email-masked]> wrote:
> 
> https://datatracker.ietf.org/doc/html/rfc4301#appendix-B  (not ok)

I’d guess the main appendix headings of 4301 don’t have the period/double-space that the htmlizer needs to recognize a heading.  My AUTH48 spies tell me there was some tinkering with that heading by the RFC editor, but that didn’t quite manage to hit the standard form.

I think this is going to be a solid WONTFIX...

Grüße, Carsten