Subject: Re: [Tools-discuss] [Gendispatch] Updating the IETF Discussion List Charter (was: Fwd: New Version Notification for draft-eggert-bcp45bis-02.txt)

From: "John Levine" <[email-masked]>
Date: 13 Jul 2021 16:14:29 -0400

It appears that Lars Eggert  <[email-masked]> said:
>On 2021-7-13, at 1:50, Eric Rescorla <[email-masked]> wrote:
>> With that said, there's no reason to be locked into the "one-size-fits-all" mailing list paradigm for this kind of automatic notification. Unlike ietf@, the number of people
>who send mail to ietf-announce is very small, so we don't really need to have it as a simple mailing list. Instead, what I would suggest is that we modify the automatic
>notification system to allow people to customize which notifications they want to receive (they can still allo appear to go to the same list, which could even be called
>ietf-announce if we want). That way, people can easily filter on the server side and get just the subset they care about. [0]
>> 
>> -Ekr
>> 
>> [0] We can of course still build an archive that has every announcement.
>
>I like this idea. Would this need to result in new custom datatracker code, or is there a third-party service that could be leveraged?
>
>(This part of the discussion should also probably move to tools-discus.)

You really, REALLY, do not want to try to reinvent a bulk mail system.

GNU Mailman has a little-used "topics" feature that I think can do the trick here.  The list manager configures
a set of topic regexps for the list, and subscribers can say which topics they want.  In each message the topic(s)
appear in the Subject or Keywords line and it sends the message to the people subscribed to the topics.  If you don't
pick any topics, by default you get all of them.

See https://www.gnu.org/software/mailman/mailman-member/node29.html

The interface within mailman to set the topics is pretty grody, but I presume it just puts stuff in the underlying
database so we could invent our own interface to it without extreme pain.

R's,
John

PS: Some of us don't subscribe to any IETF lists but instead retrieve the messages from the IMAP server, but I think we
can fend for ourselves.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Tue, 13 Jul 2021 17:43:36 -0400

The reason to not reinvent a bulk mail system is simple: It is a terrible
idea that has always sucked.

The Achilles heel of SMTP is that it is a push mode system. NNTP was better
because messages were pulled. An NNTP based discussion scheme would be a
much more effective way to manage 'mailing list' traffic because it is a
pull mode scheme.

The big mismatch between functionality and features here is that we are
trying to use SMTP as a workflow system which it is not what it is designed
to do.

A better solution would be an append only log of events such as ID
publication, RFC publication, interims, etc. that might trigger actions for
specific users and client software capable of processing those events on
the user's behalf according to rules specified by the user.

Sign the logs as a Merkle Tree and we have authenticated events and can do
more interesting stuff.

Of course, this is yet another of those 'things we could actually do with
crock-chain' which the crock-chain world completely ignores.

On Tue, Jul 13, 2021 at 4:14 PM John Levine <[email-masked]> wrote:

> >> With that said, there's no reason to be locked into the
> "one-size-fits-all" mailing list paradigm for this kind of automatic
> notification. Unlike ietf@, the number of people
> >who send mail to ietf-announce is very small, so we don't really need to
> have it as a simple mailing list. Instead, what I would suggest is that we
> modify the automatic
> >notification system to allow people to customize which notifications they
> want to receive (they can still allo appear to go to the same list, which
> could even be called
> >ietf-announce if we want). That way, people can easily filter on the
> server side and get just the subset they care about. [0]
> >>
> >> -Ekr
> >>
> >I like this idea. Would this need to result in new custom datatracker
> code, or is there a third-party service that could be leveraged?
> >
> appear in the Subject or Keywords line and it sends the message to the
> people subscribed to the topics.  If you don't
> The interface within mailman to set the topics is pretty grody, but I
> presume it just puts stuff in the underlying
> PS: Some of us don't subscribe to any IETF lists but instead retrieve the
> messages from the IMAP server, but I think we
> can fend for ourselves.
>
> --
> Gendispatch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/gendispatch
>

---

From: "John R Levine" <[email-masked]>
Date: 13 Jul 2021 17:52:19 -0400

> much more effective way to manage 'mailing list' traffic because it is a

That's why I have an IMAP->NNTP gateway and read all the lists from my 
news server.  The threading and killfiles are nice, too.  But as you know, 
I am strange.

> Sign the logs as a Merkle Tree and we have authenticated events and can do

Unfortunately, decades of experience tell us that the reason we all still 
use e-mail is that it *is* a push system, the stuff shows up 
automatically, and we all still check our e-mail.  If we have to check 
some whizzo other thing, we won't, and it will fail.  The news hack works 
for me because I put every mailing list I read from everywhere into it, so 
it's only one place to look.

R's,
John

>> GNU Mailman has a little-used "topics" feature that I think can do the trick here.

---

From: Jay Daley <[email-masked]>
Date: Mon, 19 Jul 2021 10:19:40 +1200

When it comes to letting people select the information that they want to get notified about, the concept of a list such as ietf-announce is perhaps a bit out of date.  Nowadays people simply use a form to say, I want this, this and that delivered to this mailbox and that to that mailbox and none of that please.  Behind the scenes this would probably best be implemented with API populated Mailman lists and possibly topics and I’m sure people would want the from address to be stay as [email-masked] <mailto:[email-masked]>, but it might actually be several lists in the background.

Jay

> On 14/07/2021, at 8:14 AM, John Levine <[email-masked]> wrote:
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "John R Levine" <[email-masked]>
Date: 18 Jul 2021 18:22:03 -0400

> When it comes to letting people select the information that they want to get notified about, the concept of a list such as ietf-announce is perhaps a bit out of date.  Nowadays people simply use a…

That's certainly a reasonable way to do it.  To minimize mysterious side 
effects in the mail archive and IMAP server, I'd do it with an API that 
adjusts the topics in one list and leave the lower level stuff alone.  I 
don't think that would be very hard.

R's,
John

>> PS: Some of us don't subscribe to any IETF lists but instead retrieve the messages from the IMAP server, but I think we

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly