Subject: [Tools-discuss] Fwd: [irsg] [EXTERNAL] Question about Codimd for w.g. minutes

From: Carsten Bormann <[email-masked]>
Date: Fri, 30 Jul 2021 00:06:57 +0200

Which markdown dialect(s) does the datatracker like these days?

(I’m asking because I need to know whether <br/> should be input as “  “ at the end of line (original brittle way), “\\” (not as widely used), or “<br/>” (ugly).)

Grüße, Carsten

> Begin forwarded message:
> 
> From: Carsten Bormann <[email-masked]>
> Subject: Re: [irsg] [EXTERNAL] Question about Codimd for w.g. minutes
> Date: 2021-07-29 at 23:37:19 CEST
> To: "STARK, BARBARA H" <[email-masked]>
> Cc: Working Group Chairs <[email-masked]>
> Archived-At: <https://mailarchive.ietf.org/arch/msg/wgchairs/jt_aPWObx7WFed-I7Won1IxNjvE>
> Archived-At: <https://mailarchive.ietf.org/arch/msg/irsg/NPtVuQ_rt3m8teinaDF8jMboCX0>
> Message-Id: <[email-masked]>
> 
> On 2021-07-29, at 22:13, STARK, BARBARA H <[email-masked]> wrote:
>> 
>> The main edit I do is to put blank lines between all paragraphs. Then I upload the .md file to datatracker.
> 
> I might throw a little tool that does that into the next kramdown-rfc revision.  Maybe just in time for other people’s minutes…
> 
> Grüße, Carsten
>

---

From: Robert Sparks <[email-masked]>
Date: Thu, 29 Jul 2021 18:19:57 -0500

I'm aiming to move all places markdown in the datatracker to render 
using https://github.com/Python-Markdown/markdown (not markdown2), 
providing extensions=['extra'] to the rendering call.

RjS

On 7/29/21 5:06 PM, Carsten Bormann wrote:
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 30 Jul 2021 01:43:06 +0200

OK, I’m mostly interested in minutes.

It seems markdown non-2 only has the super-brittle original markdown double end-of-line spaces and <br/>.  Not the choice I was hoping for, but maybe what was to be expected (this is not a well-lit part of the markdown landscape).

Grüße, Carsten

> On 2021-07-30, at 01:19, Robert Sparks <[email-masked]> wrote:
> 
> I'm aiming to move all places markdown in the datatracker to render using https://github.com/Python-Markdown/markdown (not markdown2), providing extensions=['extra'] to the rendering call.
> 
> RjS
> 
>

---

From: Robert Sparks <[email-masked]>
Date: Thu, 29 Jul 2021 19:32:30 -0500

Maybe we can provide out own extension that does better?

It would be a boon if there were a suppurted python renderer that followed the sane-for-server-side part of codimd’s renderer. 

Or maybe we push the rendering to the browser and leave the wont do js folks behind?

Sent from my iPhone

> On Jul 29, 2021, at 6:43 PM, Carsten Bormann <[email-masked]> wrote:
>

---

From: Bob Hinden <[email-masked]>
Date: Thu, 29 Jul 2021 17:39:36 -0700

Robert,

I hope we can make sure that the common tools like Codimd and the Datatracker do compatible things.   I ran into this today uploading the 6man minutes.

I now know more about mark down that I wanted to know :-)

Bob

> On Jul 29, 2021, at 5:32 PM, Robert Sparks <[email-masked]> wrote:
>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 30 Jul 2021 02:52:14 +0200

> Maybe we can provide out own extension that does better?

We could.

GitHub went the other direction and stopped trying to fragment the markdown community.

What I called “GFM” really is the GFM of five years ago; GitHub now does soft-wrapping like everyone else and it one of the truest followers of commonmark.

I think CodiMD is the outlier here because it is really easier to type up things interactively using hard-wrapping; the benefits of soft-wrapping come in when you store the documents, do edits and diffs etc.

So I think the upload could indeed offer an option to convert CodiMD markdown to standard markdown (while still allowing people to upload standard markdown as well).
Or people continue to do the conversion on their laptops, e.g. before/after they edit the notes.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 30 Jul 2021 13:13:50 +0200

On 2021-07-30, at 02:39, Bob Hinden <[email-masked]> wrote:
> 
> I hope we can make sure that the common tools like Codimd and the Datatracker do compatible things.   

I have been informed by a friendly HedgeDoc maintainer (HedgeDoc = independent open-source version of CodiMD) that this is easy to achieve [0].  Just insert

---
breaks: false
...

at the start of the CodiMD document and all will be standard(*).

(This also can be set system-wide, but that might break existing documents written without this.)

I’d stick with the CodiMD default `breaks: true`, though, as this is nicer for note-taking; see [1] for the discussion that led to this being the default for hedgedoc.  This is where the de-gfm tool that is now in kramdown-rfc will come in handy.  Or let CodiMD do the HTML conversion, but then there is no standard markdown to put into repos etc.

Grüße, Carsten

[0]: https://demo.hedgedoc.org/s/yaml-metadata#breaks

(*) note that the docs say

---
breaks: false
---

(probably because it’s more pleasingly symmetrical) but that is not standard YAML, so I recommend the three-dot version (which is also the one accepted in kramdown-rfc documents.).

[1]: https://community.hedgedoc.org/t/should-we-change-the-hedgedoc-default-for-breaks-from-true-to-false/298
Beautiful “vote” in there!

---

From: David Mehren <[email-masked]>
Date: Fri, 30 Jul 2021 13:48:51 +0200

Hi everyone, another HedgeDoc maintainer here.

Am 30.07.21 um 13:13 schrieb Carsten Bormann:
> I have been informed by a friendly HedgeDoc maintainer (HedgeDoc = independent open-source version of CodiMD) that this is easy to achieve [0].
HedgeDoc is actually the same project that released CodiMD 1.6 (which is 
the version currently deployed at codimd.ietf.org). We renamed to reduce 
confusion with the project that we forked from. More details can be 
found on our history page at [1].
> (This also can be set system-wide, but that might break existing documents written without this.)
There currently is no system-wide setting that would override existing 
notes. An administrator can set the default content for *new* notes, as 
outlined in [2]. This may actually be the solution for your instance?

I would recommend to upgrade the instance at codimd.ietf.org to HedgeDoc 
1.8.2, as previous releases have multiple security vulnerabilities (see 
[3]).

Best regards
David

[1] https://hedgedoc.org/history/
[2] https://github.com/hedgedoc/hedgedoc/issues/59#issuecomment-489188611
[3] https://github.com/hedgedoc/hedgedoc/security/advisories?state=published