Subject: [Tools-discuss] Google Scholar not indexing Internet-Drafts

From: Marc Petit-Huguenin <[email-masked]>
Date: Wed, 28 Jul 2021 10:15:01 -0700

Hi,

We had this discussion already on ietf@ (https://mailarchive.ietf.org/arch/msg/ietf/I0BIw22bhd99buZz9lE-kFcrFGI/), but the problem is still there.

Anything from arXiv is indexed, so I do not see why Internet-Drafts could not get the same treatment.  It in fact put IETFers at a disadvantage.

What need to be done, and how can I help?

Thanks.

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug

---

From: "John Levine" <[email-masked]>
Date: 28 Jul 2021 23:39:51 -0400

>We had this discussion already on ietf@ (https://mailarchive.ietf.org/arch/msg/ietf/I0BIw22bhd99buZz9lE-kFcrFGI/), but the problem is

I thought we fixed it but I'll take a look.  Might be meta tags, might be too convoluted paths
from the home pages.

R's,
John

---

From: "John Levine" <[email-masked]>
Date: 28 Jul 2021 23:52:32 -0400

>Anything from arXiv is indexed, so I do not see why Internet-Drafts could not get the same treatment.  It in fact put IETFers at a disadvantage.

They're not even indexing RFCs, other than some old ones where it finds copies that the ACM has.  Yow.

R's,
John

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 29 Jul 2021 16:02:07 +1200

> They're not even indexing RFCs, other than some old ones where it finds copies that the ACM has.  Yow.

It depends, apparently. They have RFC 8799 (cited by 3, and one of those citations was only published this month).

    Brian

---

From: Warren Kumari <[email-masked]>
Date: Thu, 29 Jul 2021 12:41:02 -0400

On Wed, Jul 28, 2021 at 11:52 PM John Levine <[email-masked]> wrote:

> >We had this discussion already on ietf@ (
> https://mailarchive.ietf.org/arch/msg/ietf/I0BIw22bhd99buZz9lE-kFcrFGI/),
> but the problem is
> >still there.
> >
> >Anything from arXiv is indexed, so I do not see why Internet-Drafts could
> not get the same treatment.  It in fact put IETFers at a disadvantage.
>

Citation needed.

Searching for bits from the abstract of a random selection of recently
published documents gives:
https://www.google.com/search?q=This+document+defines+a+BGP+path+attribute+known+as+the+%22Tunnel+Encapsulation+attribute%22

https://www.google.com/search?q=%22This+document+describes+a+new+Uniform+Resource+Name+%28URN%29+namespace%22

https://www.google.com/search?q=%22This+document+defines+a+process+experiment+under+RFC+3933%22

In an incognito window, the RFC Editor result was the first, second or
third result for all of these...

W

>
> R's,
> John
>
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

-- 
The computing scientist’s main challenge is not to get confused by the
complexities of his own making.
  -- E. W. Dijkstra

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 29 Jul 2021 09:45:32 -0700

> third result for all of these...

This is about Google Scholar.

---

From: "John R Levine" <[email-masked]>
Date: 29 Jul 2021 12:57:06 -0400

>> copies that the ACM has.  Yow.

Try site:rfc-editor.org or site:tools.ietf.org and you get nothing,

> third result for all of these...

There's two separate issues here.  While Google does index our web sites, 
the results are pretty random.  Once the tools server is retired, some 
sitemaps and meta tags would help.  The sitemap on datatracker.ietf.org 
only includes IPR disclosures and liason statements which seems 
suboptimal.  rfc-editor.org has no sitemap at all.

The other issue is that Google Scholar isn't finding any of the three 
copies of RFCs on our servers.  Our file formats leave something to be 
desired (there are industry standard HTML tags for bibliographic info 
which we don't use) but I don't think that's it, because it found a copy 
of a recent HTML RFC on Brian Carpenter's institution's site.

I think I will try some experiments with sitemaps, and maybe try adding 
the industry standard citation tags that Google says they prefer.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Warren Kumari <[email-masked]>
Date: Thu, 29 Jul 2021 12:58:30 -0400

> This is about Google Scholar.
Oh, yes, you are right -- I'd completely managed to swap out the context of
this thread...
<blush>
W

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 30 Jul 2021 13:28:07 +0200

On 2021-07-29, at 18:57, John R Levine <[email-masked]> wrote:
> 
> The other issue is that Google Scholar isn't finding any of the three copies of RFCs on our servers.

Ages ago I had copies of all RFCs in some PDF form on our servers and finally got some bibliography servers to index them.  That must have been 15 years or more ago, I don’t remember the details.

Clearly, Google Scholar should be taught to find the canonical RFCs at https://rfc-editor.org/rfc - having many secondary copies is an SEO anathema.

Internet-Drafts, hmm.  Many are not arxiv quality, and we don’t want the I-D repository as a dumping ground for people who just want to get their garbage into Scholar.  But the main problem is that the references to the drafts will stay active even when the RFC has been published(*) (or the I-D replaced), so we should be very careful with what we offer under the URI that will be indexed.

Let’s stop kicking the can on the doc.ietf.org thing!

Grüße, Carsten

(*) E.g., I get https://tools.ietf.org/id/draft-ietf-core-observe-09.html as the first hit for CoAP Observe.  No metadata block, seven versions off, ...

---

From: "John R Levine" <[email-masked]>
Date: 30 Jul 2021 07:35:11 -0400

> Clearly, Google Scholar should be taught to find the canonical RFCs at https://rfc-editor.org/rfc - having many secondary copies is an SEO anathema.

Right.  I hope some sitemaps will help.

> Internet-Drafts, hmm.  Many are not arxiv quality, and we don’t want the 
> I-D repository as a dumping ground for people who just want to get their 
> garbage into Scholar.  But the main problem is that the references to 
> the drafts will stay active even when the RFC has been published(*) (or 
> the I-D replaced), so we should be very careful with what we offer under 
> the URI that will be indexed.

I agree they're not what Scholar is looking for.

I'm not worried about people gaming it, you should be able to get anything 
into Scholar if you put it on a web server with the right metadata, but 
the last thing I want is yet another reason people will imagine that every 
I-D is an Internet Standard.

Regards,

---

From: Julian Reschke <[email-masked]>
Date: Fri, 30 Jul 2021 17:09:43 +0200

Am 30.07.2021 um 13:35 schrieb John R Levine:
>> Clearly, Google Scholar should be taught to find the canonical RFCs at
>> https://rfc-editor.org/rfc - having many secondary copies is an SEO
>> anathema.
>
> ...

That would be surprising, but would be good to know.

That said, as acting RFC Editor, why don't you just ask them?

Best regards, Julian

---

From: Jay Daley <[email-masked]>
Date: Sat, 31 Jul 2021 07:17:15 +1200

> On 30/07/2021, at 11:28 PM, Carsten Bormann <[email-masked]> wrote:
> 

Do you have a link to a more detailed statement of why we should have doc.ietf.org <http://doc.ietf.org/> ?

Jay

> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Lars Eggert <[email-masked]>
Date: Fri, 30 Jul 2021 22:33:18 +0300

On 2021-7-30, at 22:17, Jay Daley <[email-masked]> wrote:
> Do you have a link to a more detailed statement of why we should have doc.ietf.org ?

And what is meant by it? I have no other email that mentions doc.ietf.org.

Thanks,
Lars

---

From: Robert Sparks <[email-masked]>
Date: Fri, 30 Jul 2021 14:42:11 -0500

A quick skim of this might help provide context:

https://mailarchive.ietf.org/arch/search/?q=doc.ietf.org

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 31 Jul 2021 09:00:14 +1200

Several times, I've been asked to claim I-Ds by Google Scholar and have
rejected them. I doubt if there's an active feed, but if they analyze the
citations in a publication that cites an I-D, it will get into their system.

The fact that they point to a University of Auckland site for RFC8799
is direct proof that they either index the university's publication
repository, or that they index the entirety of repositories based on
symplectic.co.uk.

They do have some very strange things, though. With a little effort,
you can extract this citation:
@article{carpenter1994aeiou,
  title={AEIOU: Address extension by IP option usage},
  author={Carpenter, B},
  journal={Internet draft-carpenter-aeiou-00. txt},
  year={1994}
}

Regards
   Brian

>> Clearly, Google Scholar should be taught to find the canonical RFCs at 
https://rfc-editor.org/rfc - having many secondary copies is an SEO anathema.

---

From: "John Levine" <[email-masked]>
Date: 30 Jul 2021 17:07:33 -0400

>That said, as acting RFC Editor, why don't you just ask them?

Ask who, Google?  Hahahahahahaha.  Scholar like everything else at Google other
than ad sales is completely automated.

R's,
John

---

From: Jeffrey Yasskin <[email-masked]>
Date: Fri, 30 Jul 2021 14:38:23 -0700

I started writing an email to someone who appears to be the right internal
contact, but I had to stop because this thread and the thread around
https://mailarchive.ietf.org/arch/msg/ietf/I0BIw22bhd99buZz9lE-kFcrFGI/
don't have enough information to constitute a bug report. What have the
rfc-editor.org maintainers done to attempt to fix this? Has anyone followed
the steps Harald pointed to at
https://scholar.google.com/intl/en/scholar/inclusion.html#troubleshooting?
If the RFC series maintainers haven't even tried the documented
troubleshooting steps, there's no point escalating.

Jeffrey

---

From: "John Levine" <[email-masked]>
Date: 30 Jul 2021 18:15:53 -0400

It appears that Jeffrey Yasskin  <[email-masked]> said:
>-=-=-=-=-=-
>rfc-editor.org maintainers done to attempt to fix this?

As far as I know, nothing.  Like I said, I'll try some experiments when I have time.

R's,
John