Subject: [Tools-discuss] Chinese name order versus surname and initial attributes in <author>

From: Ted Lemon <[email-masked]>
Date: Mon, 26 Jul 2021 11:41:23 -0700

The way that xml2rfc handles Chinese names is broken in a way that I think
is really problematic. Chinese family names come first, not last. But
there's no way to tell xml2rfc to use this ordering, and it uses the
surname and initial on the title page. This is actually not necessary, at
least for HTML output, and worse it's wrong in a way that I think is not
acceptable. Furthermore, I don't even know if Chinese has any notion of an
"initial" so I actually put the author's first name in instead, since it's
only two glyphs.

Have people run into this before? I know this isn't the first Chinese
author, by a long shot.

Right now I'm addressing the problem by reversing surname and initial, but
that is obviously not a good solution when the document makes it to RFC,
since a citation will then come out wrong.

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 26 Jul 2021 11:56:49 -0700

> since a citation will then come out wrong.

Yes, we have run into this before, and it is more problematic than you 
state because some people with Chinese names (not just Chinese authors) 
prefer to put their given name first (the "modern" way), while others 
prefer to put it last (the "traditional" way). There is no way to 
programmatically determine which method was chosen.

To be clear, this isn't just an RFC format issue: it hits all 
publishing.

--Paul Hoffman

---

From: Michael Richardson <[email-masked]>
Date: Mon, 26 Jul 2021 20:38:02 -0400

Paul Hoffman <[email-masked]> wrote:
    >> least for HTML output, and worse it's wrong in a way that I think is

    > Yes, we have run into this before, and it is more problematic than you state
    > because some people with Chinese names (not just Chinese authors) prefer to
    > put their given name first (the "modern" way), while others prefer to put it
    > last (the "traditional" way). There is no way to programmatically determine
    > which method was chosen.

    > To be clear, this isn't just an RFC format issue: it hits all publishing.

It seems that we need an ordering bit added then.

(The meta-problem is that we seem to be perpetually behind on fixing our XML
specifications. At least, that's what it appears to me)

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 27 Jul 2021 03:11:44 +0200

> specifications. At least, that's what it appears to me)

If we try to do semantic markup, and don’t think the semantics through, we'll need to do endless fixing.

In a similar case, postal addresses, we are in the process of deciding to get away from semantic markup and let everyone format their addresses the way they like them.  May seem like a regression, or like a liberation, depending on your perspective.

Personal names are really hard to get right [1].
RFCs make that much harder than it needs to be by employing initials, which are a computation on personal names that only makes sense if you don’t care about most of the people in the world.
If we got rid of that, we could reduce the need for semantic markup of names, and everything would be wonderful.  Depending on your perspective.

Grüße, Carsten

[1]: https://www.kalzumeus.com/2010/06/17/falsehoods-programmers-believe-about-names/
Read on at least until you get down to number 40 :-)

---

From: Lars Eggert <[email-masked]>
Date: Tue, 27 Jul 2021 11:18:08 +0300

> RFCs make that much harder than it needs to be by employing initials, which are a computation on personal names that only makes sense if you don’t care about most of the people in the world.

A personal +1 t that.

The only use case for initials are in references in academic publishing, when you hit the page limit for a submission and need to fight for every mm of vertical space:-)

Thanks,
Lars

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 27 Jul 2021 15:57:38 +0200

In the first place it would be good to figure out if we can
come up with the list of things someone is expected to provide
to the IETF community if that person wants to be correctly
addressed by the community. Whether in publishing or email.

a) Identity pronoun
b) How to address the person in informal communications (email)
   given name only ? Surname ? surname-given-name ? ...
c) How to address the person in information communications
   when there is a need for further disambiguation (as in JohnA...JohnZ).

d) How to address the person in places where the IETF may be
under some legal constraints, which i guess is RFC publishing.
Aka: Sufficient good faith effort for IETF not being made
responsible in any possible legal proceedins like IPR litigation
(Your John Doe does not exist, IETF is violating copy and trademarks
 in this RFC, please pay $$$$$$).

IMHO, d) mostly likely comes for free when we had a)-c) in before,
and i for once do regularily struggle with a)-c) for people
whom i have not met in at least voice conferencing, but only
encounter in IETF email threads. 

Alternatively, we can simply address IETF'ler in email by 
the first RFC number in which that person is the first
named author. But that is probably discriminatory ;-)

Of course, i am also happy to address other IETF'er purely
by "rfcXXXX siad"
I am happy to address

On Tue, Jul 27, 2021 at 03:11:44AM +0200, Carsten Bormann wrote:
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

-- 
---
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 27 Jul 2021 22:05:34 +0200

Btw: Someone told me in PM that my mail was perceived as a joke
and as an attack against persons, cultures and identities. It
actually is meant very serious, and i don't quite understand
how it could be misunderstood in that way.

I have repeatedly had trouble figuring out gender/pronouns for 
IETF participants that i never met in person, especially because
given names often do not even are clear indicators of gender and
of course not at all any preferred pronoun if its not simply derived
from obvious gender. Sure, its not a deadly problem one can
write text around it, just repeating the name instead of using
a pronoun, but then if one makes a mistak with the name, then
that blunder (such as using wrong order or using the surname
when you wanted to use the given name but didn't know which of the
two names that is) becomes even more problematic.

As far as i know from passing, social networks do provide the
option to explicitly enter public profile information like
given name, surname, preferred pronoun. I think it would be
great if datatracker would provide such fields. When i then again
fumble addressing a person in IETF mails incorrectly, i can at least
suggest to the person to fill in the datatracker profile to avoid others
to make the same mistakes. And maybe preferred name ordering
(surname given-name or other way around) would be useful information
to declare as well.

To the extend that the mayority of RFC authors have datatracker
accounts, this might also help with the original issue of this
thread.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: "John Levine" <[email-masked]>
Date: 27 Jul 2021 17:36:48 -0400

>It seems that we need an ordering bit added then.

Nope.

In Spanish speaking countries, people usually have a matronymic name
written after their surname. For example, the prime minister of Spain
is named Pedro Sánchez Pérez-Castejón and his surname is Sánchez.
Names in former colonies get even longer, like the president of
Equitorial Guinea, Teodoro Obiang Nguema Mbasogo, whose surname is
Obiang.

When I was in college one of my classmates was named Tim of Angle,
surname "of Angle". He was really tired of forms that made him Tim O.
Angle. In Indonesia people use a single name which may not be a single
word, like former president Suharto and current president Joko Widodo,
invariably known as Jokowi.

Keeping in mind Lars' note that there's no reason for us to use
initials, I think it would work for the author and contact elements to
have an attribute for the full name and another for the surname, I
suppose with the surname defaulting to the last word of the full name
since most of us use the American name order.  It is not obvious how to
alphabetize such a list of authors, so we should just leave them in whatever
order the document lists them.

>specifications. At least, that's what it appears to me)

We definitely shipped the beta, but given that we decided to invent
our own XML grammar rather than adapting one known to work in
publishing like Docbook, that's not a big surprise. We're going to be
updating our grammar for quite a while. We still need to figure out
whether to update the XML (not text) of published RFCs when we fix the
grammar, or live with multiple not quite compatible versions.

R's,
John
-- 
Regards,
John Levine, [email-masked], Primary Perpetrator of "The Internet for Dummies",
Please consider the environment before reading this e-mail. https://jl.ly