Subject: [Tools-discuss] Meeting support for contributors

From: Carsten Bormann <[email-masked]>
Date: Sat, 24 Jul 2021 18:55:17 +0200

Here I am sitting with the IETF111 agenda.

I have a simple question:

Which WG/RG slots
	— have scheduled me to lead a topic
	- are discussing one of “my” Internet-Drafts
	- are discussing an “important-for-me” Internet-Draft

Obviously, that can be found out with some significant amount of tedium.

Obstacles:

— I can’t download and sync the agenda documents for all the meetings.
  (I can download each individual one, which is busywork for 126 WG/RG meetings.)
  Syncing is hard because the URIs/filenames change.
— agenda documents don’t have a defined way to summon me: CB, cabo, Carsten, C. Bormann, …
- agenda documents don’t have a defined way to list an I-D (some don’t give even the full draft-ietf-foo-bar name) — well, datatracker has a way to record that information outside the agenda document now, but very few WGs are taking advantage of that capability (statistics?).
— datatracker does not know which Internet-Drafts are “important-for-me” (which is probably not a boolean quality either).

So, we’d need:

(1) A mass download/sync for agenda documents (unless all the mining can be done centrally).
(2) A way to put recognizable person identifiers (“names”) on the agenda document.
(3) A way to get chairs to record which drafts are up on a meeting.  Can this be mined from the agenda?  Possibly with an “All OK” button for the chairs?
(4) A way to push “watch” on an I-D while I’m logged into datatracker, possibly with different interest levels.  Of course, I’m already watching drafts that I’m an author, a shepherd, … of.
(5) lots of glue, masking tape, and spit, to correlate all this information and present it in a contributor dashboard.

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Sat, 24 Jul 2021 15:16:54 -0400

> — agenda documents don’t have a defined way to summon me: CB, cabo,

The DT has a way to indicate who needs to be present, as a clue to the scheduler.
But, I don't think that works right.

    > - agenda documents don’t have a defined way to list an I-D (some don’t
    > give even the full draft-ietf-foo-bar name) — well, datatracker has a
    > way to record that information outside the agenda document now, but
    > very few WGs are taking advantage of that capability (statistics?).

Chairs can indicate which documents are on which agenda, and I think that the
DT could tell you this.  Chairs are not doing this frequently yet.

    > — datatracker does not know which Internet-Drafts are
    > “important-for-me” (which is probably not a boolean quality either).

Yeah.  This is the hard part.

I take it that you are trying to make sure you are present where you need to
be.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide