Subject: [Tools-discuss] Sup to nuts

From: Yaron Sheffer <[email-masked]>
Date: Wed, 07 Jul 2021 19:14:45 +0300

Hi,

I’ve been using the “sup” XML element (superscript). It goes well through the Markdown tooling, and through xml2rfc v3.4.0 (with –v3). But then it bombs when I submit the I-D. Is this just a version difference, or should I somehow set xml2rfc to be more strict?

FWIW, this message “Element sup is not declared in t list of possible children” appears to contradict RFC 7991.

Thanks,

                Yaron

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 7 Jul 2021 18:59:21 +0200

> FWIW, this message “Element sup is not declared in t list of possible children” appears to contradict RFC 7991.

Hi Yaron,

you are submitting something that the nostalgic software at the submission point believes to be a pure v2 document, and this it enforces historic purity.

In order to persuade this software that it’s 2021, you need to convert it to pristine v3 first.

You can do that with

kdrfc -3c foo.md

or, if you prefer to work from the xml output, by 

kdrfc -3c foo.xml
or
xml2rfc --v2v3 foo.xml

In all of these cases, you get a foo.v2v3.xml that can be submitted without invoking v2 nostalgia in the submission software.

Grüße, Carsten

(Yes, I know that the submission service will be fixed very soon.)

---

From: Yaron Sheffer <[email-masked]>
Date: Thu, 08 Jul 2021 00:23:07 +0300

Hi Carsten,

Yes, this fixed my problem. Thanks for your help!

	Yaron

On 7/7/21, 19:59, "Carsten Bormann" <[email-masked]> wrote:

    Hi Yaron,

    You can do that with

    kdrfc -3c foo.md

    kdrfc -3c foo.xml
    or
    xml2rfc --v2v3 foo.xml

    Grüße, Carsten