Subject: [Tools-discuss] Status of IdNits

From: Paul Kyzivat <[email-masked]>
Date: Mon, 27 Sep 2021 16:40:48 -0400

Is the proper version of IdNits to be using the one at:

https://tools.ietf.org/tools/idnits

Its been acting flakey recently. I know there are issues with tools that 
makes it slow, but I'm seeing problems beyond that.

Of particular concern right now I'm getting:

tmp/draft-ietf-rum-rue-08.txt(1893): Found non-ascii character (�) in 
position 42.
tmp/draft-ietf-rum-rue-08.txt(1914): Found non-ascii character (�) in 
position 22.

But those line numbers are well beyond the end of the file. There are 
only 1097 lines in the xml and only 1602 lines in the generated txt.

(This source has not yet been uploaded, so don't bother looking for it.)

Is this a known problem? Is there a work-around? Or shall I just ignore it?

	Thanks,
	Paul

---

From: Bob Hinden <[email-masked]>
Date: Mon, 27 Sep 2021 14:01:06 -0700

I use 

https://www6.ietf.org/tools/idnits

Bob

> On Sep 27, 2021, at 13:41, Paul Kyzivat <[email-masked]> wrote:
> 
> Its been acting flakey recently. I know there are issues with tools that makes it slow, but I'm seeing problems beyond that.
> 
> tmp/draft-ietf-rum-rue-08.txt(1893): Found non-ascii character (�) in position 42.
> tmp/draft-ietf-rum-rue-08.txt(1914): Found non-ascii character (�) in position 22.
> 
> But those line numbers are well beyond the end of the file. There are only 1097 lines in the xml and only 1602 lines in the generated txt.
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Robert Sparks <[email-masked]>
Date: Wed, 29 Sep 2021 09:32:29 -0500

I'm working with Paul on this directly, but the larger answer is "Ignore 
this if you know you've included non-ascii characters in the document, 
like in someone's name". (In this case, the warning are because of are 
because of things like this in the txt file:

'   [RFC8865]  Holmberg, C. and G. Hellström, "T.140 Real-Time Text'

I believe the line numbers reported below are actually relevant to help 
find the characters if you didn't mean to include them.

A future version of idnits will be aware that we allow non-ascii UTF-8 
in documents now.

RjS

On 9/27/21 3:40 PM, Paul Kyzivat wrote:
> Its been acting flakey recently. I know there are issues with tools 
> that makes it slow, but I'm seeing problems beyond that.
>
> List info (including how to Unsubscribe): 
> https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 29 Sep 2021 16:46:39 +0200

On 2021-09-29, at 16:32, Robert Sparks <[email-masked]> wrote:
> 
> help find the characters if you didn't mean to include them.

This reminds me of a gap that we have in the authoring information model: 

If a tool is meant to find unusual, but not outright forbidden, things, it would be good if the author could acknowledge that a particular instance of this actually was meant to be like this.

(#pragma warning disable…)

None of this needs to be in the canonical (published) XML, so this is not an RFCXML question per se, but obviously it is if we use variants of RFCXML as an authoring format or as an input format to idnits.

Grüße, Carsten