Subject: [Tools-discuss] "Distantly related Internet-Drafts"?

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 30 Sep 2021 17:59:29 -0500

So, just for completeness, I should also ask this question about my oddly
filenamed Internet-Draft.

If you look at the QUIC working group's document page (
https://datatracker.ietf.org/wg/quic/documents/), and scan down to

Related Internet-Drafts (24 hits)
you'll see these three drafts.

<https://datatracker.ietf.org/doc/draft-dawkins-quic-multipath-selection/reviewrequest/addreviewwish/?next=/wg/quic/documents/>
draft-dawkins-quic-multipath-selection-01
<https://datatracker.ietf.org/doc/draft-dawkins-quic-multipath-selection/>
Path Selection for Multiple Paths In QUIC
2021-06-02
13 pages
I-D Exists
<https://datatracker.ietf.org/community/personal/[email-masked]/trackdocument/draft-dawkins-sdp-rtp-quic/>
<https://datatracker.ietf.org/doc/draft-dawkins-sdp-rtp-quic/reviewrequest/addreviewwish/?next=/wg/quic/documents/>
draft-dawkins-sdp-rtp-quic-00
<https://datatracker.ietf.org/doc/draft-dawkins-sdp-rtp-quic/>
SDP Offer/Answer for RTP using QUIC as Transport
2021-09-08
11 pages
I-D Exists
<https://datatracker.ietf.org/community/personal/[email-masked]/trackdocument/draft-dawkins-sdp-rtp-quic-questions/>
<https://datatracker.ietf.org/doc/draft-dawkins-sdp-rtp-quic-questions/reviewrequest/addreviewwish/?next=/wg/quic/documents/>
draft-dawkins-sdp-rtp-quic-questions-00
<https://datatracker.ietf.org/doc/draft-dawkins-sdp-rtp-quic-questions/>
SDP Offer/Answer for RTP using QUIC as Transport - Design Questions
2021-09-29
12 pages
New
I-D Exists
The first document filename starts with "draft-dawkins-*quic*". I expect
this one to be listed as a related Internet-Draft. The filename is
"draft-author-wgname-*", as suggested for Internet-Drafts in
https://www.ietf.org/standards/ids/guidelines/#7, and it is related to the
QUIC working group.

The second and third document filenames start with "draft-dawkins-sdp-rtp-
*quic*". I wasn't expecting to see these listed as related to the QUIC
working group. These drafts are intended for discussion on the MOQ ("Media
Over QUIC'') non-WG mailing list, and (if I understand the guidance I've
gotten from the TSV and ART ADs correctly) are actually out of scope for
the QUIC working group.

Is it possible that the datatracker is scanning the filename looking for *any
*occurrence of a working group name, not just in the third position?

>From the "Spencer is not the center of the universe" department, is it
reasonable to list individual drafts as "related", if the filename includes
the working group name in any position? If so, maybe that just needs to be
documented someplace (it doesn't look like
https://www.ietf.org/standards/ids/guidelines has been updated since Russ
Housley was IETF Chair), and I should be aware of that when choosing
filenames.

I thought the matching logic had been tightened up several years ago, when
we had an author whose name had a working group short name as a substring,
so anything that person submitted was listed as a Related Internet-Draft
for the working group. But maybe that was just making sure that the working
group short name had dashes on both sides?

Best,

Spencer

---

From: Lars Eggert <[email-masked]>
Date: Fri, 1 Oct 2021 09:24:50 +0300

Hi,

On 2021-10-1, at 1:59, Spencer Dawkins at IETF <[email-masked]> wrote:
> The first document filename starts with "draft-dawkins-quic". I expect this one to be listed as a related Internet-Draft. The filename is "draft-author-wgname-*", as suggested for Internet-Drafts in https://www.ietf.org/standards/ids/guidelines/#7, and it is related to the QUIC working group.
> 
> The second and third document filenames start with "draft-dawkins-sdp-rtp-quic". I wasn't expecting to see these listed as related to the QUIC working group. These drafts are intended for discussion on the MOQ ("Media Over QUIC'') non-WG mailing list, and (if I understand the guidance I've gotten from the TSV and ART ADs correctly) are actually out of scope for the QUIC working group.
> 
> Is it possible that the datatracker is scanning the filename looking for any occurrence of a working group name, not just in the third position?

IIRC, when I was a QUIC co-chair, I manually tweaked the pattern for the QUIC WG in the datatracker settings, because people were submitting QUIC-related I-Ds that were not showing up on our datatracker page and we hence didn't learn about until (sometimes much) later.

Since I'm not a co-chair anymore, I don't have access to the "manage document list" button anymore, so I can't verify this.

Thanks,
Lars