Subject: [Tools-discuss] Closing the chat trial instances

From: Robert Sparks <[email-masked]>
Date: Wed, 15 Sep 2021 11:14:23 -0500

All -

We are turning off the chat trial instances. This includes:

xmpp-trial1.ietf.org, matrix-trial1.ief.org, and zulip-trial1.ietf.org

We've kept them running quite a bit longer than originally planned, and 
we think we have the information we needed to gather from them.

Going forward:

We are in the process of setting up a standing Zulip server and will 
investigate whether we can integrate that directly with Meetecho as the 
backend for messaging during Meetecho sessions. We will have XMPP-Zulip 
bridging in place as long as both services are active. See the service 
plan at 
https://github.com/rjsparks/zulip-implementation/blob/main/Service-Plan.md

We received feedback from a small number of people that providing a 
Jabber login service was useful, but haven't seen a lot of use of it. 
We're not currently planning on providing this service going forward. 
Anyone relying on it should take advantage of other existing services. 
There is an updated list of alternatives at 
https://www.ietf.org/how/meetings/groupchat/.

We are not planning to continue provide a Matrix service. Interest was 
limited, and it presented a more difficult set of operational 
challenges. See 
https://mailarchive.ietf.org/arch/msg/tools-discuss/AI5hBp1qnLAH-S9T7XhLF-omFS0/

We have heard and continue to keep in mind the feedback to prefer IETF 
standards.

Timing:

The matrix trial server will be taken down now.
The xmpp trial server will be taken down in two weeks, giving the few 
people who had been using it an opportunity to set up something else.
The zulip trial server will be taken down shortly after the standing 
server is made available to the community.

Please take care to send all discussion to [email-masked]

RjS

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 15 Sep 2021 20:07:43 +0100

Pity about the matrix gateway going.

If it were possible to document how someone with e.g.
their own homeserver could setup interop with the ongoing
IETF IM services that'd be great. I understand if that's
not a priority and might need some possibly tricky
anti-spam policies to be setup/agreed. I'd be willing
to try setup interop with my homeserver if that were a
possibility sometime.

Cheers,
S.

On 15/09/2021 17:14, Robert Sparks wrote:
> _______________________________________________
> Manycouches mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manycouches

---

From: "Maisonneuve, Julien (Nokia - FR/Paris-Saclay)" <[email-masked]>
Date: Wed, 15 Sep 2021 20:34:13 +0000

Hello,
I think I was among the people who expressed this was useful, and failed to use it in the last two meetings because I (wrongly ?) relied on Meetecho. I should have tried the new servers/services (which I failed to notice), but was busy with other things.
I'd like to observe that we can't complain that people are not using Jabber enough, and at the same time remove things that  make Jabber easier to use/configure. Making Jabber harder than it already is will simply decrease usage. We might have a plan to use only Meetecho going forward, but this is a different issue.
Arguably the instructions at https://www.ietf.org/how/meetings/groupchat/ got much better than in the past, but the notion of IETF having its own server(s) instead of relying on third parties for a somewhat critical service sounded like a sane idea.
I get the same impression as for the (absence of) debate on the destruction of the FTP service: we cut it because is not used enough, regardless of the inconvenience to people who use it or might use it. Cost cutting in IETF is relatively new, and to me it's not pretty,  I hope it's worth it.
Best regards,
Julien.

-----Original Message-----
From: ietf <[email-masked]> On Behalf Of Robert Sparks
Sent: Wednesday, September 15, 2021 6:14 PM
To: tools-discuss <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Closing the chat trial instances

All -

We've kept them running quite a bit longer than originally planned, and we think we have the information we needed to gather from them.

Going forward:

We are in the process of setting up a standing Zulip server and will investigate whether we can integrate that directly with Meetecho as the backend for messaging during Meetecho sessions. We will have XMPP-Zulip bridging in place as long as both services are active. See the service plan at https://github.com/rjsparks/zulip-implementation/blob/main/Service-Plan.md

We received feedback from a small number of people that providing a Jabber login service was useful, but haven't seen a lot of use of it. 
We're not currently planning on providing this service going forward. 
Anyone relying on it should take advantage of other existing services. 
There is an updated list of alternatives at https://www.ietf.org/how/meetings/groupchat/.

We are not planning to continue provide a Matrix service. Interest was limited, and it presented a more difficult set of operational challenges. See https://mailarchive.ietf.org/arch/msg/tools-discuss/AI5hBp1qnLAH-S9T7XhLF-omFS0/

We have heard and continue to keep in mind the feedback to prefer IETF standards.

Timing:

The matrix trial server will be taken down now.
The xmpp trial server will be taken down in two weeks, giving the few people who had been using it an opportunity to set up something else.
The zulip trial server will be taken down shortly after the standing server is made available to the community.

RjS

---

From: Jay Daley <[email-masked]>
Date: Thu, 16 Sep 2021 11:41:05 +1200

Hi Julien

> On 16/09/2021, at 8:34 AM, Maisonneuve, Julien (Nokia - FR/Paris-Saclay) <[email-masked]> wrote:
> 
> Hello,
> Arguably the instructions at https://www.ietf.org/how/meetings/groupchat/ <https://www.ietf.org/how/meetings/groupchat/> got much better than in the past, but the notion of IETF having its own server(s) instead of relying on third parties for a somewhat critical service sounded like a sane idea.

This is not a cost cutting decision and we do not make a cost saving from it.

cheers
Jay

> From: ietf <[email-masked] <mailto:[email-masked]>> On Behalf Of Robert Sparks
> To: tools-discuss <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked] <mailto:[email-masked]>
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked] <mailto:[email-masked]>
> * Report tools.ietf.org <http://tools.ietf.org/> bugs to: [email-masked] <mailto:[email-masked]>
> * Report all other bugs or issues to: [email-masked] <mailto:[email-masked]>
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss>
-- 
Jay Daley
IETF Executive Director
[email-masked]