Subject: [Tools-discuss] Design workshops - concept for discussion tomorrow

From: Jay Daley <[email-masked]>
Date: Tue, 14 Sep 2021 08:55:05 +1200

Hi All

Robert and I want to discuss at the tools meeting tomorrow a proposal for a series of design workshops that help plan future development for a specific topic.  The workshop would include a presentation on each topic and the various components, current requirements, known issues, existing plans and ideas, then open up for a general discussion on each of these.  The workshop would be written up, shared and that writeup referred to as the plan develops and in future community discussions.

We are imagining a 2-3 hour remote workshop, open to all.

The topics we have identified so far are:

0. Mail processing
- IDN support
  - What a Mailman 3 migration would require
  - What would be different with Mailman 3
  - what would have to change in the rest of the processing chain
- Spam abatement
  - Virus scanning
  - Spamassassin
  - Postconfirm
  - Use of mailman's mechanisms
- Ability to moderate a given participant
- DMARC rewriting
- Alias maintenance (<group>-chairs@, <document>-authors@, etc.)

1. Mail archive and related user interfaces
- Mail archive tool usage and issues
- Potential mail archive tool improvements
  - Possible integration of IM chat logs
  - Statistics endpoint (# posts per list per day, etc.)
- Usage of IMAP
- Self-service subscription management in Datatracker

2.  RFC and I-D publication
- Documenting the different sites and different access mechanisms
- Varying URL constructs across those sites
- SEO and directing people to the authoritative site
- doc.ietf.org idea

3.  Datatracker refactoring
- Current objects: document, group, person, etc
  - Adding an optional 'affiliation' to person
  - Making RFCs a separate document type
- Current interfaces: agenda, submission, etc
  - Possible new interface to find a person
  - Making the agenda interface mobile friendly
  - Possible integration of CodiMD-like interface directly into Datatracker
- Role management
  - Document roles
- What could be removed?

Happy to take comments now or at our meeting tomorow.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Oscar González de Dios <[email-masked]>
Date: Tue, 14 Sep 2021 18:31:28 +0000

Hi all,

        As now it is a common practice in some IETF drafts to have comments and contributions tracked in github via issues and pull requests (full guidance documented in RFC 8874),  would it make sense to incorporate in datatracker a potential integration with github? For example incorporate a query of the issues /PRs of the draft complementary to current mailing list query (or even maintaining a copy of the issues for the records).

        Best Regards,

        Oscar

-----Mensaje original-----
De: Tools-discuss <[email-masked]> En nombre de Jay Daley
Enviado el: lunes, 13 de septiembre de 2021 22:55
Para: tools-discuss <[email-masked]>
Asunto: [Tools-discuss] Design workshops - concept for discussion tomorrow

Hi All

0. Mail processing
- IDN support

Jay

--
Jay Daley
IETF Executive Director
[email-masked]

___________________________________________________________
Tools-discuss mailing list - [email-masked] This list is for discussion, not for action requests or bug reports.
* Report datatracker and mailarchive bugs to: [email-masked]
* Report tools.ietf.org bugs to: [email-masked]
* Report all other bugs or issues to: [email-masked] List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Salz, Rich" <[email-masked]>
Date: Tue, 14 Sep 2021 18:34:28 +0000

You can do that already, by defining an "external reference"  They're available at the WG and document level.  A few standards ext-refs are already defined, including GitHub repo.