Subject: [Tools-discuss] Read-only mailing list subscriptions ?

From: Toerless Eckert <[email-masked]>
Date: Thu, 23 Sep 2021 21:53:32 +0200

Wasn't there in the past week some notion of upgrading our mailing list system
as something thats going to happen anyhow ?

I was wondering if we could get a way to subscribe to IETF mailing lists
that are supposed to have closed membership (who can write to the list),
but whose archive is public. I think this applies to all directorates
and maybe other lists as well. Without actually getting mails sent to such a list
forwarded, its quite convoluted to poll such lists. 

Having an ability to subscribe read-only/non-member to such lists would be lovely!

Cheers
    Toerless

---

From: Jay Daley <[email-masked]>
Date: Fri, 24 Sep 2021 08:14:50 +1200

> On 24/09/2021, at 7:53 AM, Toerless Eckert <[email-masked]> wrote:
> 

Use IMAP.  https://www.ietf.org/how/lists/

Jay

> 
> Cheers
>    Toerless
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss
> 

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 23 Sep 2021 13:22:03 -0700

> Use IMAP.  https://www.ietf.org/how/lists/

Hi Jay,

FWIW, I don't actually think that this is as important a function as
Toerless does, but if
we *do* think it's important, I don't think "use IMAP" is a reasonable
answer, given the
large number of people who use Webmail.

-Ekr

> > List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
> >
>
> --
> Jay Daley
> IETF Executive Director
> [email-masked]
>
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 23 Sep 2021 22:28:35 +0200

Polling mailing lists via imap also looks time-consuming for the client i
have. Not sure if/how there are better options to pull new mails from
such mailing lists. I Tried to cut down on local copies of IETF mailing
lists, but opening a mailing list via IMAP Dacan take minutes, depending
of how long the list is.

-- 
---
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Fri, 24 Sep 2021 08:35:50 +1200

> On 24/09/2021, at 8:22 AM, Eric Rescorla <[email-masked]> wrote:
> 
> 
> 
> On Thu, Sep 23, 2021 at 1:15 PM Jay Daley <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> > On 24/09/2021, at 7:53 AM, Toerless Eckert <[email-masked] <mailto:[email-masked]>> wrote:
> > 
> Use IMAP.  https://www.ietf.org/how/lists/ <https://www.ietf.org/how/lists/>
> 
> Hi Jay,
> 
> FWIW, I don't actually think that this is as important a function as Toerless does, but if
> we *do* think it's important, I don't think "use IMAP" is a reasonable answer, given the

OK.  I’m working on a requirements document for new tools functionality for people to manage their email subscriptions and I’ll add being able to subscribe to a "closed but public" list in read-only mode to that (though I do not know if it is possible).

Jay

> > Tools-discuss mailing list - [email-masked] <mailto:[email-masked]>
> > * Report datatracker and mailarchive bugs to: [email-masked] <mailto:[email-masked]>
> > * Report tools.ietf.org <http://tools.ietf.org/> bugs to: [email-masked] <mailto:[email-masked]>
> > * Report all other bugs or issues to: [email-masked] <mailto:[email-masked]>
> > List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss>
> > 
> 
> -- 
> Jay Daley
> IETF Executive Director
> [email-masked] <mailto:[email-masked]>
> 
> Tools-discuss mailing list - [email-masked] <mailto:[email-masked]>
> * Report datatracker and mailarchive bugs to: [email-masked] <mailto:[email-masked]>
> * Report tools.ietf.org <http://tools.ietf.org/> bugs to: [email-masked] <mailto:[email-masked]>
> * Report all other bugs or issues to: [email-masked] <mailto:[email-masked]>
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss>
-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "John Levine" <[email-masked]>
Date: 23 Sep 2021 17:12:59 -0400

>lists, but opening a mailing list via IMAP Dacan take minutes, depending

I read IETF lists by copying mail from the IMAP folders to a local
news server. It is a small python script, which uses the standard
python IMAP libraries, and it can scan 75 lists and copy the new
messages in under a minute, that is, less than a second per list.

Perhaps you could look for an IMAP client with reasonable performance,
rather than asking us to duplicate the existing perfectly functional
service.

I suppose for the webmail crowd it wouldn't be hard to set up a POP
proxy in front of the IMAP server and people could tell their webmail
service to poll it. That works well in Gmail which seems to be the
webmail that most people use.

R's,
John

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 23 Sep 2021 23:27:53 +0200

Why do we then have the option for any IETF mailing list to
subscribe to it through email ? Why shouldn't everybody use
IMAP to receive all his/her ietf emails ?

I don't see the difference. I think we always need a push
subscription model. IMAP is pull/poll.

-- 
---
[email-masked]

---

From: "John R Levine" <[email-masked]>
Date: 23 Sep 2021 17:40:16 -0400

> IMAP to receive all his/her ietf emails ?

I dunno.  There's a lot of mail systems where everyone reads all their 
mail with IMAP.

> subscription model. IMAP is pull/poll.

We have one for our regular mail.  You're asking to provide a special 
case, read-only access to semi-public lists, WHICH IMAP ALREADY PROVIDES.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Toerless Eckert <[email-masked]>
Date: Thu, 23 Sep 2021 23:48:39 +0200

On Thu, Sep 23, 2021 at 05:40:16PM -0400, John R Levine wrote:
> I dunno.  There's a lot of mail systems where everyone reads all their mail
> with IMAP.

Yes, but not to read emails on mail boxes with 10,000 messages or more
and a TCP connection across the globe. 

> We have one for our regular mail.  You're asking to provide a special case,
> read-only access to semi-public lists, WHICH IMAP ALREADY PROVIDES.

I bet if you ask how most IETF participants read IETF mailing list mails,
i bet it will be through subscription to the mailing list, getting
those emails into their mail box. So when we created mailing lists
you can not send email to, we simply forgot to make them work for
reading in the same way that most IETF participants like to read
emails.

Cheers
    Toerless

---

From: "John R Levine" <[email-masked]>
Date: 23 Sep 2021 19:08:27 -0400

> and a TCP connection across the globe.

Sheesh.

I use Alpine which opens a folder on my server with 293,000 messages, or 
the main IETF list folder with 138,000 messages in a few seconds.  (I just 
tried it.)  My wife uses Thunderbird which is about the same.  IMAP is 
asynchronous and pipelined so I find connections to servers in Asia not 
much slower than connections within the US.

I do not think that one person's unfamiliarity with IMAP means the 
IETF has to invent something else new and certainly worse.

Regards,

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 23 Sep 2021 16:10:19 -0700

On Thu, Sep 23, 2021 at 4:08 PM John R Levine <[email-masked]> wrote:

> mail

I don't understand what is being invented. Mailing lists that one can
subscribe to but not send to are not some kind of advanced technology.
Indeed, IETF operates one: ietf-announce.

-Ekr

---

From: "John R Levine" <[email-masked]>
Date: 23 Sep 2021 21:47:41 -0400

> Indeed, IETF operates one: ietf-announce.

Mailman has moderated lists, but it doesn't have lists where one set of 
people subscribe and a separate set can post.

I can think of ways to set up a hack where you have the blah list to 
which only specified people subscribe, the blah-read list to which anyone 
can subscribe but everything is moderated, and a kludgetastic script in 
which a secret address subscribes to the blah list which forwards to 
blah-read and adds a header with the moderator password.  But ugh.

Regards,

---

From: Jay Daley <[email-masked]>
Date: Fri, 24 Sep 2021 13:54:46 +1200

> On 24/09/2021, at 1:47 PM, John R Levine <[email-masked]> wrote:
> 
> Mailman has moderated lists, but it doesn't have lists where one set of people subscribe and a separate set can post.

I don’t think that’s correct.  It’s possible to have a list where new people can only subscribe with their moderation bit set, which prevents them posting and which they cannot change, while those who are allowed to post have their moderation bits unset, either manually or by API.  This is how ietf-announce works after all.

Jay

> 
> I can think of ways to set up a hack where you have the blah list to which only specified people subscribe, the blah-read list to which anyone can subscribe but everything is moderated, and a kludgetastic script in which a secret address subscribes to the blah list which forwards to blah-read and adds a header with the moderator password.  But ugh.
> 
> Regards,

-- 
Jay Daley
IETF Executive Director
[email-masked]