Subject: Re: [Tools-discuss] Content at notes.ietf.org is not archival

From: Qin Wu <[email-masked]>
Date: Fri, 17 Sep 2021 04:11:53 +0000

On 17-Sep-21 07:22, Michael Richardson wrote:
> 
> Carsten Bormann <[email-masked]> wrote:
>     >> On 16. Sep 2021, at 09:46, Mark Nottingham <[email-masked]> wrote:
>     >> 
>     >> Or, just automatically delete notes 30 days after creation.
> 
>     > (Again, I don’t know whether this was a serious proposal. 
 I’ll treat
>     > is as such for the purpose of this message.)
> 
> Well, I'm serious.
> I think 30 days might be way too long.
> 
> WG and design team leaders should know to download minutes at the end 
> of the session.  It's not hard.
> But, in order to train that, the contents needs to disappear within 
> the
day,
> and there will be some crying.   Some WG session minutes will go away.

One day is too short; back in the good old days, when most of us suffered jet lag after each meeting, a week to capture the minutes and copy-edit them was hardly enough. But I do agree, this is a major duty of WG chairs or secretaries, and needs to be done promptly. 

I wouldn't call it notes.ietf.org. I'd call it temp.ietf.org. Or at least, put everything in notes.ietf.org/temp/ and move it to notes.ietf.org/recycle/ after 30 days and then to /dev/null after another 30 days. Something like that, anyway, depending on how it would integrate with HedgeDoc.

   Brian 
[Qin] If you log on HedgeDoc using your IETF account, you will see all the WG's notes.ietf.org you have visited before. I can even see some WG notes 10 months ago. I agree to keep these temporary notes for a while. But to avoid confusion with formal notes/minutes maintained in each WG data tracker tool, we should stick to single source of truth principle and trust published minutes verified by WG chairs.

---

From: Qin Wu <[email-masked]>
Date: Fri, 17 Sep 2021 04:15:55 +0000

-----邮件原件-----
发件人: WGChairs [mailto:[email-masked]] 代表 Brian E Carpenter
发送时间: 2021年9月17日 6:16
收件人: Henk Birkholz <[email-masked]>; Michael Richardson <[email-masked]>; Carsten Bormann <[email-masked]>; Working Chairs <[email-masked]>; IETF discussion list <[email-masked]>; tools-discuss <[email-masked]>
主题: Re: [Tools-discuss] Content at notes.ietf.org is not archival

On 17-Sep-21 09:14, Henk Birkholz wrote:
> Minutes are not the only notes taken at notes.ietf.org. I would stop 
> using it, if things would simply disappear, obviously. How is this a 
> good idea?

Henk, I may well be old-fashioned, but when I want something to be kept, I keep it: save it on my disk, and make sure it's in a directory that gets backed up routinely.

Anybody who used geocities.com knows why.

(I'm biased on this question. In about 1993 I tried to persuade Tim Berners-Lee to make an expiry date obligatory for every HTML page.
I still think he was wrong to refuse.)

[Qin] Create date is more useful than expiry date when you read some blog and trace the history of idea in the HTML page. :-)

It's also important to specify this from the start. We probably don't want rough notes to become part of the public record of standards activities, and subject to subpoena.

    Brian
> 
> 
> On 16.09.21 23:09, Brian E Carpenter wrote:
of the
>>> session.  It's not hard.
>> One day is too short; back in the good old days, when most of us 
>> suffered jet lag after each meeting, a week to capture the minutes 
>> and copy-edit them was hardly enough. But I do agree, this is a major 
>> duty of WG chairs or secretaries, and needs to be done promptly.
>>
>> I wouldn't call it notes.ietf.org. I'd call it temp.ietf.org. Or at 
>> least, put everything in notes.ietf.org/temp/ and move it to 
>> notes.ietf.org/recycle/ after 30 days and then to /dev/null after 
>> another 30 days. Something like that, anyway, depending on how it would integrate with HedgeDoc.
>>
>>     Brian
>>>
>>>      > Collecting notes in our own service (as opposed to hackmd.io or Google
>>>      > docs) gives us more control.  Another benefit of having a common
>>>      > service is that, after a while, everybody knows how to use it 
>>> and
>> we
>>>      > can integrate it into other tools.
>>>
>>> Agreed.
>>>
>>>
>>