Subject: Re: [Tools-discuss] slow tools reaction

From: Qin Wu <[email-masked]>
Date: Sat, 18 Sep 2021 12:37:49 +0000

I agree, online rfcdiff tool is extremely useful,which I used often for draft updating checking, although offline tool such as beyond compare can do the similar thing, but comparing with rfcdiff, not elegant as I thought when you get used to the rfcdiff.

-Qin
-----邮件原件-----
发件人: Jeffrey (Zhaohui) Zhang [mailto:[email-masked]] 
发送时间: 2021年9月17日 21:07
收件人: Qin Wu <[email-masked]>; Benjamin Kaduk <[email-masked]>; Donald Eastlake <[email-masked]>; [email-masked]
主题: RE: slow tools reaction

Hi Qin,

While those tools are available for published drafts, sometimes we need to use them for some unpublished ones yet. For example, we may want to do a spell check, or do a diff of new (yet to be published) revision against an existing revision. Therefore, a separate tools page like current tools.ietf.org would be nice.

Thanks.
Jeffrey

-----Original Message-----
From: Qin Wu <[email-masked]>
Sent: Friday, September 17, 2021 2:01 AM
To: Jeffrey (Zhaohui) Zhang <[email-masked]>; Benjamin Kaduk <[email-masked]>; Donald Eastlake <[email-masked]>; [email-masked]
Subject: RE: slow tools reaction

[External Email. Be cautious of content]

Jeffrey:
-----邮件原件-----
发件人: WGChairs [mailto:[email-masked]] 代表 Jeffrey (Zhaohui) Zhang
发送时间: 2021年9月16日 20:32
收件人: Benjamin Kaduk <[email-masked]>; Donald Eastlake <[email-masked]>; [email-masked]
主题: RE: slow tools reaction

[ moving to tools-discuss ]

Hi Ben,

Thanks for pointing out the decommissioning. Sorry for not noticing the announcement before, and apparently there are quite some people like me 😊

Anyway, I use the diff/idnit/spell/xml2rfc and draft submission tools at tools.ietf.org and they've been slow recently. After learning that tools.ietf.org is replaced by the datatracker, I went to datatracker.ietf.org. There the only links related to the tools that I use are "Draft Submission" under the "Documents" tab, and "IETF Tools" at the lower right bottom.

[Qin]: I have been realized that idnit tools has been slow recently in the datatracker.
Jeff, diff and idnites have been integrated into datastracker tools if you click on the document you are looking for in the data tracker webpage.
You will see diff tool in the history tab, idnits tool is in the middle of status tab for each document https://urldefense.com/v3/__https://datatracker.ietf.org/doc/draft-ietf-xxxx__;!!NEt6yMaO-gk!VNk2tqKTjrbakF3-589GE45_aEUx9OzlswVKbh67aX11SqSGRWSENMkZlSVTREoc$
Spell tool unfortunately I haven't seen it integrated into datatracker tool. It would be great to get access to these tools in a single place.

However, "IETF Tools" simply points to "tools.ietf.org", and "Draft Submission" link in "tools.ietf.org" is the same as "Draft Submission" under the "Documents" tab (all point to https://urldefense.com/v3/__https://datatracker.ietf.org/submit/__;!!NEt6yMaO-gk!VNk2tqKTjrbakF3-589GE45_aEUx9OzlswVKbh67aX11SqSGRWSENMkZlY7O9bC9$ ).

So I am still a bit lost - appreciate if someone could share a link to the announcement that I missed.

Thanks.
Jeffrey

-----Original Message-----
From: Benjamin Kaduk <[email-masked]>
Sent: Thursday, September 16, 2021 12:14 AM
To: Donald Eastlake <[email-masked]>
Cc: [email-masked]; Mankamana Mishra (mankamis) <[email-masked]>; Jeffrey (Zhaohui) Zhang <[email-masked]>
Subject: Re: slow tools reaction

[External Email. Be cautious of content]

I assume that everyone is referring to sites hosted under tools.ietf.org, the old server that is slated for decommisioning.
I have seen slowness as well, but it does not really concern me much because everything I regularly use is actually on the datatracker, and the slowness only comes about because links (e.g., from google) have not updated to point to datatracker directly instead of tools.

Also, tools-discuss is probably a better list at which to discuss any issues.

-Ben

On Wed, Sep 15, 2021 at 10:13:55PM -0400, Donald Eastlake wrote:
> Me too...
>
> Thanks,
> Donald
> ===============================
>  Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
>  2386 Panoramic Circle, Apopka, FL 32703 USA  [email-masked]
>
> On Wed, Sep 15, 2021 at 8:42 PM Mankamana Mishra (mankamis) 
> <mankamis=[email-masked]> wrote:
> >
> > Yes , it’s been slow for me too .
> >
> > Mankamana
> > ________________________________
> > From: WGChairs <[email-masked]> on behalf of Jeffrey
> > (Zhaohui) Zhang <zzhang=[email-masked]>
> > Sent: Wednesday, September 15, 2021 5:33:32 PM
> > To: [email-masked] <[email-masked]>
> > Subject: slow tools reaction
> >
> > Hi,
> >
> > Is it just me or have you also noticed that IETF tools have been quite slow recently?
> >
> > Thanks.
> > Jeffrey
> >
> > Juniper Business Use Only
> >
>

Juniper Business Use Only

Juniper Business Use Only

---

From: Benjamin Kaduk <[email-masked]>
Date: Sat, 18 Sep 2021 22:12:51 -0700

For rfcdiff specifically, https://www.ietf.org/rfcdiff lets you upload or
reference arbitrary files.

I haven't had a need for standalone idnits, so I have no data on that one.

-Ben