Subject: [Tools-discuss] Propose slides for interims datatracker option ?

From: Toerless Eckert <[email-masked]>
Date: Fri, 10 Sep 2021 04:42:54 +0200

Hi folks - was just wondering if there is a datatracker option to 
propose slides for interrims, because if there is, then it is hiding itself
well from me ;-)

If not, then it would be lovely to also get this option..
(but wouldn't want to assign a priority to it relative to anything els. Just observing)

Cheers
    toerless

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 10 Sep 2021 08:03:58 +0200

> propose slides for interrims, because if there is, then it is hiding itself

It is indeed well-hidden.

Go to:

https://datatracker.ietf.org/meeting/upcoming

Log in to datatracker (!).

In the column “meetings”, click on the meeting of your choice, say:

https://datatracker.ietf.org/meeting/interim-2021-core-10/session/core

Click “Propose slides”.

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 10 Sep 2021 08:19:37 +0200

> Log in to datatracker (!).

… and that line is part of a general annoyance with datatracker.

There are many functions that only work (or change behavior) if you are logged in.
These functions are simply not shown (e.g., propose slides) or silently work differently if you are not.

Normally, you are still logged in with datatracker from the last thing you did there.
But random events can log you out, and it takes some time to notice that the weirds behavior you are seeing from datatracker is because it doesn’t work right any more when logged out.

I now have this nervous glance to the menu bar whenever I’m using datatracker — does it say “User” or “[email-masked]”.
At least the visualization of being properly logged in might be stronger (change colour of the menu bar etc.) to alert one that datatracker is not going to work right.

Functions that are disabled without login could also still be shown and ask for login when invoked.
(But maybe the trapdoor effect is intended, to fend off the unwashed?
Also, this probably doesn’t make sense for minority functions like those afforded to WG chairs and ADs.)

(A weakly related gripe is that functions that depend on datatracker login like meetecho are structured in a way that the detour through datatracker requires explicit confirmation — which is fine for random relying parties using the datatracker OAuth, but should not be necessary for core IETF functions.)

Grüße, Carsten

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 10 Sep 2021 20:03:40 +0200

Thanks Carsten.

I agree with your points about the GUI being confusing.

Unfortunately, i have to confess that i was probably yesterday evening just
blind to see the "Propose Slides" button at the bottom of the material page.. Not sure *sigh*...
But i am pretty sure i was logged in yesterday too.

But good to know its all consistent with normal meetings.

Cheers
    Toerless

-- 
---
[email-masked]