Subject: [Tools-discuss] Unknown idnits error

From: Balázs Lengyel <[email-masked]>
Date: Thu, 9 Sep 2021 21:37:25 +0000

Hello,

I am trying to check a new version of my
draft-ietf-netmod-yang-instance-file-format-18 (attached).

I tried to check the draft running the web based idnits tool.
<https://tools.ietf.org/tools/idnits/> https://tools.ietf.org/tools/idnits/

The draft’s previous version did not have any idnits errors or warnings. Now
suddenly I get: 
 
== Couldn't figure out when the document was first submitted -- there may
     comments or warnings related to the use of a disclaimer for pre-RFC5378
     work that could not be issued because of this.  Please check the Legal
     Provisions document at https://trustee.ietf.org/license-info to
determine
     if you need the pre-RFC5378 disclaimer.
I did not change any boilerplate info. Why do I get this warning and how to
get rid of it?
It is impossible to understand the problem and how to handle it from this
error message. 
 
Please help, Balazs

-- 

Balazs Lengyel                    Senior Specialist
Ericsson Hungary Ltd. 

Mobile: +36-70-330-7909              email: [email-masked]
<mailto:[email-masked]>

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 10 Sep 2021 00:11:47 +0200

I already gave a partial answer in <https://mailarchive.ietf.org/arch/msg/netmod/KP6go3dCvXYicBEYI9Iu4gO4ZMk>

But it sure would be nice to get an update on where we are with respect to strengthening the idnits implementation and backend.

Grüße, Carsten

---

From: Robert Sparks <[email-masked]>
Date: Thu, 9 Sep 2021 17:37:25 -0500

Balazs - Please try using https://www.ietf.org/tools/idnits instead.

I do not currently get the warning you are seeing when I use that 
instance of the service.

On 9/9/21 4:37 PM, Balázs Lengyel wrote:
> https://tools.ietf.org/tools/idnits/ 
> <https://tools.ietf.org/tools/idnits/>
>
> The draft’s previous version did not have any idnits errors or 
> warnings. Now suddenly I get:
>       Provisions document athttps://trustee.ietf.org/license-info  <https://trustee.ietf.org/license-info>  to determine
> I did not change any boilerplate info. Why do I get this warning and 
> how to get rid of it?
> It is impossible to understand the problem and how to handle it from 
> this error message.
> Please help, Balazs
>
> -- 
>
> Balazs Lengyel                    Senior 
> Specialist                       Ericsson Hungary Ltd.
>
> Mobile: +36-70-330-7909              email: 
> [email-masked] <mailto:[email-masked]>
>
>
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Robert Sparks <[email-masked]>
Date: Thu, 9 Sep 2021 17:44:58 -0500

I think the incremental improvement of the existing idnits that you are 
asking for here has already taken place.

The version running at www.ietf.org feeds off of the datatracker. I'll 
follow up on improving what happens when someone uses the tools.ietf.org 
url.

Work on completely replacing the current implementation is underway.

RjS