Subject: [Tools-discuss] What does "n.d." mean?

From: "Salz, Rich" <[email-masked]>
Date: Wed, 1 Sep 2021 18:15:10 +0000

The TXT and HTML versions have this:
[IANA]     "IANA", n.d., <https://www.ietf.org/standards/iana>.

The MD file has this:
  IANA:
    target: https://www.ietf.org/standards/iana
    title: IANA

What am I doing wrong?  And is this written down someplace that I should have read?  Tnx.

---

From: Lars Eggert <[email-masked]>
Date: Wed, 1 Sep 2021 21:19:04 +0300

Hi,

I think I hit this in the past and decided it must mean "no date". IIRC it was added for entries without a publication date.

Thanks,
Lars

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 1 Sep 2021 22:25:43 +0200

“n.d." indeed means “no date”.

In scholarly citations, if there is no date associated with a reference, one can use “n.d.” to identify the reference as undated.
Of course, styles differ here, but AFAICT, both APA and the Chicago Manual of Style (CMOS) use “n.d.” (*).
(Incidentally, the RFC editor doesn’t seem to like “n.d.”, even though CMOS is the underlying style guide for RFCs.)

“n.d." is the default value that kramdown-rfc assigns for a reference’s date when none is given.

The reason for this kramdown-rfc default is that it is easy to forget putting in a date, and getting n.d. provides a reminder that you should put in one.
(It is also the “correct” way to handle undated sources, but see “the RFC editor…” above.)

If you really don’t want a date, explicitly set

  date: false

BTW, there is an example for that in

https://github.com/cabo/kramdown-rfc2629#references

I probably should add more detail to

https://github.com/cabo/kramdown-rfc2629/wiki/Pitfalls#reference-pitfalls

Now https://github.com/cabo/kramdown-rfc2629/issues/130

Grüße, Carsten

(*) I love the advice given in [1] for MLA style:

Do not use n.d. unless your professor asks you to do so.  

[1]: https://libanswers.snhu.edu/faq/129215

> On 1. Sep 2021, at 20:15, Salz, Rich <rsalz=[email-masked]> wrote:
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 1 Sep 2021 20:37:18 +0000

I figured n.d. meant no date, but I couldn't figure out the format and didn't know about false.  Tnx.