Subject: [Tools-discuss] New Author Tools Release 0.3.0

From: Kesara Rathnayake <[email-masked]>
Date: Fri, 19 Nov 2021 07:59:44 +1300

Website: https://author-tools.ietf.org/

API documentation: https://author-tools.ietf.org/doc/

iddiff (rfcdiff alternative) is available at 
https://author-tools.ietf.org/iddiff

Notable changes:
* From the front page, the uploaded draft can be compared with the 
latest draft from the datatracker. The draft name is identified using 
the filename.

* From https://author-tools.ietf.org/iddiff, you can compare two drafts 
side by side. You can either upload a draft or provide a draft name. If 
the second draft is not provided, author tools will try to retrieve the 
latest draft from the datatracker.

* Note: If the uploaded draft is the same as the latest draft on 
datatracker, author tools will use the previous draft for the comparison.

API Changelog:
* Implemented iddiff (rfcdiff alternative).
* Added details about how to get a personal API key.
* Fixed an edge case with filename verifications.
* Updated idnits location to the GitHub mirror.
* Updated various dependencies and tools.

UI Changelog:
* Added iddiff (rfcdiff alternative) functionality.
* Added ability to generate id diff with the latest revision with a 
single click.
* The download file is presented with the correct file extension.
* Removed automatic disappearance of experimental notice.
* Updated XML schema information description.

-- 
Kesara Rathnayake
Senior Software Development Engineer - IETF LLC
[email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Thu, 18 Nov 2021 14:05:44 -0500

The Diff feature is a bit weird. In the current tools site, we can diff two
specific input files, diff against an existing draft (doesn't have to be
the latest), diff two existing versions of a draft, etc. Is that going to
work with this new system?

On Thu, Nov 18, 2021 at 1:59 PM Kesara Rathnayake <[email-masked]>
wrote:

> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Kesara Rathnayake <[email-masked]>
Date: Fri, 19 Nov 2021 08:13:41 +1300

On 19/11/21 8:05 am, Ted Lemon wrote:
> The Diff feature is a bit weird. In the current tools site, we can diff 
> two specific input files, diff against an existing draft (doesn't have 
> to be the latest), diff two existing versions of a draft, etc. Is that 
> going to work with this new system?

You can compare two draft versions using
https://author-tools.ietf.org/iddiff

   --Kesara

> 
> On Thu, Nov 18, 2021 at 1:59 PM Kesara Rathnayake <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Website: https://author-tools.ietf.org/ <https://author-tools.ietf.org/>
> 
>     <https://author-tools.ietf.org/doc/>
> 
>     <https://author-tools.ietf.org/iddiff>
> 
>     Notable changes:
>     * From https://author-tools.ietf.org/iddiff
>     <https://author-tools.ietf.org/iddiff>, you can compare two drafts
>     [email-masked] <mailto:[email-masked]>
> 
>     <mailto:[email-masked]>
>     * Report datatracker and mailarchive bugs to:
>     [email-masked] <mailto:[email-masked]>
>     * Report tools.ietf.org <http://tools.ietf.org> bugs to:
>     [email-masked] <mailto:[email-masked]>
>     <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/tools-discuss>
>

---

From: Russ Housley <[email-masked]>
Date: Thu, 18 Nov 2021 14:28:21 -0500

Which is supposed to be the Older File "First Draft" or "Second Draft"?

Russ

> On Nov 18, 2021, at 2:13 PM, Kesara Rathnayake <[email-masked]> wrote:
> 
> 
> 
>> The Diff feature is a bit weird. In the current tools site, we can diff two specific input files, diff against an existing draft (doesn't have to be the latest), diff two existing versions of a draft, etc. Is that going to work with this new system?
> 
>> On Thu, Nov 18, 2021 at 1:59 PM Kesara Rathnayake <[email-masked] <mailto:[email-masked]>> wrote:
>>    --     Kesara Rathnayake
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Kesara Rathnayake <[email-masked]>
Date: Fri, 19 Nov 2021 09:18:39 +1300

> Which is supposed to be the Older File "First Draft" or "Second Draft"?

There's in no order.
"First Draft" will be on left side and "Second Draft" will end up on the 
right side of the result.

   --Kesara