Subject: Re: [Tools-discuss] Accepting email on any IETF list with a single subscription

From: Toerless Eckert <[email-masked]>
Date: Tue, 9 Nov 2021 14:52:42 +0100

Cc'ing tools-discuss at the marginal hope, that the work to upgrade
our mailman solution might get us to a point where one could actually
validate not only email addresses to which messages should be sent to,
but also send-only addresses, from which the list should accept
emails.

Aka: i have run very often into this same sender != receiver mailbox
problem. For example on this very mailbox of mine there are still weird
historic artefacts that makes email get originated from other aliases.

Don't even know right now the right place to submit an RFE for something like this.
Implementation wise it might be as simple as subscribing with an address
and a new delivery option: "NO delivery" (subscriber web interface).

Cheers
   Toerless

On Tue, Nov 09, 2021 at 08:46:30AM -0500, Paul Wouters wrote:
> On Tue, 9 Nov 2021, Lars Eggert wrote:
> 
> > On 2021-11-9, at 4:45, Paul Wouters <[email-masked]> wrote:
> > > I know each list / WG can configure whether to accept email from IETF participants subscribed to other ietf list without being held for moderation. In my own transitioning of email address I am finding that most WGs have not enabled this option.
> > 
> > this is not an answer for the question you asked, but you can change your email address globally, i.e., for all mailman lists at ietf.org. Would that address your issue?
> 
> In my personal case, no. My receiving path and sending path are different.
> 
> But I didn't want to make this just about my use case / situation here.
> In general, we will see people who can't send email to a list even if
> they read the lists using our IMAP servers, eg they are not subscribed.
> 
> I feel the idea of subscribing to one allows you to mail to all of them
> is an important feature. We kind of made it but then we seem to have
> crippled it by making it a WG opt-in.
> 
> Paul

---

From: Jay Daley <[email-masked]>
Date: Wed, 10 Nov 2021 03:01:22 +1300

> On 10/11/2021, at 2:52 AM, Toerless Eckert <[email-masked]> wrote:
> 

Take a look at 

	https://www.ietf.org/media/documents/Mail_Subscription_Mockup_2021-10-12.pdf

as explained in 

	https://mailarchive.ietf.org/arch/msg/tools-discuss/tczQzcpBhe6ppdu8VDN4OzWbPtA/

to see if that addresses your requirements.

Jay

-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 9 Nov 2021 15:33:43 +0100

Great. Yes. Seems to also support the kitchen-sink feature.

Any timeline for when this may go into trial phase ?

Cheers
   Toerless

-- 
---
[email-masked]

---

From: Jay Daley <[email-masked]>
Date: Wed, 10 Nov 2021 03:51:37 +1300

> On 10/11/2021, at 3:33 AM, Toerless Eckert <[email-masked]> wrote:
> 

Not yet.  Robert is organising some community workshops to discuss mail features and after that we have some dependencies (mailman upgrade) and planning to complete first.

Jay

> [email-masked] <mailto:[email-masked]>
-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: Jared Mauch <[email-masked]>
Date: Tue, 9 Nov 2021 10:56:56 -0500

> On Nov 9, 2021, at 8:52 AM, Toerless Eckert <[email-masked]> wrote:
> 

I think the issue is that the people who do these interesting things are a subset of the users.  The rest of us know that we must send from the same address we are subscribed from, or at least have the mailers configured (eg: mutt send-hooks) to match this.

- Jared

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 9 Nov 2021 17:22:12 +0100

> I think the issue is that the people who do these interesting things are a subset of the users.  The rest of us know that we must send from the same address we are subscribed from, or at least have…

Given how this was already on the work plan from RjS, it
seems we have a sufficiently large subset. Or maybe just one
important enough user (usually wih a similar name than the developer ? ;-))

Cheers
    toerless

---

From: Mirja Kuehlewind <[email-masked]>
Date: Tue, 9 Nov 2021 17:30:12 +0100

Quite some people use the IMAP server to read lists and are not subscribed anymore.

> On 9. Nov 2021, at 17:22, Toerless Eckert <[email-masked]> wrote:
>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 9 Nov 2021 17:33:36 +0100

> Quite some people use the IMAP server to read lists and are not subscribed anymore.

If i could just figure out how to make mutt start up, and not load messages older
than e.g.: 5 months, i would go that way too. Right now it can be painfully slow for
many of the lists i read.

---

From: "John Levine" <[email-masked]>
Date: 9 Nov 2021 18:11:12 -0500

>but also send-only addresses, from which the list should accept

The current setup accepts mail from (roughly) any address that is subscribed
to any IETF list.  You do not have to be subscribed to the list to which
you are sending a message.

I subscribe to one or two lists and pull dozens more from the IMAP server,
to which I send messages in the normal way.  Works great.

I would be pretty unhappy if our lists allowed actual send-only addresses
to which one could not reply.  I get enough mail like that from my bank,
don't want it from the IETF.

R's,
John

---

From: "John Levine" <[email-masked]>
Date: 9 Nov 2021 18:13:22 -0500

>many of the lists i read.

That is a problem with mutt, not with IMAP.

I use alpine, the most antique IMAP client of all, and Thunderbird, both of which can
open any of the IETF server's folders in a few seconds.

R's,
John

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 10 Nov 2021 01:02:57 +0100

> don't want it from the IETF.

Agreed.

I would hope and expect that every email that is added to the new IETF mailman solution
would still be verified with a message receipt, as it is also done today.

The only difference should be that mailman will not send any mailing list
mails to that address, but continue to support any subscriber functions
for that email address (like listing subscribers etc.). Probably exactly for
lists that you only read via IMAP.

---

From: "John R Levine" <[email-masked]>
Date: 9 Nov 2021 20:54:19 -0500

> lists that you only read via IMAP.

Um, mailman has had that feature for about 20 years.  Perhaps this would 
be a good time to RTFM.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail. https://jl.ly

---

From: Toerless Eckert <[email-masked]>
Date: Wed, 10 Nov 2021 02:58:05 +0100

On Tue, Nov 09, 2021 at 08:54:19PM -0500, John R Levine wrote:
> Um, mailman has had that feature for about 20 years.  Perhaps this would be
> a good time to RTFM.

Ok, but why then where you concerned ?

Cheers
    Toerless