Subject: [Tools-discuss] Change datatracker landing page to be RFC?

From: Eric Rescorla <[email-masked]>
Date: Tue, 28 Dec 2021 16:05:56 -0800

Hi folks,

I'm sure you've noticed that when you search with the datatracker, the
landing page is not the RFC/I-D itself but rather the datatracker info
page, like so:

https://datatracker.ietf.org/doc/rfc8555/

It seems to me that the majority of people who are trying to find
drafts/RFCs don't want this metadata but rather want the document itself
(especially for RFCs, where it's not like there is much activity.) What
would people think of having that be the default, or at least having two
links on the search page, one for the doc and one for the metadata?

-Ekr

---

From: tjw ietf <[email-masked]>
Date: Tue, 28 Dec 2021 19:21:23 -0500

What about when you search expired rfc?  The info page makes a wee bit more sense. 

Sent from my iPhone

> On Dec 28, 2021, at 19:06, Eric Rescorla <[email-masked]> wrote:
> 
> 
> Hi folks,
> 
> I'm sure you've noticed that when you search with the datatracker, the landing page is not the RFC/I-D itself but rather the datatracker info page, like so:
> 
> It seems to me that the majority of people who are trying to find drafts/RFCs don't want this metadata but rather want the document itself (especially for RFCs, where it's not like there is much activity.) What would people think of having that be the default, or at least having two links on the search page, one for the doc and one for the metadata?
> 
> -Ekr
> 
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 28 Dec 2021 16:28:37 -0800

> What about when you search expired rfc?  The info page makes a wee bit

Well, RFCs don't expire, so this particular case seems like a non-issue.
Perhaps you mean I-Ds?
In any case, my answer is the same: show the document, and if you like show
a banner with its status,
which in fact is more or less what we do if you finally click your way
there:

https://datatracker.ietf.org/doc/html/draft-barnes-acme-04

Given that this is HTML, we could even show some giant "expired" overlay if
people insist,
like so. Note that you already have to go to some effort to get the DT to
even show
you expired drafts, so I don't think people are going to be that confused.

My basic thesis is that the vast majority of people want to read the
document, not
look at the metadata, so why are we making them go to a lot more work.

-Ekr

> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
>

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 28 Dec 2021 16:50:12 -0800

On Tue, Dec 28, 2021 at 4:28 PM Eric Rescorla <[email-masked]> wrote:

> In any case, my answer is the same: show the document, and if you like
> show a banner with its status,
> Given that this is HTML, we could even show some giant "expired" overlay
> if people insist,
> like so.
>

Or rather, like so:
https://w3c-ccg.github.io/did-method-web/

> Note that you already have to go to some effort to get the DT to even show

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 29 Dec 2021 14:06:56 +1300

I tend to disagree. Yes, for those of us here every day, a direct link saves a few seconds. But shouldn't we more or less force people to see if what they are looking for is (a) not the latest version (b) has been replaced (c) is dead (d) is already in Last Call (e) whatever?

For RFCs I alway use the search box at https://www.rfc-editor.org/ these days, unless I specifically want the tracker history. Why the IETF still bothers to mirror the content of published RFCs is unclear, since the RFC 
Editor now displays the htmlized versions of older RFCs.

Regards
    Brian

On 29-Dec-21 13:50, Eric Rescorla wrote:
> 
> 
> On Tue, Dec 28, 2021 at 4:28 PM Eric Rescorla <[email-masked] <mailto:[email-masked]>> wrote:
> 
> 
> 
>     On Tue, Dec 28, 2021 at 4:21 PM tjw ietf <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     Well, RFCs don't expire, so this particular case seems like a non-issue. Perhaps you mean I-Ds?
>     In any case, my answer is the same: show the document, and if you like show a banner with its status,
>     which in fact is more or less what we do if you finally click your way there:
> 
>     https://datatracker.ietf.org/doc/html/draft-barnes-acme-04 <https://datatracker.ietf.org/doc/html/draft-barnes-acme-04>
> 
>     Given that this is HTML, we could even show some giant "expired" overlay if people insist,
>     like so. 
> 
> 
> Or rather, like so:
> https://w3c-ccg.github.io/did-method-web/ <https://w3c-ccg.github.io/did-method-web/>
> 
>     My basic thesis is that the vast majority of people want to read the document, not
>>         On Dec 28, 2021, at 19:06, Eric Rescorla <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>         
>>         Hi folks,
>>
>>         https://datatracker.ietf.org/doc/rfc8555/ <https://datatracker.ietf.org/doc/rfc8555/>
>>
>>         Tools-discuss mailing list - [email-masked] <mailto:[email-masked]>
>>         * Report datatracker and mailarchive bugs to: [email-masked] <mailto:[email-masked]>
>>         * Report tools.ietf.org <http://tools.ietf.org> bugs to: [email-masked] <mailto:[email-masked]>
>>         * Report all other bugs or issues to: [email-masked] <mailto:[email-masked]>
>>         List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss>
> 
>

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 28 Dec 2021 17:08:58 -0800

On Tue, Dec 28, 2021 at 5:07 PM Brian E Carpenter <
[email-masked]> wrote:

> I tend to disagree. Yes, for those of us here every day, a direct link
> saves a few seconds. But shouldn't we more or less force people to see if
> what they are looking for is (a) not the latest version (b) has been
> replaced (c) is dead (d) is already in Last Call (e) whatever?
>

Why can't this be done with a banner?

For RFCs I alway use the search box at https://www.rfc-editor.org/ these
> days, unless I specifically want the tracker history. Why the IETF still
> bothers to mirror the content of published RFCs is unclear, since the RFC

Well, the DT actually points to rfc-editor.org for some of the versions. As
for which search box to use, it seems unhelpful to require people to use a
different site for RFCs and I-Ds.

-Ekr

> >     https://datatracker.ietf.org/doc/html/draft-barnes-acme-04 <
> https://datatracker.ietf.org/doc/html/draft-barnes-acme-04>
> >
> > https://w3c-ccg.github.io/did-method-web/ <
> https://w3c-ccg.github.io/did-method-web/>
> >
> >>         I'm sure you've noticed that when you search with the
> datatracker, the landing page is not the RFC/I-D itself but rather the
> datatracker info page, like so:
> >>
> >>         https://datatracker.ietf.org/doc/rfc8555/ <
> https://datatracker.ietf.org/doc/rfc8555/>
> >>
> >>         It seems to me that the majority of people who are trying to
> find drafts/RFCs don't want this metadata but rather want the document
> itself (especially for RFCs, where it's not like there is much activity.)
> What would people think of having that be the default, or at least having
> two links on the search page, one for the doc and one for the metadata?
> >>
> >>         -Ekr
> >>
> >>
> >>         * Report datatracker and mailarchive bugs to:
> [email-masked] <mailto:[email-masked]>
> >>         * Report tools.ietf.org <http://tools.ietf.org> bugs to:
> [email-masked] <mailto:[email-masked]>
> <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/tools-discuss <
> https://www.ietf.org/mailman/listinfo/tools-discuss>
> >
> >

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 29 Dec 2021 14:22:12 +1300

On 29-Dec-21 14:08, Eric Rescorla wrote:
> 
> 
> On Tue, Dec 28, 2021 at 5:07 PM Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     I tend to disagree. Yes, for those of us here every day, a direct link saves a few seconds. But shouldn't we more or less force people to see if what they are looking for is (a) not the latest version (b) has been 
> Why can't this be done with a banner?

Yes, that would be fine.

> 
> 
>     For RFCs I alway use the search box at https://www.rfc-editor.org/ <https://www.rfc-editor.org/> these days, unless I specifically want the tracker history. Why the IETF still bothers to mirror the content of published RFCs is unclear, since the RFC
> Well, the DT actually points to rfc-editor.org <http://rfc-editor.org> for some of the versions. As for which search box to use, it seems unhelpful to require people to use a different site for RFCs and I-Ds.

Fair enough, but the tracker search is definitely more geeky. It has some 
quirks that probably need attention. If I type in "5430" I get useful information (like, it's obsolete) and eventually a page that links to https://www.rfc-editor.org/rfc/rfc5430.html
*and* to https://datatracker.ietf.org/doc/html/rfc5430, which is essentially identical but just slightly different.

   Brian

>      > On Tue, Dec 28, 2021 at 4:28 PM Eric Rescorla <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>      >
>      >
>      >
>      >     On Tue, Dec 28, 2021 at 4:21 PM tjw ietf <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>      >
>      > https://datatracker.ietf.org/doc/html/draft-barnes-acme-04 <https://datatracker.ietf.org/doc/html/draft-barnes-acme-04> <https://datatracker.ietf.org/doc/html/draft-barnes-acme-04 <https://datatracker.ietf.org/doc/html/draft-barnes-acme-04>>
>      >
>      > https://w3c-ccg.github.io/did-method-web/ <https://w3c-ccg.github.io/did-method-web/> <https://w3c-ccg.github.io/did-method-web/ <https://w3c-ccg.github.io/did-method-web/>>
>      >
>      >>         On Dec 28, 2021, at 19:06, Eric Rescorla <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
>      >>
>      >>         
>      >>         Hi folks,
>      >>
>      >> https://datatracker.ietf.org/doc/rfc8555/ <https://datatracker.ietf.org/doc/rfc8555/> <https://datatracker.ietf.org/doc/rfc8555/ <https://datatracker.ietf.org/doc/rfc8555/>>
>      >>
>      >>         Tools-discuss mailing list - [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>      >>         * Report datatracker and mailarchive bugs to: [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>      >>         * Report tools.ietf.org <http://tools.ietf.org> <http://tools.ietf.org <http://tools.ietf.org>> bugs to: [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>      >>         * Report all other bugs or issues to: [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
>      >>         List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss> <https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss>>
>      >
>      >

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 28 Dec 2021 17:50:26 -0800

On Tue, Dec 28, 2021 at 5:22 PM Brian E Carpenter <
[email-masked]> wrote:

> [email-masked] <mailto:[email-masked]>> wrote:
> >
> >     I tend to disagree. Yes, for those of us here every day, a direct
> link saves a few seconds. But shouldn't we more or less force people to see
> if what they are looking for is (a) not the latest version (b) has been
> >     For RFCs I alway use the search box at https://www.rfc-editor.org/ <
> https://www.rfc-editor.org/> these days, unless I specifically want the
> tracker history. Why the IETF still bothers to mirror the content of
> published RFCs is unclear, since the RFC
> > Well, the DT actually points to rfc-editor.org <http://rfc-editor.org>
> for some of the versions. As for which search box to use, it seems
> unhelpful to require people to use a different site for RFCs and I-Ds.
>
> quirks that probably need attention. If I type in "5430" I get useful
> information (like, it's obsolete) and eventually a page that links to
> https://www.rfc-editor.org/rfc/rfc5430.html
> *and* to https://datatracker.ietf.org/doc/html/rfc5430, which is
> essentially identical but just slightly different.
>

To be clear, all I'm suggesting is that the link off the search results
page go right to the document.

I.e., when I click RFC 8555 below.

   Brian
> >      > On Tue, Dec 28, 2021 at 4:28 PM Eric Rescorla <[email-masked]
> <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
> >      >
> >      >
> >      >
> >      >     On Tue, Dec 28, 2021 at 4:21 PM tjw ietf <[email-masked]
> <mailto:[email-masked]> <mailto:[email-masked] <mailto:
> [email-masked]>>> wrote:
> >      >
> https://datatracker.ietf.org/doc/html/draft-barnes-acme-04> <
> https://datatracker.ietf.org/doc/html/draft-barnes-acme-04>>
> >      >
> https://w3c-ccg.github.io/did-method-web/> <
> https://w3c-ccg.github.io/did-method-web/>>
> >      >
> >      >>         On Dec 28, 2021, at 19:06, Eric Rescorla <[email-masked]
> <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
> >      >>
> >      >>         
> >      >>         Hi folks,
> >      >>
> https://datatracker.ietf.org/doc/rfc8555/> <
> https://datatracker.ietf.org/doc/rfc8555/>>
> >      >>
> >      >>         It seems to me that the majority of people who are
> trying to find drafts/RFCs don't want this metadata but rather want the
> document itself (especially for RFCs, where it's not like there is much
> activity.) What would people think of having that be the default, or at
> least having two links on the search page, one for the doc and one for the
> metadata?
> >      >>
> >      >>         -Ekr
> >      >>
> >      >>
> >      >>
> <mailto:[email-masked]> <mailto:[email-masked] <mailto:
> [email-masked]>>
> <mailto:[email-masked] <mailto:[email-masked]
> >>
> >      >>         * Report tools.ietf.org <http://tools.ietf.org> <
> http://tools.ietf.org <http://tools.ietf.org>> bugs to:
> [email-masked] <mailto:[email-masked]> <mailto:
> [email-masked] <mailto:[email-masked]>>
> >      >>         * Report all other bugs or issues to:
> [email-masked] <mailto:[email-masked]> <mailto:
> [email-masked] <mailto:[email-masked]>>
> https://www.ietf.org/mailman/listinfo/tools-discuss> <
> https://www.ietf.org/mailman/listinfo/tools-discuss>>
> >      >
> >      >

---

From: tjw ietf <[email-masked]>
Date: Tue, 28 Dec 2021 22:12:31 -0500

Maybe I am weird but I never search for RFCs from the data tracker. I type RFC8020 into the address bar and let the magic happen.  

Tim.  

Sent from my iPhone

> On Dec 28, 2021, at 20:51, Eric Rescorla <[email-masked]> wrote:
> 
> 
> 
> 
>> On Tue, Dec 28, 2021 at 5:22 PM Brian E Carpenter <[email-masked]> wrote:
> To be clear, all I'm suggesting is that the link off the search results page go right to the document.
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 29 Dec 2021 11:30:23 +0100

> https://w3c-ccg.github.io/did-method-web/

Hi Eric,

can you say what you are trying to demonstrate?

This html file arrives completely unstyled here, so I don’t know what is special about it (maybe the "TypeError: undefined is not a constructor” has something to do with that).

(Nice counterexample demo for attaching metadata to HTML pages.)

Grüße, Carsten

---

From: Bob Hinden <[email-masked]>
Date: Wed, 29 Dec 2021 08:54:49 -0800

Tim,

Same for me.   When I do use the data tracker search, is more likely that I am interested in data tracker info page for the document.

Bob

> On Dec 28, 2021, at 7:12 PM, tjw ietf <[email-masked]> wrote:
>

---

From: Michael Richardson <[email-masked]>
Date: Wed, 29 Dec 2021 16:32:26 -0500

> https://datatracker.ietf.org/doc/rfc8555/

I think that did this on purpose a year or so ago for DT and rfc-editor.org,
in an attempt to make the meta-data, and choice of formats, more in people's face.

I agree that maybe it's poor UX, and we shouldn't do this with a banner.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide