Subject: Re: [Tools-discuss] The Citation Tool

From: Robert Sparks <[email-masked]>
Date: Thu, 2 Dec 2021 17:00:14 -0600

Hi Ole -

See https://github.com/ietf-tools/tools-transition-plan/issues/5

We're not planning to build a replacement for that particular service 
immediately. I'll capture it as a wish for re-implementation.

RjS

On 10/19/21 10:10 AM, Ole Jacobsen wrote:
> Hi folks,
>
> One tool that I used constantly was written specifically "for me" by 
> Henrik
> and can be found here:
>
> https://tools.ietf.org/tools/citation/
>
> This is a really useful way to generate citations for either IDs or 
> RFCs in
> one of two variant formats.
>
> Change the default template to "andlist" then enter "1918" and you 
> will get:
>
> Daniel Karrenberg, Yakov Rekhter, Eliot Lear, and Geert Jan de Groot, 
> "Address Allocation for Private Internets," RFC 1918, February 1996.
>
> I should note that this only works for RFCs up to 8990 presumably 
> because some underlying
> indexing script stops running.
>
> Would LOVE to see this functionality replicated in your new system.
>
> Cheers,
>
> Ole
>
> Ole J. Jacobsen
> Editor and Publisher
> The Internet Protocol Journal
> Office: +1 415-550-9433
> Cell:   +1 415-370-4628
> Web: protocoljournal.org <http://protocoljournal.org>
> E-mail: [email-masked] <mailto:[email-masked]>
> E-mail: [email-masked]
> Skype: organdemo
>
>
>
>
> ___________________________________________________________
> Tools-discuss mailing list [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to:[email-masked]
> * Report tools.ietf.org bugs to:[email-masked]
> * Report all other bugs or issues to:[email-masked]
> List info (including how to Unsubscribe):https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 3 Dec 2021 14:47:30 +1300

Ole,

For RFCs, try the "Cite this RFC: TXT" field at (e.g)
https://www.rfc-editor.org/info/rfc1984

For drafts, it seems trivial to create the format you want from (e.g.)
https://datatracker.ietf.org/doc/draft-ietf-anima-asa-guidelines/04/bibtex/

Regards
    Brian

On 03-Dec-21 12:00, Robert Sparks wrote:
> We're not planning to build a replacement for that particular service immediately. I'll capture it as a wish for re-implementation.
> 
> RjS
> 
>> One tool that I used constantly was written specifically "for me" by Henrik
>> and can be found here:
>>
>> This is a really useful way to generate citations for either IDs or RFCs in
>> Change the default template to "andlist" then enter "1918" and you will get:
>>
>> Daniel Karrenberg, Yakov Rekhter, Eliot Lear, and Geert Jan de Groot, "Address Allocation for Private Internets," RFC 1918, February 1996.
>>
>> I should note that this only works for RFCs up to 8990 presumably because some underlying
> Tools-discuss mailing list - [email-masked]
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss
>