Subject: [Tools-discuss] I-D names ending in -[0-9][0-9]

From: Carsten Bormann <[email-masked]>
Date: Mon, 24 Jan 2022 08:09:20 +0100

*** reference.I-D.spaghetti-idr-deprecate-8-9-10.xml: *** Status code 404 while fetching https://datatracker.ietf.org/doc/bibxml3/draft-spaghetti-idr-deprecate-8-9-10.xml

While the version-numbered link does exist:
https://datatracker.ietf.org/doc/bibxml3/draft-spaghetti-idr-deprecate-8-9-10-00.xml

I thought we had this nailed…
(Maybe we should have disallowed draft names ending in -[0-9][0-9] ?  But that’s too late now.)

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 24 Jan 2022 14:38:00 +0100

> (Maybe we should have disallowed draft names ending in -[0-9][0-9] ?  But that’s too late now.)

And while we are at that, we could disallow submitting v3 drafts with different names in /rfc/@docName and /rfc/front/seriesInfo/@value — I’ve seen different parts of the toolchain pick up different values from those two places, which can get very confusing.  (Some 255 I-Ds have inconsistencies here, including at least one I co-authored :-), so this is not a theoretical concern.)

Grüße, Carsten

---

From: Julian Reschke <[email-masked]>
Date: Mon, 24 Jan 2022 15:22:10 +0100

> And while we are at that, we could disallow submitting v3 drafts with different names in /rfc/@docName and /rfc/front/seriesInfo/@value — I’ve seen different parts of the toolchain pick up differen…

Even better would be to eliminate the option to put the same thing into
two places...

Best regards, Julian

(and yes:
https://github.com/reschke/xml2rfc/blob/ff4ff07ad7e3871ec6e68fe0c709c76778c7f8a9/rfc2629.xslt#L3182-L3186)

---

From: Robert Sparks <[email-masked]>
Date: Mon, 24 Jan 2022 09:36:07 -0600

On 1/24/22 8:22 AM, Julian Reschke wrote:
>> And while we are at that, we could disallow submitting v3 drafts with 
>> different names in /rfc/@docName and /rfc/front/seriesInfo/@value — 
>> I’ve seen different parts of the toolchain pick up different values 
>> from those two places, which can get very confusing.  (Some 255 I-Ds 
>> have inconsistencies here, including at least one I co-authored :-), 
>> so this is not a theoretical concern.)
>

Are you re-raising this as a grammar change we should consider?

The original 799x proposal turned out to be quite problematic - 
especially when a document might have more than one bit of series info 
(something published as a BCP (and necessarily as an RFC), for example. 
There were other rough spots called out starting at 
https://datatracker.ietf.org/doc/html/draft-levkowetz-xml2rfc-v3-implementation-notes-13#section-3.1.18.

IIRC, list discussion around this and similar changes pointed out the 
issue with changing what people expect, both as authors and as tool 
maintainers.

If we did want to change the vocabulary, perhaps we give up on the reuse 
of seriesInfo in front, and build a structure that unambiguously 
declares the name, and a list of other names the document might go by.

Whatever we do, finding the name shouldn't become more difficult than 
the current, where it's possible to pull the name of the document out 
with a fairly simple regex.

> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: 
> [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): 
> https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Julian Reschke <[email-masked]>
Date: Mon, 24 Jan 2022 16:42:01 +0100

> Are you re-raising this as a grammar change we should consider?

For some value of "re-raising". See
<https://github.com/rfc-format/draft-iab-xml2rfc-v3-bis/issues/7>. (That
issue has been open for 5 years now...).

IMHO the simplest thing to do is to undo the changes to seriesInfo,
un-deprecate what we have in RFC 7749, and then see whether something is
missing.

Best regards, Julian