Subject: [Tools-discuss] xml2rfc rendering of <contact>

From: Eric Rescorla <[email-masked]>
Date: Fri, 7 Jan 2022 16:50:27 -0800

Hi folks,

When generating txt, xml2rfc renders <contact> with a superfluous space
between the affiliation and the email address, like so:

   Eric Rescorla
   RTFM, Inc.

   Email: [email-masked]

This is not true in the HTML version, which looks sensible:

How hard would it be to address this?

-Ekr

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 8 Jan 2022 14:36:20 +1300

That blank line has been there in .txt format RFCs for many years, including RFC2223 and RFC7322. So I assume it was intentional to generate it in xml2rfc.

Regards
    Brian

On 08-Jan-22 13:50, Eric Rescorla wrote:
> Hi folks,
> 
> When generating txt, xml2rfc renders <contact> with a superfluous space between the affiliation and the email address, like so:
> 
>     Eric Rescorla
>     RTFM, Inc.
> 
>     Email:[email-masked]  <mailto:[email-masked]>
> 
> image.png
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Eric Rescorla <[email-masked]>
Date: Fri, 7 Jan 2022 17:39:03 -0800

I do see what you mean. But when you have a list of people it's... not good.

For instance, here's how DTLS 1.3's contributors section is coming out:

   Hanno Becker
   Arm Limited

   Email: [email-masked]

   David Benjamin
   Google

   Email: [email-masked]

   Thomas Fossati
   Arm Limited

   Email: [email-masked]

   Tobias Gondrom
   Huawei

   Email: [email-masked]

   Felix Günther
   ETH Zurich

   Email: [email-masked]

   Benjamin Kaduk
   Akamai Technologies

   Email: [email-masked]

   Ilari Liusvaara
   Independent

   Email: [email-masked]

   Martin Thomson
   Mozilla

   Email: [email-masked]

   Christopher A. Wood
   Apple Inc.

   Email: [email-masked]

   Yin Xinxing
   Huawei

   Email: [email-masked]

-Ekr

On Fri, Jan 7, 2022 at 5:36 PM Brian E Carpenter <
[email-masked]> wrote:

> That blank line has been there in .txt format RFCs for many years,
> including RFC2223 and RFC7322. So I assume it was intentional to generate
> it in xml2rfc.
>
> Regards
>     Brian
>
> > List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
> >
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 8 Jan 2022 14:44:13 +1300

Yes, it's ugly.

Regards
    Brian Carpenter

On 08-Jan-22 14:39, Eric Rescorla wrote:
>     Email: [email-masked] <mailto:[email-masked]>
> 
> 
>     David Benjamin
>     Google
> 
>     Email: [email-masked] <mailto:[email-masked]>
> 
> 
>     Thomas Fossati
>     Arm Limited
> 
>     Email: [email-masked] <mailto:[email-masked]>
> 
> 
>     Tobias Gondrom
>     Huawei
> 
>     Email: [email-masked] <mailto:[email-masked]>
> 
> 
>     Felix Günther
>     ETH Zurich
> 
>     Email: [email-masked] <mailto:[email-masked]>
> 
> 
>     Benjamin Kaduk
>     Akamai Technologies
> 
>     Email: [email-masked] <mailto:[email-masked]>
> 
> 
>     Ilari Liusvaara
>     Independent
> 
>     Email: [email-masked] <mailto:[email-masked]>
> 
> 
>     Martin Thomson
>     Mozilla
> 
>     Email: [email-masked] <mailto:[email-masked]>
> 
> 
>     Christopher A. Wood
>     Apple Inc.
> 
>     Email: [email-masked] <mailto:[email-masked]>
> 
> 
>     Yin Xinxing
>     Huawei
> 
>     Email: [email-masked] <mailto:[email-masked]>
> 
> 
> -Ekr
> 
> 
> 
> On Fri, Jan 7, 2022 at 5:36 PM Brian E Carpenter <[email-masked] <mailto:[email-masked]>> wrote:
> 
>      > Email:[email-masked] <mailto:[email-masked]>  <mailto:[email-masked] <mailto:[email-masked]>>
>      >
>      > Tools-discuss mailing list - [email-masked] <mailto:[email-masked]>
>      > * Report datatracker and mailarchive bugs to: [email-masked] <mailto:[email-masked]>
>      > * Report tools.ietf.org <http://tools.ietf.org> bugs to: [email-masked] <mailto:[email-masked]>
>      > * Report all other bugs or issues to: [email-masked] <mailto:[email-masked]>
>      > List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss>
>      >
>

---

From: Robert Sparks <[email-masked]>
Date: Fri, 7 Jan 2022 22:08:11 -0600

Unless there's a strong reason to keep it, even if ugly, let's change it.

On 1/7/22 7:44 PM, Brian E Carpenter wrote:
>> <mailto:[email-masked]>
>>
>>
>>     Felix Günther
>>     ETH Zurich
>>
>> On Fri, Jan 7, 2022 at 5:36 PM Brian E Carpenter 
>> <[email-masked] <mailto:[email-masked]>> 
>> wrote:
>>
>>     That blank line has been there in .txt format RFCs for many 
>> years, including RFC2223 and RFC7322. So I assume it was intentional 
>> to generate 
> it in xml2rfc.
>>
>>     Regards
>>          Brian
>>
>>      > Hi folks,
>>      >
>>      > When generating txt, xml2rfc renders <contact> with a 
>> superfluous space between the affiliation and the email address, like 
>> so:
>>      >
>>      >     Eric Rescorla
>>      >     RTFM, Inc.
>>      >
>>      > Email:[email-masked] <mailto:[email-masked]>  
>> <mailto:[email-masked] <mailto:[email-masked]>>
>>      >
>>      > This is not true in the HTML version, which looks sensible:
>>      >
>>      > image.png
>>      > How hard would it be to address this?
>>      >
>>      > -Ekr
>>      >
>>      >
>>      >
>>      > ___________________________________________________________
>>      > Tools-discuss mailing list - [email-masked] 
>> <mailto:[email-masked]>
>>      > This list is for discussion, not for action requests or bug 
>> reports.
>>      > * Report datatracker and mailarchive bugs to: 
>> [email-masked] <mailto:[email-masked]>
>>      > * Report tools.ietf.org <http://tools.ietf.org> bugs to: 
>> [email-masked] <mailto:[email-masked]>
>>      > * Report all other bugs or issues to: [email-masked] 
>> <mailto:[email-masked]>
>>      > List info (including how to Unsubscribe): 
>> <https://www.ietf.org/mailman/listinfo/tools-discuss>
>>      >
>>
>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 12 Jan 2022 09:00:58 +1300

However, it seems like a style guide issue in the RFC Editor Service's
remit. (If anybody still cares about the style guide for plain text.)

Regards
    Brian

---

From: John Scudder <[email-masked]>
Date: Tue, 11 Jan 2022 20:13:44 +0000

On Jan 7, 2022, at 8:44 PM, Brian E Carpenter <[email-masked]<mailto:[email-masked]>> wrote:

Yes, it's ugly.

Not only is it aesthetically ugly, it’s functionally ugly as it (mildly) impairs usability of the document by introducing a small ambiguity.

—John

---

From: Julian Reschke <[email-masked]>
Date: Wed, 12 Jan 2022 06:42:15 +0100

>     Brian Carpenter

1) We shouldn't care about ugliness in the plain text version.

2) Changing this *might* disrupt scripts that mine for author
information (and yes, these should change to use the XML when available)

Best regards, Julian

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 12 Jan 2022 06:14:51 -0800

> 1) We shouldn't care about ugliness in the plain text version.

I don't agree with that. But to the extent to which you don't care what the
text version looks like, when perhaps we can accommodate people who do.

> information (and yes, these should change to use the XML when available)

As could any change of any kind., This seems like a weak reason.

-Ekr

---

From: Sandy Ginoza <[email-masked]>
Date: Thu, 13 Jan 2022 17:58:55 -0800

Hi all,

So, there is a Style Guide component in that RFC 7322 <https://www.rfc-editor.org/rfc/rfc7322.html#section-4.11> includes the following:

   At the
   discretion of the author(s), contact addresses may also be included
   in the Contributors section, for those contributors whose knowledge
   makes them useful future contacts for information about the RFC.  The
   format of any contact information should be similar to the format of
   information in the Author's Address section.

It sounds like we’re leaning toward changing the format of the Contributors to remove the blank line that appears before email.  I propose we remove it from the Authors’ Addresses section as well.  Then the format for Contributors and Authors’ Addresses will be the same, and the format will match across outputs.  

Thanks,
Sandy 

> On Jan 12, 2022, at 6:14 AM, Eric Rescorla <[email-masked]> wrote:
> 
> 
> 
> On Tue, Jan 11, 2022 at 9:42 PM Julian Reschke <[email-masked]> wrote:
> I don't agree with that. But to the extent to which you don't care what the text version looks like, when perhaps we can accommodate people who do.
>  
>

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 13 Jan 2022 18:30:24 -0800

That sounds good to me. It's confusing there as well.

-Ekr

On Thu, Jan 13, 2022 at 5:58 PM Sandy Ginoza <[email-masked]> wrote:

> Hi all,
>
> So, there is a Style Guide component in that RFC 7322
> <https://www.rfc-editor.org/rfc/rfc7322.html#section-4.11> includes the
> following:
>
>    At the
> It sounds like we’re leaning toward changing the format of the
> Contributors to remove the blank line that appears before email.  I propose
> we remove it from the Authors’ Addresses section as well.  Then the format
> for Contributors and Authors’ Addresses will be the same, and the format
> will match across outputs.
>
> Thanks,
> Sandy
>
>
>
> I don't agree with that. But to the extent to which you don't care what
> the text version looks like, when perhaps we can accommodate people who do.
>
>

---

From: Bob Hinden <[email-masked]>
Date: Thu, 13 Jan 2022 20:10:09 -0800

I agree as well.

Bob

> On Jan 13, 2022, at 6:30 PM, Eric Rescorla <[email-masked]> wrote:
> 
> So, there is a Style Guide component in that RFC 7322 includes the following:
> 
>    At the

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 14 Jan 2022 09:11:56 +0100

On 2022-01-14, at 02:58, Sandy Ginoza <[email-masked]> wrote:
> 
>  I propose we remove it from the Authors’ Addresses section as well.

Indeed.  The definition of <contact includes:

>> can be used as a direct child of <section>, where it will be rendered the same way as an author address block within the "Authors' Addresses" section.

It would be very weird to render contributors different (and only in this single aspect) from authors, so this thread really is a discussion about the rendering of Author’s/Authors’ Addresses.

(I don’t think we want to change the separate aspect of in-paragraph rendering of <contact.)

Grüße, Carsten