Subject: [Tools-discuss] Time to move Kramdown from experimental to the main xml2frc page?

From: John Mattsson <[email-masked]>
Date: Thu, 27 Jan 2022 17:01:13 +0000

I think it is time to move Kramdown from the experimental page to the main xml2frc page.

OLD:
https://xml2rfc.tools.ietf.org/experimental.html

NEW:
https://xml2rfc.tools.ietf.org/

The Kramdown conversion seems pretty stable to me, and has been for a long time.

Is any human editing xml directly anymore? It feels as productive as assembly programming.

Cheers,
John

---

From: Tom Pusateri <[email-masked]>
Date: Thu, 27 Jan 2022 12:06:32 -0500

+1

Tom

> On Jan 27, 2022, at 12:01 PM, John Mattsson <john.mattsson=[email-masked]> wrote:
> 
> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Julian Reschke <[email-masked]>
Date: Thu, 27 Jan 2022 19:58:28 +0100

> https://xml2rfc.tools.ietf.org/

tools.ietf.org is so deprecated :-). A new site with new UI is in the
works, and I believe it includes kramdown support.

> Is any human editing xml directly anymore? It feels as productive as

Disagreed.

I find kramdown nice for simple stuff, but once you want to do more, it
gets in the way.

But chacun à son goût.

Best regards, Julian

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 27 Jan 2022 14:35:14 -0500

John and Tom,

Kramdown is included in the new IETF authors online converter -
https://author-tools.ietf.org . Also, you can find the source in the Tools
Catalog at https://authors.ietf.org/tools-catalog . See
https://authors.ietf.org for an overview of the new sites.

Cheers,
Andy

On Thu, Jan 27, 2022 at 12:06 PM Tom Pusateri <[email-masked]> wrote:

> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 27 Jan 2022 21:00:13 +0100

> I find kramdown nice for simple stuff, but once you want to do more, it

This depends a bit on what you mean by “do more”.

If you want to write your own authoring tools (which is pretty much what the http spec authors did), by all means target RFCXML, not markdown.

If you want to collaborate, possibly in a team with diverse backgrounds, to author a specification, without writing (much) additional software for the actual text handling, kramdown—rfc can be quite useful.
(Even for RFCs like RFC7400, which was in large parts generated by a program.)

The story behind kramdown-rfc was that some time in 2010, I had two days to write a number of I-Ds (I seem to remember it was six of them).  I gambled and spent one day to write the first version of kramdown-rfc, so I could write the actual drafts twice as fast on the other day.  I’m pretty sure I came out ahead.

Kudos to the people setting up https://author-tools.ietf.org — we now have many tools that help in IETF/IRTF document authoring, and the effort to make these more accessible to the authors is most welcome.

Grüße, Carsten

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 27 Jan 2022 20:03:01 +0000

And thanks to you for kramdown-rfc!

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 28 Jan 2022 11:35:29 +1300

To repeat what we were told many months ago: *.tools.ietf.org is obsolescent.

I switched to using author-tools.ietf.org ages ago, and my (minor) issues
have been fixed promptly and with a smile. It accepts kramdown, of course.

     Brian

On 28-Jan-22 08:35, Andrew G. Malis wrote:
> John and Tom,
> 
> Kramdown is included in the new IETF authors online converter - https://author-tools.ietf.org <https://author-tools.ietf.org> . Also, you can find the source in the Tools Catalog at https://authors.ietf.org/tools-catalog <https://authors.ietf.org/tools-catalog> . See https://authors.ietf.org <https://authors.ietf.org> for an overview of the new sites.
> 
> Cheers,
> Andy
> 
> 
> On Thu, Jan 27, 2022 at 12:06 PM Tom Pusateri <[email-masked] <mailto:[email-masked]>> wrote:
> 
>     +1
> 
>     Tom
> 
>>     On Jan 27, 2022, at 12:01 PM, John Mattsson <john.mattsson=[email-masked] <mailto:[email-masked]>> wrote:
>>
>>     
>>
>>     I think it is time to move Kramdown from the experimental page to the main xml2frc page.____
>>
>>     __ __
>>
>>     OLD:____
>>
>>     https://xml2rfc.tools.ietf.org/experimental.html <https://xml2rfc.tools.ietf.org/experimental.html>____
>>
>>     __ __
>>
>>     NEW:____
>>
>>     https://xml2rfc.tools.ietf.org/ <https://xml2rfc.tools.ietf.org/>____
>>
>>     __ __
>>
>>     The Kramdown conversion seems pretty stable to me, and has been for a long time.____
>>
>>     __ __
>>
>>     Is any human editing xml directly anymore? It feels as productive as assembly programming. ____
>>
>>     __ __
>>
>>     Cheers,____
>>
>>     John____
>>
>>     Tools-discuss mailing list - [email-masked] <mailto:[email-masked]>
>>     * Report datatracker and mailarchive bugs to: [email-masked] <mailto:[email-masked]>
>>     * Report tools.ietf.org <http://tools.ietf.org> bugs to: [email-masked] <mailto:[email-masked]>
>>     * Report all other bugs or issues to: [email-masked] <mailto:[email-masked]>
>>     List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss>
>     Tools-discuss mailing list - [email-masked] <mailto:[email-masked]>
>     * Report datatracker and mailarchive bugs to: [email-masked] <mailto:[email-masked]>
>     * Report tools.ietf.org <http://tools.ietf.org> bugs to: [email-masked] <mailto:[email-masked]>
>     * Report all other bugs or issues to: [email-masked] <mailto:[email-masked]>
>     List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss>
> 
>

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 28 Jan 2022 09:02:40 +0100

+1