Subject: [Tools-discuss] Oauth DT->Registration

From: Eric Rescorla <[email-masked]>
Date: Tue, 22 Feb 2022 18:54:17 -0800

I just went to register and I got prompted with an OAuth dialog to give
permission for the registration system to see my information from DT. Is
there some reason why we need this? Generally, it seems like people should
expect that www.ietf.org, datatracker.ietf.org, and registration.ietf.org
can share information between them.

-Ekr

---

From: Robert Sparks <[email-masked]>
Date: Wed, 23 Feb 2022 08:48:08 -0600

The important thing was the login. We'll look at not asking for the grants.

RjS

On 2/22/22 8:54 PM, Eric Rescorla wrote:
> I just went to register and I got prompted with an OAuth dialog to 
> give permission for the registration system to see my information from 
> DT. Is there some reason why we need this? Generally, it seems like 
> people should expect that www.ietf.org <http://www.ietf.org>, 
> datatracker.ietf.org <http://datatracker.ietf.org>, and 
> registration.ietf.org <http://registration.ietf.org> can share 
> information between them.
>
> -Ekr
>
>
>
>
>
>
>
>
>
>
> ___________________________________________________________
> Tools-discuss mailing list [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to:[email-masked]
> * Report tools.ietf.org bugs to:[email-masked]
> * Report all other bugs or issues to:[email-masked]
> List info (including how to Unsubscribe):https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 23 Feb 2022 09:11:35 -0800

Thanks. It seems to me like it ought to be possible to make this invisible
to the user.

-Ekr

On Wed, Feb 23, 2022 at 6:48 AM Robert Sparks <[email-masked]> wrote:

> Tools-discuss mailing list - [email-masked]
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss
>
> Tools-discuss mailing list - [email-masked]
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: Robert Sparks <[email-masked]>
Date: Thu, 24 Feb 2022 14:56:55 -0600

This is done

On 2/23/22 11:11 AM, Eric Rescorla wrote:
> Thanks. It seems to me like it ought to be possible to make this 
> invisible to the user.
>
> -Ekr
>
>
>>     I just went to register and I got prompted with an OAuth dialog
>>     to give permission for the registration system to see my
>>     information from DT. Is there some reason why we need this?
>>     Generally, it seems like people should expect that www.ietf.org
>>     <http://www.ietf.org>, datatracker.ietf.org
>>     <http://datatracker.ietf.org>, and registration.ietf.org
>>     <http://registration.ietf.org> can share information between them.
>>
>>     -Ekr
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>     * Reporttools.ietf.org  <http://tools.ietf.org>  bugs to:[email-masked]
>     * Report tools.ietf.org <http://tools.ietf.org> bugs to:
>     [email-masked]

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 24 Feb 2022 13:00:29 -0800

Great!