Subject: [Tools-discuss] Targeted email/chat group for reaching WG chairs.

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Thu, 14 Apr 2022 13:52:36 +0000

Hi,

I had an action, I think from a previous IEG retreat, about seeing if we could set up a targeted email alias to reach WG chairs with important information that all WGs chairs would be expected to see/read.

The aim: Have a way of getting limited important information to the WG chairs in a way that is likely to reach them (e.g., in-person meeting announcements, or nomcom requests).  There was some brief discussion as to whether an alias similar the <area>-chairs would be more effective than a standard mailing list, but the conclusion was to seek your expert opinions on this.

Of course, we already have wgchairs@, but some chairs miss some of the announcements sent to the list, or read the information too late.  This may be because they filter it, or there is too much other discussion on the alias which drowns the important news from general discussion.  So, the goal is a very cutdown lists with much more limited emails.  E.g., probably in the order of approx. 1 or 2 per week between meetings, and a bit more in the run up to IETF.

In addition, there was also some discussion about having something similar setup for Slack/Zulip.  I.e., a place to send announcements for WG chairs to read.

A final consideration is that we would probably want to direct follow ups to a more general discussion list, i.e., aiming to keep the volume of the email on the announce email lists (and chat channel) to be very low, perhaps with a restricted sender's group.

Do you have any suggestions as to what is feasible here and what the recommended approach might be?  Could DMARC be an issue with an <area-chairs> type of approach?

Thanks in advance,
Rob

---

From: Robert Sparks <[email-masked]>
Date: Thu, 14 Apr 2022 09:26:21 -0500

Some inline notes, then discussion at the end.

On 4/14/22 8:52 AM, Rob Wilton (rwilton) wrote:
> Of course, we already have wgchairs@, but some chairs miss some of the announcements sent to the list, or read the information too late.
>   This may be because they filter it, or there is too much other discussion on the alias which drowns the important news from general discussion.  So, the goal is a very cutdown lists with much more limited emails.  E.g., probably in the order of approx. 1 or 2 per week between meetings, and a bit more in the run up to IETF.
>
Creating a zulip channel would be relatively easy, but wouldn't meet the 
claimed needs unless we had a critical mass of chairs using zulip in a 
way that they would see the messages or get alerts that they didn't 
filter away.
> Do you have any suggestions as to what is feasible here and what the recommended approach might be?  Could DMARC be an issue with an <area-chairs> type of approach?

Right now _aliases_ are failing badly because of dmarc. The 
acronym-chairs@ or draftname@ addresses are aliases, with the values 
they expand to visible on the email address tab of groups and documents.

wgchairs@ is a mailman list. We are doing several custom things in order 
for the lists to play more nicely with dmarc that we are not yet doing 
for aliases. Extending the notion to the aliases is a future work item.

I am skeptical that yet another email channel will make a difference. 
You should be looking for a mechanism that is not going to end up 
filtered (or just ignored) the same way the current mechanisms are.

One possibility I've been considering for audiences like the set of 
chairs is using the messaging framework in the datatracker. As chairs or 
ADs, you've seen popups at the top of pages that show you've done 
something that sends email. That same mechanic could be used to say 
"Headline: <foo>. Go read <important list>" or something along those 
lines. Chairs are likely to be logged in and frequently using the 
datatracker during the periods before meetings. But not all chairs will 
actively do so in the periods between, but the chairs of sleepy groups 
may not be who you are trying to reach.

In the end, this is mostly a management problem - a social issue, not a 
technology issue. If you haven't already discussed potential changes 
from that perspective within the IESG, please do so.

>
> Thanks in advance,
> Rob
>
>
>
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 14 Apr 2022 14:31:18 +0000

I very strongly agree with this.

In addition to Robert's suggestion about a change of perspective, have you considered asking what the denizens of wgchairs think?

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 14 Apr 2022 17:02:34 +0200

On 2022-04-14, at 16:31, Salz, Rich <rsalz=[email-masked]> wrote:
> 
> have you considered asking what the denizens of wgchairs think?

The ones that read wgchairs will say it’s just fine, why another channel.
(That would include me.)

Those that don’t, won’t answer, so you’ll be none-the-wiser.

A wgchairs-announce to which you are force-subscribed by becoming WG chair would work if the message count stays low.
(And you’ll have to always send from a dmarc-neutered account or do the DMARC dance like mailman, but not the alias mechanism, does.)

Grüße, Carsten

---

From: "Salz, Rich" <[email-masked]>
Date: Thu, 14 Apr 2022 15:04:17 +0000

>   The ones that read wgchairs will say it’s just fine, why another channel.
 
Or you could work with Karen O'D and get it on the agenda for the next wgchairs meeting.

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 14 Apr 2022 17:05:36 +0200

> A wgchairs-announce to which you are force-subscribed by becoming WG chair would work if the message count stays low.

(I also have the mental image of a Totmann key, where datatracker randomly sends out messages to which you need to reply within some time or the train pulls the emergency brake.)

Grüße, Carsten

---

From: Michael Richardson <[email-masked]>
Date: Thu, 14 Apr 2022 13:13:04 -0400

Rob Wilton \(rwilton\) <rwilton=[email-masked]> wrote:
    > The aim: Have a way of getting limited important information to the WG
    > chairs in a way that is likely to reach them (e.g., in-person meeting
    > announcements, or nomcom requests).  There was some brief discussion as
    > to whether an alias similar the <area>-chairs would be more effective
    > than a standard mailing list, but the conclusion was to seek your
    > expert opinions on this.

In order to increase reachability, you'll need to unicast, not relay through
DT as Robert says.  That could mean that the DT originates the emails.
I suggest intentionally omitting the List-Id:

    > the goal is a very cutdown lists with much more limited emails.  E.g.,
    > probably in the order of approx. 1 or 2 per week between meetings, and
    > a bit more in the run up to IETF.

So that's like 60 emails/year if I understood you correctly.
That's a lot really.   It seems like much of that ought to also be in an
archive and/or blog.

Probably IMAP access and mailarchive already provides this, we just don't
have a clear place, like a wgchairs-announce to which things could be archived.

    > In addition, there was also some discussion about having something
    > similar setup for Slack/Zulip.  I.e., a place to send announcements for
    > WG chairs to read.

I'm regularly connected to Jabber, Hallway and WGs to which I co-chair, and
I'd say that it would be completely ineffective in reaching me in a timely manner.

Carsten Bormann <[email-masked]> wrote:
    >> A wgchairs-announce to which you are force-subscribed by becoming WG
    >> chair would work if the message count stays low.

    > (I also have the mental image of a Totmann key, where datatracker
    > randomly sends out messages to which you need to reply within some time
    > or the train pulls the emergency brake.)

To me, this actually is a good idea.
Perhaps the specific email is an invitation from the AD to have a 3-times
yearly post-meeting debrief.    Failure to answer/schedule with your AD
raises quite a few questions.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Tim Wicinski <[email-masked]>
Date: Thu, 14 Apr 2022 14:10:36 -0400

Robert

thanks for explaining the -chairs@ are aliases and not mailing lists (DNSOP
chairs breathe a sigh
of relief over all the AD trash talking is not being saved)

I'm not a fan of alternative channels, mostly because I find chat systems
very distracting and either I
ignore them or I fill them with cat and dog videos until I am banned.  It's
a curse of mine, and maybe
a blessing.

tim

On Thu, Apr 14, 2022 at 10:26 AM Robert Sparks <[email-masked]> wrote:

> > I had an action, I think from a previous IEG retreat, about seeing if we
> could set up a targeted email alias to reach WG chairs with important
> information that all WGs chairs would be expected to see/read.
> >
> announcements, or nomcom requests).  There was some brief discussion as to
> whether an alias similar the <area>-chairs would be more effective than a
> standard mailing list, but the conclusion was to seek your expert opinions
> on this.
> >
> > Of course, we already have wgchairs@, but some chairs miss some of the
> announcements sent to the list, or read the information too late.
> >   This may be because they filter it, or there is too much other
> discussion on the alias which drowns the important news from general
> discussion.  So, the goal is a very cutdown lists with much more limited
> emails.  E.g., probably in the order of approx. 1 or 2 per week between
> meetings, and a bit more in the run up to IETF.
> >
> similar setup for Slack/Zulip.  I.e., a place to send announcements for WG
> chairs to read.
> > A final consideration is that we would probably want to direct follow
> ups to a more general discussion list, i.e., aiming to keep the volume of
> the email on the announce email lists (and chat channel) to be very low,
> perhaps with a restricted sender's group.
> >
> > Do you have any suggestions as to what is feasible here and what the
> recommended approach might be?  Could DMARC be an issue with an
> <area-chairs> type of approach?
>
> > List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>
> List info (including how to Unsubscribe):
> https://www.ietf.org/mailman/listinfo/tools-discuss
>

---

From: "John Levine" <[email-masked]>
Date: 14 Apr 2022 17:14:32 -0400

It appears that Rob Wilton (rwilton) <[email-masked]> said:
>The aim: Have a way of getting limited important information to the WG chairs in a way that is likely to reach them (e.g., in-person meeting
>announcements, or nomcom requests).  There was some brief discussion as to whether an alias similar the <area>-chairs would be more effective than a
>standard mailing list, but the conclusion was to seek your expert opinions on this.

Given that the wgchairs list already exists, you're not going to do any better.

The usual problem is that what *I* think is important is not always
what *you* think is important, and I can't force you to pay attention.
I can force subscribe you to wgchars-announce-really-important, you
can filter it to oblivion.

The DMARC problems Robert described with mail aliases don't affect our mailing
lists which are anti-DMARC'ed about as well as is possible.

R's,
John

---

From: "Andrew G. Malis" <[email-masked]>
Date: Fri, 15 Apr 2022 07:17:36 -0400

I agree with John. And as Robert said, this is really a management issue,
not a technology one. I think ADs just have to make it clear to their WG
chairs that paying attention to the wgchairs@ list is a part of the job
description. And WG chairs serve at the pleasure of their ADs.

Cheers,
Andy (a WG chair)

On Thu, Apr 14, 2022 at 5:15 PM John Levine <[email-masked]> wrote:

> to whether an alias similar the <area>-chairs would be more effective than a