Subject: Re: [Tools-discuss] Datatracker Addition Resource tag "github_repo"fails with gitlab.com

From: "Salz, Rich" <[email-masked]>
Date: Fri, 8 Apr 2022 22:09:33 +0000

>    if "gitlab_repo" and "github repo" are just aliases to populate other
    fields related to issue trackers, queues of proposed changes, etc, it
    seems like it'd be better to just make the generic "repo" tag clever

Being able to describe the type of link can be useful to tooling.  For example, the ietf-gh-scripts I wrote and need to pick back up again, could automatically create a repo using the GitHub API when a draft is adopted.  At least, that was my intention.

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Fri, 08 Apr 2022 16:58:52 -0700

> Being able to describe the type of link can be useful to tooling.  For example, the ietf-gh-scripts I wrote and need to pick back up again, could automatically create a repo using the GitHub API wh…

sure, but if the link is "repo", and the value starts with
"https://github.com/" then your tooling can figure out that it should do
its magic, right?

             --dkg

---

From: "Salz, Rich" <[email-masked]>
Date: Sat, 9 Apr 2022 13:25:19 +0000

Sure.