Subject: [Tools-discuss] Datatracker Addition Resource tag "github_repo" fails with gitlab.com

From: Tim Wicinski <[email-masked]>
Date: Thu, 7 Apr 2022 21:01:10 -0400

URL must be a github url : https://gitlab.com/dkg/dprive-unilateral-probing

I used the "webpage" tag.

tim

---

From: "Salz, Rich" <[email-masked]>
Date: Fri, 8 Apr 2022 14:56:04 +0000

*   URL must be a github url : https://gitlab.com/dkg/dprive-unilateral-probing<https://urldefense.com/v3/__https:/gitlab.com/dkg/dprive-unilateral-probing__;!!GjvTz_vk!D3T5AVo1TM2Y6j1cdy9fWUFztHYaHm_xYpUzFG3xYRjqrwgfoOh3hHvSde4Z$>

  *   I used the "webpage" tag.

Oh DKG and his pesky morals. :)  Is there no “gitlab” tab?  If not, we should create one, should be pretty easy for Robert to do so; the list of ‘external resource types’ is just another table.

---

From: Tim Wicinski <[email-masked]>
Date: Fri, 8 Apr 2022 10:59:21 -0400

On Fri, Apr 8, 2022 at 10:56 AM Salz, Rich <[email-masked]> wrote:

>
>
>    - URL must be a github url :
>    https://gitlab.com/dkg/dprive-unilateral-probing
>    <https://urldefense.com/v3/__https:/gitlab.com/dkg/dprive-unilateral-probing__;!!GjvTz_vk!D3T5AVo1TM2Y6j1cdy9fWUFztHYaHm_xYpUzFG3xYRjqrwgfoOh3hHvSde4Z$>
>
>
>
>    - I used the "webpage" tag.
>
>
>
> Oh DKG and his pesky morals. :)  Is there no “gitlab” tab?  If not, we
> should create one, should be pretty easy for Robert to do so; the list of
> ‘external resource types’ is just another table.
>

We love our DKG and we will defend his DKG-ness !!

There is a "gitlab_username" (whaaa?). but no gitlab_repo

---

From: Tim Wicinski <[email-masked]>
Date: Fri, 8 Apr 2022 11:01:50 -0400

But wanted to say this is a low priority issue. I have a workaround.

---

From: Robert Sparks <[email-masked]>
Date: Fri, 8 Apr 2022 10:20:50 -0500

gitlab_repo added.

There is also a generic 'repo' tag already there.

RjS

On 4/8/22 10:01 AM, Tim Wicinski wrote:
>           * URL must be a github url :
>         Oh DKG and his pesky morals. :)  Is there no “gitlab” tab?  If
>         not, we should create one, should be pretty easy for Robert to
>         do so; the list of ‘external resource types’ is just another
>         table.
>
>
>
> ___________________________________________________________
> Tools-discuss mailing list [email-masked]
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to:[email-masked]
> * Report tools.ietf.org bugs to:[email-masked]
> * Report all other bugs or issues to:[email-masked]
> List info (including how to Unsubscribe):https://www.ietf.org/mailman/listinfo/tools-discuss

---

From: Tim Wicinski <[email-masked]>
Date: Fri, 8 Apr 2022 13:29:15 -0400

You are right Robert.My eyes rolled right past it more than once.

Maybe group them by some relate

we have now:

faq, github_org, github_repo, github_username, gitlab_repo,
gitlab_username, jabber_log, jabber_room, mailing_list,
mailing_list_archive, related_implementations, repo, slack, tracker,
webpage, wiki, yc_entry, yc_impact, zulip

hand wavy:

src/code: github_org, github_repo, github_username, gitlab_repo,
gitlab_username, repo, related_implementations,
chat/com:  jabber_log, jabber_room,  slack, zulip, mailing_list,
mailing_list_archive,
etc:  faq, tracker, webpage, wiki, yc_entry,

It's also Friday

tim

On Fri, Apr 8, 2022 at 11:21 AM Robert Sparks <[email-masked]> wrote:

> Tools-discuss mailing list - [email-masked]
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss
>
>

---

From: Daniel Kahn Gillmor <[email-masked]>
Date: Fri, 08 Apr 2022 14:33:54 -0700

> There is also a generic 'repo' tag already there.

do we need "gitlab_repo" and "github_repo" if we can already just use
"repo"?

github and gitlab both offer:

 - revision control (using git)
 - issue trackers
 - queues of proposed changes ("pull requests" on github, "merge
   requests" on gitlab)

if "gitlab_repo" and "github repo" are just aliases to populate other
fields related to issue trackers, queues of proposed changes, etc, it
seems like it'd be better to just make the generic "repo" tag clever
enough to look for likely URLs for issue trackers and queues of proposed
changes.

(i'm active on at least a dozen distinct installations of the gitlab
software, and would be kinda sad if i had to ask for a special tag like
"torproject_repo" to point toward something hosted on
https://gitlab.torproject.org/ 😛)

        --the always-pesky dkg