Subject: [Tools-discuss] Upcoming change to the look of the datatracker

From: Robert Sparks <[email-masked]>
Date: Tue, 12 Apr 2022 16:58:02 -0500

All -

As previously noted on several of these lists, and mentioned at the IETF 
113 Plenary, the datatracker is being modified to use bootstrap5, and 
has undergone a massive overhaul to improve its html5 compliance. The 
result will allow us to more easily include updates to the underlying 
dependencies going forward.

The look is quite different, but the core functionality remains 
essentially the same. There will be bug fixes and enhancements included 
from the IETF 113 codesprint.

We expect this to deploy to production later this week.

Below is an example of what the site will look like after that deployment.

RjS

(note that reply-to is set to [email-masked])

---

From: John C Klensin <[email-masked]>
Date: Tue, 12 Apr 2022 20:09:10 -0400

Robert,

Is it reasonable to assume that links pointing into the
datatracker, particularly for documents in progress, will
continue to work?

thanks, 
  john

--On Tuesday, April 12, 2022 16:58 -0500 Robert Sparks
<[email-masked]> wrote:

> All -
> 
> As previously noted on several of these lists, and mentioned
> at the IETF 113 Plenary, the datatracker is being modified to
> use bootstrap5, and has undergone a massive overhaul to
> improve its html5 compliance. The result will allow us to more
> easily include updates to the underlying dependencies going
> forward.
> 
> The look is quite different, but the core functionality
> remains essentially the same. There will be bug fixes and
> enhancements included from the IETF 113 codesprint.
>

---

From: Jay Daley <[email-masked]>
Date: Wed, 13 Apr 2022 11:14:52 +0100

> On 13 Apr 2022, at 01:09, John C Klensin <[email-masked]> wrote:
> 
> Robert,
> 

Only the look and feel is affected.

Jay

> <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> All -
>> 
> ___________________________________________________________
> Tools-discuss mailing list - [email-masked] <mailto:[email-masked]>
> This list is for discussion, not for action requests or bug reports.
> * Report datatracker and mailarchive bugs to: [email-masked] <mailto:[email-masked]>
> * Report tools.ietf.org <http://tools.ietf.org/> bugs to: [email-masked] <mailto:[email-masked]>
> * Report all other bugs or issues to: [email-masked] <mailto:[email-masked]>
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss <https://www.ietf.org/mailman/listinfo/tools-discuss>
-- 
Jay Daley
IETF Executive Director
[email-masked]

---

From: "John Levine" <[email-masked]>
Date: 13 Apr 2022 12:40:59 -0400

>> datatracker, particularly for documents in progress, will

I bit my tongue and resisted the urge to tell him that all of the
current URLs will stop working, the new ones will differ in arbitrary
and unpredictable ways, and to save typing the new URLs will omit the
two slashes after the scheme name.  Sheesh.

A few days ago Klensin told me that he refuses to look at using a Mac
because of something Steve Jobs said to him 40 years ago.  He was entirely
serious.

On an unrelated note, do you want to talk about the RPC software revamp gig?
If it seems like too much of a conflict of interest or overload, I wouldn't
be astonished.

R's,
John

---

From: Julian Reschke <[email-masked]>
Date: Wed, 13 Apr 2022 19:05:50 +0200

> datatracker, particularly for documents in progress, will

The IETF tools development is in very good hands nowadays, so I think
it's a given that changes will not mangle URIs.

Best regards, Julian

---

From: Michael Richardson <[email-masked]>
Date: Wed, 13 Apr 2022 12:24:15 -0400

Jay Daley <[email-masked]> wrote:
    >> Is it reasonable to assume that links pointing into the datatracker,
    >> particularly for documents in progress, will continue to work?

    > Only the look and feel is affected.

It seems that the colour change is gratuitous.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 13 Apr 2022 17:48:09 +0000

>   It seems that the colour change is gratuitous.

Are you sure that it is not better for color-blind, etc.?

Further, any change from the default is a cost we have to carry forward forever.

---

From: Michael Richardson <[email-masked]>
Date: Wed, 13 Apr 2022 15:01:03 -0400

> Are you sure that it is not better for color-blind, etc.?

Well, that's why I'm asking.

    > Further, any change from the default is a cost we have to carry forward

Colour changes tend to be relative cheap, and we already need to have a
colour change control to denote sandbox, and development instances.

--
Michael Richardson <[email-masked]>   . o O ( IPv6 IøT consulting )
           Sandelman Software Works Inc, Ottawa and Worldwide

---

From: Robert Sparks <[email-masked]>
Date: Wed, 13 Apr 2022 15:45:12 -0500

The colors reflect an explicit choice to delegate most color decisions 
to someone else with a larger team that pays attention to things like 
accessibility - in this case the bootstrap team. We're using bootstrap 
default colors, with very few places where we override them. We do have 
a site-wide theme for bootstrap that we had built for us by a 
professional web development organization (and the project involved 
accessibility testing) that is not yet integrated, but the changes there 
will not be major.

Yes, the development instances will have a different header color than 
production.

RjS

On 4/13/22 2:01 PM, Michael Richardson wrote:
> Tools-discuss mailing list - [email-masked]
> * Report datatracker and mailarchive bugs to: [email-masked]
> * Report tools.ietf.org bugs to: [email-masked]
> * Report all other bugs or issues to: [email-masked]
> List info (including how to Unsubscribe): https://www.ietf.org/mailman/listinfo/tools-discuss