Subject: [Txauth] A Request/Response Flow Diagram

From: "Amanjeev Sethi" <[email-masked]>
Date: Tue, 10 Mar 2020 10:56:53 -0400

Hello everyone,

Is it possible to see or create a rough diagram of the current request/response understanding of TxAuth?

I am trying to get the overview and sometimes I find it easier to look at this flow diagram to see the important parts of the protocol.

If something like this exists already, could you please point me to that? I was hoping this https://oauth.xyz/interaction/ would host the diagrams.

Best,
AJ

---

From: Justin Richer <[email-masked]>
Date: Tue, 10 Mar 2020 12:01:24 -0400

For XYZ, it depends on the kind of interaction you are doing and how you’re getting back to things. If you’re doing a full redirect back and forth, it looks like this:

https://www.websequencediagrams.com/cgi-bin/cdraw?lz=cGFydGljaXBhbnQgYnJvd3NlciBhcyBiCgANDGNsaWVudCBhcyBjAAsNdHJhbnNhY3Rpb25cbmVuZHBvaQAhBnQAMg1pbnRlcgATFGkKCmMtPnQ6IHN0YXIAQA9DYWxsYmFjayB1cmwgKEMpXG5DAIEABm5vbmNlIChjbikKbm90ZSBvdmVyIGM6IHNob3VsZCAoQykgYmUgdW5pcXVlIHBlcgCBGgw_CnQtPmM6AIEtDCBoYW5kbGUgKFQxKVxuSQCBIQogVVJMIChJKVxuU2VydmVyAHEIcwBsDXQ6IChJKSBpcwBbFwpjLT5iOiBnbyB0byAoSSkKYi0-aTogPj4ABwY8AAkFYXV0aGVudGljYXRlIHVzZXIsAA4Fb3JpemUKaQAsBUxvb2sgdXAAgmUORmluZACBDAUsAIILBSwgKEMpACkHY3JlYXRlAIJvDCByZWYgKFIAEg9oYXNoOlxuKEgpID0ACAUoY24sIHNuLCAAJAZiOiBHAIE2BkMpXG4gaW5jbHVkZSAoSCksIChSKSAKYgCCTAU-PgCDHgYAEAgAgw0OdmFsaWRhdAAyBQCDawcAgnYMY29udGludWUgcmVxdWVzdACDBwUAQQZ0AIQaBQA3CQCDLAwAGA1jOiBhY2Nlc3MgdG9rZW4gKEEpLCAoVDIpCgo&s=earth

If you’re doing a user code with no callback, it looks like this:

https://www.websequencediagrams.com/cgi-bin/cdraw?lz=cGFydGljaXBhbnQgdXNlciBhcyB1CgAKDGJyb3cAEgdiAAwNY2xpZW50IGFzIGMAJA10cmFuc2FjdGlvblxuZW5kcG9pACEGdABLDQBpBWNvZGUAFw5pCgpjLT50OiBzdGFyAEANCnQtPmM6AFMMIGhhbmRsZSAoVDEpXG5VAEkIIChVQwAICENvZGUgVVJMIChVQ1UpCmMtPnU6IGNvbW11bmljYXQAJgYsIG1heWIAMwVVKQp1LT5iOiBnbyB0bwAvB2ItPmk6ID4-AAcIPAALBWF1dGhlbnQAQQZ1c2VyCnUAIwVlbnQAfQwKaQA5BUxvb2sgdXAAgUQNAD4Lb3JpemUKaQB2BXNob3cgImNvbXBsZXRlIiBtZXNzYWdlCgpsb29wIHBvbGwgd2hpbGUgd2FpdGluZwogICAgAIIvBmNvbnRpbnVlAIIZDShUbikAHwV0AB4GaGVjawCCOg1zdGF0dXMAGwhjOgBUBSByZXNwb25zZSAoVCBuKzEpCmVuZAoAgn4HYWNjZXNzIHRva2VuIChBKQoKCg&s=earth

If you’re doing a QR code, it looks like:

https://www.websequencediagrams.com/cgi-bin/cdraw?lz=cGFydGljaXBhbnQgdXNlciBhcyB1CgAKDGJyb3cAEgdiAAwNY2xpZW50IGFzIGMAJA10cmFuc2FjdGlvblxuZW5kcG9pACEGdABLDUludGVyABMUaQoKYy0-dDogc3RhcgBCDQp0LT5jOgBVDCBoYW5kbGUgKFQxKVxuAEgLIEUAcQgoSSkKYy0-dTogY29tbXVuaWNhdGUAEQV1LT5iOiBnbyB0bwAhBWItPmk6ID4-AAcGPAAJBWF1dGhlbnQALwZ1c2VyCmkAIQVMb29rIHVwAIERDQAoC29yaXplCmkAXAVzaG93ICJjb21wbGV0ZSIgbWVzc2FnZQoKbG9vcCBwb2xsIHdoaWxlIHdhaXRpbmcKICAgIACBfAZjb250aW51ZQCBZg0oVG4pAB8FdAAeBmhlY2sAggcNc3RhdHVzABsIYzoAVAUgcmVzcG9uc2UgKFQgbisxKQplbmQKAIJLB2FjY2VzcyB0b2tlbiAoQSkKCgo&s=earth

I need to clean these up but I would like to put them up on the website once they’re in good shape.

 — Justin

> On Mar 10, 2020, at 10:56 AM, Amanjeev Sethi <[email-masked]> wrote:
> 
> Hello everyone,
> 
> If something like this exists already, could you please point me to that? I was hoping this https://oauth.xyz/interaction/ <https://oauth.xyz/interaction/> would host the diagrams.
> 
> Best,
> AJ
> -- 
> Txauth mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>