Subject: [Txauth] on naming

From: Nigel Hamilton <[email-masked]>
Date: Tue, 17 Mar 2020 06:13:32 +0000

The 'auth' in Oauth2 - is a bit confusing for the newcomer. Is that 'auth'
referring to authentication or authorisation?

I like the brevity of 'tx' and this combined with something else (e.g.,
keytx, safetx, suretx etc) will help its search engine findability.

Nige

---

From: Justin Richer <[email-masked]>
Date: Tue, 17 Mar 2020 09:12:04 -0400

In OAuth 2 it’s for “authorization”, which is itself a bit misleading because it’s a delegation protocol at its heart. What we’re proposing here covers aspects of both authorization delegation as well as authentication and identity. 

 — Justin

> On Mar 17, 2020, at 2:13 AM, Nigel Hamilton <[email-masked]> wrote:
> 
> 
> The 'auth' in Oauth2 - is a bit confusing for the newcomer. Is that 'auth' referring to authentication or authorisation? 
> 
> I like the brevity of 'tx' and this combined with something else (e.g., keytx, safetx, suretx etc) will help its search engine findability.
> 
> Nige
> 
> -- 
> Txauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth