Subject: [Txauth] TxAuth BoF draft agenda

From: Dick Hardt <[email-masked]>
Date: Mon, 16 Mar 2020 16:04:24 -0700

Virtual Meeting:

Monday, March 23
20:00 - 22:00 UTC *

*Agenda*
Chair slides, agenda bashing - 10 min.
Charter (link, solicit comments, discuss WG name) - 20 min.
XYZ - Justin (with Q&A) - 20 min.
XAuth - Dick  (with Q&A) - 20 min.
Yaron , Dick, Justin - Discussion of differences between protocols - 40 min.
Next steps - 10 min.

Additions / suggestions?

*Tech*
The technology to be used is still TBD. We will update the list when we
know. We are expecting it will be the IETF WebEx. (my preference would be
Zoom if anyone has an account to have LOTS of people on it =)

We are planning on using EtherPad for notes, and for queue management.

*Scribe*
Would someone like to volunteer to be the scribe on EtherPad? We would like
to get as much coordination done prior as possible to make the best use of
the time.

/Dick

* Some time math for 20:00 - 22:00 UTC:

Pacific Time                   13:00-15:00
Eastern Time               16:00-18:00
Coordinated Universal Time        20:00-02:00
Central European Time          21:00-23:00
India Standard Time            01:30-03:30
China Standard Time          04:00-06:00
Australian Eastern Standard Time       07:00-09:00
ᐧ

---

From: "Bron Gondwana" <[email-masked]>
Date: Tue, 17 Mar 2020 20:36:38 +1100

It looks like adding large meeting support (1000 people) on to a regular pro account costs just over $100/month. I don't know if you can just turn it on for the months you want it though.

A regular Pro account supports up to 100 people, but I guess we don't know ahead of time how many people to expect, particularly in this interesting time.

Bron.

On Tue, Mar 17, 2020, at 10:04, Dick Hardt wrote:
> The technology to be used is still TBD. We will update the list when we know. We are expecting it will be the IETF WebEx. (my preference would be Zoom if anyone has an account to have LOTS of people on it =)
> 
> Would someone like to volunteer to be the scribe on EtherPad? We would like to get as much coordination done prior as possible to make the best use of the time.
> 
> /Dick
> 
> -- 
> Txauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
> 

--
 Bron Gondwana, CEO, Fastmail Pty Ltd
 [email-masked]

---

From: Matthew De Haast <[email-masked]>
Date: Tue, 17 Mar 2020 11:51:19 +0200

My Zoom account seems to be able to support

   - You can host meetings with unlimited minutes for up to 300
   participants.

Can check with my Company if they good with us hosting it on our account.
But it should be ok if that's what people want to use.

Matt

On Tue, Mar 17, 2020 at 11:38 AM Bron Gondwana <[email-masked]>
wrote:

> It looks like adding large meeting support (1000 people) on to a regular
> pro account costs just over $100/month.  I don't know if you can just turn
> it on for the months you want it though.
>
> A regular Pro account supports up to 100 people, but I guess we don't know
> ahead of time how many people to expect, particularly in this interesting
> time.
>
> Bron.
>
> Would someone like to volunteer to be the scribe on EtherPad? We would
> like to get as much coordination done prior as possible to make the best
> use of the time.
>
> /Dick
>
> https://www..ietf.org/mailman/listinfo/txauth
>
>
> --

---

From: Yaron Sheffer <[email-masked]>
Date: Tue, 17 Mar 2020 12:25:21 +0200

The IESG will be running a trial session tomorrow for working group chairs, with the tool we have used in the past for virtual WG meetings, namely WebEx (along with Etherpad and Jabber). Let’s see how it goes.

Thanks,

                Yaron

From: Txauth <[email-masked]> on behalf of Matthew De Haast <matt=[email-masked]>
Date: Tuesday, March 17, 2020 at 11:51
Cc: <[email-masked]>
Subject: Re: [Txauth] TxAuth BoF draft agenda

You can host meetings with unlimited minutes for up to 300 participants.
Can check with my Company if they good with us hosting it on our account. But it should be ok if that's what people want to use.

Matt

On Tue, Mar 17, 2020 at 11:38 AM Bron Gondwana <[email-masked]> wrote:

Bron.

Virtual Meeting: 

Monday, March 23

20:00 - 22:00 UTC *

Agenda

Next steps - 10 min.

Additions / suggestions?

Tech

Scribe

/Dick

Pacific Time                   13:00-15:00

Eastern Time               16:00-18:00

ᐧ

-- 

Txauth mailing list

[email-masked]

 

--

  [email-masked]

-- Txauth mailing list [email-masked] https://www.ietf.org/mailman/listinfo/txauth

---

From: "Richard Backman, Annabelle" <[email-masked]>
Date: Thu, 19 Mar 2020 15:28:23 +0000

I expect a lot of discussion around whether/to what extent it should include “identity” and without some structure that could easily consume the whole meeting. Should we timebox that discussion, and/or get some volunteers to summarize the various positions?

–
Annabelle Backman (she/her)
AWS Identity
https://aws.amazon.com/identity/

From: Txauth <[email-masked]> on behalf of Dick Hardt <[email-masked]>
Date: Monday, March 16, 2020 at 4:07 PM
To: "[email-masked]" <[email-masked]>
Cc: Yaron Sheffer <[email-masked]>
Subject: [EXTERNAL][Txauth] TxAuth BoF draft agenda

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you can confirm the sender and know the content is safe.

Virtual Meeting:

Monday, March 23
20:00 - 22:00 UTC *

Agenda

Additions / suggestions?

Tech

Scribe

/Dick

Pacific Time                   13:00-15:00
Eastern Time               16:00-18:00
[https://mailfoogae.appspot.com/t?sender=aZGljay5oYXJkdEBnbWFpbC5jb20%3D&type=zerocontent&guid=77a10b07-4662-43a4-9ccd-8dfad9c3b987]ᐧ

---

From: Mike Jones <[email-masked]>
Date: Thu, 19 Mar 2020 18:00:23 +0000

Given that four people have raised questions about the identity aspect of the proposed charter, I would request that the chairs allocate at least 20 minutes to discussion of whether identity should be in or out of scope, and if in scope, what aspects of identity should be in and out of scope.  This should have its own time slot, rather than including it in the 20 minutes of charter and naming discussions currently allocated, as it’s a foundational decision to scoping the work, and is likely to need at least 20 minutes on its own.

Torsten’s and Vladimir’s feedback about interoperability among authorization servers and resource servers should also be explicitly included somewhere in the charter discussions.

If we’re short on time, I’d rather we first get agreement on the charter and scope than discuss the engineering merits and tradeoffs among particular proposed starting point drafts.

                                                          Thanks,
                                                          -- Mike

From: Txauth <[email-masked]> On Behalf Of Richard Backman, Annabelle
Sent: Thursday, March 19, 2020 8:28 AM
To: Dick Hardt <[email-masked]>; [email-masked]
Cc: Yaron Sheffer <[email-masked]>
Subject: [EXTERNAL] Re: [Txauth] TxAuth BoF draft agenda

–

From: Txauth <[email-masked]<mailto:[email-masked]>> on behalf of Dick Hardt <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 16, 2020 at 4:07 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Yaron Sheffer <[email-masked]<mailto:[email-masked]>>
Subject: [EXTERNAL][Txauth] TxAuth BoF draft agenda

Virtual Meeting:

Monday, March 23
20:00 - 22:00 UTC *

Agenda

Additions / suggestions?

Tech

Scribe

/Dick

Pacific Time                   13:00-15:00
Eastern Time               16:00-18:00

---

From: Mike Jones <[email-masked]>
Date: Thu, 19 Mar 2020 18:35:43 +0000

Actually, it’s five.  I missed seeing Filip’s comments.

From: Mike Jones
Sent: Thursday, March 19, 2020 11:00 AM
To: Richard Backman, Annabelle <richanna=[email-masked]>; Dick Hardt <[email-masked]>; [email-masked]
Cc: Yaron Sheffer <[email-masked]>
Subject: RE: [Txauth] TxAuth BoF draft agenda

                                                          Thanks,
                                                          -- Mike

From: Txauth <[email-masked]<mailto:[email-masked]>> On Behalf Of Richard Backman, Annabelle
Sent: Thursday, March 19, 2020 8:28 AM
To: Dick Hardt <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Yaron Sheffer <[email-masked]<mailto:[email-masked]>>
Subject: [EXTERNAL] Re: [Txauth] TxAuth BoF draft agenda

–

Virtual Meeting:

Monday, March 23
20:00 - 22:00 UTC *

Agenda

Additions / suggestions?

Tech

Scribe

/Dick

Pacific Time                   13:00-15:00
Eastern Time               16:00-18:00

---

From: Justin Richer <[email-masked]>
Date: Thu, 19 Mar 2020 15:11:48 -0400

+1 to adding both of these discussions to the agenda.

 — Justin

> On Mar 19, 2020, at 2:00 PM, Mike Jones <Michael.Jones=[email-masked]> wrote:
> 
> From: Txauth <[email-masked] <mailto:[email-masked]>> On Behalf Of Richard Backman, Annabelle
> To: Dick Hardt <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> Cc: Yaron Sheffer <[email-masked] <mailto:[email-masked]>>
> https://aws.amazon.com/identity/ <https://aws.amazon.com/identity/>
>  
>  
> From: Txauth <[email-masked] <mailto:[email-masked]>> on behalf of Dick Hardt <[email-masked] <mailto:[email-masked]>>
> To: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>
> Cc: Yaron Sheffer <[email-masked] <mailto:[email-masked]>>
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>

---

From: Dick Hardt <[email-masked]>
Date: Thu, 19 Mar 2020 17:10:48 -0700

We are still looking for an EtherPad scribe to take meeting minutes.

WebEx will be used for audio and presentation visuals. The WebEx chat
feature will be used for queue management.

Jabber will be used for back channel chats.

EtherPad will be used for the blue sheets, and for meeting minutes.

More details here:

https://www.ietf.org/how/meetings/107/session-presenter-guide/

ᐧ

---

From: Torsten Lodderstedt <[email-masked]>
Date: Sat, 21 Mar 2020 14:31:24 +0100

Hi, 

+1 for adding identity slices and AS - RS interop to the agenda.

I would also ask for time to discuss my proposal to support RS-specific access tokens and Nat’s suggestion to write an architecture document. 

As this will have an impact on the agenda, I fully support Mike's statement: agreeing on the charter is more important now than discussing the different drafts. Adopting the agenda accordingly is reasonable. 

best regards,
Torsten, 

> On 19. Mar 2020, at 20:11, Justin Richer <[email-masked]> wrote:
>

---

From: Dick Hardt <[email-masked]>
Date: Sat, 21 Mar 2020 11:59:20 -0700

Hi Torsten

Our objectives for this meeting are in order of importance:

- get consensus on charter
- see if we can get some consensus on the different approaches between XYZ
and XAuth to guide us to select a starting document

Yaron, Justin, and I have been working on a slightly revised charter that
attempts to address scope identity, multiple tokens in a response, and
AS<->RS interactions. That will be posted really-soon-now. :)

On Sat, Mar 21, 2020 at 6:31 AM Torsten Lodderstedt <[email-masked]>
wrote:

> I would also ask for time to discuss my proposal to support RS-specific
> access tokens and Nat’s suggestion to write an architecture document.
>
> As this will have an impact on the agenda, I fully support Mike's
> statement: agreeing on the charter is more important now than discussing
> the different drafts. Adopting the agenda accordingly is reasonable.
>
> best regards,
> Torsten,
>
> >> Given that four people have raised questions about the identity aspect
> of the proposed charter, I would request that the chairs allocate at least
> 20 minutes to discussion of whether identity should be in or out of scope,
> and if in scope, what aspects of identity should be in and out of scope.
> This should have its own time slot, rather than including it in the 20
> minutes of charter and naming discussions currently allocated, as it’s a
> foundational decision to scoping the work, and is likely to need at least
> 20 minutes on its own.
> >>
> >> Torsten’s and Vladimir’s feedback about interoperability among
> authorization servers and resource servers should also be explicitly
> included somewhere in the charter discussions.
> >>
> >> If we’re short on time, I’d rather we first get agreement on the
> charter and scope than discuss the engineering merits and tradeoffs among
> particular proposed starting point drafts.
> >>
> >>                                                           Thanks,
> >>                                                           -- Mike
> >>
> >> I expect a lot of discussion around whether/to what extent it should
> include “identity” and without some structure that could easily consume the
> whole meeting. Should we timebox that discussion, and/or get some
> volunteers to summarize the various positions?
> >>
> >> –