Subject: Re: [Txauth] WG name brainstorming - please participate!

From: Mike Jones <[email-masked]>
Date: Tue, 12 May 2020 21:09:13 +0000

Web Resource Access Collaboration (WRAC)

From: Txauth <[email-masked]> On Behalf Of Brian Campbell
Sent: Tuesday, May 12, 2020 12:38 PM
To: Dick Hardt <[email-masked]>
Cc: Jared Jennings <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [Txauth] WG name brainstorming - please participate!

I always thought WRAP (Web Resource Authorization Protocol) was a good name. Perhaps a riff on that? Like WRAC, pronounced "rack", that expands to Web Resource Authorization Concord (or Compact or Convention).

On Tue, May 12, 2020 at 11:32 AM Dick Hardt <[email-masked]<mailto:[email-masked]>> wrote:
Ok

FYI: The working group does need a name to go with the charter.

On Tue, May 12, 2020 at 10:29 AM Jared Jennings <[email-masked]<mailto:[email-masked]>> wrote:
Yeah, I wasn't really thinking of expanding the name. I'm not really a fan of it though and don't mind if it's not included. I had provided several others over the weekend.

Personally, I am going to vote on OAuth 3.0 and maybe XAuth.

On May 12, 2020, at 09:27, Dick Hardt <[email-masked]<mailto:[email-masked]>> wrote:

Im looking for the phrase it expands to, and not wanting to assume what Jared was proposing.

On Tue, May 12, 2020 at 6:24 AM Justin Richer <[email-masked]<mailto:[email-masked]>> wrote:
I could be wrong, but I believe the intended expansion is “EdgeAuth” as stated in the email below. Or are you looking to expand “Edge” as an acronym as well?

 — Justin

On May 11, 2020, at 6:42 PM, Dick Hardt <[email-masked]<mailto:[email-masked]>> wrote:

Jared: to have your suggestion be listed, you will need to provide an expansion on the name of the WG.

On Tue, May 5, 2020 at 6:39 AM Jared Jennings <[email-masked]<mailto:[email-masked]>> wrote:
EdgeAuth or EAuth - something along those lines.

-Jared
Skype:jaredljennings
Signal:+1 816.730.9540
WhatsApp: +1 816.678.4152

On Fri, May 1, 2020 at 4:09 PM Dick Hardt <[email-masked]<mailto:[email-masked]>> wrote:
We now have our criteria for names, and we can now start the next step in our process, brainstorming names!

Here is the criteria again:

Required:

  1.  No confusion with another protocol, major software project, or IETF/IRTF WG name
  2.  no existing registered trademarks in related classes
  3.  Less than 1M results in Google
  4.  Descriptive of protocol (this criteria is subjective)
  5.  Not an offensive meaning to a member of the mail list
Desirable:

  1.  Straightforward to pronounce
  2.  Easy to spell
  3.  Easy to read
  4.  Shortish
We won't be judging or ranking names at this time -- we are brainstorming names that are descriptive of the protocol.
We are hoping we can get the WG approved in the telechat May 21,
so ideally we would have rough consensus on the name by May 18.

Let's brainstorm for a week, and then we can stack rank them on our objective criteria, and then vote on the top candidates.

I'll start by submitting my favorite:

XAuth - Extensible delegated Authorization and Authentication protocol, or just view the X as a placeholder and XAuth is OAuth ++

--
Txauth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/txauth
--
Txauth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/txauth

--
Txauth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/txauth

CONFIDENTIALITY NOTICE: This email may contain confidential and privileged material for the sole use of the intended recipient(s). Any review, use, distribution or disclosure by others is strictly prohibited..  If you have received this communication in error, please notify the sender immediately by e-mail and delete the message and any file attachments from your computer. Thank you.

---

From: Dick Hardt <[email-masked]>
Date: Tue, 12 May 2020 14:09:52 -0700

FYI: we have moved past brainstorming and are now voting!!! :)

On Tue, May 12, 2020 at 2:09 PM Mike Jones <[email-masked]>
wrote:

> *From:* Txauth <[email-masked]> *On Behalf Of *Brian Campbell
> *Sent:* Tuesday, May 12, 2020 12:38 PM
> *To:* Dick Hardt <[email-masked]>
> *Cc:* Jared Jennings <[email-masked]>; [email-masked];
> [email-masked]
> *Subject:* Re: [Txauth] WG name brainstorming - please participate!
>
>
>
> I always thought WRAP (Web Resource Authorization Protocol) was a good
> name. Perhaps a riff on that? Like WRAC, pronounced "rack", that expands to
> Web Resource Authorization Concord (or Compact or Convention).
>
>
>
> On Tue, May 12, 2020 at 11:32 AM Dick Hardt <[email-masked]> wrote:
>
> Ok
>
>
>
> On Tue, May 12, 2020 at 10:29 AM Jared Jennings <[email-masked]>
> wrote:
>
> Yeah, I wasn't really thinking of expanding the name. I'm not really a fan
> of it though and don't mind if it's not included. I had provided several
> others over the weekend.
>
>
>
> On May 12, 2020, at 09:27, Dick Hardt <[email-masked]> wrote:
>
>
>
> On Tue, May 12, 2020 at 6:24 AM Justin Richer <[email-masked]> wrote:
>
> I could be wrong, but I believe the intended expansion is “EdgeAuth” as
> stated in the email below. Or are you looking to expand “Edge” as an
> acronym as well?
>
>
>
>  — Justin
>
>
>
> On May 11, 2020, at 6:42 PM, Dick Hardt <[email-masked]> wrote:
>
>
>
> On Tue, May 5, 2020 at 6:39 AM Jared Jennings <[email-masked]>
> wrote:
>
> On Fri, May 1, 2020 at 4:09 PM Dick Hardt <[email-masked]> wrote:
>
> We won't be judging or ranking names at this time -- we are brainstorming
> names that are descriptive of the protocol.
>
> so ideally we would have r*ough consensus on the name by May 18.*
>
>
>
> Let's brainstorm for a week, and then we can stack rank them on our
> objective criteria, and then vote on the top candidates.
>
>
>
> XAuth - Extensible delegated Authorization and Authentication protocol, or
> just view the X as a placeholder and XAuth is OAuth ++
>
>
>
>
>
> --
> Txauth mailing list
> [email-masked]
> [email-masked]
> [email-masked]
> *CONFIDENTIALITY NOTICE: This email may contain confidential and
> privileged material for the sole use of the intended recipient(s). Any
> review, use, distribution or disclosure by others is strictly prohibited..
> If you have received this communication in error, please notify the sender
> immediately by e-mail and delete the message and any file attachments from
> your computer. Thank you.*
>

---

From: Mike Jones <[email-masked]>
Date: Tue, 12 May 2020 21:14:19 +0000

I hope you can enter this name into the voting then.  Brian was searching for a good “C” word just a few minutes ago and I think “Collaboration” is a good candidate.

                                                          -- Mike

From: Txauth <[email-masked]> On Behalf Of Dick Hardt
Sent: Tuesday, May 12, 2020 2:10 PM
To: Mike Jones <[email-masked]>
Cc: Jared Jennings <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: [EXTERNAL] Re: [Txauth] WG name brainstorming - please participate!

On Tue, May 12, 2020 at 2:09 PM Mike Jones <[email-masked]<mailto:[email-masked]>> wrote:
Web Resource Access Collaboration (WRAC)

From: Txauth <[email-masked]<mailto:[email-masked]>> On Behalf Of Brian Campbell
Sent: Tuesday, May 12, 2020 12:38 PM
To: Dick Hardt <[email-masked]<mailto:[email-masked]>>
Cc: Jared Jennings <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Txauth] WG name brainstorming - please participate!

 — Justin

-Jared
Skype:jaredljennings
Signal:+1 816.730.9540

Required:

Let's brainstorm for a week, and then we can stack rank them on our objective criteria, and then vote on the top candidates..