Subject: [Txauth] WG name brainstorming - please participate!

From: Dick Hardt <[email-masked]>
Date: Fri, 1 May 2020 14:08:43 -0700

We now have our criteria for names, and we can now start the next step in
our process, brainstorming names!

Here is the criteria again:

Required:

   1. No confusion with another protocol, major software project, or
   IETF/IRTF WG name
   2. no existing registered trademarks in related classes
   3. Less than 1M results in Google
   4. Descriptive of protocol (this criteria is subjective)
   5. Not an offensive meaning to a member of the mail list

Desirable:

   1. Straightforward to pronounce
   2. Easy to spell
   3. Easy to read
   4. Shortish

We won't be judging or ranking names at this time -- we are brainstorming
names that are descriptive of the protocol.
We are hoping we can get the WG approved in the telechat May 21,
so ideally we would have r*ough consensus on the name by May 18.*

Let's brainstorm for a week, and then we can stack rank them on our
objective criteria, and then vote on the top candidates.

I'll start by submitting my favorite:

XAuth - Extensible delegated Authorization and Authentication protocol, or
just view the X as a placeholder and XAuth is OAuth ++

---

From: Justin Richer <[email-masked]>
Date: Sat, 2 May 2020 10:25:41 -0400

Dick,

Thanks for kicking this off. I’m going to submit that we keep the current name of the mailing list:

TxAuth

 - Either “Transactional Authn” or “The neXt Authn” or any number of other things. Or just “TxAuth” without an expansion, like the “O” in OAuth today doesn’t officially expand into anything (it’s officially the Web Authorization Protocol Framework, not “Open Authorization” as it might have been at one point). Considering the only push against TxAuth that I’ve heard is that some people don’t like “transactional” in the name, I think that’s easy enough to work around.

Not only does it have <1M hits on google, most of them point to this working group or writings about this working group. It’s a brand we already own and control, and we are the ones who can decide what it means.

Are we providing feedback inline for other proposals while we’re at it? Because “XAuth” fails the first required parameter below pretty badly:

https://www.x.org/archive/X11R6.8.1/doc/xauth.1.html <https://www.x.org/archive/X11R6.8.1/doc/xauth.1.html>

 — Justin

> On May 1, 2020, at 5:08 PM, Dick Hardt <[email-masked]> wrote:
> 
> We now have our criteria for names, and we can now start the next step in our process, brainstorming names!
> 
> No confusion with another protocol, major software project, or IETF/IRTF WG name
> no existing registered trademarks in related classes
> Less than 1M results in Google
> Descriptive of protocol (this criteria is subjective)
> Not an offensive meaning to a member of the mail list
> Desirable:
> Straightforward to pronounce
> Easy to spell
> Easy to read
> Shortish
> We won't be judging or ranking names at this time -- we are brainstorming names that are descriptive of the protocol.
> so ideally we would have rough consensus on the name by May 18.
> 
> Let's brainstorm for a week, and then we can stack rank them on our objective criteria, and then vote on the top candidates.
> 
> XAuth - Extensible delegated Authorization and Authentication protocol, or just view the X as a placeholder and XAuth is OAuth ++
> 
> -- 
> Txauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth

---

From: Dick Hardt <[email-masked]>
Date: Sat, 2 May 2020 10:33:38 -0700

Hi Justin

I'm confused why you would suggest that TxAuth stands for transactional
authn as we just did have a discussion that made it clear that there is
more support against "transactional" then there is for it. It seems that
you are not respecting decisions that have been made in the group. I hope
this is not indicative of how you will interact with the group going
forward as it is counter productive.

What would you like your proposal of TxAuth to represent? (I don't think it
can not expand into something. OAuth is unique as it was a strong brand
prior to the work in the IETF, and Tx is known to stand for either
"transmission", or "transaction")

Suggestion: I think that the extensibility of the protocol is a key aspect.
If there is a word that the T (besides transactional) that is descriptive
of the work, then TXAuth could be a great name. T_____ eXtensible
Authorization or something like that.

wrt. your question on providing feedback on other proposals, we are in
brainstorming mode of a name and expansion. Per my email, "We won't be
judging or ranking names at this time"

As to your comment on disqualifying XAuth that it "fails the first required
parameter below pretty badly", I would not consider the xauth program to
control X server to be a "major software project", but I was never a big X
server user, so happy to be told otherwise by anyone on the group that may
be regularly using the xauth program and would find it confusing.

/Dick

On Sat, May 2, 2020 at 7:25 AM Justin Richer <[email-masked]> wrote:

>  - Either “Transactional Authn” or “The neXt Authn” or any number of other
> things. Or just “TxAuth” without an expansion, like the “O” in OAuth today
> doesn’t officially expand into anything (it’s officially the Web
> Authorization Protocol Framework, not “Open Authorization” as it might have
> been at one point). Considering the only push against TxAuth that I’ve
> heard is that some people don’t like “transactional” in the name, I think
> that’s easy enough to work around.
>
> Not only does it have <1M hits on google, most of them point to this
> working group or writings about this working group. It’s a brand we already
> own and control, and we are the ones who can decide what it means.
>
>
>
>
> Are we providing feedback inline for other proposals while we’re at it?
> Because “XAuth” fails the first required parameter below pretty badly:
>
> https://www.x.org/archive/X11R6.8.1/doc/xauth.1.html
>
>
>  — Justin
>

---

From: Justin Richer <[email-masked]>
Date: Mon, 4 May 2020 09:40:36 -0400

> On May 2, 2020, at 1:33 PM, Dick Hardt <[email-masked]> wrote:
> 
> Hi Justin
> 
> I'm confused why you would suggest that TxAuth stands for transactional authn as we just did have a discussion that made it clear that there is more support against "transactional" then there is for it. It seems that you are not respecting decisions that have been made in the group. I hope this is not indicative of how you will interact with the group going forward as it is counter productive.
> 
> What would you like your proposal of TxAuth to represent? (I don't think it can not expand into something. OAuth is unique as it was a strong brand prior to the work in the IETF, and Tx is known to stand for either "transmission", or "transaction")
> 

As I said in my email below, and in many emails prior, I’m also happy with the “Tx” expanding to something else. I’m also happy with it expanding into nothing, which I don’t think we should dismiss as an option.

> Suggestion: I think that the extensibility of the protocol is a key aspect. If there is a word that the T (besides transactional) that is descriptive of the work, then TXAuth could be a great name. T_____ eXtensible Authorization or something like that.

Thank you for agreeing with what I said in my email below.

> 
> wrt. your question on providing feedback on other proposals, we are in brainstorming mode of a name and expansion. Per my email, "We won't be judging or ranking names at this time"

Which is in interesting given the first half of your response was providing feedback on my proposal.

> 
> As to your comment on disqualifying XAuth that it "fails the first required parameter below pretty badly", I would not consider the xauth program to control X server to be a "major software project", but I was never a big X server user, so happy to be told otherwise by anyone on the group that may be regularly using the xauth program and would find it confusing. 
> 

I’ve been a unix/linux user for over two decades, and xauth is an established program in that space. Especially considering it’s a security utility for a network protocol (x11), I don’t think we should be stepping on it with another security effort for another network protocol. It’s not only the same name but it’s a similar-ish function.

I have many other comments about xauth as a name, and the rationale given for it, but as requested I will provide those when we are discussing things if this is still a relevant option.

In the mean time I’ll continue to submit ideas to the brainstorm process,

Thanks,
 — Justin

> /Dick
> 
> On Sat, May 2, 2020 at 7:25 AM Justin Richer <[email-masked] <mailto:[email-masked]>> wrote:
> Dick,
> 
>> On May 1, 2020, at 5:08 PM, Dick Hardt <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>
>

---

From: "retnikt ." <[email-masked]>
Date: Sun, 3 May 2020 07:28:43 +0100

Hello
I am new here, you don't know me. But I would like to say that I think
"neXt Authn" is a terrible name. It's too forced, just to use the letter X
because it's 'cool'. And +1 to TxAuth alone
retnikt

---

From: Justin Richer <[email-masked]>
Date: Mon, 4 May 2020 14:35:47 -0400

While I’m also a fan of TxAuth on its own without an expansion, I was also thinking that it could be used to mean “Transmission of Authority”.

Because that’s what delegation is — it’s a transmission of one party’s authority to another party. And fundamentally, delegation is what this protocol is trying to solve. This also sidesteps whether this is an authorization or authentication protocol. At its core, OAuth is neither, and I think that this is true here as well. We can transmit authority in multiple ways with a single protocol.

 — Justin

> On May 3, 2020, at 2:28 AM, retnikt . <[email-masked]> wrote:
> 
> Hello
> I am new here, you don't know me. But I would like to say that I think "neXt Authn" is a terrible name. It's too forced, just to use the letter X because it's 'cool'. And +1 to TxAuth alone
> retnikt
> 
> On Sat, 2 May 2020 at 15:26, Justin Richer <[email-masked] <mailto:[email-masked]>> wrote:
> Dick,
>

---

From: Justin Richer <[email-masked]>
Date: Mon, 4 May 2020 14:55:47 -0400

IDDP - Intent-Driven Delegation Protocol

 — Justin

---

From: Dick Hardt <[email-masked]>
Date: Mon, 4 May 2020 16:15:45 -0700

XAuthZ - eXtensible AuthoriZation

A nod to both XYZ and OAuth. Also clarifies it is authorization (authZ)
rather than authentication (authN)
ᐧ

---

From: Mike Varley <[email-masked]>
Date: Tue, 5 May 2020 00:31:37 +0000

On paper I like XAuthZ, but I believe it fails the ‘straightforward to pronounce’ test. It’s a bit tricky for me, and I can imagine it being difficult for folks to process on conference calls, especially if English is not their first language.

I’m sorry I don’t have a counter proposal. I do like it on paper, but trying to say it aloud got my tongue tied. Others may have better luck.

MV

________________________________
From: Txauth <[email-masked]> on behalf of Dick Hardt <[email-masked]>
Sent: Monday, May 4, 2020 7:15:45 PM
To: [email-masked] <[email-masked]>
Subject: Re: [Txauth] WG name brainstorming - please participate!

A nod to both XYZ and OAuth. Also clarifies it is authorization (authZ) rather than authentication (authN)
[https://mailfoogae.appspot.com/t?sender=aZGljay5oYXJkdEBnbWFpbC5jb20%3D&type=zerocontent&guid=636e8882-bdaf-4770-a4bc-52234e5702f3]ᐧ

On Mon, May 4, 2020 at 11:55 AM Justin Richer <[email-masked]<mailto:[email-masked]>> wrote:
IDDP - Intent-Driven Delegation Protocol

 — Justin

On May 1, 2020, at 5:08 PM, Dick Hardt <[email-masked]<mailto:[email-masked]>> wrote:

Required:

  1.  No confusion with another protocol, major software project, or IETF/IRTF WG name

Desirable:

--
Txauth mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/txauth

This email and any attachments are for the sole use of the intended recipients and may be privileged, confidential or otherwise exempt from disclosure under law. Any distribution, printing or other use by anyone other than the intended recipient is prohibited. If you are not an intended recipient, please contact the sender immediately, and permanently delete this email and its attachments.

---

From: "Bron Gondwana" <[email-masked]>
Date: Tue, 05 May 2020 22:29:42 +1000

There's the Zed / Zee confusion as well as the "XAuthZ" sounds much more like it's related to XAuth than TxAuth does.

Another +1 to TxAuth from me. The backronym might be tricky but it's easy to pronounce, easy to search, and already known.

Bron.

On Tue, May 5, 2020, at 10:31, Mike Varley wrote:
> *From:* Txauth <[email-masked]> on behalf of Dick Hardt <[email-masked]>
> *Sent:* Monday, May 4, 2020 7:15:45 PM
> *To:* [email-masked] <[email-masked]>
> *Subject:* Re: [Txauth] WG name brainstorming - please participate! 
> 
>>> **

--
 Bron Gondwana, CEO, Fastmail Pty Ltd
 [email-masked]

---

From: Jared Jennings <[email-masked]>
Date: Tue, 5 May 2020 08:39:46 -0500

EdgeAuth or EAuth - something along those lines.

-Jared
Skype:jaredljennings
Signal:+1 816.730.9540
WhatsApp: +1 816.678.4152

---

From: Dick Hardt <[email-masked]>
Date: Tue, 5 May 2020 18:12:52 -0700

Reminder to participate in name suggestions! The cutoff for suggestions is
Friday.

Nigel has created a list here:

https://nigelhamilton.com/pages/txauth-name-game.html

ᐧ

---

From: Justin Richer <[email-masked]>
Date: Thu, 7 May 2020 08:54:42 -0400

NIRAD - Negotiation of Intent Registration and Authority Delegation

 ^— from a google search this seems to be a given name of Indian origin but I don’t know the details of this

NADIR - Negotiation of Authority Delegation and Intent Registration

  ^— note that this one also means “the lowest point” so not really my favorite meaning

 — Justin

---

From: Dick Hardt <[email-masked]>
Date: Thu, 7 May 2020 11:43:30 -0700

GNAP - Grant Negotiation and Authorization Protocol
(pronounced nap) only 373K hits on Google
ᐧ

---

From: Dick Hardt <[email-masked]>
Date: Thu, 7 May 2020 11:53:21 -0700

Reminder of brainstorming. I'm thinking we will cut off brainstorming this
week and move to discussion and selection.

FYI: if you are interested in keeping the txauth name by creating a
backronym[1], here is a list of adjectives that start with T.

https://adjectivesstarting.com/with-t/

A couple name suggestions:

TXAuth - Testable eXtensible Authorization

TXAuth - Truly eXtensible Authorization

[1] https://en.wikipedia.org/wiki/Backronym

---

From: Leif Johansson <[email-masked]>
Date: Fri, 8 May 2020 00:14:35 +0200

> We now have our criteria for names, and we can now start the next step in our process, brainstorming names!

TINTO - This Is NoT OAuth

---

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 08 May 2020 13:34:19 +1000

> TINTO - This Is NoT OAuth

You'd be wanting TINOA with 102k results rather than TINTO with 67 million results I expect if you're gonna do that acronym derivation.

I gotta say, I don't particularly like technology names which are "this isn't <thing that exists at the time>" because if it's wildly popular and the referenced tech dies, then your name contains an non-descriptive stale pointer.

Bron.

---

From: David Skaife <[email-masked]>
Date: Fri, 8 May 2020 14:51:37 +0100

Two suggestions from me:

*IDPAuthZ *- Intent-driven Protocol for Authorization
The IdP reference could be considered deliberate or incidental - can be
interpreted either way :)

*PAuthZ *- Protocol for Authorization
Very straightforward and simple, meaning no confusion or misinterpretation,
and it also removes the misunderstanding around authorization vs
authentication. Additionally, this includes a reference to "P following
after O" (i.e. this protocol follows after OAuth) - I think Dick suggested
something similar a few weeks back.

Many thanks,
David Skaife

<http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
Virus-free.
www.avg.com
<http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
<#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>

On Fri, May 8, 2020 at 4:34 AM Bron Gondwana <[email-masked]> wrote:

> You'd be wanting TINOA with 102k results rather than TINTO with 67 million
> results I expect if you're gonna do that acronym derivation.
>
> I gotta say, I don't particularly like technology names which are "this
> isn't <thing that exists at the time>" because if it's wildly popular and
> the referenced tech dies, then your name contains an non-descriptive stale
> pointer.
>
> Bron.
>
>
> --

---

From: Dick Hardt <[email-masked]>
Date: Fri, 8 May 2020 12:05:32 -0700

Pauthz is a common last name according to Google with 30M hits

Could also be

*PAZ* - Protocol for AuthoriZation

paz means peace in Spanish, and there are 610M hits on Google

Either could be pronounced like 'paws' -- as a dog owner, I think this one
is fun -- similar to JWT.

On Fri, May 8, 2020 at 6:52 AM David Skaife <
[email-masked]> wrote:

> Very straightforward and simple, meaning no confusion or
> misinterpretation, and it also removes the misunderstanding around
> authorization vs authentication. Additionally, this includes a reference to
> "P following after O" (i.e. this protocol follows after OAuth) - I think
> Dick suggested something similar a few weeks back.
>
>
> Many thanks,
> David Skaife
>
>
> <http://www.avg..com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail> Virus-free.
> www.avg.com
> <#m_3460353666472774731_DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>
>> You'd be wanting TINOA with 102k results rather than TINTO with 67
>> million results I expect if you're gonna do that acronym derivation.
>>

---

From: Aaron Parecki <[email-masked]>
Date: Fri, 8 May 2020 12:18:18 -0700

What's not clear to me is whether this is the intended name of the new WG
or the spec itself.

If we're talking about the spec itself, I'd like to throw "OAuth 3" into
the mix. Obviously that's not a good name for the WG though.

Is there a requirement that the spec produced by this group have the same
name as the group itself?

Aaron

On Tue, May 5, 2020 at 6:13 PM Dick Hardt <[email-masked]> wrote:

>> XAuth - Extensible delegated Authorization and Authentication protocol,
>> or just view the X as a placeholder and XAuth is OAuth ++
>>
>> --
> Txauth mailing list
> [email-masked]

---

From: Dick Hardt <[email-masked]>
Date: Fri, 8 May 2020 12:33:38 -0700

> What's not clear to me is whether this is the intended name of the new WG

likely both, but WG name is what we are deciding now for WG creation

> the mix. Obviously that's not a good name for the WG though.

We had earlier discussions that I think concluded that OAuth 3 was not an
appropriate. Name.

> name as the group itself?

Not a hard requirement, but is usual. The mail list will continue to be
[email-masked]. Calling the core protocol something different would create
confusion I think.

>> Reminder to participate in name suggestions! The cutoff for suggestions
>> is Friday.
>>
>>> We won't be judging or ranking names at this time -- we are
>>> brainstorming names that are descriptive of the protocol.

---

From: Aaron Parecki <[email-masked]>
Date: Fri, 8 May 2020 12:36:10 -0700

I do think there are some valid reasons for calling the spec OAuth 3, but I
will save that for the later discussion of naming the spec if this is just
about the WG name for now.

On Fri, May 8, 2020 at 12:34 PM Dick Hardt <[email-masked]> wrote:

> [email-masked]. Calling the core protocol something different would
> create confusion I think.
>
>
>
>>
>> Aaron
>>

---

From: Dick Hardt <[email-masked]>
Date: Fri, 8 May 2020 12:43:22 -0700

GranPro - GRAnt Negotiation Protocol

---

From: David Skaife <[email-masked]>
Date: Fri, 8 May 2020 20:56:13 +0100

Hi Dick,

*>> " Pauthz is a common last name according to Google with 30M hits"*

I'm not sure how you're getting 30M hits for that? I only see 1410 hits. It
seems to be a surname, but an extremely uncommon Nicarguan surname.
I think PAuthZ meets the criteria of being Google-able.

I like the "paws" pronunciation suggestion :)

Many thanks,
David Skaife

---

From: Dick Hardt <[email-masked]>
Date: Fri, 8 May 2020 14:51:02 -0700

On Fri, May 8, 2020 at 12:56 PM David Skaife <
[email-masked]> wrote:

> I'm not sure how you're getting 30M hits for that? I only see 1410 hits.
> It seems to be a surname, but an extremely uncommon Nicarguan surname.
> <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail> Virus-free.
> www.avg.com
> <#m_3957966066373443694_DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>

---

From: Jared Jennings <[email-masked]>
Date: Fri, 8 May 2020 22:16:34 -0500

If I may submit a few.

Identity Authentication Authorization Protocol
IAAP
Google Hits 849,000

Tokenized Identity and Access Protocol
TIAAP
Google Hits 30,800

Tokenized Identity and Access Protocol
TIAP
Google Hits 81,500,000

Identity Token Access Protocol
ITAP
Google Hits 3,800,000

Comprehensive Token Access Protocol
CTAP
Google Hits 959,000

Comprehensive Identity Access Protocol
CIAP
Google Hits 1,780,000

Comprehensive Privileged Authentication Authorization Protocol
CPAAP
Google Hits 15,100

Restrictive Identity Access Protocol
RIAP
Google Hits 910,000

Privilege Authorization Access Protocol
PAAP
Google Hits 3,020,000

Tokenized Identity and Access Resource Protocol
TIARP
Google Hits 59,900

Tokenized Authorization Attestation Protocol
TAAP
Google Hits 1,110,000

Unique Protocol Token Authorization
UPTA
Google Hits 1,460,000

-Jared
Skype:jaredljennings
Signal:+1 816.730.9540

On Fri, May 8, 2020 at 4:51 PM Dick Hardt <[email-masked]> wrote:

>> <#m_-8101888854208669969_m_3957966066373443694_DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>>
>> On Fri, May 8, 2020 at 8:43 PM Dick Hardt <[email-masked]
>> <[email-masked]>> wrote:
>>
>>>>> XAuth - Extensible delegated Authorization and Authentication
>>>>> protocol, or just view the X as a placeholder and XAuth is OAuth ++
>>>>>
>>>>> --
>>> Txauth mailing list
>>> [email-masked]

---

From: Leif Johansson <[email-masked]>
Date: Sat, 9 May 2020 10:54:32 +0200

Next you’re gona tell me that Grant Token Authorization isn’t working either.

Maybe we should rethink the priorities of this group.

Skickat från min iPhone

> 8 maj 2020 kl. 05:35 skrev Bron Gondwana <[email-masked]>:
> 
> 
>

---

From: Dick Hardt <[email-masked]>
Date: Mon, 11 May 2020 15:42:13 -0700

Jared: to have your suggestion be listed, you will need to provide an
expansion on the name of the WG.

---

From: Dick Hardt <[email-masked]>
Date: Mon, 11 May 2020 16:13:51 -0700

Well, I poked at this a bit as a google for "pauthz" (ie, including the
quotes in the search) gave very few results. I then tried just pauthz and
went to all the hits, and when I got to page 9, Google said there were a
small number of hits. Very confusing.

On Fri, May 8, 2020 at 2:51 PM Dick Hardt <[email-masked]> wrote:

>> <#m_8274633637896646466_m_3957966066373443694_DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>>

---

From: Justin Richer <[email-masked]>
Date: Tue, 12 May 2020 09:24:55 -0400

I could be wrong, but I believe the intended expansion is “EdgeAuth” as stated in the email below. Or are you looking to expand “Edge” as an acronym as well?

 — Justin

> On May 11, 2020, at 6:42 PM, Dick Hardt <[email-masked]> wrote:
> 
> Jared: to have your suggestion be listed, you will need to provide an expansion on the name of the WG.
> 
> On Tue, May 5, 2020 at 6:39 AM Jared Jennings <[email-masked] <mailto:[email-masked]>> wrote:
> On Fri, May 1, 2020 at 4:09 PM Dick Hardt <[email-masked] <mailto:[email-masked]>> wrote:

---

From: Justin Richer <[email-masked]>
Date: Tue, 12 May 2020 09:26:30 -0400

Google is likely trying to be helpful. I just tried this and got the following result:

It is likely including the results for the suggested correction “pautz" in the results estimate. 

 — Justin

> On May 11, 2020, at 7:13 PM, Dick Hardt <[email-masked]> wrote:
> 
> Well, I poked at this a bit as a google for "pauthz" (ie, including the quotes in the search) gave very few results. I then tried just pauthz and went to all the hits, and when I got to page 9, Google said there were a small number of hits. Very confusing.
> 
> 
> 
> On Fri, May 8, 2020 at 2:51 PM Dick Hardt <[email-masked] <mailto:[email-masked]>> wrote:
> <Screen Shot 2020-05-08 at 2.50.28 PM.png>
> 
> On Fri, May 8, 2020 at 12:56 PM David Skaife <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Dick,
> 
> >> " Pauthz is a common last name according to Google with 30M hits"
> 
> I'm not sure how you're getting 30M hits for that? I only see 1410 hits. It seems to be a surname, but an extremely uncommon Nicarguan surname.
>  <http://www.avg..com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>	Virus-free. www.avg.com <http://www.avg.com/email-signature?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail> <x-msg://168/#m_8274633637896646466_m_3957966066373443694_DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
> On Fri, May 8, 2020 at 8:43 PM Dick Hardt <[email-masked] <mailto:[email-masked]>> wrote:
> On Tue, May 5, 2020 at 6:12 PM Dick Hardt <[email-masked] <mailto:[email-masked]>> wrote:
> Reminder to participate in name suggestions! The cutoff for suggestions is Friday.
> 
> https://nigelhamilton.com/pages/txauth-name-game.html <https://nigelhamilton.com/pages/txauth-name-game.html>
> 
> ᐧ
> 
> On Fri, May 1, 2020 at 2:08 PM Dick Hardt <[email-masked] <mailto:dick.hardt@gmail..com>> wrote:

---

From: Dick Hardt <[email-masked]>
Date: Tue, 12 May 2020 07:27:43 -0700

Im looking for the phrase it expands to, and not wanting to assume what
Jared was proposing.

On Tue, May 12, 2020 at 6:24 AM Justin Richer <[email-masked]> wrote:

> I could be wrong, but I believe the intended expansion is “EdgeAuth” as
> stated in the email below. Or are you looking to expand “Edge” as an
> acronym as well?
>
>  — Justin
>

---

From: Jared Jennings <[email-masked]>
Date: Tue, 12 May 2020 12:29:05 -0500

Yeah, I wasn't really thinking of expanding the name. I'm not really a fan of it though and don't mind if it's not included. I had provided several others over the weekend.

Personally, I am going to vote on OAuth 3.0 and maybe XAuth.

> On May 12, 2020, at 09:27, Dick Hardt <[email-masked]> wrote:
> 
> Im looking for the phrase it expands to, and not wanting to assume what Jared was proposing.
> 
> On Tue, May 12, 2020 at 6:24 AM Justin Richer <[email-masked] <mailto:[email-masked]>> wrote:
>> On May 11, 2020, at 6:42 PM, Dick Hardt <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Skype:jaredljennings <>

---

From: Dick Hardt <[email-masked]>
Date: Tue, 12 May 2020 10:32:12 -0700

Ok

FYI: The working group does need a name to go with the charter.

On Tue, May 12, 2020 at 10:29 AM Jared Jennings <[email-masked]>
wrote:

> Yeah, I wasn't really thinking of expanding the name. I'm not really a fan
> of it though and don't mind if it's not included. I had provided several
> others over the weekend.
>

---

From: Brian Campbell <[email-masked]>
Date: Tue, 12 May 2020 13:37:39 -0600

I always thought WRAP (Web Resource Authorization Protocol) was a good
name. Perhaps a riff on that? Like WRAC, pronounced "rack", that expands to
Web Resource Authorization Concord (or Compact or Convention).

On Tue, May 12, 2020 at 11:32 AM Dick Hardt <[email-masked]> wrote:

>> Yeah, I wasn't really thinking of expanding the name. I'm not really a
>> fan of it though and don't mind if it's not included. I had provided
>> several others over the weekend.
>>

-- 
_CONFIDENTIALITY NOTICE: This email may contain confidential and privileged 
material for the sole use of the intended recipient(s). Any review, use, 
distribution or disclosure by others is strictly prohibited.  If you have 
received this communication in error, please notify the sender immediately 
by e-mail and delete the message and any file attachments from your 
computer. Thank you._

---

From: David Skaife <[email-masked]>
Date: Tue, 12 May 2020 21:14:48 +0100

You could perhaps stick with Web Resource Authorization Protocol but write
it as WReAP.
Pronounced the same as "reap".

On Tue, May 12, 2020 at 8:38 PM Brian Campbell <bcampbell=
[email-masked]> wrote:

>>>>>> We now have our criteria for names, and we can now start the next
>>>>>> step in our process, brainstorming names!
>>>>>>
> *CONFIDENTIALITY NOTICE: This email may contain confidential and
> privileged material for the sole use of the intended recipient(s). Any
> review, use, distribution or disclosure by others is strictly prohibited..
> If you have received this communication in error, please notify the sender
> immediately by e-mail and delete the message and any file attachments from
> your computer. Thank you.*--
> Txauth mailing list
> [email-masked]