Subject: [Txauth] Name suggestion for next round...

From: Vijay IETF <[email-masked]>
Date: Thu, 28 May 2020 15:08:37 +0530

Hi,

I'd like to suggest AuthX for inclusion in the next round...

Why AuthX?

The group's draft charter includes concepts, not in words but perhaps by
induction, from the realms of identity, authorization, and authentication.

1. The X in AuthX indicates that.
2. It's simple.
3. Avoids the unproductive conversations on the semantics of Transaction.
4. It indicates that the group is open to exploring all things X (known,
unknown) wrt identity, authorization, authentication.

No matter how narrow we try to scope the charter down, those are
inescapable and related concepts.

Witness the massive confusion thrust upon developers arising from OIDC and
OAuth2 specifications coming from two different organizations on concepts
that in my mind are inseparable from a systems perspective.

Specifications that are not self contained are confusing at minimum. And do
a disservice to the wider community at worst when they punt on something
fundamental and related as being out of scope.

If we are breaking from the past then it behoves upon us to not repeat the
mistakes from the past.

- Vijay

---

From: Justin Richer <[email-masked]>
Date: Thu, 28 May 2020 10:37:18 -0400

Hi Vijay,

Sorry to say this, but according to the process put forward by the chairs, the cut-off for suggesting new names has already passed. Now the group is looking for feedback on the existing list of candidates, not for additional candidates. 

In addition, AuthX is an existing company name in this space: https://www.authx.com/

 — Justin

> On May 28, 2020, at 5:38 AM, Vijay IETF <[email-masked]> wrote:
> 
> Hi,
> 
> The group's draft charter includes concepts, not in words but perhaps by induction, from the realms of identity, authorization, and authentication. 
> 
> 4. It indicates that the group is open to exploring all things X (known, unknown) wrt identity, authorization, authentication.
> 
> No matter how narrow we try to scope the charter down, those are inescapable and related concepts. 
> 
> Witness the massive confusion thrust upon developers arising from OIDC and OAuth2 specifications coming from two different organizations on concepts that in my mind are inseparable from a systems perspective.
> 
> Specifications that are not self contained are confusing at minimum. And do a disservice to the wider community at worst when they punt on something fundamental and related as being out of scope.
> 
> If we are breaking from the past then it behoves upon us to not repeat the mistakes from the past.
> 
> - Vijay
> -- 
> Txauth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth

---

From: Yaron Sheffer <[email-masked]>
Date: Thu, 28 May 2020 17:56:39 +0300

Please see here for the latest on the name selection process: https://mailarchive.ietf.org/arch/msg/txauth/Gr_FZOKAmIeZOjPvVK_2JyaVIZY/

The deadline is June 4, 0800 UTC.

Thanks,
	Yaron

On 5/28/20, 17:37, "Txauth on behalf of Justin Richer" <[email-masked] on behalf of [email-masked]> wrote:

    Hi Vijay,

     — Justin

---

From: Vijay IETF <[email-masked]>
Date: Thu, 28 May 2020 21:13:12 +0530

Hi Justin,

Thanks. My bad. Suggesting a name of a company that exists is a
terrible idea. I should have done my homework. Sorry about that!

Was flooded by DNSOP WG emails and lost track of the cut-off dates and the
name selection process thread.

I give up. Naming is hard.

I do find the process to "strongly object" in order to eliminate a popular
vote a bit odd.

Is there a precedent for this mode of selection in any setting within IETF?
Genuinely curious since I am new to the working internals of IETF.

On Thu, 28 May 2020 at 20:07, Justin Richer <[email-masked]> wrote:

> Hi Vijay,
>
> Sorry to say this, but according to the process put forward by the chairs,
> the cut-off for suggesting new names has already passed. Now the group is
> looking for feedback on the existing list of candidates, not for additional
> candidates.
>
> > Witness the massive confusion thrust upon developers arising from OIDC
> and OAuth2 specifications coming from two different organizations on
> concepts that in my mind are inseparable from a systems perspective.
> >
> > Specifications that are not self contained are confusing at minimum. And
> do a disservice to the wider community at worst when they punt on something

---

From: Dick Hardt <[email-masked]>
Date: Thu, 28 May 2020 16:03:16 -0700

Vijay

The IETF does not operate by voting, but by rough consensus. Consensus is a
solution where there are no strong objections. It is not the most popular
solution.

Here is a good read:

On Consensus and Humming in the IETF
https://tools.ietf.org/html/rfc7282

ᐧ

On Thu, May 28, 2020 at 8:43 AM Vijay IETF <[email-masked]> wrote:

> Is there a precedent for this mode of selection in any setting within
> IETF? Genuinely curious since I am new to the working internals of IETF.
>
>
>> Sorry to say this, but according to the process put forward by the
>> chairs, the cut-off for suggesting new names has already passed. Now the
>> group is looking for feedback on the existing list of candidates, not for
>> additional candidates.
>>
>> > The group's draft charter includes concepts, not in words but perhaps
>> by induction, from the realms of identity, authorization, and
>> authentication.
>> >
>> > 4. It indicates that the group is open to exploring all things X
>> (known, unknown) wrt identity, authorization, authentication.
>> >
>> > Specifications that are not self contained are confusing at minimum.
>> And do a disservice to the wider community at worst when they punt on
>> something fundamental and related as being out of scope.
>> >