Subject: Re: [Txauth] GNAP it is

From: Mike Jones <[email-masked]>
Date: Mon, 15 Jun 2020 19:38:29 +0000

I don’t care a lot one way or the other.  My main point is that no matter what guidance we give, many people are likely to pronounce the “G”.  If we try to insist on it being silent, we should get used to the fact that we’ll probably be hearing both pronunciations.

                                                       -- Mike

P.S.  Thanks for the Smurfs link, Vittorio!

From: [email-masked] <[email-masked]>
Sent: Monday, June 15, 2020 12:25 PM
To: 'Dick Hardt' <[email-masked]>; 'Peter Saint-Andre' <[email-masked]>
Cc: Mike Jones <[email-masked]>; 'Jared Jennings' <[email-masked]>; 'Amanjeev Sethi' <[email-masked]>; 'Fabien Imbault' <[email-masked]>; [email-masked]
Subject: RE: [Txauth] GNAP it is

Perhaps not to be taken too seriously, but here’s prior art on GNAP pronunciation.
As Leif mentioned few mails ago, “GNAP” appeared on the Smurfs comic and was reprised in a cartoon episode as well.
You’ll find few examples around 3:30
 https://www.youtube.com/watch?v=GEl8IBv98vg&feature=youtu.be&fbclid=IwAR0GVfFeNl4M1OhHKE7FfyCqKTDJI960mU-ai8hLqMO8A_qzCS-WBJgPbpQ

From: Txauth <[email-masked]<mailto:[email-masked]>> On Behalf Of Dick Hardt
Sent: Monday, June 15, 2020 12:18 PM
To: Peter Saint-Andre <[email-masked]<mailto:[email-masked]>>
Cc: Mike Jones <[email-masked]<mailto:[email-masked]>>; Jared Jennings <[email-masked]<mailto:[email-masked]>>; Amanjeev Sethi <[email-masked]<mailto:[email-masked]>>; Fabien Imbault <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Txauth] GNAP it is

Checking in again on pronunciation.

Mike: do you still have concerns with a silent 'G'?

Anyone else have concerns?

I'd like to nip pronunciation confusion in the bud by having the recommended pronunciation in the charter.

ᐧ

On Sun, Jun 7, 2020 at 1:23 PM Peter Saint-Andre <[email-masked]<mailto:[email-masked]>> wrote:
Looks like we were caught gnapping. ;-)

OK, that's the last of my snarky comments, let's get to work!

Peter

On 6/7/20 2:09 PM, Dick Hardt wrote:
> It is if you are familiar with any of the GNU projects.
>
> https://www.gnu.org/gnu/pronunciation.en.html
>
> A quick search on the internet has the "normal" pronunciation of "gnu"
> to have a silent 'g'.
>
> https://www.howtopronounce.com/gnu
> https://dictionary.cambridge.org/us/pronunciation/english/gnu
>
>
> ᐧ
>
> On Sun, Jun 7, 2020 at 12:51 PM Mike Jones <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>>> wrote:
>
>     I had assumed Guh-Nap – parallel to the pronunciation of GNU.  I
>     think that’s the most natural way to read it.____
>
>     __ __
>
>                                                            -- Mike____
>
>     __ __
>
>     *From:* Txauth <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>> *On Behalf Of *Dick Hardt
>     *Sent:* Sunday, June 7, 2020 12:45 PM
>     *To:* Amanjeev Sethi <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>
>     *Cc:* Fabien Imbault <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>>; Jared Jennings
>     <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>>;
>     [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
>     *Subject:* Re: [Txauth] GNAP it is____
>
>     __ __
>
>     Anyone have objection to the recommended pronunciation being the
>     English word "nap", as in "gnaw"?____
>
>     __ __
>
>     If not, then we could add a pronunciation recommendation to the
>     Charter.____
>
>     __ __
>
>     ᐧ____
>
>     __ __
>
>     On Sat, Jun 6, 2020 at 8:03 AM Amanjeev Sethi <[email-masked]<mailto:[email-masked]>
>     <mailto:[email-masked]<mailto:[email-masked]>>> wrote:____
>
>         Vote for 'G' silent, as in 'lagnappe' ;)____
>
>         __ __
>
>         On Sat, Jun 6, 2020, at 10:52 AM, Jared Jennings wrote:____
>
>             I vote for G silent. For the reason it's most common to
>             pronounce, especially for those not familiar with open
>             source usages.____
>
>             __ __
>
>             On Sat, Jun 6, 2020, 08:45 Dick Hardt <[email-masked]<mailto:[email-masked]>
>             <mailto:[email-masked]<mailto:[email-masked]>>> wrote:____
>
>                 The obvious pronunciation choices are:____
>
>                 __ __
>
>                 nap (silent g as in gnaw)____
>
>                 __ __
>
>                 guh-nap (as in the GNU OS
>                 - https://www.gnu.org/gnu/pronunciation.en..html
>                 <https://www.gnu.org/gnu/pronunciation.en.html>)____
>
>                 __ __
>
>                 gee-nap (as in G-man - government man
>                 - https://en.wikipedia.org/wiki/G-man)____
>
>                 __ __
>
>                 __ __
>
>                 __ __
>
>                 ᐧ____
>
>                 __ __
>
>                 On Sat, Jun 6, 2020 at 1:34 AM Fabien Imbault
>                 <[email-masked]<mailto:[email-masked]>
>                 <mailto:[email-masked]<mailto:[email-masked]>>> wrote:____
>
>                     So, let's adopt a GNAP! We can even come with a
>                     little mascot (a bit like go gopher) as imagined
>                     by http://elisegravel.com/blog/adopte-un-gnap/,
>                     loved by little Canadians :-) ____
>
>                     __ __
>
>                     Just to be sure, how do you recommand we pronounce
>                     it? ____
>
>                     __ __
>
>                     Looking forward to the next steps too.. ____
>
>                     __ __
>
>                     Thxs____
>
>                     Fabien____
>
>                     --____
>
>                     Txauth mailing list____
>
>                     [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>____
>
>                     https://www.ietf.org/mailman/listinfo/txauth____
>
>                 --____
>
>                 Txauth mailing list____
>
>                 [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>____
>
>                 https://www.ietf.org/mailman/listinfo/txauth____
>
>             -- ____
>
>             Txauth mailing list____
>
>             [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>____
>
>             https://www.ietf.org/mailman/listinfo/txauth____
>
>             __ __
>
>         __ __
>
>

---

From: Dick Hardt <[email-masked]>
Date: Mon, 15 Jun 2020 12:42:24 -0700

Hi Mike

I agree that some people will mispronounce it, but if there is a
recommended pronunciation, then there will be consistency amongst those of
us that know it rather than inconsistency between us.

ᐧ

On Mon, Jun 15, 2020 at 12:38 PM Mike Jones <[email-masked]>
wrote:

> I don’t care a lot one way or the other.  My main point is that no matter
> what guidance we give, many people are likely to pronounce the “G”.  If we
> try to insist on it being silent, we should get used to the fact that we’ll
> probably be hearing both pronunciations.
>
>
>
>                                                        -- Mike
>
>
>
> *From:* [email-masked] <[email-masked]>
> *Sent:* Monday, June 15, 2020 12:25 PM
> *To:* 'Dick Hardt' <[email-masked]>; 'Peter Saint-Andre' <
> [email-masked]>
> *Cc:* Mike Jones <[email-masked]>; 'Jared Jennings' <
> [email-masked]>; 'Amanjeev Sethi' <[email-masked]>; 'Fabien
> Imbault' <[email-masked]>; [email-masked]
> *Subject:* RE: [Txauth] GNAP it is
>
>
>
> As Leif mentioned few mails ago, “GNAP” appeared on the Smurfs comic and
> was reprised in a cartoon episode as well.
>
> *From:* Txauth <[email-masked]> *On Behalf Of *Dick Hardt
> *Sent:* Monday, June 15, 2020 12:18 PM
> *To:* Peter Saint-Andre <[email-masked]>
> *Cc:* Mike Jones <[email-masked]>; Jared Jennings <
> [email-masked]>; Amanjeev Sethi <[email-masked]>; Fabien
> Imbault <[email-masked]>; [email-masked]
> *Subject:* Re: [Txauth] GNAP it is
>
>
>
> I'd like to nip pronunciation confusion in the bud by having the
> recommended pronunciation in the charter.
>
>
>
>
>
> ᐧ
>
>
>
> On Sun, Jun 7, 2020 at 1:23 PM Peter Saint-Andre <[email-masked]>
> wrote:
>
> > On Sun, Jun 7, 2020 at 12:51 PM Mike Jones <[email-masked]
> > <mailto:[email-masked]>> wrote:
> >
> >     *From:* Txauth <[email-masked]
> >     <mailto:[email-masked]>> *On Behalf Of *Dick Hardt
> >     *To:* Amanjeev Sethi <[email-masked] <mailto:[email-masked]>>
> >     *Cc:* Fabien Imbault <[email-masked]
> >     <mailto:[email-masked]>>; Jared Jennings
> >     <[email-masked] <mailto:[email-masked]>>;
> >     [email-masked] <mailto:[email-masked]>
> >     On Sat, Jun 6, 2020 at 8:03 AM Amanjeev Sethi <[email-masked]
> >     <mailto:[email-masked]>> wrote:____
> >
> >             On Sat, Jun 6, 2020, 08:45 Dick Hardt <[email-masked]
> >             <mailto:[email-masked]>> wrote:____
> >
> >                 <[email-masked]
> >                 <mailto:[email-masked]>> wrote:____
> >
> >                     [email-masked] <mailto:[email-masked]>____
> >
> >                 [email-masked] <mailto:[email-masked]>____
> >
> >             [email-masked] <mailto:[email-masked]>____
> >

---

From: Justin Richer <[email-masked]>
Date: Mon, 15 Jun 2020 16:56:47 -0400

I agree with Mike, in that we should get used to answering to both.

In my head, it reads with a hard “G”, at least partially because of the Smurfs video’s legacy.

 — Justin

> On Jun 15, 2020, at 3:38 PM, Mike Jones <Michael.Jones=[email-masked]> wrote:
> 
> From: [email-masked] <mailto:[email-masked]> <[email-masked] <mailto:[email-masked]>> 
> To: 'Dick Hardt' <[email-masked] <mailto:[email-masked]>>; 'Peter Saint-Andre' <[email-masked] <mailto:[email-masked]>>
> Cc: Mike Jones <[email-masked] <mailto:[email-masked]>>; 'Jared Jennings' <[email-masked] <mailto:[email-masked]>>; 'Amanjeev Sethi' <[email-masked] <mailto:[email-masked]>>; 'Fabien Imbault' <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
>  https://www.youtube.com/watch?v=GEl8IBv98vg&feature=youtu.be&fbclid=IwAR0GVfFeNl4M1OhHKE7FfyCqKTDJI960mU-ai8hLqMO8A_qzCS-WBJgPbpQ <https://www.youtube.com/watch?v=GEl8IBv98vg&feature=youtu.be&fbclid=IwAR0GVfFeNl4M1OhHKE7FfyCqKTDJI960mU-ai8hLqMO8A_qzCS-WBJgPbpQ>
>  
> From: Txauth <[email-masked] <mailto:[email-masked]>> On Behalf Of Dick Hardt
> To: Peter Saint-Andre <[email-masked] <mailto:[email-masked]>>
> Cc: Mike Jones <[email-masked] <mailto:[email-masked]>>; Jared Jennings <[email-masked] <mailto:[email-masked]>>; Amanjeev Sethi <[email-masked] <mailto:[email-masked]>>; Fabien Imbault <[email-masked] <mailto:[email-masked]>>; [email-masked] <mailto:[email-masked]>
> On Sun, Jun 7, 2020 at 1:23 PM Peter Saint-Andre <[email-masked] <mailto:[email-masked]>> wrote:
> > https://www.gnu.org/gnu/pronunciation.en.html <https://www.gnu.org/gnu/pronunciation.en.html>
> > 
> > https://www.howtopronounce.com/gnu <https://www.howtopronounce.com/gnu>
> > https://dictionary.cambridge.org/us/pronunciation/english/gnu <https://dictionary.cambridge.org/us/pronunciation/english/gnu>
> > 
> > 
> > ᐧ
> > 
> > On Sun, Jun 7, 2020 at 12:51 PM Mike Jones <[email-masked] <mailto:[email-masked]>
> > <mailto:[email-masked] <mailto:[email-masked]>>> wrote:
> > 
> >     *From:* Txauth <[email-masked] <mailto:[email-masked]>
> >     <mailto:[email-masked] <mailto:[email-masked]>>> *On Behalf Of *Dick Hardt
> >     *To:* Amanjeev Sethi <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>
> >     *Cc:* Fabien Imbault <[email-masked] <mailto:[email-masked]>
> >     <mailto:[email-masked] <mailto:[email-masked]>>>; Jared Jennings
> >     <[email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>>;
> >     [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>
> >     On Sat, Jun 6, 2020 at 8:03 AM Amanjeev Sethi <[email-masked] <mailto:[email-masked]>
> >     <mailto:[email-masked] <mailto:[email-masked]>>> wrote:____
> > 
> >             On Sat, Jun 6, 2020, 08:45 Dick Hardt <[email-masked] <mailto:[email-masked]>
> >             <mailto:[email-masked] <mailto:[email-masked]>>> wrote:____
> > 
> >                 - https://www.gnu.org/gnu/pronunciation.en..html <https://www.gnu.org/gnu/pronunciation.en..html>
> >                 <https://www.gnu.org/gnu/pronunciation.en.html <https://www.gnu.org/gnu/pronunciation.en.html>>)____
> > 
> >                 __ __
> > 
> >                 - https://en.wikipedia.org/wiki/G-man)____ <https://en.wikipedia.org/wiki/G-man)____>
> > 
> >                 __ __
> > 
> >                 __ __
> > 
> >                 __ __
> > 
> >                 ᐧ____
> > 
> >                 __ __
> > 
> >                 <[email-masked] <mailto:[email-masked]>
> >                 <mailto:[email-masked] <mailto:[email-masked]>>> wrote:____
> > 
> >                     by http://elisegravel.com/blog/adopte-un-gnap/ <http://elisegravel.com/blog/adopte-un-gnap/>,
> >                     [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>____
> > 
> >                     https://www.ietf.org/mailman/listinfo/txauth____ <https://www.ietf.org/mailman/listinfo/txauth____>
> > 
> >                 --____
> > 
> >                 Txauth mailing list____
> > 
> >                 [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>____
> > 
> >                 https://www.ietf.org/mailman/listinfo/txauth____ <https://www.ietf.org/mailman/listinfo/txauth____>
> > 
> >             -- ____
> > 
> >             Txauth mailing list____
> > 
> >             [email-masked] <mailto:[email-masked]> <mailto:[email-masked] <mailto:[email-masked]>>____
> > 
> >             https://www.ietf.org/mailman/listinfo/txauth____ <https://www.ietf.org/mailman/listinfo/txauth____>
> > 
> >             __ __
> > 
> >         __ __
> > 
> > 
> -- 
> Txauth mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>

---

From: Dick Hardt <[email-masked]>
Date: Mon, 15 Jun 2020 15:14:26 -0700

I agree we should be prepared for both. Can we agree that we can be
consistent? Personally I don't care which we choose -- I only care that we
choose one.

I was working to address the concern that you (Justin) had brought up:

This is ok, but it has a couple downsides. The pronunciation of a hard “g”
or not is going to potentially be confusing, as is the fact that it looks
like it’s part of the GNU project because of that.

On Mon, Jun 15, 2020 at 1:56 PM Justin Richer <[email-masked]> wrote:

> On Jun 15, 2020, at 3:38 PM, Mike Jones <
> Michael.Jones=[email-masked]> wrote:
>
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
>
>
>

---

From: Justin Richer <[email-masked]>
Date: Tue, 16 Jun 2020 10:42:46 -0400

I don’t believe we should add a proposed pronunciation to the charter. It seems silly to focus on this so much.

 — Justin

> On Jun 15, 2020, at 6:14 PM, Dick Hardt <[email-masked]> wrote:
> 
> I agree we should be prepared for both. Can we agree that we can be consistent? Personally I don't care which we choose -- I only care that we choose one.
> 
>> This is ok, but it has a couple downsides. The pronunciation of a hard “g” or not is going to potentially be confusing, as is the fact that it looks like it’s part of the GNU project because of that.
>> 
>> 
> 
> On Mon, Jun 15, 2020 at 1:56 PM Justin Richer <[email-masked] <mailto:[email-masked]>> wrote:
>> On Jun 15, 2020, at 3:38 PM, Mike Jones <Michael.Jones=[email-masked] <mailto:Michael.Jones=[email-masked]>> wrote:
>>

---

From: Dick Hardt <[email-masked]>
Date: Tue, 16 Jun 2020 10:08:44 -0700

It seems strange that you now call addressing the concerns you raised
"silly".

While there is no confusion in written communication with GNAP, there
clearly will be in verbal communication.

Starting off with a suggested pronunciation looks to me to nip a
significant amount of the confusion in the bud.

We can deal with it now, or deal with it later, or it can be a source of
confusion and communication friction forever.

Why not just pick one pronunciation and move on?

On Tue, Jun 16, 2020 at 7:42 AM Justin Richer <[email-masked]> wrote:

> This is ok, but it has a couple downsides. The pronunciation of a hard
> “g” or not is going to potentially be confusing, as is the fact that it
> looks like it’s part of the GNU project because of that.
>
>
>

---

From: Justin Richer <[email-masked]>
Date: Tue, 16 Jun 2020 13:44:14 -0400

My concern on the pronunciation remains, and I don’t think putting a pronunciation in the charter, which hardly anyone will read again after a couple weeks from now, is going to address it. That’s why I think we should just get used to hearing it multiple ways, which you’ve agreed with. I personally think it’s just a problem we’ll have to live with, and that was one of the concerns I had with the name.

But really, does it matter? I don’t think it does.

 — Justin

> On Jun 16, 2020, at 1:08 PM, Dick Hardt <[email-masked]> wrote:
> 
> It seems strange that you now call addressing the concerns you raised "silly". 
> 
> While there is no confusion in written communication with GNAP, there clearly will be in verbal communication. 
> 
> Starting off with a suggested pronunciation looks to me to nip a significant amount of the confusion in the bud.
> 
> We can deal with it now, or deal with it later, or it can be a source of confusion and communication friction forever.
> 
> On Tue, Jun 16, 2020 at 7:42 AM Justin Richer <[email-masked] <mailto:[email-masked]>> wrote:
>> On Jun 15, 2020, at 6:14 PM, Dick Hardt <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Dick Hardt <[email-masked]>
Date: Tue, 16 Jun 2020 10:52:34 -0700

I think precision in communication matters, so yes, I think it matters. How
will we pronounce it in our in-person or virtual meetings?

While I agree that we need to anticipate people will mispronounce it, we
can inform them of the suggested pronunciation.

While putting the pronunciation in the charter does not solve the issue, it
is a starting point. I have added the suggested pronunciation to XAuth.

What is your concern with putting it in the charter? Why would you not want
to minimize miscommunication?

FWIW: I think that guh-nap is a better pronunciation choice as it makes it
clear it is not spelled "NAP"

On Tue, Jun 16, 2020 at 10:44 AM Justin Richer <[email-masked]> wrote:

> My concern on the pronunciation remains, and I don’t think putting a
> pronunciation in the charter, which hardly anyone will read again after a
> couple weeks from now, is going to address it. That’s why I think we should
> just get used to hearing it multiple ways, which you’ve agreed with. I
> personally think it’s just a problem we’ll have to live with, and that was
> one of the concerns I had with the name.
>
>>> I don’t care a lot one way or the other.  My main point is that no
>>> matter what guidance we give, many people are likely to pronounce the “G”.
>>> If we try to insist on it being silent, we should get used to the fact that
>>> we’ll probably be hearing both pronunciations.
>>>
>>>                                                        -- Mike
>>>

---

From: Justin Richer <[email-masked]>
Date: Tue, 16 Jun 2020 14:23:30 -0400

I’m really confused as to what the problem here is:

I’ve said that I prefer it with a hard “g” and will likely continue to read it like that in my head. I have also stated that I don’t think putting it in the charter will help people people “fix” the pronunciation. This is my opinion on the matter, which I have stated and now been made to defend a number of times.

None of this stops anyone from putting pronunciation guides into the charter or eventual specs if people think it’s worth it. I’m not the only voice here, and I’ve said it doesn’t really matter to me because I don’t think it will actually help. 

Therefore if it really is that important to you, and the chairs and ADs agree to the charter text change, then just do it. 

Can you help me understand what else you’re looking for from me?

 — Justin

> On Jun 16, 2020, at 1:52 PM, Dick Hardt <[email-masked]> wrote:
> 
> I think precision in communication matters, so yes, I think it matters. How will we pronounce it in our in-person or virtual meetings? 
> 
> While I agree that we need to anticipate people will mispronounce it, we can inform them of the suggested pronunciation.
> 
> While putting the pronunciation in the charter does not solve the issue, it is a starting point. I have added the suggested pronunciation to XAuth.
> 
> What is your concern with putting it in the charter? Why would you not want to minimize miscommunication?
> 
> FWIW: I think that guh-nap is a better pronunciation choice as it makes it clear it is not spelled "NAP"
> 
> 
> 
> On Tue, Jun 16, 2020 at 10:44 AM Justin Richer <[email-masked] <mailto:[email-masked]>> wrote:
>> On Jun 16, 2020, at 1:08 PM, Dick Hardt <[email-masked] <mailto:[email-masked]>> wrote:
>>

---

From: Dick Hardt <[email-masked]>
Date: Tue, 16 Jun 2020 11:30:37 -0700

You stated "I don’t believe we should add a proposed pronunciation to the
charter"

Which sounds like a concern with putting it in the charter. If you now
don't care about putting it in the charter, then we can end the discussion.

I missed your preference for a hard G. Nice to know we are aligned on our
opinions there!

On Tue, Jun 16, 2020 at 11:23 AM Justin Richer <[email-masked]> wrote:

> I’ve said that I prefer it with a hard “g” and will likely continue to
> read it like that in my head. I have also stated that I don’t think putting
> it in the charter will help people people “fix” the pronunciation. This is
> my opinion on the matter, which I have stated and now been made to defend a
> number of times.
>
> None of this stops anyone from putting pronunciation guides into the
> charter or eventual specs if people think it’s worth it. I’m not the only
> voice here, and I’ve said it doesn’t really matter to me because I don’t
> think it will actually help.
>
> Therefore if it really is that important to you, and the chairs and ADs
> agree to the charter text change, then just do it.
>
> I think precision in communication matters, so yes, I think it matters.
> How will we pronounce it in our in-person or virtual meetings?
>
> While putting the pronunciation in the charter does not solve the issue,
> it is a starting point. I have added the suggested pronunciation to XAuth.
>
>>>> As Leif mentioned few mails ago, “GNAP” appeared on the Smurfs comic
>>>> and was reprised in a cartoon episode as well.