Subject: [Txauth] using github.com/ietf-wg-gnap

From: Dick Hardt <[email-masked]>
Date: Thu, 23 Jul 2020 19:16:36 -0700

Justin brought up the decision on where we are going to capture our work,
and if we would do it on GitHub.

I'm supportive of that. Per

https://tools.ietf.org/html/draft-ietf-git-using-github

there are a number of choices of how to use GitHub, and which features to
use in the WG.

Config is covered by:

https://tools.ietf.org/html/draft-ietf-git-github-wg-configuration

Note these documents are still being worked on, but perhaps we can give
that WG feedback on their docs?

/Dick

ᐧ

---

From: Yaron Sheffer <[email-masked]>
Date: Fri, 24 Jul 2020 15:53:15 +0300

Hi Dick,

I just created the GitHub org with Leif as co-owner, but from a quick read of the I-D, I don’t think we have any use for it until we have adopted working group documents. Am I missing anything?

Thanks,

                Yaron

From: Dick Hardt <[email-masked]>
Date: Friday, July 24, 2020 at 05:17
To: Yaron Sheffer <[email-masked]>, Leif Johansson <[email-masked]>
Cc: Justin Richer <[email-masked]>, <[email-masked]>
Subject: using github.com/ietf-wg-gnap

Justin brought up the decision on where we are going to capture our work, and if we would do it on GitHub.

there are a number of choices of how to use GitHub, and which features to use in the WG.

Config is covered by:

Note these documents are still being worked on, but perhaps we can give that WG feedback on their docs?

/Dick

ᐧ

---

From: Justin Richer <[email-masked]>
Date: Fri, 24 Jul 2020 09:04:45 -0400

Yaron, thanks for doing that! This will be a very helpful set of tools for the WG. 

Yes, it will be very important when we have adopted WG documents, but ahead of that, there are other features that we can use. We can create a repository to get access to an issue tracker and wiki, before we have any documents. These might be very useful, especially coming out of next week’s meeting.

 — Justin

> On Jul 24, 2020, at 8:53 AM, Yaron Sheffer <[email-masked]> wrote:
> 
> Hi Dick,
>  
> https://tools.ietf.org/html/draft-ietf-git-using-github <https://tools.ietf.org/html/draft-ietf-git-using-github>
>  
> https://tools.ietf.org/html/draft-ietf-git-github-wg-configuration <https://tools.ietf.org/html/draft-ietf-git-github-wg-configuration>
>

---

From: Dick Hardt <[email-masked]>
Date: Fri, 24 Jul 2020 10:31:03 -0700

Thanks Yaron!

Assuming the WG wants to follow the ID, the IETF Secretariat and
responsible AD are the owners, and there is a team with Administrative
access that includes the WG Chairs.

The chairs also ask for WG consensus on using GitHub, and which features to
use.

Presuming there is WG consensus, I propose we create a use case repo where
we can document start documenting use cases. I agree with Justin's earlier
comments that there is no use case document that is a product of the WG as
an ID, but that it is used to get consensus on use cases that are in scope,
and aligns the WG on the requirements.

ᐧ

On Fri, Jul 24, 2020 at 6:04 AM Justin Richer <[email-masked]> wrote:

> Yes, it will be very important when we have adopted WG documents, but
> ahead of that, there are other features that we can use. We can create a
> repository to get access to an issue tracker and wiki, before we have any
> documents. These might be very useful, especially coming out of next week’s
> meeting.
>
>  — Justin
>
> I just created the GitHub org with Leif as co-owner, but from a quick read
> of the I-D, I don’t think we have any use for it until we have adopted
> working group documents. Am I missing anything?
>
> Thanks,
>                 Yaron
>
> *From: *Dick Hardt <[email-masked]>
> *Date: *Friday, July 24, 2020 at 05:17
> *To: *Yaron Sheffer <[email-masked]>, Leif Johansson <
> [email-masked]>
> *Cc: *Justin Richer <[email-masked]>, <[email-masked]>
> *Subject: *using github.com/ietf-wg-gnap
>