Subject: [GNAP] Design team formed

From: Yaron Sheffer <[email-masked]>
Date: Tue, 11 Aug 2020 13:43:01 +0300

Thank you all for attending the inaugural GNAP meeting at IETF-108. We had quite a few volunteers, and the chairs picked the following people for the design team:

* Kathleen Moriarty
* Justin Richer
* Dick Hardt
* Mike Jones
* Fabien Imbault

Kathleen has graciously agreed to convene the sessions and report on the team's outcome. Thank you all who volunteered!

We expect the design team to decide on a solution outline that combines the best of both proposals, and present this outline by Sep. 15. Anything is as usual subject to approval by the whole working group.

Thanks,
	Leif and Yaron

---

From: Mike Jones <[email-masked]>
Date: Tue, 11 Aug 2020 16:14:30 +0000

Thanks for your confidence in me and the rest of the design team.  I plan to read both individual specs cover-to-cover as part of my preparation for this work.

Dick and Justin, are there additional edits you plan to publish before I should do my review, or should I review the currently published drafts?

				Thanks,
				-- Mike

-----Original Message-----
From: TXAuth <[email-masked]> On Behalf Of Yaron Sheffer
Sent: Tuesday, August 11, 2020 3:43 AM
To: GNAP Mailing List <[email-masked]>
Subject: [GNAP] Design team formed

* Kathleen Moriarty
* Justin Richer
* Dick Hardt
* Mike Jones
* Fabien Imbault

Thanks,
	Leif and Yaron

-- 
TXAuth mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/txauth

---

From: Dick Hardt <[email-masked]>
Date: Tue, 11 Aug 2020 10:02:04 -0700

Leif / Yaron: thanks for organizing!

Kathleen, Mike, Fabien: thanks for stepping up.

Mike: I have a number of adjustments I had queued for a new version prior
to the WG meeting, but I did not think it was useful to push new concepts
or material given the path to have a design team.

On Tue, Aug 11, 2020 at 9:14 AM Mike Jones <Michael.Jones=
[email-masked]> wrote:

> Thanks for your confidence in me and the rest of the design team.  I plan
> to read both individual specs cover-to-cover as part of my preparation for
> this work.
>
> Dick and Justin, are there additional edits you plan to publish before I
> should do my review, or should I review the currently published drafts?
>
>                                 Thanks,
>                                 -- Mike
>
> Thank you all for attending the inaugural GNAP meeting at IETF-108. We had
> quite a few volunteers, and the chairs picked the following people for the
> design team:
>
> * Kathleen Moriarty
> * Justin Richer
> * Dick Hardt
> * Mike Jones
> * Fabien Imbault
>
> Kathleen has graciously agreed to convene the sessions and report on the
> team's outcome. Thank you all who volunteered!
>
> We expect the design team to decide on a solution outline that combines
> the best of both proposals, and present this outline by Sep. 15. Anything
> is as usual subject to approval by the whole working group.
>
> Thanks,
>         Leif and Yaron
>
>
>
> --
> TXAuth mailing list
> [email-masked]

---

From: Francis Pouatcha <[email-masked]>
Date: Tue, 11 Aug 2020 13:25:06 -0400

It is unfortunate I didn't make it. Would have liked to bring in my 22
years of experience in building authz applications.

Best regards.
/Francis

-- 
Francis Pouatcha
Co-Founder and Technical Lead
adorsys GmbH & Co. KG
https://adorsys-platform.de/solutions/

---

From: Dick Hardt <[email-masked]>
Date: Tue, 11 Aug 2020 12:54:10 -0700

Mike: I'm going to add in the updated terms I just posted to the list to
the XAuth ID later today.

On Tue, Aug 11, 2020 at 10:02 AM Dick Hardt <[email-masked]> wrote:

>> Thank you all for attending the inaugural GNAP meeting at IETF-108. We
>> had quite a few volunteers, and the chairs picked the following people for
>> the design team:
>>
>> * Kathleen Moriarty
>> * Justin Richer
>> * Dick Hardt
>> * Mike Jones
>> * Fabien Imbault
>>

---

From: Justin Richer <[email-masked]>
Date: Wed, 12 Aug 2020 11:24:11 -0400

Francis,

The design team is just a temporary construct to get things started here, and it will dissolve back into the WG when the task is over. I, for one, am really thankful to have you bring your experience to this working group. I’ve appreciated your contributions greatly so far, and I look forward to continuing to work with you.

We still have a long way to go and a lot of work to do. The output of the design team is just the start of the working group, and there are many more things to figure out.

 — Justin

> On Aug 11, 2020, at 1:25 PM, Francis Pouatcha <fpo=[email-masked]> wrote:
> 
> It is unfortunate I didn't make it. Would have liked to bring in my 22 years of experience in building authz applications.
> 
> Best regards.
> /Francis
> 
> On Tue, Aug 11, 2020 at 6:43 AM Yaron Sheffer <[email-masked] <mailto:[email-masked]>> wrote:
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/txauth <https://www.ietf.org/mailman/listinfo/txauth>
> 
> 
> -- 
> Francis Pouatcha
> https://adorsys-platform.de/solutions/ <https://adorsys-platform.de/solutions/>-- 
> TXAuth mailing list
> [email-masked]

---

From: Francis Pouatcha <[email-masked]>
Date: Wed, 12 Aug 2020 11:31:46 -0400

Justin,

Thanks for your response. I hope the design team will keep addressing
essential topics on the list so we can contribute.

Best regards.
/Francis

On Wed, Aug 12, 2020 at 11:24 AM Justin Richer <[email-masked]> wrote:

> Francis,
>
> The design team is just a temporary construct to get things started here,
> and it will dissolve back into the WG when the task is over. I, for one, am
> really thankful to have you bring your experience to this working group.
> I’ve appreciated your contributions greatly so far, and I look forward to
> continuing to work with you.
>
> We still have a long way to go and a lot of work to do. The output of the
> design team is just the start of the working group, and there are many more
> things to figure out.
>
>  — Justin
>

---

From: Justin Richer <[email-masked]>
Date: Wed, 12 Aug 2020 12:05:12 -0400

The goal of the design team is to take a step aside from the public mailing list and, hopefully, get more done in a short time period. Discussion on a public mailing list is powerful, but slow and prone to derailing and miscommunication. The design team will discuss things more directly to avoid those problems in the short term, much the way that a small subcommittee can bring targeted expertise to a group’s problem by using higher bandwidth communication channels and regular interaction. The results will be brought back to the list to be discussed and, hopefully, adopted as a starting point. That starting point document will then be debated, edited, and refined by the working group. Nothing in the starting document is sacred, but at least it will be something concrete to build on.

While the design team is working, discussion will continue on the list, and all the design team members are still participating on the list. This ongoing conversation is still very valuable for the group as a whole, including the design team, even if it’s not a direct feed of the design team’s discussions. 

There are a LOT of amazing people in this group — I see that as a testament to how important this problem space is and how much of an appetite there is for solving things in that space. This process is going to take a while, maybe years of debate and engineering before we reach a final standard. There is going to be a lot of opportunity to contribute, and I look forward to your continuing contributions.

The IETF has this writeup on the nature and utility of design teams, which you might find useful: https://www.ietf.org/about/groups/iesg/statements/design-teams/ <https://www.ietf.org/about/groups/iesg/statements/design-teams/>

 — Justin

> On Aug 12, 2020, at 11:31 AM, Francis Pouatcha <[email-masked]> wrote:
> 
> Justin,
> 
> Thanks for your response. I hope the design team will keep addressing essential topics on the list so we can contribute.
> 
> Best regards.
> /Francis
> 
> On Wed, Aug 12, 2020 at 11:24 AM Justin Richer <[email-masked] <mailto:[email-masked]>> wrote:
> Francis,
> 
>> On Aug 11, 2020, at 1:25 PM, Francis Pouatcha <fpo=[email-masked] <mailto:fpo=[email-masked]>> wrote:
>> 
> https://adorsys-platform.de/solutions/ <https://adorsys-platform.de/solutions/>

---

From: Yaron Sheffer <[email-masked]>
Date: Wed, 12 Aug 2020 19:32:34 +0300

A big +1 to Justin’s two responses on the design team as a temporary construct, with the challenge of bringing a document back to the full working group, a document that will serve as a *starting point* for our work.

Thanks,

                Yaron

From: Justin Richer <[email-masked]>
Date: Wednesday, August 12, 2020 at 19:05
To: Francis Pouatcha <[email-masked]>
Cc: Yaron Sheffer <[email-masked]>, GNAP Mailing List <[email-masked]>
Subject: Re: [GNAP] Design team formed

The IETF has this writeup on the nature and utility of design teams, which you might find useful: https://www.ietf.org/about/groups/iesg/statements/design-teams/

 — Justin

Justin,

Best regards.

/Francis

Francis,

 — Justin

Best regards.

/Francis

* Kathleen Moriarty
* Justin Richer
* Dick Hardt
* Mike Jones
* Fabien Imbault

Thanks,
        Leif and Yaron

 

-- 

Francis Pouatcha

adorsys GmbH & Co. KG

 

-- 

Francis Pouatcha

adorsys GmbH & Co. KG

---

From: Francis Pouatcha <[email-masked]>
Date: Wed, 12 Aug 2020 12:34:29 -0400

Hello Justin, Yaron,

Thanks for this reference. Even though the design team document is just an
input for the working group, the drafted structure generally defines the
fundament.

Is there any reason to limit the design team to 5 participants? I still do
believe my contribution to the basic structure will be too substantial to
be fitted afterward in a published initial draft.

I hereby apply again to be part of that initial team, and I do believe
there is a lot for me to bring in there now.

Best regards.
/Francis

On Wed, Aug 12, 2020 at 12:05 PM Justin Richer <[email-masked]> wrote:

> The goal of the design team is to take a step aside from the public
> mailing list and, hopefully, get more done in a short time period.
> Discussion on a public mailing list is powerful, but slow and prone to
> derailing and miscommunication. The design team will discuss things more
> directly to avoid those problems in the short term, much the way that a
> small subcommittee can bring targeted expertise to a group’s problem by
> using higher bandwidth communication channels and regular interaction. The
> results will be brought back to the list to be discussed and, hopefully,
> adopted as a starting point. That starting point document will then be
> debated, edited, and refined by the working group. Nothing in the starting
> document is sacred, but at least it will be something concrete to build on.
>
> While the design team is working, discussion will continue on the list,
> and all the design team members are still participating on the list. This
> ongoing conversation is still very valuable for the group as a whole,
> including the design team, even if it’s not a direct feed of the design
> team’s discussions.
>
> There are a LOT of amazing people in this group — I see that as a
> testament to how important this problem space is and how much of an
> appetite there is for solving things in that space. This process is going
> to take a while, maybe years of debate and engineering before we reach a
> final standard. There is going to be a lot of opportunity to contribute,
> and I look forward to your continuing contributions.
>
> The IETF has this writeup on the nature and utility of design teams, which
> you might find useful:
> https://www.ietf.org/about/groups/iesg/statements/design-teams/
>
>
>  — Justin
>