Subject: [GNAP] Implementation of RS hiding

From: Fabien Imbault <[email-masked]>
Date: Fri, 14 Aug 2020 18:33:13 +0200

Hello,

Following discussions we had on the mailing list, here's a mvp which
includes RS hiding.
https://github.com/acertio/mvp_gnap_privacy

=> it works fine.

In the same release we also improved the IS flow (including Justin's
feedback), and started to implement a more realistic use case.
The documentation has been updated accordingly.

Fabien

---

From: Justin Richer <[email-masked]>
Date: Fri, 14 Aug 2020 13:40:29 -0400

Fabien,

Thank you for writing this up! This is really interesting to read through, and it’s especially interesting to see that it doesn’t seem to be that much of a lift on top of the base protocol. 

Now that you’ve built it, do you think there’s much of an impediment for a developer to send the additional header alongside the token? I think we need to explore some other ways this could run, like using a structured header[1] for token presentation in this case.

 — Justin

[1] https://tools.ietf.org/html/draft-ietf-httpbis-header-structure-17 <https://tools.ietf.org/html/draft-ietf-httpbis-header-structure-17>

> On Aug 14, 2020, at 12:33 PM, Fabien Imbault <[email-masked]> wrote:
> 
> Hello, 
> 
> Following discussions we had on the mailing list, here's a mvp which includes RS hiding. 
> https://github.com/acertio/mvp_gnap_privacy <https://github.com/acertio/mvp_gnap_privacy>
> 
> => it works fine.
> 
> In the same release we also improved the IS flow (including Justin's feedback), and started to implement a more realistic use case. 
> -- 
> TXAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth

---

From: Fabien Imbault <[email-masked]>
Date: Fri, 14 Aug 2020 21:43:02 +0200

Hi Justin,

At least for now I think it does the job very well.

Haven't used structured headers so far but did read some interesting
articles from fastly.
https://www.fastly.com/blog/improve-http-structured-headers

Cheers
Fabien

Le ven. 14 août 2020 à 19:40, Justin Richer <[email-masked]> a écrit :

> Fabien,
>
> Thank you for writing this up! This is really interesting to read through,
> and it’s especially interesting to see that it doesn’t seem to be that much
> of a lift on top of the base protocol.
>
> Now that you’ve built it, do you think there’s much of an impediment for a
> developer to send the additional header alongside the token? I think we
> need to explore some other ways this could run, like using a structured
> header[1] for token presentation in this case.
>
>  — Justin
>
> [1] https://tools.ietf.org/html/draft-ietf-httpbis-header-structure-17
>