Subject: [GNAP] Extraction of Editor's Notes

From: Justin Richer <[email-masked]>
Date: Fri, 13 Nov 2020 11:54:59 -0500

The editors have gone through the draft document and extracted all of the existing “Editor’s Note” items from the text and turned them into discrete GitHub issues for discussion. Several closely-related notes were collapsed into single issues. Apart from fixing a couple typos or adding context from surrounding text, the text of the editor’s note was pulled verbatim from the document into GitHub. These are all in the project repository’s issue tracker:

https://github.com/ietf-wg-gnap/gnap-core-protocol/issues <https://github.com/ietf-wg-gnap/gnap-core-protocol/issues>

A pull request has been submitted that removes the editor’s note and replaces it with a link to the corresponding GitHub issue:

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/119 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/119>

Each issue’s text contains the current section number and title that the text was extracted from in order to facilitate people finding the appropriate context in which the notes were originally written. However, do note that as Yaron posted to the list earlier today, in general we don’t want to have to refer to things in GitHub issues by section number, since the section numbers can and will change over time as the document evolves. Therefore future issues should avoid including section numbers, and must not rely on section numbers as the only content reference pointer.

This extraction was done to facilitate ongoing conversation on each of the items raised by the notes. Notational text in the document itself is necessarily static, and it can’t incorporate multiple perspectives and opinions. Moving these items to GitHub issues will allow others to comment on the issue directly to provide their own opinions, input, and contexts; and ultimately for the working group to arrive to consensus and drive document changes from these discussions.

The editors will eventually remove the issue references from the spec as things are closed, and we won’t necessarily be adding links to new issues into the draft spec going forward unless there is a compelling reason for it like an ongoing discussion for options or a major design change.

 — Justin, Fabien, and Aaron

---

From: Dave Tonge <[email-masked]>
Date: Mon, 16 Nov 2020 11:06:27 +0100

HI Editors

Just a quick question - there are a lot of issues. Would you like WG
members to comment on each issue?
Also what is the process on closing an issue, it would be good to get some
issues closed, or else I fear that we will be stuck with 100+ issues for a
considerable amount of time.

Dave

On Fri, 13 Nov 2020 at 17:55, Justin Richer <[email-masked]> wrote:

> The editors have gone through the draft document and extracted all of the
> existing “Editor’s Note” items from the text and turned them into discrete
> GitHub issues for discussion. Several closely-related notes were collapsed
> into single issues. Apart from fixing a couple typos or adding context from
> surrounding text, the text of the editor’s note was pulled verbatim from
> the document into GitHub. These are all in the project repository’s issue
> tracker:
>
> https://github.com/ietf-wg-gnap/gnap-core-protocol/issues
>
> A pull request has been submitted that removes the editor’s note and
> replaces it with a link to the corresponding GitHub issue:
>
> https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/119
>
> Each issue’s text contains the current section number and title that the
> text was extracted from in order to facilitate people finding the
> appropriate context in which the notes were originally written. However, do
> note that as Yaron posted to the list earlier today, in general we don’t
> want to have to refer to things in GitHub issues by section number, since
> the section numbers can and will change over time as the document evolves.
> Therefore future issues should avoid including section numbers, and must
> not rely on section numbers as the only content reference pointer.
>
> This extraction was done to facilitate ongoing conversation on each of the
> items raised by the notes. Notational text in the document itself is
> necessarily static, and it can’t incorporate multiple perspectives and
> opinions. Moving these items to GitHub issues will allow others to comment
> on the issue directly to provide their own opinions, input, and contexts;
> and ultimately for the working group to arrive to consensus and drive
> document changes from these discussions.
>
> The editors will eventually remove the issue references from the spec as
> things are closed, and we won’t necessarily be adding links to new issues
> into the draft spec going forward unless there is a compelling reason for
> it like an ongoing discussion for options or a major design change.
>
> --
> TXAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth
>

-- 
Dave Tonge
CTO
<http://www.google.com/url?q=http%3A%2F%2Fmoneyhubenterprise.com%2F&sa=D&sntz=1&usg=AFQjCNGUnR5opJv5S1uZOVg8aISwPKAv3A>
Moneyhub Financial Technology, 5th Floor, 10 Temple Back, Bristol, BS1 6FL
t: +44 (0)117 280 5120

Moneyhub Enterprise is a trading style of Moneyhub Financial Technology
Limited which is authorised and regulated by the Financial Conduct
Authority ("FCA"). Moneyhub Financial Technology is entered on the
Financial Services Register (FRN 809360) at *https://register.fca.org.uk/
<https://register.fca.org.uk/>*. Moneyhub Financial Technology is
registered in England & Wales, company registration number  06909772 .
Moneyhub Financial Technology Limited 2019 ©

DISCLAIMER: This email (including any attachments) is subject to copyright,
and the information in it is confidential. Use of this email or of any
information in it other than by the addressee is unauthorised and unlawful.
Whilst reasonable efforts are made to ensure that any attachments are
virus-free, it is the recipient's sole responsibility to scan all
attachments for viruses. All calls and emails to and from this company may
be monitored and recorded for legitimate purposes relating to this
company's business. Any opinions expressed in this email (or in any
attachments) are those of the author and do not necessarily represent the
opinions of Moneyhub Financial Technology Limited or of any other group
company.

-- 

Moneyhub Enterprise is a trading style of Moneyhub Financial Technology 
Limited which is authorised and regulated by the Financial Conduct 
Authority ("FCA"). Moneyhub Financial Technology is entered on the 
Financial Services Register (FRN 809360) at https://register.fca.org.uk/ 
<https://register.fca.org.uk/>. Moneyhub Financial Technology is registered 
in England & Wales, company registration number 06909772. Moneyhub 
Financial Technology Limited 2020 © Moneyhub Enterprise, Regus Building, 
Temple Quay, 1 Friary, Bristol, BS1 6EA. 

DISCLAIMER: This email 
(including any attachments) is subject to copyright, and the information in 
it is confidential. Use of this email or of any information in it other 
than by the addressee is unauthorised and unlawful. Whilst reasonable 
efforts are made to ensure that any attachments are virus-free, it is the 
recipient's sole responsibility to scan all attachments for viruses. All 
calls and emails to and from this company may be monitored and recorded for 
legitimate purposes relating to this company's business. Any opinions 
expressed in this email (or in any attachments) are those of the author and 
do not necessarily represent the opinions of Moneyhub Financial Technology 
Limited or of any other group company.

---

From: Yaron Sheffer <[email-masked]>
Date: Mon, 16 Nov 2020 12:12:58 +0200

Process discussion coming up tomorrow, https://datatracker.ietf.org/meeting/109/materials/slides-109-gnap-process-proposal-00

Please note though that we will be strict on time – it’s just too easy to spend the meeting on process and never get to the protocol discussion.

Spoiler: yes, please comment on the issues (you don’t have to comment on all 100…).

Thanks,

                Yaron

From: TXAuth <[email-masked]> on behalf of Dave Tonge <[email-masked]>
Date: Monday, November 16, 2020 at 12:06
To: Justin Richer <[email-masked]>
Cc: GNAP Mailing List <[email-masked]>
Subject: Re: [GNAP] Extraction of Editor's Notes

HI Editors

Just a quick question - there are a lot of issues. Would you like WG members to comment on each issue? 

Also what is the process on closing an issue, it would be good to get some issues closed, or else I fear that we will be stuck with 100+ issues for a considerable amount of time.

Dave

 

-- 

Dave Tonge

CTO

t: +44 (0)117 280 5120

Moneyhub Enterprise is a trading style of Moneyhub Financial Technology Limited which is authorised and regulated by the Financial Conduct Authority ("FCA"). Moneyhub Financial Technology is entered on the Financial Services Register (FRN 809360) at https://register.fca.org.uk/. Moneyhub Financial Technology is registered in England & Wales, company registration number  06909772 .

DISCLAIMER: This email (including any attachments) is subject to copyright, and the information in it is confidential. Use of this email or of any information in it other than by the addressee is unauthorised and unlawful. Whilst reasonable efforts are made to ensure that any attachments are virus-free, it is the recipient's sole responsibility to scan all attachments for viruses. All calls and emails to and from this company may be monitored and recorded for legitimate purposes relating to this company's business. Any opinions expressed in this email (or in any attachments) are those of the author and do not necessarily represent the opinions of Moneyhub Financial Technology Limited or of any other group company.

Moneyhub Enterprise is a trading style of Moneyhub Financial Technology Limited which is authorised and regulated by the Financial Conduct Authority ("FCA"). Moneyhub Financial Technology is entered on the Financial Services Register (FRN 809360) at https://register.fca.org.uk/. Moneyhub Financial Technology is registered in England & Wales, company registration number 06909772. Moneyhub Financial Technology Limited 2020 © Moneyhub Enterprise, Regus Building, Temple Quay, 1 Friary, Bristol, BS1 6EA. 

DISCLAIMER: This email (including any attachments) is subject to copyright, and the information in it is confidential. Use of this email or of any information in it other than by the addressee is unauthorised and unlawful. Whilst reasonable efforts are made to ensure that any attachments are virus-free, it is the recipient's sole responsibility to scan all attachments for viruses. All calls and emails to and from this company may be monitored and recorded for legitimate purposes relating to this company's business. Any opinions expressed in this email (or in any attachments) are those of the author and do not necessarily represent the opinions of Moneyhub Financial Technology Limited or of any other group company.

-- TXAuth mailing list [email-masked] https://www.ietf.org/mailman/listinfo/txauth

---

From: Fabien Imbault <[email-masked]>
Date: Mon, 16 Nov 2020 11:19:00 +0100

Hi Dave,

That's a very good point.
I think it really depends on the issue. Some are more informational (ex:
issue #46) and may be closed quickly. The majority requires some work, a
few are really around design choices.
We probably need to make a bit of triage, in terms of priority and impact.
But the goal is certainly to close as much as we can, and avoid the
unmanageable backlog.

The chairs and editors have initial thoughts of a process, to be discussed.

Cheers,
Fabien

On Mon, Nov 16, 2020 at 11:06 AM Dave Tonge <[email-masked]> wrote:

>> This extraction was done to facilitate ongoing conversation on each of
>> the items raised by the notes. Notational text in the document itself is
> DISCLAIMER: This email (including any attachments) is subject to
> copyright, and the information in it is confidential. Use of this email or
> of any information in it other than by the addressee is unauthorised and
> unlawful. Whilst reasonable efforts are made to ensure that any attachments
> are virus-free, it is the recipient's sole responsibility to scan all
> Financial Services Register (FRN 809360) at https://register.fca.org.uk/.
> Moneyhub Financial Technology is registered in England & Wales, company
> registration number 06909772. Moneyhub Financial Technology Limited 2020 ©
> Moneyhub Enterprise, Regus Building, Temple Quay, 1 Friary, Bristol, BS1
> 6EA.
>
> DISCLAIMER: This email (including any attachments) is subject to
> copyright, and the information in it is confidential. Use of this email or
> of any information in it other than by the addressee is unauthorised and
> unlawful. Whilst reasonable efforts are made to ensure that any attachments
> are virus-free, it is the recipient's sole responsibility to scan all