Subject: [GNAP] Trimmed Features

From: Justin Richer <[email-masked]>
Date: Fri, 25 Jun 2021 16:30:09 -0400

In the past, we’ve discussed the need to trim down some of the advanced features included in GNAP core. After a discussion this week, the editors have targeted two features for removal and have pushed a PR to take these out of the spec.

Namely, these are:

 - the “capabilities” array, which was intended to be a holding place for extension identifiers and additional functionality. However, no extensions have shown up that needed this field, and so the editors are recommending that we remove it.
 - the “existing_grant” field, which was a way to allow a client to reference an existing grant request and create a new request based on it. This was born out of a few early use cases, but now that there’s no longer an explicit identifier for the grant itself, there is less to hold on to here. Additionally, the continuation “update” function might be able to fit most of the identified use cases. 

The PR that removes these is here:

https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/270 <https://github.com/ietf-wg-gnap/gnap-core-protocol/pull/270>

If you have a compelling reason to keep either of these in the core document, please start that discussion now and help us understand why they should stay. Keep in mind that either or both of these could be added back in by a separate extension document, given GNAP core’s highly extensible nature.

— Justin

---

From: Justin Richer <[email-masked]>
Date: Mon, 28 Jun 2021 16:00:38 -0400

I just pushed another commit to this PR that removes the separate “instance_id” field from the client request. Previously it was possible to send this both as a field within a restricted object as well as a separate string value on its own. Now, only the latter remains as an option, and this change would close https://github.com/ietf-wg-gnap/gnap-core-protocol/issues/45 <https://github.com/ietf-wg-gnap/gnap-core-protocol/issues/45> in the process.

 — Justin

> On Jun 25, 2021, at 4:30 PM, Justin Richer <[email-masked]> wrote:
> 
> -- 
> TXAuth mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/txauth