Subject: [urn] Some more thoughts on draft-ietf-urnbis-rfc3188bis-nbn-urn-02

From: Bengt Neiss <[email-masked]>
Date: Wed, 1 Feb 2012 14:18:33 +0000

Hello all..

Some more thoughts on the text..

1.       Page 6, first paragraph, last sentence says the following - "All manifestations of a resource SHOULD be interlinked, for example via providing persistent links in the descriptive metadata". I think we need to define or explain what we mean with the term "persistent link" in this document. It's a term that, I believe, have a slightly different meaning in different user communities.

2.       Page 13, a paragraph near the end states that "All two-letter codes are reserved by the ISO 3166 Maintenance Agency for either existing and possible future ISO country codes (or for private use)". I think this paragraph is somewhat redundant and could be removed due to the fact that in the formal declaration for the NSS we state that the "iso_cc" part is "country code as assigned by ISO 3166" and as I understand it two-letter codes (that aren't ISO 3166 codes) are allowed as a "subspc", like urn:nbn:se:kb:abc-123.

3.       On page 7, second paragraph from top has a sentence that says "In these cases , the resolution process SHOULD link the URN:NBN to a URI belonging to an object such as a text file containing a chapter of a book". I think the word "link" should be "resolve" in this sentence. Is the term "URI" the correct one to use or should it be changed to "URL" possibly.

4.       I think there is a need to revise the use of the acronym NBN in the text. Sometimes it refers to National Bibliography Number in a literal sense and sometimes, it seems to me, being used in the meaning URN:NBN. It could be a source for confusion for readers. It might be that my English is not good enough though...so...

5.       I think there is an error in chapter 1.2, Background properties of URNs, in "draft-ietf-urnbis-rfc2141bis-urn-01" where it states that the properties found in RFC 1738 etc. Shouldn't it be RFC 1737.

6.       One more thing - should text-proposals be sent to the list or directly to the editor(s)?

Regards,

//Bengt

---------------------------------------------------------
Bengt Neiss
Kungl. Biblioteket / National Library of Sweden
Phone: +46 (0)10 709 35 41

---

From: Juha Hakala <[email-masked]>
Date: Wed, 01 Feb 2012 16:53:40 +0200

Hello Bengt,

I will take the comments 1-5 into account when preparing the next 
version of rfc3188bis. An immediate response to comment 6 is below.

> directly to the editor(s)?

It is better to send them to the list, because that fosters discussion 
and makes the life of the editor easier - a comment does not need to be 
replicated, when people see that it has been made already.

All the best,

Juha
> ------------------------------------------------------------------------
> 
> _______________________________________________
> urn mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/urn

-- 

  Juha Hakala
  Senior advisor, standardisation and IT

  The National Library of Finland
  P.O.Box 15 (Unioninkatu 36, room 503), FIN-00014 Helsinki University
  Email [email-masked], tel +358 50 382 7678