Subject: Re: #1029: USEFOR 3.2.2 References: Should comments be a MUST NOT? (fwd)

From: Frank Ellermann <[email-masked]>
Date: Fri, 01 Jul 2005 06:18:33 +0200

Forrest J. Cavalier III wrote:

>> === NEW ===
>>    o  Message identifiers MUST be separated with CFWS, typically a
>>       space or FWS.
>>
>>    references      =  "References:" SP msg-id-list CRLF
>>    msg-id-list     =  [CFWS] *( msg-id CFWS ) msg-id [CFWS] CRLF
>> === END ===

>> Your point 5 going to USEPRO, is that okay ?

> USEFOR can CFWS in ABNF without limit, but in USEPRO have
> this idea....
>      Comments in CFWS between message identifiers can cause
>      interoperability problems, so comments SHOULD NOT be
>      generated, but MUST be accepted, and MAY be removed.

> I know, "MUST accept+MAY remove" is probably unheard of,

No, it's almost like RFC 2821 about source-routes "MUST accept,
SHOULD ignore, MAY respect".

> this is probably a weird idea, but please find a real reason
> to dismiss it

I've no reason to dismiss it, we already discussed "MAY remove"
in conjunction with trimming.  Charles started a quest for the
"semantical content" (= no comments, but then we stumbled over
the problem with backslashes within <no-fold-2822-crap>).  And
somebody else also wanted to strip the comments in an attempt
to stay within our obscure unfolded length limit 998.

Strip comments and reinject, that could be evil, I've no idea
how stuff like a signed header works.  But you didn't propose
to strip and reinject, so that point is probably moot.  Bye

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 01 Jul 2005 06:36:48 +0200

>>> o Message identifiers MUST be separated with CFWS,
>>>    typically a space or FWS.
>>>

    msg-id-list =  [CFWS] *( msg-id CFWS ) msg-id [CFWS]

---

From: "Charles Lindsey" <[email-masked]>
Date: Fri, 1 Jul 2005 19:12:21 GMT

In <[email-masked]> "Forrest J. Cavalier III" <[email-masked]> writes:

>5. Agents MAY remove comments from References.

Aaarrrrrrrrggggggggghhhhhhhhh! No!

It is a fundamental principle of everything we have done that agents do
NOT change articles in transit. Usenet is a distributed database, and we
want a given article to the the same (modulo variant headers) wherever it
it stored.

There is a limited provision for injecting agents to "mend" things that
are incomplete (and we spent a lot of time a few years back reaching a
consensus on exactly how "limited" that was to be).

I don't really think this one is a good candidate even for that, though.

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131 Fax: +44 161 436 6133   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 02 Jul 2005 07:03:16 +0200

> Aaarrrrrrrrggggggggghhhhhhhhh! No!

For followup-agents it's perfectly okay.  For other UAs or even
gateways it's tricky.  Looking again at it, actually it should
be "followup-agents MAY replace CFWS by FWS", we don't want an
<a@b>(c)<d@e> to <a@b><d@e> effect, but <a@b> <d@e> is okay in
a followup.  In fact it's better.
                                    Bye, Frank

---

From: "Ruud H.G. van Tol" <[email-masked]>
Date: Sat, 2 Jul 2005 08:50:32 +0200

Charles Lindsey:
> Forrest J. Cavalier III:

> [...]
> There is a limited provision for injecting agents to "mend" things
> that are incomplete [...]

Incomplete in the sense of 'unfinished'. :)

> I don't really think this one is a good candidate even for that,

Of course such header fields MUST NOT change in 'public' transit. 
A followup-agent "MAY replace CFWS by FWS" (as Frank says).

-- 
Grtz, Ruud

---

From: "Charles Lindsey" <[email-masked]>
Date: Mon, 4 Jul 2005 13:56:22 GMT

>a followup.  In fact it's better.

Indeed, for followup agents, it is fine, but most certainly not for others.

However, the currently proposed USEPRO wording allows all you could
possibly want as regards removing/inserting comments by followup-agents.