Subject: On the issue of publication interval between USEFOR and USEPRO

From: Harald Alvestrand <[email-masked]>
Date: Thu, 14 Dec 2006 17:16:00 +0100

Folks,

after reviewing the archives, it's become clear to me that this WG has
been operating under the assumption that USEFOR would not be published
as an RFC before USEPRO rolled out of the WG - or the WG shut down
without producing USEPRO.

After reviewing the linkages between the two, I've concluded that
formally and practically, we DO have the option of letting USEFOR be
published at this time (once the IESG is through with it).

In order to have USEFOR be held, we have to enter an explicit request
with the IESG to hold it, and we haven't done that yet. We could simply
not do it.

(This would, of course, mean that if we were to find something in USEPRO
that required a change in USEFOR, we would have to issue a new version
of USEFOR.)

I realize that this is a new idea. I'm not sure it's a good one.But
I want to make sure it's been aired.

Thoughts?

                  Harald

---

From: "Forrest J. Cavalier III" <[email-masked]>
Date: Thu, 14 Dec 2006 12:20:59 -0500

> without producing USEPRO.

Was this an assumption, or just the consensus of a choice?

> Thoughts?

Hold USEFOR.

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 14 Dec 2006 23:00:39 +0100

> Thoughts?

I'd prefer to get a USEFOR RFC a.s.a.p.  That needs an approval.
That needs the two [Discuss] cleared or swapped into [Abstain].

To clear the [Discuss] we'd probably need a normative reference,
putting USEFOR on hold.  If we don't add a normative reference
it is already blocked by the [Discuss].

So for my goal doing nothing has probably the same effect as 
asking for a hold.  Doing nothing could also be faster, if Sam
and Russ change their [Discuss] into [Abstain].  

Besides with this WG it's as shaky as with SPF, folks won't stop
to promote wild and wonderful changes until the last microsecond
of AUTH48.

I'll only believe it if it's published with a proper RFC number.
The RFC is also quite important for the sleeping 2822upd draft:

Telling the author "BTW, you got the Message-ID wrong as noted
in I-D.ietf-usefor-usefor-12, and the <unstructured> [FWS] is 
also dubious, noted in an obscure pending errata mbox, and the
same I-D" isn't very convincing.  With a proper RFC number it's
better.  USEFOR should have an RFC number before the discussions
about 2822bis start.

Frank

---

From: "Charles Lindsey" <[email-masked]>
Date: Fri, 15 Dec 2006 20:02:59 GMT

>Thoughts?

I have always said it is better to hold it back, and I think Forrest agrees.

But whatever, please don't start tinkering with trying to make USEPRO a
Normative Reference.

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131 Fax: +44 161 436 6133   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5

---

From: Lisa Dusseault <[email-masked]>
Date: Mon, 18 Dec 2006 12:12:26 -0800

> But whatever, please don't start tinkering with trying to make  

Why not?

It's pretty easy to argue that you need parts of USEPRO in order to  
be able to generate certain headers defined in USEFOR, without which  
(if I understand correctly) you don't have a valid article.  The  
Security Considerations issue is an independent reason to have a  
normative reference.

thx,
Lisa

---

From: "Charles Lindsey" <[email-masked]>
Date: Tue, 19 Dec 2006 15:28:45 GMT

In <[email-masked]> Lisa Dusseault <[email-masked]> writes:

>--Apple-Mail-5--813014145
>Content-Transfer-Encoding: 7bit
>Content-Type: text/plain;
>	charset=US-ASCII;
>	delsp=yes;
>	format=flowed

>Why not?

Because I don't think any of the items mentioned so far actually require a
normative reference.

7.proper.com ([192.245.12.227])
	by ietf-mx.ietf.org with esmtp (Exim 4.43)
	id 1GwiYY-00028C-K7
	for [email-masked]; Tue, 19 Dec 2006 12:15:16 -0500
To: [email-masked]
Xref: clerew local.usefor:23926
Path: clerew!chl
From: "Charles Lindsey" <[email-masked]>
Subject: Re: On the issue of publication interval between USEFOR and USEPRO
Date: Tue, 19 Dec 2006 15:28:45 GMT
Lines: 32
Sender: [email-masked]

In <[email-masked]> Lisa Dusseault <[email-masked]> writes:

>--Apple-Mail-5--813014145
>Content-Transfer-Encoding: 7bit
>Content-Type: text/plain;
>	charset=US-ASCII;
>	delsp=yes;
>	format=flowed

>Why not?

Because I don't think any of the items mentioned so far actually require a
normative reference.