Subject: Re: agenda items for SF ? ISPs document

From: Alain Durand <[email-masked]>
Date: Mon, 03 Feb 2003 12:39:55 -0800

MicklesCK wrote:

> We do not have an author for the datacenter
>section.  I propose we drop the additional datacenter 
>section since, as I pointed out at the interim meeting, there
>would be overlap with the Enterprise draft.
>
One point I would like to raise about IPv6 in the datacenter
is load balancers. They basically are NAT boxes dispatching the traffic
to a number of servers. Are we going to need NATv6 afterall?

Anyway, I think this concern is specific to the big datacenter
and should be addressed in the ISP scenario.

    - Alain.

---

From: Roy Brabson <[email-masked]>
Date: Mon, 3 Feb 2003 16:25:40 -0500

> to a number of servers. Are we going to need NATv6 afterall?

I guess that depends on the load balancing device.  I'm familiar with many 
which do not use NAT for dispatching traffic.  Instead, the load 
balancer(s) advertise a server address to which client traffic is 
directed.  Each server which is part of the load balancing group also 
defines the same address, but in a manner such that the address is not 
advertised if the server is running dynamic routing protocol.  Depending 
on the proximity of the load balancer to the servers, the load balancer 
may rewrite the destination MAC address to direct the packet to the chosen 
server or may use some form of tunneling (such as GRE) to send the packet 
to the chosen server.  Neither approach requires the use of NAT.

> and should be addressed in the ISP scenario.

I don't agree, at least not for the enterprise customers I work with. Many 
use and deploy load balancers within the datacenter and do not rely on the 
ISP to provide this type of service.  I would see this as belonging within 
the Enterprise scenario document instead of the ISP scenario document.

Roy

---

From: "Cleve Mickles" <[email-masked]>
Date: Mon, 3 Feb 2003 17:08:13 -0500

I've asked existing L4 vendors about this over the past year
and even though this is widely done in the IPv4 world, the vendors
don't have any plans to add this IPv6 functionality until market
forces dictate it.

From what I see today, the only alternative is to use DNS
to load balance.  We know using DNS to load balance won't
give us the best performance.  We also will probably run into
the same UDP packet size limits with IPv4 DNS rotors.  It
does however gives us something to work with until we have
a critical mass of IPv6 capable servers which we can then go
to the vendors and ask them to give us the functionality.

NATv6 is a possible solution and the WG may decide that is the best
recommendation in the long run.  The vendors will probably end up doing
their own proprietary solutions as I have not seem many interoperable L4
load balancers to date.  I would assume the work on NATv6 would be done
in the IPv6 WG.

Whether we describe this in the ISP document or Enterprise document is up
to the WG.  At the interim meeting the WG wanted a datacenter description
in both, at last IETF the status of whether to include datacenters in the
ISP scenarios was inconclusive.  In any event, no authors have come forward
to work on the section so it will not be included unless the WG feels it
should
be retained and someone steps forward.

Cleve...

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Alain Durand
> Sent: Monday, February 03, 2003 3:40 PM
> To: MicklesCK
> Cc: Jun-ichiro itojun Hagino; Margaret Wasserman; JORDI PALET MARTINEZ;
> [email-masked]
> Subject: Re: agenda items for SF ? ISPs document
>
>
>
>
> MicklesCK wrote:
>

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 04 Feb 2003 14:57:57 +0100

Cleve Mickles wrote:
...
> recommendation in the long run.  

Only over numerous dead bodies. As Roy Brabson pointed out, this is
by no means a requirement for server load balancing (and wouldn't
be too helpful if you happened to be using IPSEC or any other
address-sensitive protocol). Also, I can't see why it would become
an IETF recommendation anyway. IPv4 load balancing is widely
implemented without any help from the IETF. We just need to avoid
making it harder.

Certainly, this topic belongs in the enterprise scenario.

    Brian

---

From: Keith Moore <[email-masked]>
Date: Mon, 3 Feb 2003 18:03:03 -0500

> recommendation in the long run. 

It would be very helpful to distinguish between the use of network address
translation for the purpose of load-balancing within a network of hosts that
are dedicated to support specific applications that are known to be compatible
with this practice, and network address translation that is imposed on a set
of hosts that are used for a variety of purposes and are expected to support
an open-ended set of applications.

NAT can work well for specific, carefully chosen cases.  It cannot be made to
work well in general.

Keith

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Tue, 4 Feb 2003 19:21:38 +0100

IPsec, yes, this could be a problem, but as I know the load balancers keep all the session (security association then ?) to the same
"server", as otherwise, the database access, bank transactions, and others, will be broken.

Anyway, may be there is another way to do load-balancing using anycast, but not sure if the actual architecture supports it, may be
again it will depend on how the load-balancers implement it.

Regarding if ISP or Enterprise, and ISP "hosting" services (so offering load balancing for large number of users), could be always
considered an Enterprise ... but I feel that the boundary between both is not clear enough among both design teams.

Regards,
Jordi

----- Original Message -----
From: "Brian E Carpenter" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Tuesday, February 04, 2003 2:57 PM
Subject: Re: agenda items for SF ? ISPs document

> Certainly, this topic belongs in the enterprise scenario.

*********************************
Madrid 2003 Global IPv6 Summit
12-14 May 2003 - Pre-register at:
http://www.ipv6-es.com
Interested in participating or sponsoring ?
Contact us at [email-masked]

---

From: Jason Goldschmidt <[email-masked]>
Date: Tue, 04 Feb 2003 18:24:45 -0800

> considered an Enterprise ... but I feel that the boundary between both is not clear enough among both design teams.

I agree that such a scenario needs documenting by one of the design 
teams and that the boundary is not clear.  If people want it documented 
sooner, rather then later, the ISP design team would be the best 
candidate.  Simply because they currently are showing greater momentum 
in producing a completed set of documents.

thanks,

-Jason

-- 
Jason Goldschmidt
Sun Microsystems
(650)-786-3502
[email-masked]