Subject: Oops! Accepting Enterprise Scenarios as WG Item

From: Margaret Wasserman <[email-masked]>
Date: Thu, 20 Feb 2003 11:46:14 -0500

Hi All,

I made a mistake last week and approved the publication
of the enterprise scenarios document as a WG work item
without actually checking with the WG first...  Sorry.

So, let's do this the right way...

The enterprise scenarios/analysis team believes that
the current version of their scenarios document is ready
for consideration as a v6ops WG item.  The document can
be found at:

http://www.ietf.org/internet-drafts/draft-ietf-v6ops-entnet-scenarios-00.txt

This work is clearly within the charter of v6ops.

Could members of the WG please comment on whether you
believe that this document should be accepted as a WG
item?  In other words, does it take the right technical
direction, and would it serve as a useful basis for our
work?  Is it sufficiently complete that it is ready for
WG review and refinement?

If there is sufficient support to accept this document,
it will remain a WG work item.  If not, we will move it
back to individual submission status.

Sorry for my mistake and any confusion it may cause.

Margaret

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Thu, 20 Feb 2003 21:09:31 +0100

I agree to consider this as a WG item.

I will try to provide some comments directly to the design team mailing list (as indicated in the document), if any.

Regards,
Jordi

----- Original Message ----- 
From: "Margaret Wasserman" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, February 20, 2003 5:46 PM
Subject: Oops! Accepting Enterprise Scenarios as WG Item

> Sorry for my mistake and any confusion it may cause.

*********************************
Madrid 2003 Global IPv6 Summit
12-14 May 2003 - Pre-register at:
http://www.ipv6-es.com
Interested in participating or sponsoring ?
Contact us at [email-masked]

---

From: Alain Durand <[email-masked]>
Date: Thu, 20 Feb 2003 16:47:32 -0800

Margaret,

First, I would like to say that I appreciate the effort of the
design team to address such a difficult issue.

However, that said, I'm not very comfortable with this document.
On one hand, it is badly needed and already very late,
on the other hand, I'm not sure it is taking the right direction.

I already have commented several times that this design team
is way too 'transition tool' centric in its approach, somehow making  
the hidden
assumption that solving the 'enterprise' case in the (yet to come)   
analysis/solution
document will consist only of picking the 'right' transition tool  
developed by NGtrans.

What I would like to see are things like the following
instantiated for a set of 'typical' enterprise environment:

- how does the internal networks looks like?
- how is the networks are managed?
   (who is responsible, what is outsourced, is IT competent/reliable or  
not ...)
- what are the procedure/tools in place to manage the network?
   (not only SNMP, but for example tools to create DNS zone files)
- is the public internet used (via VPN...)?
- what are the connections to the Internet?
- Is the v4 address space private or public?
- Is the v4 address space 'portable'? (hint: do they need portable v6  
address space)
- How much v4 address space is available?
- Are they multi-homed?
- how is security enforced?
- how does the datacenter looks like if there is one?
- what kind of applications are used in the  
Internet/intranet/extranets/...)
   (is it in-house code? is the source code available? is an Ipv6  
version of the
  code available to buy?....)
- how naming service/directory service is performed (two face DNS?)
-...

There is a little of that buried in section 4, variable description,
but I think this document should really instantiate those variables
and more (the ones I just described above for example, certainly much  
more)
in a set of several 'typical' enterprise environments instead of  
focusing
on cases describing how enterprises are thinking of deploying v6 at the  
IP level
(section 5, which is basically which networks to connect) or abstract  
cases of transition mechanisms
(section 6, point of transition methods) which belongs not in this  
document
but in the solution document.

With this in mind, I would not recommend the wg adopting this document.

	- Alain.

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 21 Feb 2003 14:43:15 +0100

I share some of Alain's concerns. I think that enterprise customers
will not look at IPv6 as a goal in itself, but as a tool for
certain business scenarios they need to support. So I think
the draft should start with a set of business scenarios,
and then maybe continue with the technology scenarios (plus
analysis of which business scenarios they support). At the end,
it would then be possible to deduce which technology scenarios
are useful.

However, I wouldn't advocate pulling back the draft. I think
we should just ask the team to go back and develop the business
scenarios (or use cases, if you prefer the term). And if necessary,
pull in more expertise for this (e.g. to cover Big Iron and
major data centers and hosting centers).

  Brian

---

From: "Fred L. Templin" <[email-masked]>
Date: Mon, 24 Feb 2003 14:25:33 -0800

Alain,

Sorry I'm just getting to this now, but I don't agree with your
point that the "...design team is way too 'transition tool' centric
in its approach...". In section 4, we see the following paragraph:

  "This document will identify those Points of Transition and discuss
   them within a set of scenarios. This document will not provide
   solutions. A set of suggested solutions will be provided in a follow
   on document to this work."

To me, this paragraph seems to be setting the appropriate scope for
the document and is not at all 'transition tool' centric. Am I missing
your point? In any event, I do think the current document takes the
right approach (albeit a bit light on text in some sections) and I
support it becoming a wg item.

Fred Templin
[email-masked]

Alain Durand wrote:
> in a set of several 'typical' enterprise environments instead of  focusing