Subject: RE: transition architecture discussion

From: "Bound, Jim" <[email-masked]>
Date: Wed, 12 Feb 2003 10:57:10 -0500

This is a good draft and piece of work we should expand upon. It adds to
the scenarios work and I esp agree about the note that we need to get
consensus on our assumptions.

That being said in a few days you will get updated Enterprise Scenario
draft and the team has come up with a way to check boxes as Pekka's
draft suggests for transition for our work on the Enterprise.  We need
to get people to agree to our algorithm for the Enterprise Scenarios and
we hope what you will see in the next draft will do that.  Then we can
begin to fill in the parts waiting for that agreement.3  But we will
keep moving forward.

Transition architecture draft should be pursued.  Though I don't fully
agree with the statements about the usefulness of DSTM and would suggest
this work not speak of any specific mechanism and speak only to the
architeture discussion.

Regards,
/jim

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 12 Feb 2003 11:20:36 -0500

Do not disagree with the below it is good perspective.  But I think the
word "transition" is more prudent than "migration" in our deliberations?

Also do we want to discuss the business case and reasons for IPv6
deployment here?  

Regards,
/jim

>-----Original Message-----
>From: Christian Strauf [mailto:[email-masked]] 
>Sent: Wednesday, February 12, 2003 3:21 AM
>To: [email-masked]
>Subject: Re: transition architecture discussion
>
>
>[ post by non-subscriber.  with the massive amount of spam, it 
>is easy to miss
>  and therefore delete posts by non-subscribers.  if you wish 
>to regularly
>  post from an address that is not subscribed to this mailing 
>list, send a
>  message to <listname>[email-masked] and ask to have the 
>alternate
>  address added to the list of addresses from which submissions are
>  automatically accepted. ]
>
>> I think the most important answer to the 'why' is simply the big 
>> chicken and egg problem:
>I think you're right. In my opinion it would be the best idea 
>to simply create a chicken first which then lays the eggs. :-) 
>It probably is a good idea to put a lot of effort into 
>migrating most of the educational networks to IPv6 so that new 
>generations get used to having IPv6 arround. Maybe the 
>convenience of having IPv6 available during their educational 
>phase will then also be important later in their jobs. People 
>usually don't want to give up things they're used to having 
>around. Maybe out of this motivation, the "need" for IPv6 
>outside the educational sector will arise. It's easier dealing 
>with something that you're "brought up" with (having IPv6, 
>that is) rather than having to implement something completely 
>new that you're not familiar with and that customers also 
>don't have an understanding of. And this will most likely make 
>it easier for those generations to see the advantages of IPv6 
>in commercial networks (both as customers and as service 
>providers). IMHO it is all about IPv6 becoming a "natural" 
>thing in the internet world.
>
>Just my 2-EUR-cents.
>
>Christian
>
>-- 
>JOIN - IP Version 6 in the WiN  Christian Strauf
>A DFN project                   Westfaelische 
>Wilhelms-Universitaet Muenster
>http://www.join.uni-muenster.de Zentrum fuer Informationsverarbeitung
>Team: [email-masked]      Roentgenstrasse 9-13
>Priv: [email-masked]    D-48149 Muenster / Germany
>GPG-/PGP-Key-ID: 1DFAAA9A       Fon: +49 251 83 31639, Fax: 
>+49 251 83 31653
>

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 12 Feb 2003 12:24:23 -0500

>The first order work is neither transition nor migration, but 
>deployment. The discussions in the last months have 
>consistently outlined a consensus towards "dual stack 
>deployment", in order to enable new applications, rather than 
>"translation for transition". 

I don't disagree with you and am in tune with the list.  I have no clue
why my mail elicit this commentary from you?  My point is that in the
world of deployment it will be a transition not a migration.  So I don't
get your comments purpose?

/jim

---

From: "Bound, Jim" <[email-masked]>
Date: Wed, 12 Feb 2003 12:43:37 -0500

I can live with coexistence for sure.  Just migration is an illusion.
Could we at least here get folks to use that then? This will influence
out of the IETF too I think and serve a good purpose from the leadership
here for those referencing the process of v6ops for the Internet.

/jim

>From: Randy Bush [mailto:[email-masked]] 
>Sent: Wednesday, February 12, 2003 12:39 PM
>To: Christian Huitema
>Cc: [email-masked]
>Subject: RE: transition architecture discussion
>
>
>i think it was brian who pointed out that the better term may 
>be 'coexistence'
>
>randy
>
>
>