Subject: Deployment of Dual Stack with Applications

From: "Bound, Jim" <[email-masked]>
Date: Wed, 12 Feb 2003 13:01:49 -0500

Folks,
 
First I think the consensus for dual stack is clearly making head way
finally in and out of the IETF.
 
But here is a real operational scenario for us I am working on right
now.
 
User believe IPv6 is important and they want to deploy.  The need to
worry about all the things we discuss here but there is another one.
When do they tell their suppliers they MUST support IPv6 and how does
this work?  And when does IPv6 get turned on?
 
The good thing about a dual stack approach is these users can mandate
all suppliers must support the dual IPv6/IPv4 stack for procurement at
some specified point in time. But they will most likely have to run IPv4
intiially on those procured boxes until the v6ops type parts are figured
out and applications are ported.
 
Now to the technical issue.
 
How are the apps ported and at what point on the suppliers boxes?
 
Using IPv4-Mapped addresses in the base API an app could port to IPv6
and take IPv6 addresses and IPv4Mapped addresses from getaddrinfo() (old
gethostbyname() for those that don't know getaddrinfo() yet) and pass
down IPv4-Mapped addresses to a dual stack implementation and they will
be put out over the network as IPv4 by a dual stack node, but to the
application layer they are just doing IPv6.
 
This will be part of the deployment recommendations from vendors,
consultants, and systems integrators for users and some users will
figure this out on their own and large application software providers
that only want to release one binary for both IPv4 and IPv6.
 
I am not sure if we should put this into any docs for v6ops or not?  It
could be viewed as implementation deployment effort and issue not a
standars issue? But it should be part of our emerging scenarios is my
belief currently (all of them)?
 
Comments.
 
Regards,
/jim

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 14 Feb 2003 10:01:54 +0100

below...

> "Bound, Jim" wrote:
> 
> Folks,
> 
> First I think the consensus for dual stack is clearly making head way finally in and out of the IETF.
> 
> But here is a real operational scenario for us I am working on right now.
> 
> User believe IPv6 is important and they want to deploy.  The need to worry about all the things we discuss here but there is
> another one.  When do they tell their suppliers they MUST support IPv6 and how does this work?  And when does IPv6 get turned
> on?
> 
> The good thing about a dual stack approach is these users can mandate all suppliers must support the dual IPv6/IPv4 stack for
> procurement at some specified point in time. But they will most likely have to run IPv4 intiially on those procured boxes
> until the v6ops type parts are figured out and applications are ported.
> 
> Using IPv4-Mapped addresses in the base API an app could port to IPv6 and take IPv6 addresses and IPv4Mapped addresses from
> getaddrinfo() (old gethostbyname() for those that don't know getaddrinfo() yet) and pass down IPv4-Mapped addresses to a dual
> stack implementation and they will be put out over the network as IPv4 by a dual stack node, but to the application layer they
> are just doing IPv6.
> 
> This will be part of the deployment recommendations from vendors, consultants, and systems integrators for users and some
> users will figure this out on their own and large application software providers that only want to release one binary for both
> IPv4 and IPv6.
> 
> I am not sure if we should put this into any docs for v6ops or not?  It could be viewed as implementation deployment effort
> and issue not a standars issue? But it should be part of our emerging scenarios is my belief currently (all of them)?

I think this is very hard to document in a vendor-independent and 
o/s independent way. For example, some vendors may be so Java dependent 
that their only message to middleware implementors is "use JDK 1.4". 
Others may simply say "use the latest socket API." Others may go
for BIA for the next twenty years.

I approve of the goal, I'm just not sure it can be done.

The good news is that I have never heard a middleware implementor
say that supporting IPv6 is hard. Sometimes they say it's annoying,
but that's as bad as it gets.

   Brian