Subject: RE: Deployment of Dual Stack with Applications

From: "Bound, Jim" <[email-masked]>
Date: Fri, 14 Feb 2003 07:39:35 -0500

Hi Brian,

I agree.  Was just passing it on as thought.

thanks
/jim

> -----Original Message-----
> From: Brian E Carpenter [mailto:[email-masked]] 
> Sent: Friday, February 14, 2003 4:02 AM
> To: Bound, Jim
> Cc: [email-masked]
> Subject: Re: Deployment of Dual Stack with Applications
> 
> 
> below...
> 
> > "Bound, Jim" wrote:
> > 
> > Folks,
> > 
> > First I think the consensus for dual stack is clearly 
> making head way 
> > finally in and out of the IETF.
> > 
> > But here is a real operational scenario for us I am working 
> on right 
> > now.
> > 
> > User believe IPv6 is important and they want to deploy.  
> The need to 
> > worry about all the things we discuss here but there is 
> another one.  
> > When do they tell their suppliers they MUST support IPv6 
> and how does 
> > this work?  And when does IPv6 get turned on?
> > 
> > The good thing about a dual stack approach is these users 
> can mandate 
> > all suppliers must support the dual IPv6/IPv4 stack for 
> procurement at 
> > some specified point in time. But they will most likely have to run 
> > IPv4 intiially on those procured boxes until the v6ops type 
> parts are 
> > figured out and applications are ported.
> > 
> > Now to the technical issue.
> > 
> > How are the apps ported and at what point on the suppliers boxes?
> > 
> > Using IPv4-Mapped addresses in the base API an app could 
> port to IPv6 
> > and take IPv6 addresses and IPv4Mapped addresses from
> > getaddrinfo() (old gethostbyname() for those that don't 
> know getaddrinfo() yet) and pass down IPv4-Mapped addresses to a dual
> > stack implementation and they will be put out over the 
> network as IPv4 by a dual stack node, but to the application 
> layer they
> > are just doing IPv6.
> > 
> > This will be part of the deployment recommendations from vendors, 
> > consultants, and systems integrators for users and some users will 
> > figure this out on their own and large application software 
> providers 
> > that only want to release one binary for both IPv4 and IPv6.
> > 
> > I am not sure if we should put this into any docs for v6ops 
> or not?  
> > It could be viewed as implementation deployment effort and 
> issue not a 
> > standars issue? But it should be part of our emerging 
> scenarios is my 
> > belief currently (all of them)?
> 
> I think this is very hard to document in a vendor-independent and 
> o/s independent way. For example, some vendors may be so Java 
> dependent 
> that their only message to middleware implementors is "use JDK 1.4". 
> Others may simply say "use the latest socket API." Others may 
> go for BIA for the next twenty years.
> 
> I approve of the goal, I'm just not sure it can be done.
> 
> The good news is that I have never heard a middleware 
> implementor say that supporting IPv6 is hard. Sometimes they 
> say it's annoying, but that's as bad as it gets.
> 
>    Brian
>

---

From: "Bound, Jim" <[email-masked]>
Date: Mon, 17 Feb 2003 20:06:38 -0500

This is a valid point. I view it as an engineering trade-off users have
to make given what you say for sure.

/jim

> From: Keith Moore [mailto:[email-masked]] 
> Sent: Monday, February 17, 2003 12:53 AM
> To: Bound, Jim
> Cc: [email-masked]; [email-masked]
> there is no simple answer to this question.  but changing the 
> behavior of existing APIs to try to hide IPv6 from apps will 
> harm interoperability.
> 
> the goal should be to facilitate a more capable Internet 
> supporting more capable apps, not merely to get apps to 
> change packet formats whether they know about it or not.  
> apps won't get more capable by being unaware of IPv6.
> 
> Keith
>