Subject: RE: IPv6 Home Use to stimulate deployment over IPv4-NAT

From: "Bound, Jim" <[email-masked]>
Date: Thu, 13 Feb 2003 07:37:45 -0500

> > Assume there is not enough Ipv4 address space for providers to give
> > out to all subscribers or cannot at reasonable cost.  But they can 
> > give the subscriber an IPv6 prefix.  This means 6to4 or 
> ISATAP won't 
> > work in this scenario in the users home.
> >
> 
> Are you saying this as an alternative to IPv4 NAT or as a complement? 
> (I assume the latter)

The latter but an extension to IPv4-NAT to support IPv6.  In other words NAT admits it is evil but now has seen the light and trys to help move users to IPv6. 
The idea is to deal with the reality but move forward.

> 
> > The home user network encaps the IPv6 packet at NAT with 
> Protocol ID 
> > equivalent to "6".  The provider then takes that packet and 
> decaps at 
> > their edge and uses native IPv6 or 6to4 to encap that 
> packet to where 
> > the IPv6 service is located.  I realize this has many 
> assumptions and 
> > I would work on those with some other folks interested in this 
> > problem. 
> 
> If you mean the first of what I wrote above, I could finally see 
> something that could  make consumer oriented operators look at IPv6.

That is one of my business goals.  Exactly.  But I can only help invent the technology.  But we do have resources in the v6 deployment community to reach out to these players.
 
> There are a number of questions still though, as cost and 
> stability of 
> equipment as well as application impact. But the two last doesn't 
> appear to have bothered this type of operators before....

I agree. My goal is to make impact to applicaton ZERO.

> 
> >  
> > I am re-reading Teredo now and working to see if it is addendum to 
> > Teredo or completely different solution.  I think it is a different 
> > solution and possibly much simpler.  I also believe this 
> solution we 
> > are looking at can do e2e IPsec over the IPv4-NAT.
> 
> That would be a useful application in a way. But I am worried 
> about the 
> poor performance of IPsec in combination with IPv6 code.

We all must deal with a fact of life.  Until we get wide mass available processors IPsec and other security mechanisms performance for e2e encryption will suck.  Period.  But in some cases the performance hit will be worth it.
But for IPv6 IPsec is MANDATORY.

Regards,
/jim

> - kurtis -

---

From: Kurt Erik Lindqvist <[email-masked]>
Date: Fri, 14 Feb 2003 10:15:03 +0100

> The latter but an extension to IPv4-NAT to support IPv6.  In other 
> words NAT admits it is evil but now has seen the light and trys to 
> help move users to IPv6.

Ok, I was hoping that we could come up with something in the middle 
that might give consumer oriented ISPs an incentive to start looking at 
IPv6. But that might be to create to much work and delay the outcome.

> That is one of my business goals.  Exactly.  But I can only help 
> invent the technology.  But we do have resources in the v6 deployment 
> community to reach out to these players.

Question is if we have the tools for them...

- kurtis -