Subject: RE: IPv6-only devices?

From: <[email-masked]>
Date: Fri, 7 Feb 2003 16:01:20 +0200

Hi all!

This has been a good discussion. So the main question seems to be, is
"the dual stack model" sufficient / the only correct way to take care of the 
IPv6 transition?

I certainly admit that it is a very good model for very many cases and it 
has many positive sides, e.g. use of dual stack & tunneling retains the 
end-to-end IP connections.

But does introducing IPv6 in a device / application always require also 
IPv4 to be there? I think it doesn't. Allowing some (new) applications /
services to be IPv6-only can make IPv6 transition happen more quickly. 
And if the application is IPv6-only, we don't need to worry about IPv4 NATs
either.

I think there will certainly be interesting discussions in San Francisco... :-)

Best Regards,
		-Juha W.-

-----Original Message-----
From: ext Brian E Carpenter [mailto:[email-masked]]
Sent: 07 February, 2003 14:45
To: Ronald van der Pol
Cc: [email-masked]
Subject: Re: IPv6-only devices?

Ronald van der Pol wrote:
> 
> On Thu, Feb 06, 2003 at 16:16:09 -0500, Keith Moore wrote:
...
> If you read my initial email again you would see that I also say that
> it is perfectly OK to have IPv6-only appliances that do not need to
> communicate to IPv4-only nodes.

And in a SOHO context or an on-board network on some kind of vehicle,
it might be very natural for those IPv6-only devices to communicate
with a local server that proxies for them in some way to the
outside world. E.g. a "building services" server that doesn't
expose individual IPv6 thermostats to the outside world, but does
expose room temperatures. That server can be dual stack.

This is to me the most natural model for really low-end devices, which 
will be very price sensitive (i.e. a few dollars difference in the cost 
of ASIC or memory really matters). Unless you want to build a NAT-PT
with a Thermostat ALG for each band of thermostat.

> 
> I think dual stack is the best migration path. I also think that the
> transition period should be short. Not a flag day, but also not a
> transition period of decades. I agree with you that running dual
> stack networks is costly *). I think the transition should be done
> in a few years.

Er, how to say this politely? "In your dreams." The only realistic
thing to plan for is an indefinite period of coexistence. Once IPv6
is seriously out there, I can't see the overlap being less than ten
years, and even that is very optimistic.

Of course, the day should come when IPv4 is an overpriced
legacy service only supported by a couple of dinosaur telcos, but
I don't expect that to happen until I'm happily retired.

> I think this means the IETF should restrict new
> work to IPv6-only. In other words: either move to IPv6 or abondon
> the effort.

It's a bit soon for that. But we should clearly not accept any
WG that does stuff that isn't IPv6-ready. So IPv6 people need to
colonise every WG that exists, and read every draft for
IPv6ness.

    Brian

---

From: Margaret Wasserman <[email-masked]>
Date: Fri, 07 Feb 2003 11:05:05 -0500

>And if the application is IPv6-only, we don't need to worry about IPv4 NATs

It makes sense to deploy IPv6-only nodes and services in two
situations:

         (1) Closed or limited network situations where you
                 know that all nodes that need to reach the
                 IPv6-only node/service have IPv6 available.

                 This might occur in hospital, a home, a
                 military application, an industrial site, etc.

         (2) New services/applications that require a
                 software upgrade, anyway.  While the
                 client is being upgraded to include the new
                 service, IPv6 can be installed or enabled.

                 A large PC software manufacturer, for example,
                 could support a new peer-to-peer game that
                 was IPv6-only, and could require that IPv6
                 be installed and enabled as part of the game
                 installation.

In these cases, it is valid to assume that any node that needs
to communicate to the IPv6-only node or service will use
IPv6 to do it.

It may be a long time, though, before it will make sense to
deploy IPv6-only servers on the public Internet to provide
existing services.  For example, how long do you think it will
be before it makes sense to deploy an IPv6-only e-commerce
site?

Margaret

---

From: Keith Moore <[email-masked]>
Date: Fri, 7 Feb 2003 14:17:40 -0500

>                  service, IPv6 can be installed or enabled.

not that these are entirely disjoint, but there are other categories
worth mentioning.  e.g.:

(3) services/applications that will make heavy use of portions of the
network that are IPv6-only, or network nodes that are only
capable of IPv6

in which case it might make more sense to impose a burden on the
(presumably far fewer for such applications) nodes that are currently
limited to IPv4, to upgrade to v6 stacks and use 6to4 or tunneling or
some such to communicate with the other nodes.

(4) new services that involve adding large numbers of new
individually addressible hosts, for which there are not enough IPv4
addresses available

for instance, various kinds of devices that would benefit from remote
monitoring or sensing (power meters, traffic sensors, security
cameras/sensors, fire/smoke alarms, etc.).

> be before it makes sense to deploy an IPv6-only e-commerce

Right, for services where there is a wide expectation that v4 access is
sufficient (email and the web being really obvious examples) you're
going to continue need to provide access using IPv4 for many more years.

Keith

---

From: Tim Chown <[email-masked]>
Date: Fri, 7 Feb 2003 21:48:42 +0000

> I think there will certainly be interesting discussions in San Francisco... :-)

If we get the extra slot... :)

Tim

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Sat, 8 Feb 2003 10:27:13 +0100

I can see also one case that can perfectly match most of this examples, never mind is more a "business" or "marketing" one:

- A team of a hardware vendor+service provider that want to create a exclusive "product/service/application", only v6, because they
only want to sell it in the provider network (as a value added service to attract new customers).

It could be the same for a new application, instead a "hardware product". The service could be installed in a standard PC
(requirement: OS IPv6 enabled), but will use only the IPv6 stack.

Regards,
Jordi

----- Original Message -----
From: "Keith Moore" <[email-masked]>
To: "Margaret Wasserman" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Friday, February 07, 2003 8:17 PM
Subject: Re: IPv6-only devices?

> going to continue need to provide access using IPv4 for many more years.

*********************************
Madrid 2003 Global IPv6 Summit
12-14 May 2003 - Pre-register at:
http://www.ipv6-es.com
Interested in participating or sponsoring ?
Contact us at [email-masked]