Subject: RE: IPv6 Home Use to stimulate deployment over IPv4-NAT

From: Margaret Wasserman <[email-masked]>
Date: Sat, 22 Feb 2003 17:22:11 -0500

Hi Jim,

At 12:59 PM 2/21/2003 -0500, Bound, Jim wrote:
>I caught that in the rfc too.  Yes we need an updated tunnel rfc or
>draft.
>Would that be valid work here ?  Chairs ?

I'm not quite sure what you are asking...  Are you asking
about an update to RFC 3053 that would explain how to use
it over a NAT?

If the need for something like this is indicated by the
unmanaged or enterprise scenario/analysis efforts, we
would probably want to pursue this in v6ops (I can't
think of another WG that would be more appropriate).

Margaret

---

From: Alain Durand <[email-masked]>
Date: Sat, 22 Feb 2003 21:45:34 -0800

The unmanaged scenario, case A, calls for tunneling over UDP.
2 possible solutions are teredo or tunnel broker with tunneling over UDP.

If we want to explore the tunnel broker solution, I do not think RFC3053
needs an update. It is a framework document that explain the concept of 
tunnel broker.
What is needed are two documents:
- one that explain IPv6 over UDP over IPv4
- one that described a simple automatic protocol to set up the 
configuration parameters
between the client (access router) and the tunnel broker. A DHCPv4 
extension would work,
somethink like marc blanchet's TSP protocol would work also. Maybe the 
first think to
do is to work on some requirements for such a protocol.

    - Alain.

---

From: Pekka Savola <[email-masked]>
Date: Sun, 23 Feb 2003 08:30:12 +0200 (EET)

On Sat, 22 Feb 2003, Alain Durand wrote:
[...]
> A DHCPv4 extension would work, somethink like marc blanchet's TSP
> protocol would work also. Maybe the first think to do is to work on some
> requirements for such a protocol.

Indeed, we have to get a better picture on what are the problems and 
non-problems.

For example, DHCP extension works only in scenarios where you obtain the
tunnel connectivity from your direct upstream ISP, the same one that
provides IPv4 connectivity.  

In many cases, this is a non-problem: it is often the case that such
IPv6-active ISP's could provide v6 access using different means already --
no all though -- if the IPv6-conscious ISP just has to keep natting
routers as CPE's and can't change them in the short term, this could still
be valuable.

So, we need to have a picture on the scenarios we're trying to address.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Sun, 23 Feb 2003 23:34:02 +0800

I think we are talking about the case where the tunnel works over NAT w/o need for UDP encapsulation.

About 60% of the NAT boxes that I tested have forwarded proto-41 w/o any problem or special configuration.

This could be documented as a possibility in RFC3053 (now is open in "known limitations", but not clear), and may be explored by the
tunnel broker or whatever is setting up the mechanism, in order to choose automatically this option or, if not available, UDP or
other alternatives.

It will be good to document what routers/models/vendors support this, but I'm not sure how to do that, as probably there are
hundreds or thousands of ;-)

Whatever is decided, I will be happy to work on this.

Regards,
Jordi

----- Original Message -----
From: "Alain Durand" <[email-masked]>
To: "Margaret Wasserman" <[email-masked]>
Cc: "Bound, Jim" <[email-masked]>; "Erik Nordmark" <[email-masked]>; "Jeroen Massar" <[email-masked]>; "JORDI PALET
MARTINEZ" <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Sunday, February 23, 2003 1:45 PM
Subject: Re: IPv6 Home Use to stimulate deployment over IPv4-NAT

> > think of another WG that would be more appropriate).

*********************************
Madrid 2003 Global IPv6 Summit
12-14 May 2003 - Pre-register at:
http://www.ipv6-es.com
Interested in participating or sponsoring ?
Contact us at [email-masked]

---

From: Margaret Wasserman <[email-masked]>
Date: Sun, 23 Feb 2003 12:38:31 -0500

Hi Pekka,

>So, we need to have a picture on the scenarios we're trying to address.

This is exactly the type of analysis that I would expect as
part of the unmanaged analysis document.  We have a scenario
that needs to be addressed, and we should now perform an
analysis of the possible solutions to address that scenario.

If you feel that there are scenarios missing from the unmanaged
scenario document, or if you feel that we need to add a bit
more detail to the existing scenarios (i.e. break out the cases
where an in-house NAT does/doesn't forward packets on port 41
for example), please provide that input as part of the last call
on the unmanaged scenarios document.

Thanks,
Margaret