Subject: RE: 3gpp-analysis document and automatic tunneling

From: "Karim El-Malki (EAB)" <[email-masked]>
Date: Tue, 27 May 2003 22:28:03 +0200

> On Tue, 27 May 2003, Fred L. Templin wrote:
 > > Pekka Savola wrote:
 > > > On Tue, 27 May 2003, Karim El-Malki (EAB) wrote:
 > > >>I have used ISATAP in 2.5 & 3G mobile networks and think it
 > > >>is a very relevant mechanism. What is your experience of
 > > >>these mechanisms in mobile networks that makes you say this?
 > > > 
 > > > 
 > > > ISATAP doesn't allow you you to connect more than a 
 > single host.  It
 > > > doesn't allow routers or networks (e.g. a /64 as 
 > recommended to the 3GPP).  
 > > > Thus, I see it being of little use at least in the 
 > 3GPP-specific part.
 > > 
 > > I don't know exactly the scenarios Karim is referring to, 
 > and I don't
 > > quite understand Pekka's comment. But, I do see a use case 
 > for ISATAP
 > > in the text of section 3.1 of "Analysis on IPv6 Transition in 3GPP
 > > Networks".
 > > 
 > > Whether/not the case described in this section will be 
 > common is a point
 > > which can't be proven until significant 3G deployment has 
 > occurred, but
 > > ISATAP does seem to provide a good fit.
 > 
 > I haven't read the analysis in detail, but the latest 
 > Scenarios draft at
 > least *seems* to very explicitly mention that GGSN supports 
 > both IPv4 and
 > IPv6.

I am pretty certain that's not what the doc says.
First, the fact that the GGSN can support IPv6 and IPv4 routing does
not mean that it has support for IPv6 native connectivity to mobile hosts.
Secondly we cannot guarantee that all GGSNs from all operators
will support IPv6 at the same time. Some GGSNs will only support
IPv4 as they do today.

/Karim

---

From: Pekka Savola <[email-masked]>
Date: Tue, 27 May 2003 23:34:15 +0300 (EEST)

> will support IPv6 at the same time. Some GGSNs will only support

It seems to that the clear implication from the draft is:

"If you want IPv4, use an IPv4 GGSN"
"If you want IPv6, use an IPv6 GGSN"

These do not need to be the same.  This seems clearly stated in Scenarios 
sect 3.1

PDP contexts could be opened to different service boxes in a service
provider's network (whichever support IPv6); and if the service provider
does not support *any* IPv6, the user is on its own *anyway*.

(of course, the UE could support a transition mechanism itself but I find 
that a bit questionable approach -- the goal is to make 3GPP devices 
simple not complex.)

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings