Subject: RE: Dynamic DNS

From: "Bound, Jim" <[email-masked]>
Date: Fri, 2 May 2003 07:10:35 -0400

Tony,

Excuse me but why do you say MS?  There are many operating systems that
have deployed IPv6 that in fact do autoregisration.

Thomas,

Send me mail off line you can post this question to an IPv6 Forum
implementors list where Linux, BSD, UNIXes, Microsoft, and Proprietary
OS developers exist to answer this question.  Also handheld developers.

Thanks
/jim

> -----Original Message-----
> From: Tony Hain [mailto:[email-masked]] 
> Sent: Friday, April 25, 2003 1:36 PM
> To: 'BEGIN, Thomas'; [email-masked]
> Subject: RE: Dynamic DNS
> 
> 
> Thomas,
> 
> These questions are more appropriate for an MS mail list on 
> IPv6. I am not sure which one, but you might start with 
> [email-masked]. 
> 
> That said, the early ship versions of many implementations 
> continue to rely on IPv4 for transport of services like DNS & 
> SNMP. Trying to build an IPv6-only network in the short term 
> will be a matter of persistence and working out which 
> products and services will work without IPv4 in your network. 
> Over time it will be possible to remove IPv4 from the 
> network, but if we required that from the start we would 
> never get anything deployed because there are too many 
> players to synchronize.
> 
> Tony
> 
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]] On Behalf Of BEGIN, Thomas
> > Sent: Thursday, April 24, 2003 5:45 AM
> > To: [email-masked]
> > Subject: Dynamic DNS
> > 
> > 
> > Hello,
> > 
> > I'm working on the relationship between IPv6 and DynamicDNS
> > on several OS. I've succeeded in making my testbed with an 
> > automatic registration into the DNS at the startup of 
> > computers. Then IPv4 and v6 addresses are well recorded 
> > inside the DNS. But the fact is that I still have the IPv4 
> > network. Next I tried to put off the IPv4 protocol from the 
> > network and get an only IPv6 network.
> > * For the linux machines -> no problems
> > * For the windows 2003 machines -> they are no more recorded 
> > inside the DNS table
> > 
> > Thus I have few questions about this thema :
> > - Is there anything special to setup in the OS to allow
> > dynamic updates over IPv6 ? may be in the netsh tool ? I've 
> > searched myself and haven't found ...
> > - Is IPv4 necessary to carry the register messages that 
> > serves for the dynamic DNS updates ? It would mean that IPv6 
> > is not autonomous on the new windows OS ? strange ...
> > - Is there an equivalent of the command ipconfig /registerdns 
> > ... that exists when IPv4 is shut down ? 
> > 
> > Regards
> > - Thomas
> > 
> > 
> 
> 
>

---

From: "Sathya Rao" <[email-masked]>
Date: Fri, 2 May 2003 13:57:57 +0200

Jim,
The problem the way I understand is that with MS we cannot get rid of IPv4
stack, whereas with others we can do.
That is one of the problem we came across while developing VoIPv6 (6VOICE),
which is operational with LINUX but not with MS.

Sathya

----- Original Message -----
From: "Bound, Jim" <[email-masked]>
To: <[email-masked]>; "BEGIN, Thomas" <[email-masked]>;
<[email-masked]>
Sent: Friday, May 02, 2003 1:10 PM
Subject: RE: Dynamic DNS

Tony,

Thomas,

Thanks
/jim

---

From: "Tony Hain" <[email-masked]>
Date: Fri, 2 May 2003 14:44:58 -0700

I was commenting on his issue with lack of records in the Windows server
dns table. As I read it the linux implementation was working for him,
and he was having a problem with the MS one. I was not saying anything
else.

Tony

> From: Bound, Jim [mailto:[email-masked]] 
> Sent: Friday, May 02, 2003 4:11 AM
> To: [email-masked]; BEGIN, Thomas; [email-masked]
> Subject: RE: Dynamic DNS
> 
> 
> Tony,
> 
> Excuse me but why do you say MS?  There are many operating 
> systems that have deployed IPv6 that in fact do autoregisration.
> 
> Thomas,
> 
> Send me mail off line you can post this question to an IPv6 
> Forum implementors list where Linux, BSD, UNIXes, Microsoft, 
> and Proprietary OS developers exist to answer this question.  
> Also handheld developers.
> 
> Thanks
> /jim
> 
> [mailto:[email-masked]] On 
> > > Behalf Of BEGIN, 
> Thomas
> > > I'm working on the relationship between IPv6 and DynamicDNS on 
> > > several OS. I've succeeded in making my testbed with an automatic 
> > > registration into the DNS at the startup of computers. 
> Then IPv4 and 
> > > v6 addresses are well recorded inside the DNS. But the 
> fact is that 
> > > I still have the IPv4 network. Next I tried to put off the IPv4 
> > > protocol from the network and get an only IPv6 network.
> > > - Is there anything special to setup in the OS to allow dynamic 
> > > updates over IPv6 ? may be in the netsh tool ? I've 
> searched myself 
> > > and haven't found ...