Subject: RE: 3gpp-analysis-04: Transition mechanisms at UEs; 3GPP IPv6 dep loyment

From: "Karim El-Malki (HF/EAB)" <[email-masked]>
Date: Thu, 24 Jul 2003 18:45:45 +0200

> On Thu, 24 Jul 2003, Karim El-Malki (HF/EAB) wrote:
 > >  > On Thu, 24 Jul 2003, Karim El-Malki (HF/EAB) wrote:
 > >  > > You're assuming that roaming is done at L3. Roaming 
 > is normally
 > >  > > done at L2 so for example ISATAP is a relevant option.
 > >  > 
 > >  > (I think you should elaborate on "normally")
 > > 
 > > According to the 3gpp standard.
 > 
 > Are there known (or planned) deviations from this standard?

Not that I know of.

 > >  > OK.  If roaming is done at L2, then IP addresses etc. should 
 > >  > stay the same
 > >  > when you roam, right?  Then IPv6 addresses will stay too, 
 > >  > right?  So, why
 > >  > do you need ISATAP there then?
 > > 
 > > Imagine a situation in which you're roaming to another
 > > operator's network. The roaming user requests v6 connectivity
 > > (PDP Context) in the new network. If the new network doesn't
 > > support it, the roaming user won't get v6 connectivity.
 > 
 > Ok; this is not necessarily a huge problem in itself.
 > 
 > But let me try to rephrase this:
 > 
 > Imagine a situation in which you're moving under another 
 > GGSN in your 
 > operator's network.  The user requests v6 connectivity
 > (PDP Context) in the network. If the network doesn't
 > support it, the user won't get v6 connectivity.
 > 
 > I.e., to be able to use v6 everywhere under your own 
 > operator's network, 
 > is it required that all GGSN's in that operator's network 
 > support IPv6 PDP 
 > contexts?

You can make it work with just one GGSN if you really want to.

 > 
 > Or let me phrase this differently:
 > 
 >  Would roaming with 3GPP UE work if the roaming agreements 
 > would include 
 >  an indication whether the foreign network supports the same 
 > PDP context 
 >  types as the original network.
 > 
 > I.e. the user can prefer those roaming partners which 
 > provide the services 
 > they want.  That should be enough of an economic incentive.

Basically the UE won't know until it tries to activate
a v6 connection and it gets refused.

 > 
 > Or, i.e. we define that "roaming" is not "true roaming" 
 > unless you provide 
 > the support for the same PDP context types; that is, there 
 > is "partial 
 > roaming" as of today and "real roaming" of tomorrow.
 > 
 > IMHO, it seems ill-advised to call something "roaming" when 
 > they fail to 
 > provide critical infrastructure capabilities the users need.

Some people would see voice, IPv4 or MMS as critical so I don't
think it makes sense to get into a discussion here on what the word
"roaming" should mean.

 > 
 > > The PDP Context is a special L2 as described in RFC 3314.
 > 
 > Ok, let me try to clarify several ambiguous points: (there 
 > are probably 
 > more but from the top of my head)
 > 
 > Does the IP address of the UE change when it roams to 
 > another network?

The active PDP Context's address doesn't change as long
as this type of "connection survivability" roaming is allowed.
However note that roaming is also when I get off the plane
in another country and turn my mobile on. So the address is
likely to change.

 > Does the GGSN always change to a GGSN of the another network?
No.

 >   If not, how is IP address kept the same?
L2 tunnelling back to the home network.

 > 
 > When the user moves inside the same operator's network does 
 > the IP address 
 > change? (I don't think so)
No.

 >  - Does the GGSN change? (I don't think so)
No.

 > 
 > What determines which GGSN you end up using in the 
 > operator's network?
The type of service "APN" you request (more in RFC 3314)

 >  - How does this work in a network where some GGSN's are 
 > v6-capable and 
 > some not?

You create a v6 "APN" mapped to the IPv6 GGSN, but I don't think
this is important in practice. I think you are concentrating too
much on the GGSN issue. Although the GGSN is your default router,
in order to activate the PDP Context you need support also in the
SGSN for example. Whether you're roaming or not this holds true.
As a user you sit under two nodes: SGSN and GGSN. The SGSN has
geographical coverage. If I am under a SGSN that refuses the
v6 pdp context or a network where there is no IPv6 GGSN then I
can use tunnelling. That's all we're saying.

 > 
 > Figure 3 (typo: should be fig 4) in page 11 seems to 
 > indicate that UE can
 > have multiple PDP contexts, to multiple ISPs.  As long as UE 
 > opens the PDP
 > context to his own ISP which supports v6, you're fine.  But 
 > can the UE do 
 > that?

It can activate mutliple PDP Contexts. However the addressing
and forwarding is through the GGSN. So, the ISP may support IPv6
but the SGSN/GGSN don't. It's just like any access router. If your
ISP supports IPv6 and your current access router is IPv4-only you'll
still need to tunnel to get to your v6 ISP.

/Karim

---

From: Pekka Savola <[email-masked]>
Date: Thu, 24 Jul 2003 22:41:56 +0300 (EEST)

> a v6 connection and it gets refused.

This seems like a potentially fatal design flaw.

If UE's were to run PPP PDP Contexts, could the lack of IPv6 support in 
remote SGSN's/GGSN's be avoided ?

> think it makes sense to get into a discussion here on what the word

Is there a significant number of roaming partners where voice, IPv4 or MMS 
are not supported (in regions where some other potential roaming partners 
would provide support for them)?  Otherwise your analogy does not seem 
fitting.

> in another country and turn my mobile on. So the address is

Ok.
 
> L2 tunnelling back to the home network.

So, as the GGSN does not always change, there should be a way to 
keep alive the association with the local GGSN?

If you use IPv6 PDP context to a local GGSN, move over to another country 
and 3GPP operator but don't switch off your UE -- retaining your old GGSN 
-- does the IPv6 still work through the IPv6 PDP context through L2 
tunneling?  If not, why not?

> much on the GGSN issue. 

Maybe so, but the IP concepts are those I'm familiar with :-)

> Although the GGSN is your default router,

If SGSN doesn't support IPv6 PDP contexts but GGSN does, you're out of 
luck? (without tunneling by the UE)

> still need to tunnel to get to your v6 ISP.

I'm not sure if my question got across, because I don't understand the 
answer in that context.

So, let's try again:

How exactly can UE's open multiple PDP _primary_ contexts to 
different operators?  Is there anything in the capabilities of the 
network(s) which may hinder your possibilities to open PDP contexts to 
different ISPs?

When you're roaming, couldn't you just try opening IPv6 PDP context, and 
if it fails, try some other roaming partner (if available) and try to open 
an IPv6 PDP context there too?   

Or even try opening PDP contexts simultaneously (would be 
more costly, I suppose -- depending on whether the billing starts after or 
before the PDP context activation is successful; in this scenario, it's 
the latter)?

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings