Subject: RE: 6to4 vs forwarding IP proto41 in NAT

From: "Bound, Jim" <[email-masked]>
Date: Wed, 16 Jul 2003 09:41:27 -0400

we either discuss it here or we go make it standard out of the ietf.  I
think its in the v6ops and ietf interest to keep discussing and see
where this goes.

do you have any technical comment on the spec?

/jim

> -----Original Message-----
> From: Rute C. Sofia [mailto:[email-masked]] 
> Sent: Wednesday, July 16, 2003 8:45 AM
> To: Tim Chown
> Cc: [email-masked]
> Subject: Re: 6to4 vs forwarding IP proto41 in NAT
> 
> 
> Tim,
> 
> >
> > 1.  To alert people to the (to some obvious) protocol41 
> "trick" to carry an
> >     IPv6 tunnel into a NAT network.   This is very handy 
> for early adoptors
> >     (the IPv6 geeks).    It is not a long-term solution.
> >
> > 2.  To alert NAT vendors to the fact that if they make what 
> should be a
> >     simple mod to their formware - *if* they are not 
> already supporting IPv6
> >     in some other way e.g. 6to4 or better - they can enable 
> their geek
> >     customers to use IPv6 at home.
> >
> > I think it's a useful informational document, so long as 
> the "trick" 
> > is just seen as an early adoptor/last resort mechanism.
> >
> > It is a mechanism we use a lot btw.
> 
> I completely agree with the sentence above, and that was 
> stated in my previous mail.
> 
> But, Point 2. above says it all: "*if* they are not already 
> supporting IPv6 in some other way e.g. 6to4 or better..."...
> 
> Given that the solution that it's trying to be "imposed" is a 
> temporary solution, not compatible with the other possible 
> ones, I do not see a point in creating a document about it. I 
> do understand that it's in use ;-P, but an individual draft 
> about this does not seem really useful, in my viewpoint. Much 
> less a WG document on this... Maybe I'm completely wrong 
> here, but again, what I'm transmitting is that I don't see 
> the need to document a temporary solution, simply arguing 
> with the purpose that vendors should give this third 
> option...which is already in use...there is so much work to 
> be done regarding v6ops, that my fear is that this document 
> just ends up in simply adding entropy...
> 
> Rute
> 
> 
>

---

From: "Rute C. Sofia" <[email-masked]>
Date: Wed, 16 Jul 2003 11:14:51 -0400 (EDT)

Jim,

> do you have any technical comment on the spec?
as the spec stands, I cannot comment, simply because for me it does not
make sense... I am waiting for the version that
Jordi says is almost ready and yes, I will comment that one.

Rute