Subject: RE: 3gpp-analysis-04: necessity for protocol translators in sect 2.3

From: Soliman Hesham <[email-masked]>
Date: Tue, 22 Jul 2003 04:08:57 -0400

> If the approach "use of NAT-PT in IPv6 UE -> IPv4 node" is 
 > accepted (and 
 > maybe even if not), I'd also modify section 2.3 slightly:
 > 
 >  1) the "Translators are typically needed" sounds too strong, 

=> The rest of the sentence is needed though "when two communicating
nodes have different IP stacks". Note that this does not
imply that they don't implement both stacks, it just
means that in the context of a certain communication
scenario, they appear to be single-stacked. See my
other response to your first issue (re PDP context).

 > modify the last paragraph to (for example):
 >                                                              
 >                                           
 >     Translators may be needed in some cases when the 
 > communicating nodes
 >     do not share the same IP version. 

=> I don't have a strong opinion on this but
a reader might ask "what do you do in the other cases?"
Because you use "some" above after assuming two
nodes with different IP stacks.

Actually, I think maybe we should not associate
translation with ALGs, after all, they don't actually
translate.

Hesham

---

From: Pekka Savola <[email-masked]>
Date: Tue, 22 Jul 2003 11:21:41 +0300 (EEST)

> nodes with different IP stacks.

If this is a worry, we could expand it a bit, maybe like:

    Translators may be needed in some cases when the communicating nodes
    do not share the same IP version; in others, it may be possible to 
    avoid such communication altogether. Translation can actually happen
    at Layer 3 (using NAT-like techniques), Layer 4 (using a TCP/UDP
    proxy) or Layer 7 (using application relays).
 
(or just remove "in some cases", it's not really a problem for me.)

> translation with ALGs, after all, they don't actually

If we'd do this, the above would hold without modifications.  I'm not sure
whether having proxies and such under translators is too big a stretch or
not (when you consider it from the end-to-end point of view, they
certainly do something..).  Removing it from here would certainly require
some new text and shift balances around quite a bit.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings