Subject: RE: [mobile-ip] Re: FW: I-D ACTION:draft-tsirtsis-dsmip-problem-0 0.txt

From: Soliman Hesham <[email-masked]>
Date: Mon, 25 Aug 2003 06:47:55 -0400

> >  > So, it seems pretty reasonable to expect many (most?) 
 > > 
 > > => More like "none" than "most". Even if they implement
 > > it, the encapsulation is normally done in the FA otherwise
 > > the local domain's ingress filter will drop the packets.
 > 
 > Have you even ever deployed MIPv4?  MN would encapsulate 
 > packets using its
 > care-of address, and local domain's ingress filter would 
 > certainly NOT
 > drop those packets.  Or what are you referring to?

=> Have you read RFC 3220? Which CoA are you referring to?
When you have an FA (almost always) the MN doesn't get a 
colocated CoA. Please read 3220.

And yes I've worked with MIP (v4 and v6) for some time...

I won't comment on the rest of the mail because there is
obviously some fundamental misunderstanding of MIPv4.

Hesham

---

From: Pekka Savola <[email-masked]>
Date: Mon, 25 Aug 2003 14:01:55 +0300 (EEST)

On Mon, 25 Aug 2003, Soliman Hesham wrote:
> => Have you read RFC 3220? 

No.

> Which CoA are you referring to?

I'm referring to the local address (obtained e.g. through DHCP) configured 
on the mobile node, whether given by FA or not.

That seems to be the only reasonable way to deploy Mobile IP, as you can't
be sure that the hosts implement or enable Mobile IP (so you will have to
provide DHCP service giving local addresses), and you can't be sure the
routers implement Mobile IP (so the hosts have to be able to reverse
tunnel back to HA).

That's how Mobile IP is deployed here, and works.

You probably have some specific specialized networks in mind.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings