Subject: RE: [mobile-ip] Re: FW: I-D ACTION:draft-tsirtsis-dsmip-problem-0 0.txt

From: Soliman Hesham <[email-masked]>
Date: Wed, 6 Aug 2003 08:39:03 -0400

> > - half the signalling in the local and home domain
 > 
 > Assuming the signalling is identical enough that they could 
 > be bundled 
 > together, and only one protocol could be used.  I don't 
 > believe this is 
 > the case..

=> Why not? Let's take a simple example:
A dual stack node that wants to be reachable on IPv4
and IPv6 addresses. It gets one v4 and one v6 home 
address. If it uses both MIP versions, every time
it moves it will send two separate messages to its
HA. Even worse, if we try to get a decent handover performance
then another two messages will need to be sent to
routers in the local network. 

 > 
 > > - One mobility management protocol is used.
 > 
 > These mobility management protocols are not interchangeable. 
 >  They have 
 > significant differences.  I do not think it is appropriate 
 > to think that 
 > we could accomplish the functions of one with the other.  If 
 > so, it would 
 > certainly require some (even a great deal of) glue to hold 
 > it together, 
 > and the end result might be even worse than the other alternatives.

=> We're not trying to get the full advantage of each
one, this is a transition mechanism. Just like any
tunnelling mechanism will make you lose some of IPv6's
feature. This mechanism is not a goal, it's a mean to short
term deployment for mobile nodes. 

 > 
 > > - IPv6 Connections survive moving from a dual stack network
 > > to a V4 only network.
 > 
 > Already happens if you enable e.g. 6to4 to gain IPv6 
 > connectivity.  If you 
 > had IPv6 connectivity in the past, but move somewhere where 
 > there is none, 
 > I think surviving the connections is not your biggest worry.

=> What is your biggest worry then? I can't imagine a wireless
operator deploying a service that works sometimes. This is
a key problem to address.

 > > => Only one MIP version is needed. Of course a dual stack
 > > is needed in the HA and MNs but _not_ dual MIP versions.
 > 
 > Which means the one MIP version would have to include all 
 > the features of 
 > the other MIP version because otherwise it would not work?

=> Absolutely not our intention. We're trying to walk first
then run. Meaning, get basic connectivity and handover working
then worry about optimal communication. Like I said above, 
this is a transitional issue, ultimately (I hope) only
MIPv6 will be used and we can get all the benefits.

  I.e., in 
 > practice dual MIP versions but just glued together in one?

=> Not really, George and I are working on two solutions
and we'll publish them soon and hopefully this will
be clarified.

Hesham

 > 
 > -- 
 > Pekka Savola                 "You each name yourselves king, yet the
 > Netcore Oy                    kingdom bleeds."
 > Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
 > 
 >

---

From: Pekka Savola <[email-masked]>
Date: Sat, 9 Aug 2003 21:33:53 +0300 (EEST)

> routers in the local network. 

You gave a description of a case where there seems to be unnecessary
signalling that one could try to optimize away (using some means). My
feeling is that there are workarounds (operational ones, i.e. no
extensions for mobility management protocols) for this non-optimized
signalling problem so the actual problem does not seem particularly
attractive.

Here, however, my point was not that: but rather, whether the two mobility 
management protocols are similar enough so that their signalling would be 
interchangeable or reasonably well doable with the other protocol (without 
significant drawbacks).  My feeling is that this is not worth the effort.

> term deployment for mobile nodes. 

Transition to *WHAT*?  IPv6-only mobility management and IPv6 being run on
every subnet where a mobile node might roam to?  I suspect both;  the
latter could take a very long while..

Wouldn't then it be just so much simpler to require the IPv6-capable node
to always use IPv6?

> => What is your biggest worry then? 

When IPv6-capable node uses IPv6 but moves to a subnet where IPv6 is not
supported, and IPv6 services are required for some purpose, it's first and
primary problem is re-establishing IPv6 support in that subnet, in any
means necessary.

> I can't imagine a wireless

I'm not sure of the context you're referring to, so I can't comment on
whether I would see this as a problem or not.  What kind of devices are we
talking about here?  And what kind of networks?  Would the network
terminal devices be smart enough to be used (and expected to work) in the
Internet by themselves (e.g. laptop with a WLAN) or not (e.g. 3GPP
device)?

> MIPv6 will be used and we can get all the benefits.

In transition, it's good to try to figure out questions like: 
 - transition to _where_,
 - transition _how_, and
 - transition for _how long_?
(for example).

With IPv6 (ngtrans/v6ops) we haven't always been too successful in
figuring that out though (and I'm not saying we're necessarily enlightened
at the moment either :-).. :-/