Subject: RE: [mobile-ip] Re: FW: I-D ACTION:draft-tsirtsis-dsmip-problem-0 0.txt

From: Soliman Hesham <[email-masked]>
Date: Sun, 24 Aug 2003 21:09:33 -0400

> On Sun, 24 Aug 2003, Soliman Hesham wrote:
 > >  > > => No it doesn't. How does the MN reverse tunnel to the
 > >  > > HA? MIPv4 does not assume reverse tunnelling.
 > >  > 
 > >  > It has worked just fine for me w/ Dynamics 
 > >  > (http://www.cs.hut.fi/Research/Dynamics/), AFAIR.
 > >  > 
 > >  > Are you saying that mobile nodes do not tunnel back to the 
 > >  > HA themselves, 
 > >  > just (optionally) rely on the FA's doing it?
 > > 
 > > => Yes. I don't know what you did with
 > > the Dynamics SW.
 > 
 > RFC3024 and MIPv4 spec at:

=> This is not relevant, this is for topologically
correct addresses, which is not the case in most
MIPv4 deployments. Normally the FA would reverse
tunnel.

 > 
 > So, it seems pretty reasonable to expect many (most?) 

=> More like "none" than "most". Even if they implement
it, the encapsulation is normally done in the FA otherwise
the local domain's ingress filter will drop the packets.

   MN's implement 
 > tunneling back to HA .. if not for any other reason than 
 > being able to 
 > operate in networks where there are no foreign agents.

=> It's not required for operating in such networks. Please
see RFC 3220

 > > 
 > > => what makes the MN reverse tunnel a packet sent to an 
 > > IPv6 address to an IPv4 address?
 > 
 > The enabling of 6to4 pseudo-interface, for example? (i.e., 
 > enabling the 
 > pseudo-interface, resulting in the 2002::/16 route).

=> see above...

 > > => I said WWAN not WLAN. 
 > 
 > I'm not familiar with the term but I assume you mean 
 > something like GSM 
 > networks.

=> Wireless Wide Area Networks, cellular networks. GSM
is one example.

Hesham

---

From: Pekka Savola <[email-masked]>
Date: Mon, 25 Aug 2003 13:28:01 +0300 (EEST)

> the local domain's ingress filter will drop the packets.

Have you even ever deployed MIPv4?  MN would encapsulate packets using its
care-of address, and local domain's ingress filter would certainly NOT
drop those packets.  Or what are you referring to?

> => It's not required for operating in such networks. Please

If ingress filters are in place in the visited network (i.e., you have to
always plan for it even if sometimes that's not the case), it surely is,
unless there is something I've missed (if so, please give a specific
pointer to what in RFC3220).

>  > pseudo-interface, resulting in the 2002::/16 route).

I do not see how the above is relevant to this part of the discussion.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings