Subject: RE: 3GPP v6-only IMS [RE: WG Last Call: 3GPP Analysis Document]

From: Soliman Hesham <[email-masked]>
Date: Fri, 3 Oct 2003 03:11:37 -0400

> On Thu, 2 Oct 2003, Soliman Hesham wrote:
 > [...]
 > > => I'd love to do that. However, how does this happen in 
 > > practice? Let's say 3GPP went with IPv6 only and 3GPP2
 > > did dual stack or IPv4 only for their IMS. And let's 
 > > say that some operators decide to enable IPv4 only
 > > in their 3GPP2 networks, or in their fixed broadband networks.
 > > Now a 3GPP operator has three options:
 > > 
 > > 1. Tell the others to upgrade to v6
 > > 2. Tell its subscribers that they can't contact certain
 > >    networks.
 > > 3. Provide a mechanism that allows subscribers to talk
 > >    to those v4 only people. 
 > > 
 > > 1) is unrealistic. If it can be done, then why hasn't
 > > it been done already? 2) doesn't seem realistic either
 > > from a commercial point of view.
 > 
 > If 3GPP2 would deliberately choose to build a 

=> 3GPP2 is only one example. There are ISPs offering
VoIP to fixed broadband users today in the US with
a large subscriber base.

 > non-interopreable network, 
 > would it be 3GPP's fault?

=> No, but no one said that "if one market
chooses AMPS and another chooses GSM then there 
is no need for those subscribers in the different
market to communicate". That would have been a disaster
for the industry.

 > 
 > The only _realistic_ choices for 3GPP2 would seem to be IPv6-only or
 > dual-stack.  And in both cases, there would be a common 
 > protocol, IPv6 --
 > no problem.

=> Famous last words.

Hesham

 > 
 > -- 
 > Pekka Savola                 "You each name yourselves king, yet the
 > Netcore Oy                    kingdom bleeds."
 > Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
 >

---

From: Pekka Savola <[email-masked]>
Date: Fri, 3 Oct 2003 10:31:06 +0300 (EEST)

> VoIP to fixed broadband users today in the US with

Are these connected to the global Internet, or terminated at the ISP?

Especially in this case, the v4 NATs are particulatly troublesome, 
upgrading those voip boxes to dual-stack would (help) the two birds with 
one stone: make it easier to use VoIP by the broadband users, and to be 
able to better interconnect to other phones, like 3GPP.

> market to communicate". That would have been a disaster

There is no physical problem here.  Using your analogy, in this case, AMPS
(or GSM) could fix the interoperability problem using a software upgrade
(to IPv6).

I think the point here is whether the markets wish to co-operate or not.  
We can't force them to..