Subject: RE: 3gpp-analysis-05: miscellaneous non-critical issues

From: <[email-masked]>
Date: Thu, 2 Oct 2003 08:54:32 +0200

> >  > My point of removing "native or tunneled" is that because
> >  > there should not 
> >  > be any (or close to any) tunneled connectivity (from the UE) 
> >  > in the first 
> >  > place, pointing it out here is irrelevant.
> > 
> > What leads you to this conclusion? Do you have practical experience 
> > that leads you to this view? I have practical experience of this 
> > tunneled service in real mobile networks that proves the 
> opposite of 
> > what you are saying. I can see that you are expressing a strong 
> > opinion but I have not read and cannot see a reason for it 
> from what I 
> > know about IPv6 in mobile networks.
> 
> I don't have a lot of experience in 3GPP networks (obviously), but 
> discussing these issues with some folks who have (e.g. from 
> Nokia), there 
> seem to be a huge distinction on what you're saying and what 
> others are 
> saying.

Well, let's add a comment from an operator here...

Here are some facts:
- Today's 2.5/3G networks are running on IPv4.
- Today's economic situation is quite difficult.
- Nobody operating a network wants to touch a running system if not
absolutely necessary.

It is therefore very much needed to think about a phased introduction of
IPv6. It is just _not_ realistic to think of a direct move from IPv4 to
native IPv6 - let's make this clear here!

Operators _need_ mechanisms to introduce IPv6 in phases. A first phase
should be fully non-intrusive, cheap but still secure. Tunneling from
the UE (e.g. using ISATAP) seems to perfectly be suited to meet these
requirements. 

I expect the v6ops WG to write guidelines that help the operators in the
introduction of IPv6 in their networks. Such guidelines just have to
consider a phased introduction. Everything else is just not realistic
and not of use for operators. I am looking forward to such documents
from this group.

Regards
Andreas

> 
> > There is always a starting point for the
> > introduction of IPv6 and we must consider this case.
> 
> Introduction of IPv6 works fine in the operator's own 
> network.  It works 
> fine if the user is satisfied with only v4 when he goes 
> abroad and the 
> roaming partner doesn't support v6, etc.
> 
> -- 
> Pekka Savola                 "You each name yourselves king, yet the
> Netcore Oy                    kingdom bleeds."
> Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
> 
> 
>

---

From: Jasminko Mulahusic <[email-masked]>
Date: Thu, 02 Oct 2003 14:47:09 +0200

> the UE (e.g. using ISATAP) seems to perfectly be suited to meet these

not clear to me at all how tunneling is cheaper and more secure than 
introducing native v6 for this particular environment.

if you would care to educate me off list, i am all ears.

jasminko