Subject: AW: IPv6 in MPLS Networks

From: "Bonness, Olaf" <[email-masked]>
Date: Thu, 19 Feb 2004 15:53:50 +0100

Hi Pekka,

scanning my several mailing lists I found your email and want to provide my 2 cents to the discussion. 

IMHO the BGPTUNNEL approach is a solution which could serve ISPs with a very large MPLS infrastructure very well.
The background of this is, that if a realy large ISP want's to implement a new service in it's platform (like IPv6) than it want's to touch as less as possible. BGPTUNNEL gives the ISP the possibility to leave the LSRs/PSs as they are (without any change in control or forwarding plane) and only the LERs/PEs have to be upgraded. The overhead for the IPv6 transport is only one MPLS label (which is IMHO acceptable) and this ensures that you get the same forwarding performance in the MPLS core (as for IPv4) and that you don't run in trouble with IPv6 routing insite your MPLS core.

Besides that, the costs for updating the software of several thousands of routers are pretty high (in comparission to the actual IPv6 business case ;-), so that IMHO the BGPTUNNEL is a very good approach (at least for the first step !) for an IPv6 service offer based on a MPLS backbone. The later steps of an IPv6 integration could be than approach 2 and approach 1 from your email.
(BTW sometimes you have to upgrade your HW as well if you want to realise "native" IPv6 MPLS and thats real expensive.)

Best regards
	Olaf

> -----Ursprungliche Nachricht-----
> Von: [email-masked] [mailto:[email-masked]]Im
> Auftrag von Pekka Savola
> Gesendet: Mittwoch, 11. Februar 2004 19:21
> An: [email-masked]
> Cc: [email-masked]
> Betreff: IPv6 in MPLS Networks
> 
> 
> Hi,
> 
> As ISP scenarios and analysis document is currently at last call, the 
> biggest issue (excluding the tunnel service considerations, 
> which need 
> resolving in other documents as well) seems to be the 
> recommendations/text about IPv6 deployment in MPLS networks.
> 
> The possibilities (or a combination of these) include at least:
> 
>  1) Requiring that MPLS networks deploy native IPv6 support or use
>     configured tunneling to achieve IPv6,
> 
>  2) Requiring that MPLS network support setting up IPv6 LSPs,
>     and IPv6 connectivity is set up using these or configured 
>     tunneling,
> 
>  3) Using only configured tunneling over IPv4 LSPs, or
> 
>  4) Using something like [BGPTUNNEL] to automatically 
> encapsulate IPv6 
>     over IPv4 over MPLS to obtain IPv6 connectivity.
> 
> Based on a quick operator poll, software upgrades in MPLS networks are
> acceptable.  Due to that, the main reason to use a mechanism like
> BGPTUNNEL appears to be to get around the vendor's shortcomings in
> IPv6 forwarding performance in the core network, so marketing solution
> such as this might have disadvantages in the medium and long term, at
> least.
> 
> We're soliciting input on how to best handle this situation.  Please
> send feedback to the chairs or on the list.  Tentatively, we're
> scheduling 20-30 minutes for discussion in Seoul, but how productive
> such discussion would be would depend on the framing and the contents
> of presentations and/or discussion.
>                                                               
>                             
> Please send your ideas (if any).
>                                                               
>                             
>  Thanks,
>   Pekka & Jonne
> 
>

---

From: Pekka Savola <[email-masked]>
Date: Mon, 23 Feb 2004 11:14:32 +0200 (EET)

On Thu, 19 Feb 2004, Bonness, Olaf wrote:
[...]
> Besides that, the costs for updating the software of several
> thousands of routers are pretty high (in comparission to the actual
> IPv6 business case ;-), so that IMHO the BGPTUNNEL is a very good
> approach (at least for the first step !) for an IPv6 service offer
> based on a MPLS backbone. The later steps of an IPv6 integration
> could be than approach 2 and approach 1 from your email. (BTW
> sometimes you have to upgrade your HW as well if you want to realise
> "native" IPv6 MPLS and thats real expensive.)

I think typically the number of PE routers is much higher than the 
number of core routers.  This would seem to imply that upgrading the 
core is irrelevant nuisance compared to upgrading PE routers.  That 
is, if you already have to upgrade 1000 PE routers -- and if v6 
doesn't work properly, the customers attached to those are screwed 
anyway -- upgrading 50 core routers is not so big an issue, when put 
into the perspective.

Further, all of this, the lack of business case etc., can be avoided
by using configured tunneling instead.  Until you have enough
customers, etc., you could just set up a more hierarchical topology --
no need to bother with a full mesh. Simple and robust, requiring zero
new mechanisms.

In a few years time it might even be that those routers which were
unable to do real IPv6 forwarding have been phased out and native IPv6
(or directly over MPLS)  introduction in the core is possible.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings