Subject: RE: comments on draft-durand-v6ops-assisted-tunneling-requirement s-00 .txt

From: "Karim El-Malki (HF/EAB)" <[email-masked]>
Date: Thu, 15 Apr 2004 19:30:09 +0200

>IP support routing. 3GPP does not support routing in the handset.
>Does this makes IP not suitable for 3GPP?
>No. You simply do not use this feature.
>Same analogy applies here. We are not trying to design something
>that works only in the 3GPP case, but can works elsewhere as well.

Your analogy doesn't fit at all IMO. You are comparing implementing
an IPv6 mobile router with an IPv4 NAT in a mobile phone. IMO an
IPv6 mobile router in a terminal is a good thing for the future of
IPv6 in 3gpp nets while a NAT is absolutely not.

/Karim

---

From: "Soliman Hesham" <[email-masked]>
Date: Fri, 16 Apr 2004 00:27:51 -0400

> > You wouldn't need or want a NAT for that.
 > 
 > Yes I want it for my IPv4 connections.

=> No you don't. There is another alternative:
use multiple PDP contexts. It's not a nice thing
but it's sure better and more realistic (in terms 
of what mobile vendors are likely to support)
than a NAT. Note that there will likely be a NAT
in the core net anyway, so the NAT in the UE is useless.

Hesham

 > 
 > > We are recommending that there should be IPv6 support (native
 > > if possible otherwise tunnelled) by the 3GPP/2 operator. That's
 > > the essence of the 3GPP analysis draft. So you can make your
 > > terminal/laptop into an IPv6 mobile router (tunnelling or native
 > > to the 3gpp/2 operator) and not get into the NAT headache. Since
 > > there is a better solution than NAT I think we should use it.
 > 
 > Of course, but I though we were talking about the case where the 3GPP
 > ISP was not (yet) offering IPv6 service.
 > 
 > 	- Alain.
 > 
 > 

========================================================
This email may contain confidential and privileged material for the sole
use of the intended recipient.  Any review or distribution by others is 
strictly prohibited.  If you are not the intended recipient please contact
the sender and delete all copies.
========================================================

---

From: <[email-masked]>
Date: Fri, 16 Apr 2004 17:57:09 +0300

Hi all!

This has been a good discussion. I also agree on the principle having no NAT in the UE.

Karim commented in an earlier e-mail:
"There are no NATs in mobile phones today since there is no use
for them and I sure hope never to see them. I think most people
would agree. So there is nothing today that hints at this
development and I think we should not be proposing solutions
that are compatible with this.

Mobile manufacturers will be shipping dual-stack mobile terminals
and that is what we should be (and are) favouring. If a PAN is
needed behind the terminal then it's an excellent case for using
IPv6."

Yes, *if* (Bluetooth) PAN is needed behind the terminal, just use IPv6 for that. That's a very simple guideline.

Cheers,
	 -Juha-

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of ext Soliman Hesham
Sent: 16 April, 2004 07:28

Hesham

---

From: <[email-masked]>
Date: Fri, 16 Apr 2004 18:05:45 +0300

Karim,

It is good that you write "future" in your comment. Near future 3GPP UEs will still mainly be hosts, and not real mobile routers. But some level of "mobile router" functionality can be necessary (when thinking e.g. Bluetooth PAN).

Cheers,
	 -Juha-

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of ext Karim El-Malki (HF/EAB)

/Karim