Subject: Re: I-D ACTION:draft-savola-v6ops-tunneling-01.txt

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Tue, 20 Apr 2004 18:48:41 -0700

Hi Pekka,

May be I miss in the list something about:
   Notes: 6to4 does not work behind a NAT, so it is not applicable in
   3GPP scenarios, and practically also not applicable in Enterprise
   scenarios

Is not clear to me that the 3GPP deployments will be done with NAT (in the network side, as is clear that the UE will not have NAT ?). May be this requires a clarification or rewording it to differentiate two cases (NAT used in the 3GPP network, or NAT not being used).

For example, today, using GPRS, you get usually a public IPv4 address, and 6to4 is working fine across Europe.

Looking at the latest documents posted in the list, I believe that unman 1.1 can also be realized with a non-authenticated TS, that can be auto-discovered (probably an update of TSP).

Regards,
Jordi

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, April 20, 2004 12:50 PM
Subject: I-D ACTION:draft-savola-v6ops-tunneling-01.txt

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> Title : Evaluation of v6ops Tunneling Scenarios and Mechanisms
> Author(s) : P. Savola, J. Soininen
> Filename : draft-savola-v6ops-tunneling-01.txt
> Pages : 16
> Date : 2004-4-20
> 
> This memo analyses the v6ops scenarios/analysis work (Unmanaged,
> 3GPP, ISP and Enterprise) for their requirements for tunneling
> solutions, and analyses the proposed mechanisms on how they might fit
> in these requirements, and discusses possibilities for choosing
> solution(s).
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-savola-v6ops-tunneling-01.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in the body of the message.  
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> 
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> "get draft-savola-v6ops-tunneling-01.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> [email-masked].
> In the body type:
> "FILE /internet-drafts/draft-savola-v6ops-tunneling-01.txt".
> 
> NOTE: The mail server at ietf.org can return the document in
> MIME-encoded form by using the "mpack" utility.  To use this
> feature, insert the command "ENCODING mime" before the "FILE"
> command.  To decode the response(s), you will need "munpack" or
> a MIME-compliant mail reader.  Different MIME-compliant mail readers
> exhibit different behavior, especially when dealing with
> "multipart" MIME messages (i.e. documents which have been split
> up into multiple messages), so check your local documentation on
> how to manipulate these messages.
> 
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 

**********************************
Madrid 2003 Global IPv6 Summit
Presentations and videos on line at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: "Liu Min" <[email-masked]>
Date: Wed, 21 Apr 2004 10:55:44 +0800

Hi Jordi:
Today in China, using GPRS, you always get a private IPv4 address.

> For example, today, using GPRS, you get usually a public IPv4 address,
and 6to4
> is working fine across Europe.

Best Wishes,
 
Liu Min
Institute of Computing Technology
Chinese Academy of Sciences
Tel: (86-10) 6256 5533-9240 
E-mail: [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of JORDI PALET MARTINEZ
> Sent: Wednesday, April 21, 2004 9:49 AM
> To: [email-masked]
> Subject: Re: I-D ACTION:draft-savola-v6ops-tunneling-01.txt
> 
> Hi Pekka,
> 
> Is not clear to me that the 3GPP deployments will be done with NAT (in
the network
> side, as is clear that the UE will not have NAT ?). May be this
requires a
> clarification or rewording it to differentiate two cases (NAT used in
the 3GPP
> network, or NAT not being used).
> 
> For example, today, using GPRS, you get usually a public IPv4 address,
and 6to4
> is working fine across Europe.
> 
> Looking at the latest documents posted in the list, I believe that
unman 1.1
> can also be realized with a non-authenticated TS, that can be
auto-discovered
> (probably an update of TSP).
> 
> Regards,
> Jordi
> 
> > [email-masked] with the word unsubscribe in the body
of the
> message.
> > You can also visit
https://www1.ietf.org/mailman/listinfo/I-D-announce
> This electronic message contains information which may be privileged
or
> confidential. The information is intended to be for the use of the
individual(s)
> named above. If you are not the intended recipient be aware that any
disclosure,
> copying, distribution or use of the contents of this information,
including
> attached files, is prohibited.
> 
> 
> 
>

---

From: Jeroen Massar <[email-masked]>
Date: 21 Apr 2004 09:22:25 +0200

>    3GPP scenarios, and practically also not applicable in Enterprise

6to4 does work behind a NAT, though depending on the setup:

Situation #1:

[Internet] --- [gw + NAT + 6to4 relay]
                         |
    [2002:aabb:ccdd::/48 RA'd to internal NATted network]

Thus the NAT box does the 6to4 relay, does require the NAT box to do
6to4. Same setup can be done with a tunnel on the NAT box of course.

Situation #2:

[Internet] -- [gw + NAT]
                  |
    [2002:<rfc1918>::/48 on internal NATted network]
    [thus multiple boxes acting as relays as they all]
    [have their own IP address]

The problem with this situation though is that one will not get global
connectivity but the 6to4 stuff will work between the hosts behind the
NAT. Notez bien that afaik XP etc won't allow rfc1918 usage in 6to4
prefixes...

----
5.  Conclusions
<SNIP>
   There seems to be clear need for a tunnel server protocol which is
   able to traverse NATs and work with dynamic IPv4 addresses.  This
   tunnel server should be able to automatically discover the server
   address if the service is provided by the ISP.
-----

The next step ;)

Greets,
 Jeroen

---

From: Pekka Savola <[email-masked]>
Date: Wed, 21 Apr 2004 12:18:58 +0300 (EEST)

> 6to4. Same setup can be done with a tunnel on the NAT box of course.

Obviously yes, but we're talking about the setups where upgrading NAT 
box is not possible.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings