Subject: Re: Scenarios analysis documents: BCP vs Informational?

From: David Meyer <[email-masked]>
Date: Tue, 27 Apr 2004 13:10:14 -0700

> Hi,
> 
> (co-chair hat on)
> 
> During the IESG review of the 3GPP analysis document there was a 
> comment wondering its intended BCP category:
> 
> =====
>   The scope of this Best Current Practices document is to analyze and 
>   solve the possible transition scenarios in the 3GPP defined GPRS 
>   network
> 
> Scenarios aren't things you *solve*; they are things you *describe*. I
> would see no objection to this as an Informational, but I think it
> (and its future companion documents from v6ops) are hardly BCPs. There
> is surely no current practice on which to base the assertion that this
> draft describes the Best.
> =====
> 
> The initial plan (which never had much justification) had been to
> publish the Scenarios documents as Informational, and analysis
> documents (describing the best understanding of the recommended
> deployment approaches) as BCP(s).
> 
> As far as I can understand, the reason why BCP seems inappropriate is 
> because the documents might not be for example:
>  1) not clearly describing _current_ practice (i.e., when there has 
>     not yet been sufficient deployment, but only analysis), or
> 
>  2) not clearly describing _best_ practice (i.e., if the document is 
>     not sufficiently detailed to pick among the alternatives, etc.)
> 
> On the other hand, BCP would seem appropriate if the description is
> detailed enough, and/or current enough so that we can justify that it
> is actually already both a _current_ and _best_ practice.  In a way,
> BCP also sends a stronger message to the community on the
> recommendations (whether that is relevant or necessary is another
> question).
> 
> Now, as there can be arguments for both ways, it would be useful to
> see if there are preferences about this in the WG:
> 
>  a) continue with BCP category,
> 
>  b) publish 3GPP analysis as Informational and consider the rest in 
>     case-by-case basis (whether Info or BCP).  Some other analysis 
>     documents may or may not fall better under the BCP category, or
> 
>  c) publish 3GPP analysis as Informational; take the rest to 
>     informational as well.
> 
> Opinions?  a), b), or c)?
> 
> (co-chair hat off)
> 

	I just reread the document, and would say that option c
	seems most reasonable. 

	Dave

---

From: <[email-masked]>
Date: Thu, 29 Apr 2004 13:03:07 +0300

Hi!

My opinion is c.

Cheers,
	 -Juha W.-

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of ext Pekka Savola

Opinions?  a), b), or c)?

---

From: "Bound, Jim" <[email-masked]>
Date: Thu, 29 Apr 2004 11:08:03 -0400

ack. cool.
/jim 

> From: Pekka Savola [mailto:[email-masked]] 
> Sent: Thursday, April 29, 2004 11:06 AM
> To: Bound, Jim
> Cc: [email-masked]
> Subject: RE: Scenarios analysis documents: BCP vs Informational?
> 
> On Thu, 29 Apr 2004, Bound, Jim wrote:
> > I support (a).  Reason.  BCPs are more easily updated as we learn 
> > Informational lasts forever.  Caveat is IETF is working on 
> all of this 
> > process so my rationale may be a moot point.  Well I we did 
> replace the
> > base API info multiple times??   I just like the sound of 
> BCP I guess
> > :--)
> 
> Maybe that's because folks get ashamed of out-of-date BCPs 
> but don't feel so strongly about Informationals? :)
> 
> In any case, Informationals can be updated as well as we gain 
> experience; if the deployment is successful, it might 
> actually be worth recycling the Informationals to BCPs after 
> some years (if deemed necessary).
> 
> > > From: [email-masked]
> > > [mailto:[email-masked]] On Behalf Of 
> > > [email-masked]
> > > Sent: Thursday, April 29, 2004 6:03 AM
> > > To: [email-masked]
> > > Subject: RE: Scenarios analysis documents: BCP vs Informational?
> > > 
> > > 
> > > Hi!
> > > 
> > > My opinion is c.
> > > 
> > > Cheers,
> > > 	 -Juha W.-
> > > 
> -- 
> Pekka Savola                 "You each name yourselves king, yet the
> Netcore Oy                    kingdom bleeds."
> Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
> 
> 
>