Subject: RE: POLL: Consensus for moving forward with Teredo?

From: "Christian Huitema" <[email-masked]>
Date: Fri, 30 Apr 2004 14:21:14 -0700

I obviously vote for (a), Go forward with Teredo.

-- Christian Huitema

---

From: "Bound, Jim" <[email-masked]>
Date: Fri, 30 Apr 2004 19:01:47 -0400

hear hear I resemble that :--)
/jim 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Tony Hain
> Sent: Friday, April 30, 2004 6:32 PM
> To: 'Pekka Savola'; [email-masked]
> Subject: RE: POLL: Consensus for moving forward with Teredo?
> 
> a)  - it complements 6to4 for the case where a NAT is in the 
> path, as it is equally trivial for consumers to use. 
> 
> The other technologies we have on the table also need to be 
> progressed to PS so the market can sort out which of them it 
> really wants. The IETF fails when it tries to dictate 
> deployment approaches to the market. 
> 
> Tony
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On 
> > Behalf Of Pekka Savola
> > Sent: Friday, April 30, 2004 10:32 AM
> > To: [email-masked]
> > Subject: POLL: Consensus for moving forward with Teredo?
> > 
> > Hi,
> > 
> > (co-chair hat on)
> > 
> > As identified in the scenarios analysis at IETF59 and in 
> > draft-savola-v6ops-tunneling-01.txt, there appears to a need which 
> > cannot be filled by another mechanism for Teredo at least 
> in one major 
> > Unmanaged scenario.
> > 
> > Is there rough consensus to move forward with Teredo? 
> (i.e., to adopt 
> > it as WG document in this WG or elsewhere, for Proposed Standard.)
> > 
> > The main issue raised has been to call for a more extensive 
> analysis 
> > for the deployment implications of native, 6to4, and 
> Teredo.  There is 
> > already discussion of this in the Unmanaged Analysis 
> document.  There 
> > seemed to be very little energy or interest in the WG to drive this 
> > much further.
> > 
> > The options regarrding Teredo at this stage seem to be:
> > 
> >  a) Go forward with Teredo, hone the deployment implications in the
> >     unmanaged analysis in parallel (if and as appropriate),
> > 
> >  b) Conclude that there is no sufficiently strong need for 
> Teredo, and
> >     not support its advancement (for PS) at this stage, or
> > 
> >  c) Decide that we need to analyze the scenarios or deployment more
> >     before being able to make a decision.
> > 
> >     If so, please state where you believe more analysis is needed..
> >     and volunteer if possible :)
> > 
> > If you have an opinion, please state it within a week, 
> i.e., by next 
> > Friday, 7th May.
> > 
> > Thanks!
> > 
> > (co-chair hat off)
> 
> 
> 
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Fri, 30 Apr 2004 19:14:29 -0400

Teredo is very baked and all of them have been implemented by two
independent parties (Teredo, ISATAP, DSTM, Tunnel Broker).  I think we
should stick to Pekkas categories.  What level a spec moves to is
another question completely.  I think we should begin working on all of
them as they are being used now and in response to real RFPs by
customers.  

/jim  

> [mailto:[email-masked]] On Behalf Of Alain Durand
> Sent: Friday, April 30, 2004 7:00 PM
> To: Pekka Savola
> Cc: [email-masked]
> Subject: Re: POLL: Consensus for moving forward with Teredo?
> 
> 
> On Apr 30, 2004, at 10:32 AM, Pekka Savola wrote:
> 
> > Hi,
> There is an alternative:
> d) publish it as Experimental.
> 
> There is code out there, deployable by the millions, so it is 
> good to document it formally. However, for the reasons Marc 
> gave, I'm not convinced that PS is the right approach.
> Actually, I would suggest that Isatap be published as 
> Experimental along Terredo, for the same reasons.
> 
> 	- Alain.
> 
> 
> 
>