Subject: RE: DSTM

From: "Bound, Jim" <[email-masked]>
Date: Wed, 23 Jun 2004 10:31:16 -0400

I support this mail from Itojun.  DSTM does not want special treatment
only to be treated fairly.

But I do want to point out to the WG that we face a delima in the market
that some of these mechanisms like DSTM are being deployed, implemented,
and shipped as product and users are using them.  Out of the IETF we
have to do something and it could be a transition consortia to get more
expedient agreement on transition deployment that would request vendor
and ISP support in such a consortia.  Clearly that could evolve direct
conflict of views with this body for deployment.  It is just to slow
here folks and also some are not getting Ipv6 native deployment and I
will start a separate thread on that for discussion to bring that out
too.

/jim 

> -----Original Message-----
> From: Jun-ichiro itojun Hagino [mailto:[email-masked]] 
> Sent: Wednesday, June 23, 2004 10:22 AM
> To: Bound, Jim
> Cc: [email-masked]
> Subject: RE: DSTM 
> 
> > > > > Some enterprises will not want 2002:: or any hard 
> coded prefix 
> > > > > in their sites network addresses only IPv6 aggregatable
> > > > address prefixes
> > > > > assigned to the site.  Transition will use IPv6 or IPv4
> > > > addresses not
> > > > > Transition prefixes and DSTM supports that operational model.
> > > > 
> > > > 	transition technology other than DSTM can 
> support the operational
> > > > 	model.  so my question is, why DSTM is given 
> special treatment here?
> > > 
> > > DSTM is not asking for special treatment here and I don't 
> understand 
> > > why you say that can you please provide more context why 
> you use the 
> > > phrase "special treatment"?  Thanks.
> > 
> > 	i was under impression that you're asking DSTM to be 
> published without
> > 	wait finishing scenario/analysis document, or if DSTM 
> being mentioned 
> > 	in the documents.  is my impression incorrrect?
> 
> 	i stand corrrected.  Teredo is receiving special 
> treatment from chairs
> 	and Jim is upset about it, and asking for the same 
> treatment as Teredo.
> 
> 	i think neither Teredo nor DSTM should receive special 
> treatment,
> 	they have to wait till analysis/scenario finishes.  
> otherwise, it's
> 	unfair to promote a/some mechanism picked by chairs.
> 
> 	and chairs has to spell out why they thought Teredo is special.
> 	(even if the special treatment is withdrawn)
> 
> itojun
> 
>

---

From: Marc Blanchet <[email-masked]>
Date: Wed, 23 Jun 2004 12:57:58 -0400

speaking about v4 in v6 encapsulation for v6 only networks, DSTM has two
variations for address assignment: one using DHCPv6 (here named
DSTM-DHCPv6) and one with TSP (here named (DSTM-TSP). So the TSP tunnel
broker is a solution that covers both v6 in v4, v6 in udp v4 (i.e. nat
traversal) and v4 in v6 (DSTM-TSP). This is very appealing to many large
sites that need the three cases to be handled. 

Some markets are telling us that v4 in v6 encap is important and key. It
will be very bad if the IETF does not consider solutions in this space.
>From Thomas comment about when, the danger again is that non-interoperable
implementations will come out, just because the spec is not stable (i.e.
RFC number), this is really bad for the whole community, including IETF. 

I guess that a subset of the wg is interested in v4 in v6 encap (DSTM) and
we could probably work in a small design group to do the final work and
then have the wg review and publish. This won't consume much of wg work and
will accomplish something important.

My 2 cents.

Marc.

>> 	(even if the special treatment is withdrawn)

------------------------------------------
Marc Blanchet
Hexago
tel: +1-418-266-5533x225
------------------------------------------
http://www.freenet6.net: IPv6 connectivity
------------------------------------------

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Wed, 23 Jun 2004 19:05:54 +0200

If we really believe, as a group, that IPv6 is being deployed (and this is actually my personal experience about the market situation), we MUST provide standard mechanism to allow the "backwards transition" stage: when we have some IPv6 only networks and we want to reach IPv4 only networks.

Otherwise it will not make any sense to keep deploying IPv6.

Regards,
Jordi

PS: Only my 0,2 cents

----- Original Message ----- 
From: "Marc Blanchet" <[email-masked]>
To: "Bound, Jim" <[email-masked]>; "Jun-ichiro itojun Hagino" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, June 23, 2004 6:57 PM
Subject: RE: DSTM

> >> (even if the special treatment is withdrawn)

**********************************
Madrid 2003 Global IPv6 Summit
Presentations and videos on line at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: "M-K. Shin" <[email-masked]>
Date: Wed, 23 Jun 2004 14:53:29 -0400

I agree on Marc's point.

Also, some enterprise scenarios (i.e., dominant IPv6 network deployment,
- it is certainly in the short term) need DSTM.

Thanks,
--
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Myung-Ki Shin, Ph.D.| [email-masked]
ETRI/NIST           | 820 West Diamond Avenue
                    | Gaithersburg, MD 20899