Subject: 9/9/2004 IP6.INT Removal (Was: 9/9/2006 : ip6.int shutdown?)

From: Jeroen Massar <[email-masked]>
Date: Thu, 22 Jul 2004 10:23:24 +0200

[I always seem to use [email-masked] instead of [email-masked], thus here it is...]
[ Cross-post, to get everybody in sync,
Other messages in this thread can be found at:
http://www.ripe.net/ripe/mail-archives/ipv6-wg/2004/msg00089.html ]

On Thu, 2004-07-22 at 09:58, Kurt Erik Lindqvist wrote:

> On 2004-07-22, at 09.43, Jeroen Massar wrote:
> 
> > But indeed, if there is concensus or not 9/9/2004 and ip6.int is gone
> > for me.
> 
> I vote for 9/9/2004 and getting rid of it properly. Maintaining two 
> reverse threes will create more problems than it will solve.

Take your pick:

http://unfix.org/~jeroen/archive/drafts/draft-massar-v6ops-ip6int-removal-00.html
http://unfix.org/~jeroen/archive/drafts/draft-massar-v6ops-ip6int-removal-00.txt
http://unfix.org/~jeroen/archive/drafts/draft-massar-v6ops-ip6int-removal-00.xml

Short, quick and easy.
If no comments are risen for 16:00 today I'll submit this as an ID.

Greets,
 Jeroen

---

From: "Bound, Jim" <[email-masked]>
Date: Sat, 31 Jul 2004 00:11:23 -0400

Thank you.
/jim 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] 
> Sent: Wednesday, July 28, 2004 7:20 AM
> To: Bound, Jim
> Cc: [email-masked]; Jeroen Massar; Anand 
> Kumria; Rob Blokzijl; [email-masked]; [email-masked]; 
> [email-masked]
> Subject: Re: [sig-ipv6] Re: 9/9/2004 IP6.INT Removal (Was: 
> 9/9/2006 : ip6.int shutdown?)
> 
> 
> 	both ip6.arpa and ip6.int
> 
> --bill
> 
> > 
> > P.S. Bill - the new initial IPv6 AAA at root for JP and KR 
> are they to 
> > use ipv6.arpa?  Thanks.
> > 
> > /jim
> > 
> > 
> > 
> > > -----Original Message-----
> > > From: [email-masked]
> > > [mailto:[email-masked]] On Behalf Of 
> > > [email-masked]
> > > Sent: Sunday, July 25, 2004 5:45 PM
> > > To: Jeroen Massar
> > > Cc: Anand Kumria; Rob Blokzijl; [email-masked]; 
> > > [email-masked]; [email-masked]
> > > Subject: Re: [sig-ipv6] Re: 9/9/2004 IP6.INT Removal (Was: 
> > > 9/9/2006 : ip6.int shutdown?)
> > > 
> > > 
> > > 	whjile i applaud each and everyone who has expunged
> > > 	all ip6.int from their lives, the fact of the matter is that
> > > 	IETF fiat or no, there exist -many- systems that can only use
> > > 	reverse maps in the ip6.int tree.   
> > > 
> > > 	it will be maintained as long as there are queries for 
> > > 	it.  for those of you for whom ip6.int is a distant memory,
> > > 	pleae understand and respect the fact that you can not, 
> > > 	despite public posturing, force others to change their 
> > > 	systems. to practically remove ip6.int incures real cost
> > > 	in both time and cash.  in the US there is a term for what
> > > 	the IETF is trying to do w/ ip6.int.  Its called an unfunded
> > > 	mandate.  Unless or until the good folk in the IETF who are
> > > 	calling for the removal of ip6.int are ready to put up the 
> > > 	cash to effect real change, I wish they would stop.
> > > 
> > > 
> > > > > > > > But indeed, if there is concensus or not 9/9/2004
> > > and ip6.int
> > > > > > > > is gone for me.
> > > > > > > 
> > > > > > > I vote for 9/9/2004 and getting rid of it properly. 
> > > Maintaining
> > > > > > > two reverse threes will create more problems than it
> > > will solve.
> > > > > 
> > > > > What, specifically, is the hurry? 
> > > > 
> > > > That this has been overdue for three years already and 
> that even 
> > > > though the deprecation was marked in August 2001 some vendors 
> > > > still not have done the change. And as it is a
> > > s/ip6.int/ip6.arpa/g which is
> > > > very easy, if vendors did not do that yet they are way
> > > overdue and you
> > > > got to wonder how much their interest is in keeping
> > > software upto date.
> > > > 
> > > > Basically we (at least me) have been waiting for the 6bone
> > > to get the
> > > > delegation so that we could remove the 2 trees and only 
> keep one:
> > > > ip6.arpa. This was decided by the IAB thus we should 
> live up to it.
> > > > 
> > > > If we do not remove ip6.int then still implementations
> > > using it will
> > > > not show up. They have had 3 years already to update...
> > > >  
> > > > > > Take your pick:
> > > > > > 
> > > > > > 
> > > > > Comments:
> > > > > 	e.f.f.3.ip6.arpa was documented in RFC3681 
> published in February
> > > > > 	2004 and actioned in July 2004.
> > > > 
> > > > Added, but note that this was all long overdue and 
> there where a 
> > > > number of other solutions that would have worked already 2
> > > years ago
> > > > if there had not been any of the political arguments
> > > holding back this
> > > > technical issue. Note also that 6bone will end per 6/6/6
> > > and that it is a TESTbed.
> > > > The TESTbed is delaying and thus hurting the production 
> networks 
> > > > in this case.
> > > > 
> > > > > 	I'm assuming the actioning of e.f.f.3.ip6.arpa 
> is the trigger
> > > > > 	for this I-D; if so, why do you want to wait so 
> little time (2
> > > > > 	months) between e.f.f.3.ip6.arpa becoming available and
> > > > > 	requiring people to have updated resolver libraries?
> > > > 
> > > > People should have updated their resolvers in the last 
> *3 years*.
> > > > If you have not done that already then you are not maintaining 
> > > > your machines properly and there is a big chance that you have 
> > > > bigger problems than a IPv6 reverse DNS that doesn't 
> work anymore 
> > > > because ip6.int is gone.
> > > > 
> > > > > 	Personally I'd be more in favour of a 6 month 
> timeout - i.e
> > > > > 	around last December or so.
> > > > 
> > > > Of course the date is up to discussion, but IMHO: ASAP and at 
> > > > least before the end of the year, the sooner the better.
> > > > 
> > > > Note that Cisco's IOS updates will be done before that date and 
> > > > Windows
> > > > XP2 will come out in August (they say) thus everybody using
> > > IPv6 has
> > > > time enough to upgrade. All "free unix flavors" already 
> support it
> > > > 
> > > > Also users agree: http://www.sixxs.net/forum/?msg=general-83948
> > > > Note the begin date of that thread, we where really waiting
> > > for 6bone
> > > > just as being nice to the people still using it.
> > > > 
> > > > On Thu, 2004-07-22 at 10:57, Rob Blokzijl wrote: 
> > > > 
> > > > >     two minor points. In the abstract and the
> > > introduction you write:
> > > > >       
> > > > >       RFC 3152 delegates IP6.ARPA for reverse IPv6
> > > delegations. For RIRs
> > > > >       (RIPE,ARIN,APNIC,LACNIC and soon AFNIC)
> > > > > 
> > > > >     Replace RIPE --> RIPE NCC
> > > > 
> > > > That I did that wrong is a major oops, I should by know the
> > > difference by now.
> > > > 
> > > > >     Replace AFNIC --> AFRINIC
> > > > > 
> > > > >       (AFNIC is the .fr registry :-) )
> > > > 
> > > > Also adjusted and added some xref's in the XML.
> > > > 
> > > > Old version is now draft-massar-v6ops-ip6int-removal-00.a
> > > new version
> > > > carries the draft-massar-v6ops-ip6int-removal-00 name.
> > > > 
> > > > Greets,
> > > >  Jeroen
> > > > 
> > > 
> > > 
> > > 
> > > > *              sig-ipv6:  APNIC SIG on IPv6 technology and 
> > > policy issues           *
> > > > _______________________________________________
> > > > sig-ipv6 mailing list
> > > > [email-masked]
> > > > http://mailman.apnic.net/mailman/listinfo/sig-ipv6
> > > 
> > > 
> > > 
>