Subject: RE: FW: I-D ACTION:draft-ietf-v6ops-ent-scenarios-03.txt

From: "Bound, Jim" <[email-masked]>
Date: Tue, 6 Jul 2004 06:35:11 -0400

Hi Tim, 

> > > If Scenario 3 is an IPv6-only infrastructure and IPv6 nodes, that 
> > > wish to communicate with a separate IPv4-only network, 
> then you're 
> > > in the NAT-PT, TRT or ALG space (depending which layer 
> you want to 
> > > translate at).
> > 
> > If you mean IPv6 only stack yes but not dual stack which 
> adds v4 in v6 
> > tunnels as solution.
> 
> OK, but that needs to be clarified, I think.   In the one 
> case you need 
> protocol translation, in the other case you can tunnel.   If 
> scenario 3
> is both, state it clearly, if it isn't, state it clearly :)

OK none of the scenarios will address IPv6 ONLY nodes where translation
is needed. That will have to be part of the analysis for really long
term planning after this spec moves forward.

>  
> > I don't believe we will see IPv6 ONLY stacks for a very long time.
> 
> Possibly, but hybrid stack nodes with only IPv6 configured is 
> happening now?

Yes I know but that is different than an IPv6 ONLY node.  As IPv4 can be
used if required and avoid translation. 

>  
> > > If Scenario 3 is IPv6 infrastructure (routers, and 
> IPv6-only on the 
> > > wire) but with some dual-stack nodes or legacy applications 
> > > communicating with each other over IPv4 (e.g.
> > > the application is IPv4 only) or to IPv4 nodes outside 
> the network, 
> > > then you may be in the DSTM solution space.
> > 
> > And tunnel broker space too.
> 
> Yes, you could run an IPv4-in-IPv6 tunnel broker.  I don't 
> think I've seen one yet, but it's possible of course.

I am hearing of prototypes.

>  
> Since we are having a minor revision, my request is thus just 
> to clarify what Scenario 3 is (or indeed if there is perhaps 
> a Scenario 4). 

I hope to have edit update today submitted or tomorrow Scenario 3 will
be clarified and in new applicability section but will not add scenario
4 as that would be a significant change for this last call.

Thanks
/jim
 
> Tim

---

From: Tim Chown <[email-masked]>
Date: Tue, 6 Jul 2004 14:44:40 +0100

OK, that's fine JIm.