Subject: Automatic Configuration of IPv6-over-IPv4 Tunnels

From: Syam Madanapalli <[email-masked]>
Date: Wed, 4 Aug 2004 08:10:34 -0700 (PDT)

Hello,

We have a draft that propose a DHCPv4 Option for
carrying Tunnel
Informtion, so that the tunnels can be configured
automatically
between the IPv6 clouds seperated by v4 network.
       
The intent of this draft is to provide a solution to
automate tunnel      
end-point configuration for a configured
IPv6-over-IPv4 tunnel. This      
uses a DHCPv4 option to distribute the tunnel
end-point configuration      
information. This is very useful to connect a newly
deployed native      
IPv6 cloud to other existing IPv6 networks using IPv4
backbone as 
well as to connect isolated dual-stack IPv4/IPv6 nodes
to IPv6 clouds
through IPv4 Network.

This draft proposesa DHCP option as well as a
procedure to automate 
the bidirectional tunnel configuration.

I am wondering if this fits into v6ops
zeroconfiguration requirements
for tunnel configuration. Any comments/suggestions
welcome.

PPT:    
http://home.megapass.co.kr/~natpp00/IETF-60-DHCPv4-CTEP.ppt
Dradft: 
http://www.ietf.org/internet-drafts/draft-daniel-dhc-dhcpv4-tep-conf-01.txt

Thank you,
Syam

__________________________________
Do you Yahoo!?
Yahoo! Mail - 50x more storage than other providers!
http://promotions.yahoo.com/new_mail

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Wed, 4 Aug 2004 10:43:58 -0700

Hi Syam,

I think this is an interesting work, and should be continued within DHC WG.

But I'm not sure will fit in the zeroconfiguration requirements, because for example in 3GPP DHCP is not being used.

Anyway, we are already discussing this and will consider the option.

But it could be feasible in ISP scenarios when only the own-ISP customers are the goal for providing a transition service.

Regards,
Jordi

---- Original Message ----
From: "Syam Madanapalli" <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, August 04, 2004 8:10 AM
Subject: Automatic Configuration of IPv6-over-IPv4 Tunnels

> http://www.ietf.org/internet-drafts/draft-daniel-dhc-dhcpv4-tep-conf-01.txt

**********************************
Madrid 2003 Global IPv6 Summit
Presentations and videos on line at:
http://www.ipv6-es.com

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Ralph Droms <[email-masked]>
Date: Wed, 04 Aug 2004 14:04:13 -0400

Jordi - I'm a little confused (perhaps by 3GPP versus 3GPP2?).  We have a 
request to fast track a DHCPv6 option for MIPv6 home agent options.  I 
guess that's for 3GPP2, not 3GPP.  3GPP is not using DHCP at all?

- Ralph

At 10:43 AM 8/4/2004 -0700, JORDI PALET MARTINEZ wrote:
>But I'm not sure will fit in the zeroconfiguration requirements, because 
>for example in 3GPP DHCP is not being used.
>
>But it could be feasible in ISP scenarios when only the own-ISP customers 
>are the goal for providing a transition service.
>
>Regards,
>Jordi
>
>This electronic message contains information which may be privileged or 
>confidential. The information is intended to be for the use of the 
>individual(s) named above. If you are not the intended recipient be aware 
>that any disclosure, copying, distribution or use of the contents of this 
>information, including attached files, is prohibited.

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Wed, 4 Aug 2004 11:12:10 -0700

Hi Ralph,

That was my understanding for 3GPP, so you may be right that this is different in 3GPP2.

Regards,
Jordi

---

From: Syam Madanapalli <[email-masked]>
Date: Wed, 4 Aug 2004 11:12:36 -0700 (PDT)

--- JORDI PALET MARTINEZ <[email-masked]>
wrote:

> But I'm not sure will fit in the zeroconfiguration
> requirements, because for example in 3GPP DHCP is
> not being used.
> 
> But it could be feasible in ISP scenarios when only
> the own-ISP customers are the goal for providing a
> transition service.
> 
> Regards,
> Jordi
> 
> This electronic message contains information which
> may be privileged or confidential. The information
> is intended to be for the use of the individual(s)
> named above. If you are not the intended recipient
> be aware that any disclosure, copying, distribution
> or use of the contents of this information,
> including attached files, is prohibited.
> 
> 
> 
> 
> 

__________________________________
Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages!
http://promotions.yahoo.com/new_mail

---

From: Syam Madanapalli <[email-masked]>
Date: Wed, 4 Aug 2004 11:20:54 -0700 (PDT)

Hi Jordi,

wrote:

> Hi Syam,
> 
> I think this is an interestng work, and should be
> continued within DHC WG.

 DHC WG does not want to take up this as an WG item
 unless the draft has consumer and its semantics are 
 correct. I think v6ops has to decide if this is 
 useful, then DHC WG looks into the syntax.

> requirements, because for example in 3GPP DHCP is

 This means we are looking for a solution covering all
 scenarios?

> Anyway, we are already discussing this and will

 Looks good, and I am wondering if the design team has
 already formed for this activity.

		
__________________________________
Do you Yahoo!?
Yahoo! Mail - You care about security. So do we.
http://promotions.yahoo.com/new_mail

---

From: "Fred L. Templin" <[email-masked]>
Date: Wed, 04 Aug 2004 11:18:21 -0700

I proposed a DHCPv4 option for tunnel endpoint discovery in an I-D
about 2 years ago, and the document was widely ignored. Why all of
a sudden this renewed interest? (Asked the other way around, why
was there no interest 2 years ago when the I-D was still active?)

Fred
[email-masked]

Ralph Droms wrote:
> Jordi - I'm a little confused (perhaps by 3GPP versus 3GPP2?).  We have 
> a request to fast track a DHCPv6 option for MIPv6 home agent options.  I 
>> But I'm not sure will fit in the zeroconfiguration requirements, 
>> because for example in 3GPP DHCP is not being used.
>>
>> But it could be feasible in ISP scenarios when only the own-ISP 
>> customers are the goal for providing a transition service.
>>
>> Regards,
>> Jordi
>>
>> This electronic message contains information which may be privileged 
>> or confidential. The information is intended to be for the use of the 
>> individual(s) named above. If you are not the intended recipient be 
>> aware that any disclosure, copying, distribution or use of the 
>> contents of this information, including attached files, is prohibited.
> 
> 
>

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Wed, 4 Aug 2004 11:27:51 -0700

Hi,

See my reply below in-line.

Regards,
Jordi

---- Original Message ----
From: "Syam Madanapalli" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Wednesday, August 04, 2004 11:20 AM
Subject: Re: Automatic Configuration of IPv6-over-IPv4 Tunnels

>  useful, then DHC WG looks into the syntax.

I already provided my positive opinion in the DHC WG meeting and also talking with Ralph. I guess is more appropriate if he can reply this according to his own decision.

>  This means we are looking for a solution covering all

This is an important goal, but not absolutely sure we can achieve it. In any case, it will make sense to have 2 solutions only instead of 3 or 4, etc., right ?

>  already formed for this activity.

Yes, not sure if we call it an "official" design team, but we started working on this as agreed in the v6ops meeting, and we will present our preliminary results in the Thursday v6ops meeting.

---

From: Syam Madanapalli <[email-masked]>
Date: Wed, 4 Aug 2004 11:31:54 -0700 (PDT)

Hi Fred,

I was not even working towards IETF two years ago.
And I am still not sure if this option is useful, if
it is, do you mind joining this work?

Thank you,
Syam

--- "Fred L. Templin" <[email-masked]> wrote:

> >> I think this is an interesting work, and should
> be continued within 
> >> DHC WG.
> >>

__________________________________
Do you Yahoo!?
Read only the mail you want - Yahoo! Mail SpamGuard.
http://promotions.yahoo.com/new_mail

---

From: "Fred L. Templin" <[email-masked]>
Date: Wed, 04 Aug 2004 11:43:13 -0700

Hello Syam,

Regarding joining your effort, I'm afraid I am spread too thin
right now on other obligations but obviously have no objections
to others pursuing it if there is a chance it will bear fruits.
Still wondering if anyone can comment on the on-again/off-again
interest in this approach?

Thanks - Fred
[email-masked]

Syam Madanapalli wrote:
>>>Jordi - I'm a little confused (perhaps by 3GPP
>>
>>versus 3GPP2?).  We have 
>>
>>>a request to fast track a DHCPv6 option for MIPv6
>>
>>home agent options.  I 
>>
>>>guess that's for 3GPP2, not 3GPP.  3GPP is not
>>
>>using DHCP at all?
>>
>>>- Ralph
>>>
>>>At 10:43 AM 8/4/2004 -0700, JORDI PALET MARTINEZ
>>
>>wrote:
>>
>>>>Hi Syam,
>>>>
>>>>But I'm not sure will fit in the
>>>
>>zeroconfiguration requirements, 
>>
>>>>because for example in 3GPP DHCP is not being
>>>
>>used.
>>
>>>>Anyway, we are already discussing this and will
>>>
>>consider the option.
>>
>>>>But it could be feasible in ISP scenarios when
>>>
>>only the own-ISP 
>>
>>>>customers are the goal for providing a transition
>>>
>>service.
>>
>>>>Regards,
>>>>Jordi
>>>>
>>>>Subject: Automatic Configuration of
>>>
>>IPv6-over-IPv4 Tunnels
>>
>>>>>Hello,
>>>>>
>>>>>We have a draft that propose a DHCPv4 Option
>>>>
>>for
>>
>>>>>carrying Tunnel
>>>>>Informtion, so that the tunnels can be
>>>>
>>configured
>>
>>>>>automatically
>>>>>between the IPv6 clouds seperated by v4
>>>>
>>network.
>>
>>>>>The intent of this draft is to provide a
>>>>
>>solution to
>>
>>>>>automate tunnel
>>>>>information. This is very useful to connect a
>>>>
>>newly
>>
>>>>>deployed native
>>>>>IPv6 cloud to other existing IPv6 networks
>>>>
>>using IPv4
>>
>>>>>backbone as
>>>>>well as to connect isolated dual-stack
>>>>
>>IPv4/IPv6 nodes
>>
>>>>>to IPv6 clouds
>>>>>through IPv4 Network.
>>>>>
>>>>>for tunnel configuration. Any
>>>>
>>comments/suggestions
>>
>>>>>welcome.
>>>>>
>>>>>PPT:
>>>>>
>>>>
>>>>>Yahoo! Mail - 50x more storage than other
>>>>
>>providers!
>>
>>>>This electronic message contains information
>>>
>>which may be privileged 
>>
>>>>or confidential. The information is intended to
>>>
>>be for the use of the 
>>
>>>>individual(s) named above. If you are not the
>>>
>>intended recipient be 
>>
>>>>aware that any disclosure, copying, distribution
>>>
>>or use of the 
>>
>>>>contents of this information, including attached
>>>
>>files, is prohibited.
>>
>>>
>>>
>>
>>
>>
>>
> 
> 
> 
>

---

From: "Soininen Jonne (Nokia-NET/Helsinki)" <[email-masked]>
Date: Wed, 04 Aug 2004 23:43:00 +0300

Ralph,

3GPP networks do not use DHCP _v4_. I'm not 100% sure of 3GPP2, but I
have a recollection of them doing PPP to configure the terminal instead
of DHCP for v4. (I could be wrong on 3GPP2, though.)

For v6 land, in 3GPP there is the option to use DHCPv6 for SIP proxy
discovery (P-CSCF discovery) in IMS. This however is not mandatory.

Cheers,

Jonne.

-- 
Jonne Soininen
Nokia

Tel: +358 40 527 46 34
E-mail: [email-masked]

---

From: Ralph Droms <[email-masked]>
Date: Wed, 04 Aug 2004 19:39:45 -0400

Jonne - thanks for your reply.  After I posted my question, I found
out through private e-mail that 3GPP2 will use DHCPv6 for configuration
of a MIP home agent address.

If I understand your response about 3GPP correctly, there is at least
one other configuration parameter supplied through DHCPv6.

It sounds like tunnel configuration through DHCPv6 might still be
feasible, as both 3GPP and #GPP2 are defining the use of DHCPv6 for
other configuration information.

- Ralph

---

From: Pekka Savola <[email-masked]>
Date: Thu, 5 Aug 2004 07:24:21 +0300 (EEST)

> other configuration information.

Nope.  You really can't set up IPv6 connectivity (v6-in-v4 tunnel) 
using DHCPv6 when you don't have v6 in the first place ;-).

DHCPv6 can only be applied after getting v6 connectivity (whether 
native or a tunnel).

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: "Soininen Jonne (Nokia-NET/Helsinki)" <[email-masked]>
Date: Thu, 05 Aug 2004 07:36:03 +0300

Ralph,

I'm not familiar with the 3GPP2 use of DHCPv6. So, I leave that to the
real experts to comment. However, in 3GPP the DHCPv6 is an option for
the SIP-proxy configuration (giving the SIP-proxy address). IP addresses
are gotten doing stateless autoconfig.

Cheers,

Jonne.

-- 
Jonne Soininen
Nokia

Tel: +358 40 527 46 34

---

From: Syam Madanapalli <[email-masked]>
Date: Thu, 5 Aug 2004 08:12:46 -0700 (PDT)

HI Pekka,

> using DHCPv6 when you don't have v6 in the first

Not necessarily true.
One can establish a unidirectional tunnel first,
and then tunnel DHCPv6 to create the tunnel on the
other side. Of course this requires knowledge of the
IPv4 address of the other side of the tunnel
termination
point.

And this procedure may be different from the way the 
DHCPv6 is being used currently.
the way it is being use

		
__________________________________
Do you Yahoo!?
Yahoo! Mail Address AutoComplete - You start. We finish.
http://promotions.yahoo.com/new_mail