Subject: Zeroconf keep-alive WAS: RE: zeroconf draft

From: "Karen E. Nielsen (AH/TED)" <[email-masked]>
Date: Tue, 24 Aug 2004 09:25:17 +0200

Hi Pekka,

> 
> > > ==> this brings other two points: 1) how does the client know when
> > > the tunnel no longer works if there are no keepalives (the router
> > > could die, the client could move to another network which cannot
> > > tunnel to the tunnel server etc.), and 2) how does the server
> > > perform garbage collection (if applicable) on the users.
> > > 
> > 
> > What we try is to say that is that no pro-active measures should
> > need to be taken by the hosts/servers to maintain
> > link-sustainability. This doesn't mean that re-active measures
> > cannot be taken and we explicitly state that mechanism comparative
> > to NUD should be available for this purpose.
> 
> Does NUD count as proactive measure?  You can consider it both ways, 
> if it probes about every 30 seconds if there hasn't been traffic.
> 

but it doesn't. NUD only probes when the 
node is sending packets towards the
destination - right ?

BR, Karen

---

From: Pekka Savola <[email-masked]>
Date: Tue, 24 Aug 2004 10:54:08 +0300 (EEST)

> node is sending packets towards the

Sorry for my confusion -- upon re-checking, you're right, NUD packets
are not sent on a completely "silent" link.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings