Subject: RE: zeroconf draft

From: "Karen E. Nielsen (AH/TED)" <[email-masked]>
Date: Tue, 24 Aug 2004 10:02:03 +0200

Hi Pekka,

> 
> As noted in the message to Jordi, I'd be concerned if one would be 
> concerned about the amount of state, not the amount of traffic.
> 
> > Load balancing among multiple router weren't part of base IPv6, but
> > it may become so (<draft-ietf-ipv6-host-load-sharing-02.txt>).
> > 
> > Load balancing could be good, whether its really required by this 
> > miminal function, I am not sure.
> 
> Just to be clear, I wasn't describing load-balancing as described in 
> draft-ietf-ipv6-host-load-sharing-02.txt (which wouldn't 
> probably even 
> work nicely, at least if you don't make assumptions about the 
> solution).
> 
> I think the goal here is that you'll be able to deploy multiple
> "tunnel servers", and be able to somehow make some of the hosts to use
> tunnel server A, some B, others C.  You probably don't want all the
> hosts sharing the load equally among servers A to C (which is what the
> load sharing spec says).  

My mistake.

I was in fact thinking of the scenarios 
where different hosts deploys different
routers. 

>In short, this probably turns out as a 
> requirement for the auto-discovery of the tunnel server, as Jordi 
> noted, but it should be explicitly discussed.
> 
> (In other words, you're concerned of seamlessly being able to deploy 
> multiple tunnel servers to be able to support a larger amount of 
> tunnel end-points.)
> 

I agree that that load balancing could be inforced
by the endpoint discovery mechanism using standard mechs, e.g., round 
robin or advanced "active load measuring" mechanisms.

Personally I may still not be convinced that 
this is a strict requirement for zeroconf. 

I will register it as an open issue.

BR, Karen

---

From: Pekka Savola <[email-masked]>
Date: Tue, 24 Aug 2004 11:44:03 +0300 (EEST)

> this is a strict requirement for zeroconf. 

I'm extremely surprised to see this view.  If a 3GPP operator has
1,000,000 customers (or even much more), do you think deploying just
one server is sufficient, if the IPv6 tunneling code gets added to the
phones?

Or what's your assumption in this kind of scenario?

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings