Subject: Re: [v6ops] A good "state of the art" overview of IPv6 Transition from FCC

From: "Lee, Yiu" <[email-masked]>
Date: Tue, 4 Jan 2011 04:02:09 +0000

Well, when DHCPv6 is getting more popular, we may be able to work around
this limitation. However, 18 trillion^2 addresses are still a lot^2.

On 1/3/11 10:56 PM, "Tom Taylor" <[email-masked]> wrote:

>But isn't it only 18 trillion trillion because everyone is getting at
>least a /64?
>
>On 03/01/2011 10:35 PM, Lee, Yiu wrote:
>>
>>> We can only hope that 340 trillion trillion trillion is enough for a
>>> while...
>>>
>>>
>>> Amen!
>>
>> _______________________________________________
>> v6ops mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/v6ops
>>
>>

---

From: David Conrad <[email-masked]>
Date: Mon, 3 Jan 2011 22:47:17 -1000

> this limitation. However, 18 trillion^2 addresses are still a lot^2.

This is sort of missing the point.  Absolute numbers are pretty much irrelevant.  What matters is the rate of consumption.

For example, let's say the amount of IPv6 address space that can be assigned is 2^45 (using the minimum /48 and chopping off 3 bits because we're only supposed to use 1/8th of the IPv6 address space for global unicast).  If you take the current IPv4 address consumption rate (call it 200 million a year for sake of argument) and map that into /48s, you'll see that the current 1/8th of IPv6 address space will last 2^45/200,000,000 = 175,921 years.  Even if you increase the rate of consumption by 1000, it's still 176 years. 

But this sort of analysis assumes rational (that is, technically justified) assignment policies.  Current RIR policies suggest /48s as the minimum recommended assignment size.  However, as Randy mentions, current allocations to ISPs (and others) are a minimum of /32, and many folks are able to justify more.  There have been a number of allocations made by the RIRs according to policy that are shorter than /20.  One might note that there are the same number of /20s in IPv6 as there are in IPv4. And this is the result of policy processes that are influenced primarily by technical folks.  There is increasing pressure from the non-technical world (e.g., governments) to use non-technical justification for IPv6 address space (e.g., "we demand our IPv6 /12 because we're a nation-state").

I still believe it's unfortunate that we focused on the "32" instead of the "fixed" part in "fixed 32-bit address" when IPv6 was being defined, but that's water under the bridge.  It does, however, mean technical folks need to be vigilant about how address policy is defined and by whom. 640K really wasn't enough for everyone.

Regards,
-drc

---

From: Gert Doering <[email-masked]>
Date: Tue, 4 Jan 2011 12:52:35 +0100

Hi,

On Mon, Jan 03, 2011 at 10:47:17PM -1000, David Conrad wrote:
> It does, however, mean technical folks need to be vigilant about how 
> address policy is defined and by whom. 

Indeed.

OTOH, I'm deeply convinced that the address space in IPv6 is there to be
*used*.  Bringing over the "conservation is holy!" IPv4 mindset to IPv6
will not do IPv6 any good.

So - if we indeed are too wasteful, we'll notice when we have burned
FP 001, and then we have 6 more tries to follow the conservationists'
advice.  Until then, I'd like to enjoy the new freedom.

(Yes, /32 is a huge chunk of addresses.  OTOH, there's 2^29 /32s in 
FP001, and I don't see 500 million LIRs appear any time soon.  Even if
we take up-to-/20-assignments into account, I still do not see a 
large enough number of correspondingly-sized enterprises around to
make this a serious problem - just how many Telcos are there that 
can warrant a /20?  More than 10.000?  There's 130.000 /20 in FP001...)

Gert Doering
        -- NetMaster
-- 
did you enable IPv6 on something today...?

SpaceNet AG                        Vorstand: Sebastian v. Bomhard
Joseph-Dollinger-Bogen 14          Aufsichtsratsvors.: A. Grundner-Culemann
D-80807 Muenchen                   HRB: 136055 (AG Muenchen)
Tel: +49 (89) 32356-444            USt-IdNr.: DE813185279

---

From: "t.petch" <[email-masked]>
Date: Tue, 4 Jan 2011 12:11:46 +0100

----- Original Message ----- 
From: "Lee, Yiu" <[email-masked]>
To: "Tom Taylor" <[email-masked]>
Cc: "IPv6 Ops WG" <[email-masked]>
Sent: Tuesday, January 04, 2011 5:02 AM

> this limitation. However, 18 trillion^2 addresses are still a lot^2.

True but not necessarily relevant.

When I first studied IPv6 all those years ago, I was also active in ATM and it
immediately struck me that IPv6 had not left enough room in the interface part
for an ATM address, so that an IPv6 address would always be too small.

Tom Petch