Subject: Re: [v6ops] 80th IETF - Working Group/BOF Scheduling

From: Fred Baker <[email-masked]>
Date: Tue, 4 Jan 2011 17:20:33 -0800

It looks like we are starting scheduling for Prague. I have signed us up for our usual 2.5 and 2 hour meetings. As usual, the ground rules for getting time on the agenda include 
 - a speaker showing up at the meeting
 - relevance to the charter, and 
 - a posted internet draft that is new since IETF 79.

There is also a sense on the IESG, I'm told, that we should be able to get agendas together a lot earlier than we have in the past. One comment I heard asked for an agenda to be posted with the request for a meeting slot. At this point, I am expecting

	draft-ietf-v6ops-multihoming-without-nat66
	draft-ietf-v6ops-v4v6tran-framework
	draft-ietf-v6ops-v6-aaaa-whitelisting-implications
	draft-v6ops-multihoming-without-nat66
	draft-wbeebee-v6ops-ipv6-cpe-router-bis
	draft-wing-v6ops-happy-eyeballs-ipv6
	draft-korhonen-v6ops-3gpp-eps

draft-v6ops-multihoming-without-nat66, draft-wing-v6ops-happy-eyeballs-ipv6 should be reposted as  draft-ietf-v6ops-*, please - working group draft. I expect that at this coming meeting we will find enough meat in cpe-router-bis to adopt it as well. We collectively need to decide what to do with draft-korhonen-v6ops-3gpp-eps; of the respondents in the survey, most felt it was something to work on, but we didn't have a clear consensus on whether or not to adopt it. I'll start that discussing in a separate thread in a few moments.

At this point, we also have 15 other drafts posted. One will for sure die (mine); it has accomplished its purpose. Another is likely to be folded into cpe-router-bis. There was a sense at IETF 79 that there was value in draft-jankiewicz-v6ops-v4v6biblio, but no clear direction on where Ed should take it - some thought it should be a working group document and some thought it should be abandoned. I'll leave that to Ed for the moment. The comments made in the survey, which I emailed to the list on 20 November, were inconclusive with respect to the others; I'll leave it to the authors to tell [email-masked] how they would like to proceed with their drafts.

On Jan 4, 2011, at 8:21 AM, IETF Agenda wrote:

> -----------------------------------------------------------------
> 80th IETF ˆ Prague, Czech Republic
> Meeting Dates: March 27-April 1, 2011
> Host: CZ.NIC
> -----------------------------------------------------------------
> IETF meetings start Monday morning and run through Friday mid-afternoon
> (15:15).
> 
> We are accepting scheduling requests for all Working Groups and BOFs
> starting today.  The milestones and deadlines for scheduling-related
> activities are as follows:
> 
> NOTE: cutoff dates are subject to change.
> 
>   2010-12-27 (Monday): Working Group and BOF scheduling begins. To
> request a Working Group session, use the IETF Meeting Session Request
> Tool. 
>   2011- 01-31 (Monday): Cutoff date for BOF proposal requests to Area
> Directors at 17:00 PT (01:00 Tuesday, February 1 UTC). To request a BOF,
> please see instructions on Requesting a BOF. 
>   2011-02-14 (Monday): Cutoff date for requests to schedule Working Group
> meetings at 17:00 PT (01:00 Tuesday, February 15 UTC). To request a
> Working Group session, use the IETF Meeting Session Request Tool. 
>   2011-02-14 (Monday): Cutoff date for Area Directors to approve BOFs at
> 17:00 PT (01:00 Tuesday, February 15 UTC). 
>   2011-02-24 (Thursday): Preliminary agenda published for comment. 
>   2011-02-28 (Monday): Cutoff date for requests to reschedule Working
> Group and BOF meetings 17:00 PT (01:00 Tuesday, March 1 UTC). 
>   2011-02-28 (Monday): Working Group Chair approval for initial document
> (Version -00) submissions appreciated by 17:00 PT (01:00 Tuesday, March 1
> UTC). 
>   2011-03-04 (Friday): Final agenda to be published. 
>   2011-03-16 (Wednesday): Draft Working Group agendas due by 17:00 PT
> (01:00 Thursday, March 17 UTC), upload using IETF Meeting Materials
> Management Tool. 
>   2011-03-21 (Monday): Revised Working Group agendas due by 17:00 PT
> (01:00 Tuesday, March 22 UTC), upload using IETF Meeting Materials
> Management Tool.
> 
> Submitting Requests for Working Group and BOF Sessions
> 
> Please submit requests to schedule your Working Group sessions using the
> "IETF Meeting Session Request Tool," a Web-based tool for submitting all
> of the information that the Secretariat requires to schedule your
> sessions.
> 
> The URL for the tool is:
> 
> https://datatracker.ietf.org/cgi-bin/wg/wg_session_requester.cgi
> 
> Instructions for using the tool are available at:
> 
> http://www.ietf.org/instructions/session_request_tool_instruction.html
> 
> Please send requests to schedule your BOF sessions to [email-masked]. 
> Please include the acronym of your BOF in the subject line of the message,
> and include all of the information specified in item (4) of "Requesting
> Meeting Sessions at IETF Meetings" in the body.  (This document is
> included below.)
> 
> Submitting Session Agendas
> 
> For the convenience of meeting attendees, we ask that you submit the
> agendas for your Working Group sessions as early as possible.  Draft
> Working Group agendas are due Wednesday, March 16, 2011 by 17:00 PT (01:00
> Thursday, March 17 UTC).  Revised Working Group agendas are due no later
> than Monday, March 21, 2011 at 17:00 PT (01:00 Tuesday, March 22 UTC). 
> The proposed agenda for a BOF session should be submitted along with your
> request for a session.  Please be sure to copy your Area Director on that
> message.
> 
> Please submit the agendas for your Working Group sessions using the "IETF
> Meeting Materials Management Tool," a Web-based tool for making your
> meeting agenda, minutes, and presentation slides available to the
> community before, during, and after an IETF meeting.  If you are a BOF
> chair, then you may use the tool to submit a revised agenda as well as
> other materials for your BOF once the BOF has been approved.
> 
> The URL for the tool is:
> 
> https://datatracker.ietf.org/cgi-bin/wg/wg_proceedings.cgi
> 
> Additional information about this tool is available at:
> 
> http://www.ietf.org/instructions/meeting_materials_tool.html
> 
> Agendas submitted via the tool will be available to the public on the
> "IETF Meeting Materials" Web page as soon as they are submitted.
> 
> The URL for the "IETF 80 Meeting Materials" Web page is:
> 
> https://datatracker.ietf.org/public/meeting_materials.cgi?meeting_num=80
> 
> If you are a Working Group chair, then you already have accounts on the
> "IETF Meeting Session Request Tool" and the "IETF Meeting Materials
> Management Tool."  The same User ID and password will work for both tools.
>  If you are a BOF chair who is not also a Working Group chair, then you
> will be given an account on the "IETF Meeting Materials Management Tool"
> when your BOF has been approved.  If you require assistance in using
> either tool, or wish to report a bug, then please send a message to:
> [email-masked].
> ===============================================================
> For your convenience, comprehensive information on requesting meeting
> sessions at IETF 80 is presented below:
> 
> 1. Requests to schedule Working Group sessions should be submitted using
> the "IETF Meeting Session Request Tool," a Web-based tool for submitting
> all of the information required by the Secretariat to schedule your
> sessions.  The URL for the tool is:
> 
> https://datatracker.ietf.org/cgi-bin/wg/wg_session_requester.cgi
> 
> Instructions for using the tool are available at:
> 
> http://www.ietf.org/instructions/session_request_tool_instruction.html
> 
> If you require an account on this tool, or assistance in using it, then
> please send a message to [email-masked].  If you are unable to use
> the tool, then you may send your request via e-mail to [email-masked],
> with a copy to the appropriate Area Director(s).
> 
> Requests to schedule BOF sessions must be sent to [email-masked] with a
> copy to the appropriate Area Director(s).
> 
> When submitting a Working Group or BOF session request by e-mail, please
> include the Working Group or BOF acronym in the Subject line.
> 
> 2. BOFs will NOT be scheduled unless the Area Director(s) approved
> request is accompanied by a BOF'S FULL NAME AND ACRONYM, AREA, CHAIR(S)
> NAME(S) (given together with e-mail address(es)), AN AGENDA AND FULL
> DESCRIPTION, and the information requested in (4) below. (Please read the
> BOF Procedure at: http://www.ietf.org/ietf/1bof-procedures.txt before
> requesting a session for a BOF.)
> 
> 3. A Working Group may request either one or two sessions.  If your
> Working Group requires more than two sessions, then your request must be
> approved by an Area Director.  Additional sessions will be assigned, based
> on availability, after Monday, February 28, 2011 at 17:00 PT (01:00
> Tuesday, March 1 UTC), the cut-off date for requests to reschedule a
> session.
> 
> 4. You MUST provide the following information before a Working Group or
> BOF session will be scheduled:
> 
>    a. Working Group or BOF full name with acronym in brackets: 
> 
>    b. AREA under which Working Group or BOF appears:
> 
>    c. CONFLICTS you wish to avoid, please be as specific as possible:
> 
>    d. Expected Attendance:
> 
>    e. Special requests:
> 
>    f. Number of sessions:
> 
>    g. Length of session: 
>       - 1 hour 
>       - 1 1/2 hours
>       - 2 hours 
>       - 2 1/2 hours
> 
> For more information on scheduling Working Group and BOF sessions, please
> refer to RFC 2418 (BCP 25), "IETF Working Group Guidelines and Procedures"
> (http://www.ietf.org/rfc/rfc2418.txt).
> ===============================================================
> For your convenience please find here a list of the IETF Area Directors
> with their e-mail addresses:
> 
> IETF Chair 
> Russ Housley <[email-masked]>
> 
> Applications Area (app)
> Alexey Melnikov <[email-masked]>
> Peter Saint-Andre <[email-masked]> 
> 
> Internet Area (int) 
> Jari Arkko <[email-masked]>
> Ralph Droms <[email-masked]> 
> 
> Operations & Management Area (ops) 
> Ronald Bonica <[email-masked]>
> Dan Romascanu <[email-masked]>
> 
> Real-time Applications and Infrastructure Area (rai)
> Gonzalo Camarillo <[email-masked]>
> Robert Sparks <[email-masked]> 
> 
> Routing Area (rtg) 
> Stewart Bryant <[email-masked]>
> Adrian Farrel <[email-masked]> 
> 
> Security Area (sec) 
> Tim Polk <[email-masked]>
> Sean Turner <[email-masked]> 
> 
> Transport Area (tsv) 
> Lars Eggert <[email-masked]>
> David Harrington <[email-masked]> 
> ===========================================================
> 79th IETF Meeting Attendance Number
> 
> Working Group	
> 
> 6lowpan - 108
> 6man - 178
> abfab - 50
> alto - 110
> ancp - 26
> apparea (AG) - 74
> armd BOF - 70
> atoca - 37
> autoconf - 29
> avt - 82
> avt (2nd session) - 55
> behave - 103
> bmwg - 15
> ccamp - 100
> ccamp (2nd session) - 79
> codec - 59
> conex - 43
> core - 81
> core (2nd session) - 67
> cuss - 14
> decade - 59
> dhc - 28
> dime - 14
> dispatch - 61
> dnsext - 99
> dnsop - 96
> drinks - 37
> dtnrg (RG) - 22
> eai - 31
> ecrit - 37
> eman - 56
> emu - 21
> fecframe - 8
> forces - 23
> geopriv - 39
> grow - 44
> hiprg (RG) - 44
> hokey - 22
> iddtspec - 13
> idr - 80
> intarea (AG) - 111
> ipfix - 37
> ippm - 23
> ipsecme - 28
> iri - 18
> isis - 52
> isms - 14
> karp - 50
> kidns - 122
> kitten - 31
> krb-wg - 12
> l2vpn - 119
> l3vpn - 92
> lisp - 69
> lwip - 156
> manet - 35
> martini - 36
> mboned - 18
> mext - 69
> mext (second session) - 64
> mif - 114
> mip4 - 10
> mmusic - 50
> mpls - 150
> mpls (2nd session) - 158
> mptcp - 101
> mptcp (2nd session) - 64
> msec - 33
> multimob - 61
> nbs BPF - 101
> nea - 30
> netconf - 42
> netext - 52
> netmod - 28
> nfsv4 - 25
> nfsv4 (second session) - NO SHEETS
> opsarea (AG) - 40
> opsawg - 51
> ospf - 53
> p2psip - 58
> pcp - 59
> pim - 47
> pkix - 30
> ppsp - 38
> precis - 31
> pwe3 - 140
> radext - 20
> roll - 72
> rtgarea (AG) - 135
> rtgwg - 56
> saag (AG) - 90
> samrg (RG) - 20
> savi - 67
> scap BOF - 44
> sidr - 68
> sipclf - 19
> sipcore - 57
> siprec - 44
> softwire - 110
> tcpm - 25
> tictoc - 17
> trill - 72
> tsvarea (AG) - 33
> tsvwg - 65
> v6ops - 203
> v6ops (second session) - 159
> vcarddav - 13
> vnrg (RG) - 48
> websec - 101
>

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 06 Jan 2011 16:34:38 +1300

Hi Fred,

I and a couple of others are working on something that starts like this:

draft-carpenter-v6ops-6to4-teredo-advisory-00

Abstract

This document provides advice to network operators about deployment of two
techniques for automatic tunneling of IPv6 over IPv4, namely 6to4 and Teredo.
It is principally addressed to Internet Service Providers, including those
that do not yet support IPv6. Content providers are also covered. The
intention of the advice is to minimise both user dissatisfaction and help
desk calls.

I'm afraid I don't have more to offer at this time (the document is
mainly empty beyond that point) but assuming we can get it out
before the cutoff, I'd like to ask for a slot.

I have no doubt it will cross reference
draft-ietf-v6ops-v6-aaaa-whitelisting-implications and
draft-wing-v6ops-happy-eyeballs-ipv6, but it is a distinct
topic.

   Brian

---

From: Fred Baker <[email-masked]>
Date: Wed, 5 Jan 2011 19:51:31 -0800

Do we really need a fourth document on the subject of teredo stuff? What are you covering that hasn't already been covered?

---

From: "Gunter Van de Velde (gvandeve)" <[email-masked]>
Date: Thu, 6 Jan 2011 12:11:44 +0100

Ole and me are working on a update based upon feedback of the WG comments on the harmful tunnels draft.
So, as result a short slot for explaining those doc changes would be useful.

G/

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Fred Baker (fred)
Sent: woensdag 5 januari 2011 2:21
To: v6ops v6ops
Subject: Re: [v6ops] 80th IETF - Working Group/BOF Scheduling

_______________________________________________
v6ops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 07 Jan 2011 08:18:23 +1300

1. It's 6to4 as well as Teredo.

2. It will cover concrete operational recommendations for ISPs.
I'm not aware of any document that does that, rather than pointing out
problems. -whitelisting and -happy-eyeballs are workarounds, not
fixes.

I believe it will fill a gap, but those are just words until the
text is ready.

Regards
   Brian

---

From: "Gunter Van de Velde (gvandeve)" <[email-masked]>
Date: Fri, 7 Jan 2011 13:05:23 +0100

I am one of the folks amongst others helping Brian out with text around
Teredo.
The way I see it is that it is not a fix, but recommendations 
to improve the user IPv6 experience at any cost, and deliver
recommendations to ISP's. 
As Brian mentioned "the tooth paste is out of the 
tube and can not be put back in again easily". Hence we should use the
lost 
elements in the best possible way.

Imho the solution is to run dual stack, and forget out non-managed
tunnels imho.
(which is btw a different draft of work I am working upon
-harmful-tunnels-)

G/

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Brian E Carpenter
Sent: donderdag 6 januari 2011 20:18
To: Fred Baker (fred)
Cc: v6ops v6ops
Subject: Re: [v6ops] 80th IETF - Working Group/BOF Scheduling

Regards
   Brian

On 2011-01-06 16:51, Fred Baker wrote:
> Do we really need a fourth document on the subject of teredo stuff?
What are you covering that hasn't already been covered?