Subject: [v6ops] 6to4-historic summary point: 6. "Keep peer to peer 6to4"

From: Fred Baker <[email-masked]>
Date: Wed, 27 Apr 2011 13:17:49 -0700

> 6. "Keep peer to peer 6to4"
> ---------------------------
>   - There are parts which mention relays, and parts which don't. I think draft-ietf-v6ops-6to4-to-historic 
>     fairly well explains what's wrong with relays, but it doesn't address what's wrong with 6to4-6to4
>     communication. And if there is not much wrong with 6to4-6to4 scenario (either between the nodes or
>     between nodes and islands), why should that part be moved to historic.
> 
> Action: Unsure. 6to4 is useful for e.g. BGP tunneling, as a way of getting "globally" scoped addresses without an
>        ISP, can be used for IPv6 transport over other managed tunnels... none of these uses are described in
>        3056, 3068. comments?

If you have an opinion in this area, please comment.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 28 Apr 2011 09:13:53 +1200

> If you have an opinion in this area, please comment.

There's nothing wrong with a closed user group using 6to4 for p2p communication,
just as there's nothing wrong with the managed-routing usage of 6to4 described
in RFC3056 (although nobody has ever been reported to use it). But we are
now moving from the era when the normal expectation was that ISPs were IPv4-only,
so those modes of 6to4 had clear value, to an era when the normal expectation
will be that ISPs support IPv6, so those modes of 6to4 will become pointless.
Since we can't conveniently declare half an RFC historic, let's just declare
the whole thing historic. This act will not cause p2p usage of 6to4 to break,
so where's the harm?

    Brian