Subject: [v6ops] comments on stateless mechanism presentation

From: Maglione Roberta <[email-masked]>
Date: Fri, 1 Apr 2011 09:56:33 +0200

Hello,
   I would like to try to clarify the comment I made yesterday on slide 6.
The third bullet of this slide says:
"ISPs may adopt flexible address rules, no extra requirements on address format and address allocation"

My understanding of this is that the purpose of this slide is to compare the impacts of the different transition mechanisms have on the address allocation scheme that the ISP has to use.

dIVI uses a specific format to build the IPv6 address, made by concatenating an IPv6 prefix with an IPv4 + a port, thus it introduces some constrains on the addresses scheme to be used in the network

While DS-Lite does not have any specific requirement on the IPv6 prefix delegated to the customers.

The table in slide 6 in the first column for DS-LIte says:
"Address of the tunnel end to be passed"

This sentence refers to the address of the AFTR that needs to be provisioned on the B4 in order to allow the B4 to setup the IPv4 over IPv6 tunnel.

This is a provisioning issue (and BTY it solved by DHCPv6 option specified in draft-ietf-softwire-ds-lite-tunnel-option, now in RFC queue).
This point is NOT related to the address allocation scheme to be used by the ISP, thus I don't think it should appear in this table.

If you want to compare the provisioning aspects of the different techniques I would suggest adding a separate slide for them.

Going to your slide 11: Flexible addressing
In my opinion DS-Lite has some advantages compared to dIVI on Flexible addressing point because, as I said before, DS-Lite does not requires a specific format for the IPv6 prefix.

Thanks,
Regards,
Roberta

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

---

From: Fred Baker <[email-masked]>
Date: Mon, 4 Apr 2011 18:00:53 +0200

Shouldn't this discussion be happening on softwire@?

On Apr 1, 2011, at 9:56 AM, Maglione Roberta wrote:

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Maglione Roberta <[email-masked]>
Date: Tue, 5 Apr 2011 16:41:02 +0200

Yes this discussion belongs to softwire, the reason why I started the thread here was because my initial comment and suggestions were related to one of the slide presented during v6ops meeting.

Thanks,
Roberta

---

From: 孙琼 <[email-masked]>
Date: Tue, 5 Apr 2011 22:46:58 +0800

Hi, all,

Thanks. I will update the slides soon and we could discuss it further in
softwire.

Best regards

Qiong

2011/4/5 Maglione Roberta <[email-masked]>

> Yes this discussion belongs to softwire, the reason why I started the
> thread here was because my initial comment and suggestions were related to
> one of the slide presented during v6ops meeting.
>
> Thanks,
> Roberta
>