Subject: [v6ops] new draft: draft-fling-v6ops-hybrid-bridged-routed-00.txt

From: <[email-masked]>
Date: Fri, 8 Apr 2011 06:55:00 -0700 (PDT)

A new draft has been posted, at http://tools.ietf.org/draft-fling-v6ops-hybrid-bridged-routed-00.txt. Please take a look at it and comment.

---

From: james woodyatt <[email-masked]>
Date: Fri, 08 Apr 2011 09:32:10 -0700

> A new draft has been posted, at http://tools.ietf.org/draft-fling-v6ops-hybrid-bridged-routed-00.txt. Please take a look at it and comment.

I have reviewed this draft.  My only comment is editorial.

This draft only applies to CPE routers that have ATM interfaces.  The title should be changed to reflect that, and I recommend prepending the phrase "In ATM networks," to the first sentence of the Introduction section.

--
james woodyatt <[email-masked]>
member of technical staff, core os networking

---

From: 朱彥如 <[email-masked]>
Date: Tue, 12 Apr 2011 11:02:24 +0800

The link for the draft is not right. Please refer to :
http://tools.ietf.org/html/draft-fling-v6ops-hybrid-bridged-routed-00

Yann-Ju
ChungHwa Telecom.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 08, 2011 9:55 PM
To: [email-masked]
Cc: [email-masked]
Subject: [v6ops] new draft: draft-fling-v6ops-hybrid-bridged-routed-00.txt

A new draft has been posted, at http://tools.ietf.org/draft-fling-v6ops-hybrid-bridged-routed-00.txt. Please take a look at it and comment.
_______________________________________________
v6ops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Fred Baker <[email-masked]>
Date: Tue, 12 Apr 2011 11:32:01 -0700

> This draft only applies to CPE routers that have ATM interfaces.  The title should be changed to reflect that, and I recommend prepending the phrase "In ATM networks," to the first sentence of the…

The authors will correct me, but I think they're talking about DSL networks, which have historically been ATM-based. They generally come out to an Ethernet interface, and use the bridged mode to get traffic to that interface.

I do question the implication there - I have no problem with someone implementing a residential CPE as a bridge, but it has direct meaning upstream, and it's a different service for the user than we usually suggest. The cpe-router drafts, both of them, have specifically looked at the CPE as an IPv6 router. So - question for the assembled throngs - what's your opinion of a CPE that runs as an Ethernet switch?

---

From: Mikael Abrahamsson <[email-masked]>
Date: Tue, 12 Apr 2011 20:48:37 +0200 (CEST)

On Tue, 12 Apr 2011, Fred Baker wrote:

> I do question the implication there - I have no problem with someone 
> implementing a residential CPE as a bridge, but it has direct meaning 
> upstream, and it's a different service for the user than we usually 
> suggest. The cpe-router drafts, both of them, have specifically looked 
> at the CPE as an IPv6 router. So - question for the assembled throngs - 
> what's your opinion of a CPE that runs as an Ethernet switch?

I've seen this in DSL deployments where rfc1483bridged is run over ATM, 
basically making the DSL transport pure L2 ethernet (ethernet uplinked 
DSLAM, ETHoATMoDSL on the access line, the modem is a media converter and 
has an ethernet downlink to the LAN which is bridged all the way to the 
uplink of the DSLAM.

The CPE in this case wouldn't do much, and the DSLAM would be a SAVI-WG 
type device which would need to do SAVI-WG functionality. The CPE in this 
case wouldn't do much at all apart from bridging the packets.

The hybrid problem might come in all the cases we've been looking into 
though, but I would really like to encourage ISPs to have a routed CPE 
anyway. Having your PE router participate in the home routing domain doing 
SLAAC has some serious scaling implications that can get ugly really 
quickly. The simple handoff with LL only (or single DHCPv6 /128 WAN 
address) for the CPE, and do DHCPv6-PD to it, seems a lot more clean and 
scalable.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: [email-masked]
Date: Tue, 12 Apr 2011 15:38:58 -0400

<inline>

On Apr 8, 2011, at 9:32 AM, james woodyatt wrote:
>> A new draft has been posted, at 
http://tools.ietf.org/draft-fling-v6ops-hybrid-bridged-routed-00.txt. 
Please take a look at it and comment.
> I do question the implication there - I have no problem with someone 
implementing 
> a residential CPE as a bridge, but it has direct meaning upstream, and 
it's a different 
> service for the user than we usually suggest. The cpe-router drafts, 
both of them, 
> have specifically looked at the CPE as an IPv6 router. So - question for 
the assembled 
> throngs - what's your opinion of a CPE that runs as an Ethernet switch?
 
IMHO, this seems to be more of a confusion about terminology than an 
actual debate about
the architecture. In CableLabish, the cable modem (CM) acts as a bridge 
and the CPE is
any ethernet device requesting an address behind that modem. Even if the 
cable modem 
implements an embedded router, it is still conceptually separated from the 
modem. 
As Fred points out, draft-ietf-v6ops-ipv6-cpe-router only considers a CPE 
from the 
routed device point of view. 

Reading draft hybrid-bridged-routed, the definition of the CPE is 
different here. The 
equipment described here as the CPE in "Bridged Mode" rather acts as a dsl 
modem, 
in a way similar to the cable modem in the CableLabs model. 

Correct me if I'm wrong here DSL people, but isn't the "Routed Mode" 
described in 
hybrid-bridged-routed actually a "Bridge Mode" device with a routed device 
in the 
same physical box? 

I believe there is some value, from a specification point of view, in 
splitting the bridging function from the routing function. Whether they 
are 
implemented in the same box or not then becomes an implementation detail. 
The important thing here is not to call them both "CPE". Is there a need 
for 
a new draft describing this terminology in details? 

/JF

---

From: Mikael Abrahamsson <[email-masked]>
Date: Tue, 12 Apr 2011 21:43:15 +0200 (CEST)

On Tue, 12 Apr 2011, [email-masked] wrote:

> described in hybrid-bridged-routed actually a "Bridge Mode" device with 
> a routed device in the same physical box?

Yes, there are plenty of CPEs that'll do "rfc1483bridge" and into that 
bridge domain, have a IP interface. This is as you say, conceptually like 
a bridge (from ETHoATM to ETH) and then internally having a router 
connected to it.

> for a new draft describing this terminology in details?

I agree. For me the ATM bridge is a CPE media converter, not a CPE router. 
They are both CPEs though (Customer Premises Equipment).

---

From: "STARK, BARBARA H (ATTSI)" <[email-masked]>
Date: Tue, 12 Apr 2011 15:56:44 -0400

I have to say that I'm a bit confused as to who the audience is for this
draft, and whether there exist members of that audience who are asking
for guidance in this area. It would appear that the draft may be
targeted at "Provider Edge" providers (aka access providers). But I'm
not aware of any such providers who are requesting guidance in this
area. At least not from IETF. Is China Telecom asking for such guidance?
Or are they wanting to give guidance to others (in which case, others
need to be wanting such guidance for a draft to make sense)?

It's true that there exist a great number of "bridge modems" for both
DOCSIS and DSL. These bridge Ethernet MAC between DOCSIS or (ATM)/DSL
and Ethernet PHY. They will continue to exist, and there's nothing wrong
with them (unless your access provider changes the access PHY ;) ). They
won't break in the presence of IPv6, because they truly don't care
what's above the Ethernet MAC layer. In early years, people attached a
single computer to the Ethernet PHY side of the bridge, and the computer
got IPv4 connectivity to/through the access provider. When people got
more computers, they put in a router (IPv4, with NAT), because many
access providers (especially in the US) would only hand out a single
IPv4 address, and the router solved that problem. Once the access
provider supports IPv6, users can swap out the old IPv4-only router with
a brand new "CE router" that does IPv4 and IPv6. The fact that a bridge
exists in-between is irrelevant. The user with a single computer behind
a bridge might be a little more challenged with IPv6, if the access
provider is using the "unnumbered model" and expecting IA_PD to be used.
But this is easily solved by putting in a router. 

In Europe (I'm not familiar with Asia), due to some interesting
regulations, some DSL access providers support bridged "residential
gateways" (RGs). These devices acquire an IPv4 address for themselves
(for management and host applications like maybe VoIP in the RG), but
bridge traffic to the home network. The user could put in their own home
network router, that could acquire an IPv4 address.

Which is to say, bridging exists all over the world, with DSL and
DOCSIS. But the existence of bridging doesn't necessarily cause the
problem that this draft seems to be trying to address. At its root, this
draft seems to be talking about an access network that wants to support
both hosts and routers. This could occur for a variety of reasons. For
example, it could be an LTE network that has many host devices, but
where there are also many people who slap a PC card into a router and
use LTE to connect their home network. Or it could be that the access
provider does still want to support that single computer that I
mentioned above, in addition to routers. Some access providers have also
discussed this in conjunction with PPPoE service (for access networks
that use PPPoE above Ethernet to access IPv6 or IPv6 and IPv4), where
the device connecting with PPPoE might be a computer or game console, or
it might be a CE router. The concern I've generally heard, is that
access providers want to provide hosts with an address via SLAAC, but
they want to give routers an address either through IA_NA or
"unnumbered" from the IA_PD pool. And if a CE router sees a SLAAC prefix
being advertised in the RA, it's likely to do SLAAC. That is what it is.
If access providers want a single IPv6 access network to support both
hosts and CE routers, then there are decisions they have to make about
how to set it up. 

The thing is, I haven't heard any providers asking someone (IETF or BBF)
to tell them how to do this.

Barbara

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Fred Baker
> Sent: Tuesday, April 12, 2011 2:32 PM
> To: james woodyatt
> Cc: IPv6 Ops WG
> Subject: Re: [v6ops] new
draft:draft-fling-v6ops-hybrid-bridged-routed-
> 00.txt
> >> A new draft has been posted, at http://tools.ietf.org/draft-fling-
> v6ops-hybrid-bridged-routed-00.txt. Please take a look at it and
> comment.
> >
> > This draft only applies to CPE routers that have ATM interfaces.
The
> title should be changed to reflect that, and I recommend prepending
the
> phrase "In ATM networks," to the first sentence of the Introduction
> section.
> 
> The authors will correct me, but I think they're talking about DSL
> networks, which have historically been ATM-based. They generally come
> out to an Ethernet interface, and use the bridged mode to get traffic
> to that interface.
>

---

From: Michael Newbery <[email-masked]>
Date: Wed, 13 Apr 2011 15:56:39 +1200

On 13/04/2011, at 7:56 AM, STARK, BARBARA H (ATTSI) wrote:

> what's above the Ethernet MAC layer. 

Not quite. DOCSIS modems are indeed bridges, but they are IP aware bridges. In particular they have extensive filters in place, based on Ethertype, IP address and netmask. Furthermore, they can snoop the traffic for DHCP. That's why DOCSIS 3.0 needed to add IPv6 support. All of the IP filters and DHCP support are IPv4 only with DOCSIS 1.0/1.1/2.0, which reduces the filter options to Ethertype, which means you can allow or deny IPv6, but not filter it.

Those filters are there for a reason. Actually, many reasons, which I don't think I need to go into here. Suffice it to say that without them, many service providers are forced to deny IPv6 carriage, which means that DOCSIS 1.0/1.1/2.0 networks may be layer 2, but they nevertheless don't support IPv6. DOCSIS 3.0 does, and the IPv6 filters have been backported to DOCOS 2.0 and are available if your cable modem can support the firmware upgrade (not all have the necessary hardware capability).

Note that this is probably not strictly relevant to the document in question.

---

From: 凌芳瑜(Fang-Yu Ling) <[email-masked]>
Date: Wed, 13 Apr 2011 16:28:32 +0800

Hi All, 

Thanks for your comments.

Our company is an ISP in Taiwan. We do encounter the coexist problems of bridged and routed mode.
We have deployed the model which is described in this draft in a trial environment with hundreds customers.
We do think it is a successful model after one year experiment.
We hope to share this experience to other ISPs who have the same requirement.

Something we need to clarify:
1. We provide VDSL access service in our company. But our model can be used for any other physical network, not only for ATM.

2. In our draft, the "bridged mode" CPE can be a "DSL Modem", only has bridge function. Subscriber connects a router behind this CPE is out of the scope. And the "routed mode" CPE is a router which is described in draft-ietf-v6ops-ipv6-cpe-router-09 (Basic Requirements for IPv6 Customer Edge Routers) or you can say it is a Home Gateway.

3. The problem we'd like to solve is to simplify the configuration of PE. Before this model, PE's operator has to know the subscriber is in bridge or routed mode. The operator configures a IPv6 address for RA if the subscriber is in bridged mode. The operator configures a IPv6 prefix for DHCP-PD if the subscriber is in routed mode. But in our model, operator configures both for each no matter the subscriber is in which mode. It is to simplify the configuration.

Regards,
Fang
-------------------------------------------
Fang-Yu Ling
Chunghwa Telecom Laboratories
mailto:[email-masked]
TEL: +886-3-424-5631
FAX: +886-3-424-4888

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael Newbery
Sent: Wednesday, April 13, 2011 11:57 AM
To: IPv6 Ops WG
Subject: Re: [v6ops] new draft:draft-fling-v6ops-hybrid-bridged-routed-00.txt

On 13/04/2011, at 7:56 AM, STARK, BARBARA H (ATTSI) wrote:

> and Ethernet PHY. They will continue to exist, and there's nothing 
> wrong with them (unless your access provider changes the access PHY ;) 
> ). They won't break in the presence of IPv6, because they truly don't 
> care what's above the Ethernet MAC layer.

---

From: [email-masked]
Date: Wed, 13 Apr 2011 10:24:05 -0400

> (Fang-Yu Ling) <[email-masked]> wrote
> 3. The problem we'd like to solve is to simplify the configuration of 
PE. 
> Before this model, PE's operator has to know the subscriber is in bridge 

> or routed mode. The operator configures a IPv6 address for RA if the 
subscriber 
> is in bridged mode. The operator configures a IPv6 prefix for DHCP-PD if 
the 
> subscriber is in routed mode. But in our model, operator configures both 
for 
> each no matter the subscriber is in which mode. It is to simplify the 
configuration.

Thank you for clarifying your need here. 

My humble opinion: 
- You need to send RAs anyway in both cases, so there's no difference in 
configuration here. 
- It's impossible to differentiate in advance between a user with an 
embedded routed CPE 
and a user with a bridged CPE with a standalone routed CPE behind it (for 
example what happens 
if a user adds a router later?). The bottom line is that you have to 
provision PD prefixes 
for all of your users anyway. 

No matter what, you shouldn't be worried about running out of IPv6 address 
space. 
If you don't have enough space for all of your users, ask your RIR for 
more space. 
Some RIRs will ask for justification of the previous block, but that's an 
issue 
with your local RIR policies and better discussed on the related mailing 
list. 

/JF

---

From: "Lee, Yiu" <[email-masked]>
Date: Thu, 14 Apr 2011 03:49:26 +0000

Hi Fang,

I agree with Jeff that you should prepare to provide PD to even the bridged host. Like Barbara said in another reply, even air-card today can be connected to a small CPE to provider routed service.

I am not 100% clear what the draft suggests.  Do you suggest that the PE sends out RA for both host and CPE? If CPE wants a PD, it would send out a DHCP-PD request to ask for PD from the PE (assuming dhcp server is collated with the PE)?

/Yiu

From: <[email-masked]<mailto:[email-masked]>>
Date: Wed, 13 Apr 2011 10:24:05 -0400
To: Fang-Yu Ling <[email-masked]<mailto:[email-masked]>>
Cc: IPv6 Ops WG <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Subject: Re: [v6ops] new draft:draft-fling-v6ops-hybrid-bridged-routed-00.txt

> (Fang-Yu Ling) <[email-masked]<mailto:[email-masked]>> wrote
> 3. The problem we'd like to solve is to simplify the configuration of PE.
> or routed mode. The operator configures a IPv6 address for RA if the subscriber
> is in bridged mode. The operator configures a IPv6 prefix for DHCP-PD if the
> subscriber is in routed mode. But in our model, operator configures both for
> each no matter the subscriber is in which mode. It is to simplify the configuration.

My humble opinion:
- You need to send RAs anyway in both cases, so there's no difference in configuration here.
- It's impossible to differentiate in advance between a user with an embedded routed CPE
and a user with a bridged CPE with a standalone routed CPE behind it (for example what happens
if a user adds a router later?). The bottom line is that you have to provision PD prefixes
for all of your users anyway.

No matter what, you shouldn't be worried about running out of IPv6 address space.
If you don't have enough space for all of your users, ask your RIR for more space.
Some RIRs will ask for justification of the previous block, but that's an issue
with your local RIR policies and better discussed on the related mailing list.

/JF

> Fang

_______________________________________________ v6ops mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/v6ops

---

From: 凌芳瑜(Fang-Yu Ling) <[email-masked]>
Date: Thu, 14 Apr 2011 15:05:25 +0800

Thanks all, we will upload a revised version to explain clearer about our idea.

Fang

From: Lee, Yiu [mailto:[email-masked]]
Sent: Thursday, April 14, 2011 11:49 AM
To: [email-masked]; 凌芳瑜(Fang-Yu Ling)
Cc: IPv6 Ops WG; [email-masked]
Subject: Re: [v6ops] new draft:draft-fling-v6ops-hybrid-bridged-routed-00.txt

Hi Fang,

/Yiu

My humble opinion:

/JF