Subject: Re: [v6ops] Subject: Re: Happy eyeballs update, draft-ietf-v6ops-happy-eyeballs-02

From: Tim Chown <[email-masked]>
Date: Wed, 1 Jun 2011 11:00:47 +0100

On 27 May 2011, at 01:57, "Dan Wing" <[email-masked]> wrote:

>> -----Original Message-----
>> From: [email-masked] [mailto:[email-masked]] On Behalf
>> Of Ray Hunter
>> 
>> So if Happy Eyeballs does have the ambition to be a more generic
>> solution to the address family selection problem, it should allow
>> tuning of the end node protocol selection parameters by the network
>> manager, as Philip Homburg and Marc Andrews have already suggested.
> 
> Such ability is suggested in the I-D, and could be gleaned from
> existing DHCPv6 parameters.  Or we may decide to define new DHCPv6
> parameters for such tuning.

Ray,

There is a dhc-based proposal for distributing RFC3484 policy tables. So if you think such a hook is also needed for HE, you can put forward a draft describing how that would work.

Tim

---

From: "Templin, Fred L" <[email-masked]>
Date: Wed, 1 Jun 2011 08:05:45 -0700

Hi Dan, 

> From: Dan Wing [mailto:[email-masked]] 
> Sent: Tuesday, May 31, 2011 6:12 PM
> To: Templin, Fred L; [email-masked]
> Cc: 'Andrew Yourtchenko (ayourtch)'
> Subject: RE: [v6ops] Subject: Re: Happy eyeballs update, 
> draft-ietf-v6ops-happy-eyeballs-02
> 
> > If I set address selection policy rules that de-prefer
> > certain IPv6 prefixes (e.g., 2001:db8:0:1::/64) and makes
> > them to be of lesser priority than IPv4, will HE respect
> > that and use IPv4?
> 
> Not as currently written, no.  The steps are 
> described in
> http://tools.ietf.org/html/draft-ietf-v6ops-happy-eyeballs-02#
> section-5.3
> 
> An algorithm that uses the host's address selection rules
> is easy:  getaddrinfo(), then attempt to connect to each 
> address in the order returned, delaying NNNN milliseconds
> between connection attempts.
> 
> What Happy Eyeballs is trying to accomplish is not simply
> walking the host's address selection table quickly; Happy
> Eyeballs is trying to react to the success (or failure)
> of IPv6 or IPv4, with the idea that (a) the address 
> selection table is incorrect or (b) there is a problem with
> the network path.  (b) cannot be fixed by the address
> selection table.
> 
> There might be some way to get Happy Eyeballs to accomplish
> its goal while still honoring the host's address selection
> policy rule better.  I don't know how to do that, though.
> Ideas welcome.

All I would ask for is that, if the address selection
table prefers IPv4 over a more-specific IPv6 prefix
such as a /64, that IPv4 destination addresses be
preferred over destination addresses covered by the
IPv6 prefix. This is necessary for mature large end-user
networks where there is little incentive to break away
from the use of IPv4 for intra-network communications.

It doesn't seem like too much extra work; do you think
HE can do that?

Thanks - Fred
[email-masked]

> -d