Subject: Re: [v6ops] New Version Notification for draft-sarikaya-v6ops-prefix-delegation-05.txt

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 1 Jun 2011 08:38:09 -0700 (PDT)

If you mean that in addition to an IETF document, a 3GPP document inline  with 
its contents would be good to pursue, I agree. Just like in DHCP  PD Exclude 
draft.

In fact 3GPP needs only some content from Section 3.1. I believe some  day it 
will get there. If you have time talk to your 3GPP people, they  might 
volunteer. 

I am going to try to do the same :-). BTW I believe 23.401 is a better place.

Regards,

Behcet

> I think the question laid by Ole is still valid i.e. whether this I-D is the  
>"best practice" or good guidance for mobile networks. Clearly the I-D has now  
>turned to mostly about 3GPP system. And I seriously think the clarification 3GPP  
>needs for its prefix delegation belongs to TS29.061. For example, it would be  
>beneficial to state there that all prefixes delegated for PDN Connections are  
>/64 (obvious) unless the UE is the requesting router, IAIDs could map to TEIDs  
>etc. Then if we face a problem that requires IETF involvement, we can deal with  
>it here. 
>
> 
> - Jouni
> 
> 
> On May 26, 2011, at 7:59 PM, Behcet Sarikaya  wrote:
> 
> > 
> > 
> >> 
> > 
> >> A new version of  I-D, draft-sarikaya-v6ops-prefix-delegation-05.txt has 
>been  
>
> >>  successfully submitted by Behcet Sarikaya and posted to the IETF   
>repository.
> >> 
> >> Filename:       draft-sarikaya-v6ops-prefix-delegation
> >> Revision:       05
> >> Title:         DHCPv6 Prefix Delegation  as  IPv6 Migration Tool in Mobile 
> >> Networks
> >>  Creation date:      2011-05-26
> >> WG ID:          Individual  Submission
> >> Number of pages:  12
> >> 
> >> Abstract:
> >>   As interest on   IPv6 deployment is increasing in cellular networks
> >>   several  migration  issues are being raised and IPv6 prefix  management
> >>   is the one  addressed in this document.   Based on the idea that DHCPv6
> >>    servers can manage  prefixes, we address prefix management issues such
> >>    as  the access router offloading delegation and release tasks of  the
> >>    prefixes to a DHCPv6 server using DHCPv6 PD.   The access router  first
> >>   requests a prefix for an  incoming mobile node from the DHCPv6  server.
> >>   The access  router may next stateless or stateful address  allocation
> >>    to the mobile node, e.g. with a Router Advertisement or  using  DHCP.
> >>   We also describe prefix management using  Authentication  Authorization
> >>   and Accounting  servers.
> >> 
> >> 
> >> 
> >> 
> >> 
> >> 
> >> The IETF Secretariat
> >> 
> >  _______________________________________________
> > v6ops mailing  list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/v6ops
> 
>

---

From: jouni korhonen <[email-masked]>
Date: Wed, 1 Jun 2011 19:53:07 +0300

> its contents would be good to pursue, I agree. Just like in DHCP  PD Exclude 

No, the other way around. First go to 3GPP, do the clarifications there and then if you find a problem that requires IETF involvement, bring it here. Just like the exclude thing was done.

> I am going to try to do the same :-). BTW I believe 23.401 is a better place.

If you are after detail, which I believe is the intent, then stage-3 documents would be the proper place, not stage-2 like 23.401.

- Jouni

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 1 Jun 2011 11:33:05 -0700 (PDT)

Hi Jouni,
  This draft is an IETF draft. I think that discussing what should be done with 
3GPP, another SDO is out of scope. If you started the exclude thing in 3GPP, 
good for you. But what counts is, it is now an IETF draft.

Many people expressed positive opinions on 
draft-sarikaya-v6ops-prefix-delegation so far. All reviews have been taken care 
of.

Behcet
> No, the other way around. First go to 3GPP, do  the clarifications there and 
>then if you find a problem that requires IETF  involvement, bring it here. Just 
>like the exclude thing was  done.
> 
> 
> If you are after detail, which I believe is the intent, then  stage-3 documents 
>would be the proper place, not stage-2 like 23.401.
> 
> -  Jouni
> 
> > 
> > Regards,
> > 
> > Behcet
> > 
> >

---

From: Cameron Byrne <[email-masked]>
Date: Wed, 1 Jun 2011 12:24:12 -0700

> good for you. But what counts is, it is now an IETF draft.

There is a coordination between the IETF and 3GPP outlined in

http://tools.ietf.org/html/rfc3113

While there is not much detail about the relationship there, my
understanding is that IETF makes the protocols and 3GPP makes the
architecture.  I believe the document in discussion here is an
architecture since it does not specify a new protocol (AFAIK).
Therefore, i think the ideas here are better fit for 3GPP.

> draft-sarikaya-v6ops-prefix-delegation so far. All reviews have been taken care

While i work at a mobile network, i cannot really understand this
draft and what it is trying to achieve clearly.  My confusion starts
with Figure 1, which does not look like any GSM/UMTS/LTE network that
i have ever seen ... although there is some text that says an access
router (AR) is a PDN .... I still do not really recognize it.
Possibly this is my fault.  It appears this draft just explains how
DHCPv6 works at a high level where a PDN talks to a DHCPv6 server and
then relays that info as an RA.... If that is all, and I have not
missed something, i do not think this draft adds much value.

I believe DHCP-PD is clearly defined at a 3GPP Release 10 feature, if
i remember correctly.... so it is already being defined there.

Once again, sorry if i missed something obviously unique to this draft
that would make it a right fit for the IETF and not 3GPP.

Cameron

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 2 Jun 2011 11:52:39 -0700 (PDT)

Hi Cameron,

> architecture. 

3GPP SA2 makes Stage 2 documents which are essentially architecture. But 3GPP 
SA3 works on Stage 3 documents which are the protocol solutions. So 3GPP makes 
both architecture and protocol, not just architecture, having said that I don't 
understand what is the point here?

>  I  believe the document in discussion here is an

Pls. look at v6ops WG documents like 
draft-ietf-v6ops-v6-in-mobile-networks and
draft-ietf-v6ops-3gpp-eps, etc.

Are they defining new protocols? 
They are tutorials.
draft-sarikaya-v6ops-prefix-delegation is of similar kind. It is describing how 
DHCPv6 PD can be used in mobile networks like 3GPP.

> missed something, i do not think this draft adds much value.

Well that is Sec. 3.1. 
Then there is Sec. 3.2 and 3.3
and so on, pls continue to read.

> i  remember correctly.... so it is already being defined there.

Not sure which specific document you're referring to. If it is being defined 
then draft-sarikaya-v6ops-prefix-delegation will be useful to them. This is 
inline with v6ops charter.

I am disappointed with the negativity in this mail which is unusual to this 
author. I was expecting a review that would lead to revision -06 but could not 
find anything to change.

Regards,

Behcet

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 6 Jun 2011 14:52:27 -0700 (PDT)

Hi Jason,

Please see my replies inline. I think Cameron also has similar concerns, I am 
replying to you both.

>
>I think this draft is useful for mobile networks. 

Thanks.

> But I still have some 
>questions and comments:

Sure.
>    - What is this draft's final goal?

We clarified this in Section 1 better now. DHCPv6 PD is a scalable method to 
manage prefixes, that is the final goal.

>    - Whether the term 'MN' is the same as 'UE'? If yes, it is better to modify 

>the figure 1.

Done.

>    - It is better to provide the full name of abbreviations. 
Done.
>    - In the figure 3, there should be a DHCP client element in ‘MN’ and a DHCP 

>Server element in AR. Is it better to show them in the figure? 
Done.
>    - What are the Solicit message and Advertise message shown in figure 3 used 

>for? It seems also need to be briefly explained in section 3.2.
Done.

Regards,

Behcet