Subject: [v6ops] Chrome and firefox - happy eyeballs

From: Rashmi <[email-masked]>
Date: Sun, 14 Aug 2011 16:13:37 +0200

Hello,

In the presentation in the recent IETF meeting, 
(http://tools.ietf.org/agenda/81/slides/v6ops-5.pptx) in the last but 
one slide, it is mentioned that "Existing Chrome and Firefox 
Implementations are compliant".
Does this mean that Google chrome and firefox had "happy eyeballs" 
implementation?

-- 
Regards,
Rashmi Purushothama

---

From: Joel Jaeggli <[email-masked]>
Date: Sun, 14 Aug 2011 07:36:13 -0700

yes, they do.

joel

On Aug 14, 2011, at 7:13 AM, Rashmi wrote:

> Hello,
> 
> In the presentation in the recent IETF meeting, (http://tools.ietf.org/agenda/81/slides/v6ops-5.pptx) in the last but one slide, it is mentioned that "Existing Chrome and Firefox Implementations are compliant".
> Does this mean that Google chrome and firefox had "happy eyeballs" implementation?
> 
> -- 
> Regards,
> Rashmi Purushothama
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Rashmi <[email-masked]>
Date: Sun, 14 Aug 2011 16:59:09 +0200

Hello Joel,

Thank you for the quick response. Is there any document I could refer 
regarding these implementations?

-- 
Regards,
Rashmi Purushothama

---

From: Joel Jaeggli <[email-masked]>
Date: Sun, 14 Aug 2011 08:21:06 -0700

think is started here in chromium...

http://src.chromium.org/viewvc/chrome?view=rev&revision=85934

in firefox you can  see it here.

https://bugzilla.mozilla.org/show_bug.cgi?id=621558

On Aug 14, 2011, at 7:59 AM, Rashmi wrote:

> Hello Joel,
> 
> Thank you for the quick response. Is there any document I could refer regarding these implementations?
> 
> -- 
> Regards,
> Rashmi Purushothama
> 
>

---

From: Erik Kline <[email-masked]>
Date: Mon, 15 Aug 2011 08:32:16 +0900

Note that these are "Happy Eyeballs" implementations only the revised
document sense.  The original "Happy Eyeballs" specified an algorithm
for connection statistics and so on.  Niether Chrome nor Firefox
implements this.

Chrome and Firefox have "fast IPv4 fallback" when the destination is
an IPv6 address.  This can be considered "Happy Eyeballs", I believe,
under the new banner of the draft, which aims not to specify an
algorithm so much as a set of criteria for "how to have more
user-appealing behaviour than just trying all addresses serially".

---

From: Mohacsi Janos <[email-masked]>
Date: Mon, 15 Aug 2011 09:24:41 +0200 (CEST)

> https://bugzilla.mozilla.org/show_bug.cgi?id=621558

Can you enable/disable to use their own IP4 fall-back algorithms in their 
configuration interface?
 	Best Regards,
 		Janos Mohacsi?