Subject: [v6ops] draft-ietf-v6ops-v6nd-problems WGLC

From: Fred Baker <[email-masked]>
Date: Sun, 8 Jan 2012 22:32:26 -0800

This is to initiate a two week working group last call of draft-ietf-v6ops-v6nd-problems. Please read it now. If you find nits (spelling errors, minor suggested wording changes, etc), comment to the authors; if you find greater issues, such as disagreeing with a statement or finding additional issues that need to be addressed, please post your comments to the list.

We are looking specifically for comments on the importance of the document as well as its content. If you have read the document and believe it to be of operational utility, that is also an important comment to make.

---

From: Ray Hunter <[email-masked]>
Date: Thu, 12 Jan 2012 12:00:21 +0100

I have reviewed this document in detail, and forwarded a number of nits 
direct to the authors.

I believe that the document contains important operational information 
and advice to the v6ops community.

regards,
RayH

---

From: Joel jaeggli <[email-masked]>
Date: Thu, 12 Jan 2012 08:50:34 -0800

> We are looking specifically for comments on the importance of the document as well as its content. If you have read the document and believe it to be of operational utility, that is also an importa…

The version 01 contains the last major change, to reflect concerns brian
raised at wg acceptance. version 02 is largely just corrections.

The diff2 from 00 to 01 is here:

http://tools.ietf.org/rfcdiff?url2=draft-ietf-v6ops-v6nd-problems-01.txt

 _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: "George, Wes" <[email-masked]>
Date: Fri, 13 Jan 2012 12:01:40 -0500

This is a very useful document overall, and I support its advancement.

A few LC comments:
Section 4 "..during testing... 4 simultaneous NMAP sessions... make a router's ND process unusable..."
Since you specify that the NMAP sessions were running on a low-end PC, it would be worth characterizing what type/vintage of router we're talking about here. Big difference between killing a small-office type router (eg 2600) vs a major core router with the latest and greatest multi-core CPU. I think that the last sentence in section 4 may be trying to imply that it really doesn't matter the relative size/scale of the platform, but it's a bit unclear, especially given the specific mention of running 4 NMAP sessions...

I'm not certain that section 5 is totally necessary - shouldn't this assume that one either knows how ND works or has read the helpful references provided elsewhere in the document?
If you keep the section, for completeness it might be worth saying something about if/when the device doesn't receive the Neighbor Advertisement and the packet gets dropped.

6.3 - might be worth discussing the alternative of using a separate routing protocol from the IGP and doing redistribution rather than using the same IGP - this at least gets away from the concern about having end hosts participating directly in the IGP.

7.1 - I'd prefer that there be some recommendation that these prioritizations be configurable - while this priority might be the default and work in most cases, for maximum flexibility, it makes sense to be able to prioritize differently rather than having this be hard-coded. #4 especially comes with some tradeoffs depending on the type of network and what the hosts are doing on it.

Thanks,

Wes George

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Fred Baker
> Sent: Monday, January 09, 2012 1:32 AM
> To: [email-masked]
> Cc: [email-masked]; Ron Bonica
> Subject: [v6ops] draft-ietf-v6ops-v6nd-problems WGLC
>
> This is to initiate a two week working group last call of draft-ietf-
> v6ops-v6nd-problems. Please read it now. If you find nits (spelling
> errors, minor suggested wording changes, etc), comment to the authors;
> if you find greater issues, such as disagreeing with a statement or
> finding additional issues that need to be addressed, please post your
> comments to the list.
>
> We are looking specifically for comments on the importance of the
> document as well as its content. If you have read the document and
> believe it to be of operational utility, that is also an important
> comment to make.

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Warren Kumari <[email-masked]>
Date: Mon, 16 Jan 2012 16:33:55 -0500

On Jan 12, 2012, at 6:00 AM, Ray Hunter wrote:

> I have reviewed this document in detail, and forwarded a number of nits direct to the authors.

Yes, yes you did[0]… and the authors are remiss in not having incorporated them yet…

> 
> I believe that the document contains important operational information and advice to the v6ops community.

Thanks!

W

[0]: And thank you for making them clear and helpful!

>> We are looking specifically for comments on the importance of the document as well as its content. If you have read the document and believe it to be of operational utility, that is also an import…

---
Don't be impressed with unintelligible stuff said condescendingly .
    -- Radia Perlman.

Warren Kumari
[email-masked]