Subject: [v6ops] [Fwd: I-D Action: draft-carpenter-v6ops-icp-guidance-02.txt]

From: Brian E Carpenter <[email-masked]>
Date: Tue, 10 Jan 2012 14:41:50 +1300

Hi,

We've updated this according to the comments received since Taipei.

At this point we'd like opinions about the future of the document.
Should it become a WG draft, or should we progress it as an
individual submission?

    Brian

-------- Original Message --------
Subject: I-D Action: draft-carpenter-v6ops-icp-guidance-02.txt
Date: Fri, 06 Jan 2012 11:37:09 -0800
From: [email-masked]
Reply-To: [email-masked]
To: [email-masked]

A New Internet-Draft is available from the on-line Internet-Drafts directories.

	Title           : IPv6 Guidance for Internet Content and Application Service Providers
	Author(s)       : Brian Carpenter
                          Sheng Jiang
	Filename        : draft-carpenter-v6ops-icp-guidance-02.txt
	Pages           : 16
	Date            : 2012-01-06

   This document provides guidance and suggestions for Internet Content
   Providers and Application Service Providers who wish to offer their
   service to both IPv6 and IPv4 customers.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-carpenter-v6ops-icp-guidance-02.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-carpenter-v6ops-icp-guidance-02.txt

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Victor Kuarsingh <[email-masked]>
Date: Mon, 09 Jan 2012 21:45:45 -0500

Brian,

I would support this as a WG item.

I think this document outlines sound guidance for considering IPv6 in the
environments (ICS / ASP) noted.  I would also suggest that sections 3-8
and 11,12 are applicable for more then just the ICS/ASP environment (good
general text). 

The document seems to capture a number of very important points for orgs
looking to support IPv6.  I would suggest that we may want to consider
putting a bit more in section 5.2 (routing) and section 6 (Load balancers)
as the document progresses.

I.e. For example, in the routing section, perhaps the mention of other
protocols such as IS-IS can be mentioned?  I would also think there may be
some additional guidance that can be given here as to what analysis
can/should be done by an org when considering running dual stack.  The
document suggests that IPv6 routing can be put in without impact to IPv4,
but I think that may be simplifying the point a bit.  There are
considerations that can be highlighted here (I.e. Performance on routers
running more protocols, non-congruent IPv4/IPv6 topology considerations,
etc).  

Also, I think much of this text in sections I highlighted above should
also be directed to enterprises as it captures many key points of
considering IPv6 deployment succinctly.

Regards,

Victor K

On 12-01-09 8:41 PM, "Brian E Carpenter" <[email-masked]>
wrote:

>v6ops mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/v6ops

---

From: "Leo Liu(bing)" <[email-masked]>
Date: Tue, 10 Jan 2012 09:44:32 +0000

Hi, Brian

I also support this to be a WG item.

I agree with Victor's comment that some of the content not only suitable for ICP, but also enterprise and any other organizations who want to introduce IPv6 to their current network. They need to know the impact to various infrastructures include routing, servers, balancers, CDN etc. I think the draft is quite helpful for them to get start with IPv6, especially for the mid-small sized organizations, who may not have enough IPv6 experience/knowledge. 

For my personal interest, I want to see more discussion of dual stack OPS in the draft, since it seems there always been controversial about the complexity of running dual stack, and I think the issue may be more sensitive for the mid-small organizations.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Victor Kuarsingh
> Sent: Tuesday, January 10, 2012 10:46 AM
> To: Brian E Carpenter; IPv6 Operations
> Subject: Re: [v6ops] [Fwd: I-D Action:
> draft-carpenter-v6ops-icp-guidance-02.txt]
> 
> Brian,
>

---

From: "George, Wes" <[email-masked]>
Date: Wed, 11 Jan 2012 09:53:58 -0500

Brian - Thanks for addressing my comments in this version.

I'm still on the fence about the draft status - I'm no longer opposed to adopting it as a WG item if that's the general consensus, but I think it would be ok as an individual draft as well.

A couple of additional comments from this read.

In your introduction, You mention the "first do no harm" concept - don't make IPv4 worse by deploying IPv6 (with the implication that some IPv6 transition technologies might have that effect).
I think you might be able to take that a step further and note that IPv4 *extension* technologies (CGN, etc) on the client side may also have that effect, meaning that this is one of the reasons why ubiquitous IPv6 support (perhaps "on by default" even) is critical for ASP/ICP - it increases the chances that their service transits to an end customer largely unmolested by IPv4 extension technologies.

Additionally, it might be worth mentioning the connection between the ICP/ASP and their partners and their partner's uplinks - that is, if an ASP/ICP has a direct business relationship with the consumers/clients of their content or the networks that connect them to their clients, they should be working with those partners to ensure that they have a plan to enable IPv6 on their side (especially in implementations that require IPv6 support in specialized programs or systems for the IPv6 support on the ICP/ASP to be useful), and that they have first-class IPv6 connectivity between the networks. This coordination and testing detail is something that's sometimes overlooked, and while it's getting to a point where it might be a safe assumption that IPv6 is already available on the remote side, at this point it's worth mentioning explicitly.

Thanks,

Wes George

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Brian E Carpenter
> Sent: Monday, January 09, 2012 8:42 PM
> To: IPv6 Operations
> Subject: [v6ops] [Fwd: I-D Action: draft-carpenter-v6ops-icp-guidance-
> 02.txt]
>
> Hi,
>

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 30 Jan 2012 11:35:13 +1300

Still waiting to hear WG opinions on this...