Subject: Re: [v6ops] IPv6 Day in 2012

From: Fred Baker <[email-masked]>
Date: Wed, 18 Jan 2012 04:50:41 -0800

On Jan 17, 2012, at 11:15 PM, Li Lianyuan wrote:

> Dear Fred,
>    This is Li Lianyuan in China Mobile speaking hello to you. We had met before in IETF meeting several times.
>    I am told that on 6 June this year, IPv6 Day will be held again. But I didn’t find any discussion in v6ops emailing list. So could you give me some information on it?
>  
>    Thanks
>  
>   Li Lianyuan

I'll do both in the same email - tell you and tell the list.

A set of usual suspects, led by the Internet Society, has announced a follow-on to the "World IPv6 Day" that was held 8 June 2011. On that one, the objective was to test connectivity and capabilities. The result was that a number sites (about 800 by my measurements) tested WWW access via IPv6, demonstrated basic capabilities, and then at least in many cases shut it down again. In this event, starting 6 June 2012, the objective is to globally turn on IPv6 and leave it on. 

http://www.worldipv6launch.org/

Apologies to all of those networks that turned on IPv6 a decade or more back and have been quietly operating it...

---

From: Willy Tarreau <[email-masked]>
Date: Wed, 18 Jan 2012 14:09:53 +0100

Hi,

On Wed, Jan 18, 2012 at 04:50:41AM -0800, Fred Baker wrote:
> >    I am told that on 6 June this year, IPv6 Day will be held again. But I didn?t find any discussion in v6ops emailing list. So could you give me some information on it?
> >  
> >    Thanks
> >  
> >   Li Lianyuan
> 
> A set of usual suspects, led by the Internet Society, has announced a
> follow-on to the "World IPv6 Day" that was held 8 June 2011. On that one, the
> objective was to test connectivity and capabilities. The result was that a
> number sites (about 800 by my measurements) tested WWW access via IPv6,
> demonstrated basic capabilities, and then at least in many cases shut it down
> again. In this event, starting 6 June 2012, the objective is to globally turn
> on IPv6 and leave it on. 

Is it known how many left it turned on after last year's event ? I personally
know a small number of sites which successfully left it enabled (at least mine
and my company's plus a few customers and enthousiasts).

Regards,
Willy

---

From: Fred Baker <[email-masked]>
Date: Wed, 18 Jan 2012 08:35:31 -0800

> and my company's plus a few customers and enthousiasts).

I personally only have my measurements. During the week before, I was curious to see what the ramp-up looked like. So I took the set of sites that had stated that they would participate (about 300 IIRC) and slowly (one page from each, and then one derivative page from each, etc) spidered their sites, picking up links outside of them as well. I added those sites to my spidering. Predictably, at the beginning of the week there were few that were IPv6-accessible, and that number grew over the week. I left the spider running through the weekend following and then turned it off. 

By my observation, the number of individual sites I was able to reach last June peaked at a tad over 700, indicating that on average each "participating" site led me to another site that was IPv6-capable but not overtly participating. To my small mind, that was the real news - that there were already a number of sites out there that were just doing it. The drop afterwards was perhaps half - some put it up as an experiment, and some simply put it (or had it) up.

Another part of the story is http://sixy.ch/. Sixy.ch, in their own words, "aims to be a directory of web sites that are accessible via IPv6." I'm not certain what motivates sites to register with sixy.ch, but as of this morning it reports 8657 sites in its database. I sat this morning clicking on links from the site for a few minutes, which is something the site really isn't set up to do (if I were Leslie Daigle, I might be interested to contact the webmasters of those sites for various reasons), but which is possible. It lists their IPv6 addresses, and when I accessed the first couple of dozen listed, I can report that I was able to access them using IPv6.

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 19 Jan 2012 18:26:25 -0800

> and my company's plus a few customers and enthousiasts).

See
https://labs.ripe.net/Members/emileaben/copy_of_alexadetail.png/view

Among all the other data available from real researchers,
I maintain http://www.employees.org/~dwing/aaaa-stats.html which
gives breakdown on actual site names that come and go, and do GET
over IPv6 TCP/80 (instead of blindly assuming an AAAA means that 
IPv6 works).  I don't have pretty graphs, though.

-d

---

From: Willy Tarreau <[email-masked]>
Date: Fri, 20 Jan 2012 08:08:50 +0100

> IPv6 works).  I don't have pretty graphs, though.

Nice, both your experiments and the graph above show what I suspected,
ie that the ipv6 day encouraged a large number of sites to leave v6
turned on after the experiment. From your stats, it appears that the
number of v6-capable sites today is 4 times what we had at the same
date one year ago, and doubled thanks to the v6-day. We could reasonably
think that after next v6-day, the number of enabled sites could roughly
match the number of participants to previous v6-day, which would already
be a nice progression.

Thanks for sharing these stats,
Willy

---

From: Mark Townsley <[email-masked]>
Date: Tue, 24 Jan 2012 01:09:05 +0100

> A set of usual suspects, led by the Internet Society, has announced a follow-on to the "World IPv6 Day" that was held 8 June 2011. On that one, the objective was to test connectivity and capabiliti…

In addition, there are participation categories for ISPs (with measurements taken by participating websites) and Residential Home Gateway products (with a commitment to pass a latest version of the CPE v6 ready logo test as well as v6 enabled by default). The point is for IPv6 to become "the normal course of business" rather than opt-in. 

- Mark

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Mark Townsley <[email-masked]>
Date: Tue, 24 Jan 2012 01:11:22 +0100

Strato, a hosting company in Germany, reportedly enabled IPv6 on world day last year to all four million sites that it hosts,  and did not turn it off after.

youtube kept AAAAs for its video streaming, which accounts for a big chunk of traffic that "stuck around" after world day. 

- Mark