Subject: [v6ops] new draft: draft-ietf-v6ops-464xlat

From: <[email-masked]>
Date: Wed, 15 Feb 2012 06:55:00 -0800 (PST)

A new draft has been posted, at http://tools.ietf.org/html/draft-ietf-v6ops-464xlat. Please take a look at it and comment.

---

From: Victor Kuarsingh <[email-masked]>
Date: Thu, 16 Feb 2012 19:31:02 -0500

Fred,

This work in my mind represents important work that should continue.
Putting a mobile operator hat on, it provides the last bit of functionally
to make IPv6 with NAT64 a real and workable option for Wireless
deployments based on known behaviours in commercially available product
(I.e. Infrequent, but need for IPv4 connections).

Given the content in the draft and testing/results provided thus far, it
appears to be a viable option with a number of benefits (especially in the
mobile space related to PCC complacence).

I would support this work in whichever forum (group) it should exist.

Regards,

Victor K

On 12-02-15 9:55 AM, "[email-masked]" <[email-masked]> wrote:

>
>A new draft has been posted, at
>http://tools.ietf.org/html/draft-ietf-v6ops-464xlat. Please take a look
>at it and comment.
>_______________________________________________
>v6ops mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/v6ops

---

From: Vízdal Aleš <[email-masked]>
Date: Mon, 20 Feb 2012 13:07:20 +0100

+1

I fully agree with Victor's words as this draft is providing a real solution
to THE IPv4 exhaustion problem. I do support it and would like to see this 
work continued.

Cheers,
Ales

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Victor
> Kuarsingh
> Sent: Friday, February 17, 2012 1:31 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: Re: [v6ops] new draft: draft-ietf-v6ops-464xlat
> 
> Fred,
>

---

From: Joel jaeggli <[email-masked]>
Date: Mon, 20 Feb 2012 12:32:12 -0800

> to THE IPv4 exhaustion problem. I do support it and would like to see this 

I would probably construe that more narrowly...

The draft provides a solution to an aspect of a providers ipv4
exhaustion problem. It appears on the face of it to provide effective
cover for the deployment of ipv6 only networks which have limited pools
of available ipv4 addresses.

---

From: MAWATARI Masataka <[email-masked]>
Date: Tue, 21 Feb 2012 11:55:27 +0900

Dear all,

I wrote my thoughts.
Basically, there are different requirement and applicable situation
between 4rd and MAP and 464XLAT.

4rd and MAP are stateless solutions due to sharing expanded address
space spliting.
These can solve requirements from ISPs that have much global IPv4
address pool.

464XLAT is stateful solution due to dynamic sharing by session time
spliting.
This can solve requirements from mobile careers that will enlarge
the number of end-users or ISPs that do not have much global IPv4
address pool.  For example, it may be difficult for advancing
countries to enough deploy IPv4/IPv6 dual stack network, I think.

Incidentally, such ISPs I heard from at least in Japan is thinking
they would not like to operate IPv4/IPv6 coexistence techniques on
each their backbone network and would like to operate IPv6-only
access network.  I would like to support them.

As all really know, 464XLAT remove 4rd and MAP, and vice versa, I
also really think.

What I really want to realize is faster deploying IPv6 network and
IPv6 service on the internet.

Kind Regards,
Masataka MAWATARI

* On Mon, 20 Feb 2012 12:32:12 -0800
* Joel jaeggli <[email-masked]> wrote:

> On 2/20/12 04:07 , Vizdal Ale? wrote:
> > +1
> >

---

From: Rémi Després <[email-masked]>
Date: Tue, 21 Feb 2012 17:06:22 +0100

Masataka-san,

Please see in line.

Le 2012-02-21 à 03:55, MAWATARI Masataka a écrit :
...

> As all really know, 464XLAT remove 4rd and MAP, and vice versa, I

I don't understand this sentence because what 464XLAT introduces is (in 4rd/MAP) vocabulary, a variant of stateless CE (one that only works wit stateful BRs whereas those of 4rd/MAP permit BRs to also be stateless). 

Isn't it natural to quickly look whether IETF-specified stateless CEs can work indifferently with stateful and stateless BRs? 

AFAIK, there is little to add to 4rd-U so that its CEs can work according to the generic 464XLAT scenario.
- I plan to work on it in Softwire.
- Would be available to share views on the proposed solution?

> IPv6 service on the internet.

Same objective (that was that of 6rd, and is also that of 4rd)

Kind regards,
RD