Subject: Re: [v6ops] draft-464XLAT not a "trial deployment report" - not to be an ietf-v6ops I.D.

From: "[email-masked]" <[email-masked]>
Date: Mon, 20 Feb 2012 09:59:15 +0000

I have to say I am really interested on this as well, as during BIH-work we were explicitly forbidden to define how BIH would work if destination has an A record (instead of only AAAA).

E.g. we could not write that if there is A record, it is passed as is to application and following IPv4 packet then translated to Ipv6....

I understand that times change, but this change is quite fast (document saying not allowed in RFC editor queue while new document saying allowed adopted as wg document..).

Maybe this document should state that described approach still is not recommended.

Or IETF(IESG) should make their mind:)

Teemu

Lähetetty Nokia-puhelimestani
---- alkuperäinen viesti ----
Lähett.: Satoru Matsushima
Lähet.:  20.02.2012, 09:11 
V.ottaja: v6ops WG
Kopio: Russell Housley
Aihe: Re: [v6ops] draft-464XLAT not a "trial deployment report" - not to be an ietf-v6ops I.D.

On 2012/02/20, at 4:23, Brian E Carpenter wrote:

> On 2012-02-20 05:37, Joel jaeggli wrote:
>> So, when I read  464xlat what I see is a stack of existing RFCs used in
>> a specific fashion which the draft describes. I don't see any new
>> standards work.
> 
> fwiw I agree with that. I think v6ops is the appropriate venue
> for descriptions of how to knit existing protocol specs together
> in operational scenarios.
> 
> I do object slightly to the way draft-ietf-v6ops-464xlat uses
> the word "architecture". It's an operational scenario, not an
> architecture, IMHO.
> 

I can see a strong statement that double protocol translation is an architecture which is not recommended by the IETF.
(http://tools.ietf.org/html/draft-ietf-behave-v4v6-bih-09)

I'd like to hear from chairs that does v6ops consent to be opposed to that statement.

cheers,
--satoru
_______________________________________________
v6ops mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/v6ops

---

From: Cameron Byrne <[email-masked]>
Date: Mon, 20 Feb 2012 08:32:21 -0800

> I understand that times change, but this change is quite fast (document saying not allowed in RFC editor queue while new document saying allowed adopted as wg document..).

I see no reason to pause progress towards enabling proven
functionality and leveraging existing standards and working code for
the purpose of posterity

> Maybe this document should state that described approach still is not recommended.

That would be quite unfortunate.

I made the case for double translation with BIH almost a year ago

http://www.ietf.org/mail-archive/web/behave/current/msg09480.html

> Or IETF(IESG) should make their mind:)

Either that or we deliver the solutions to customers without them.  My
hope is that reality and the IETF specs do not part ways, yet again.

CB