Subject: [v6ops] PD-exclude was approved by the IESG -> should be included into 6204bis

From: Teemu Savolainen <[email-masked]>
Date: Fri, 17 Feb 2012 10:42:48 +0200

Hi v6ops,

You may have already noticed that draft-ietf-dhc-pd-exclude-04 was
yesterday approved by the IESG.

I would like to add to the draft-ietf-v6ops-6204bis section 4.2 a new
requirement (to W-4, or maybe to the WPD-x series) that says support for
pd-exclude is a SHALL for IPv6 CE router.

Best regards,

Teemu

FYI: ---

State changed to Approved-announcement to be sent from IESG Evaluation.

ID Tracker URL: http://datatracker.ietf.org/doc/draft-ietf-dhc-pd-exclude/

---

From: Vízdal Aleš <[email-masked]>
Date: Fri, 17 Feb 2012 09:50:12 +0100

+1

From: [email-masked] [mailto:[email-masked]] On Behalf Of Teemu Savolainen
Sent: Friday, February 17, 2012 9:43 AM
To: [email-masked]
Subject: [v6ops] PD-exclude was approved by the IESG -> should be included into 6204bis

Hi v6ops,

You may have already noticed that draft-ietf-dhc-pd-exclude-04 was yesterday approved by the IESG.

I would like to add to the draft-ietf-v6ops-6204bis section 4.2 a new requirement (to W-4, or maybe to the WPD-x series) that says support for pd-exclude is a SHALL for IPv6 CE router.

Best regards,

Teemu

FYI: ---

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Fri, 17 Feb 2012 06:23:16 -0600

Teemu,

When we update the rfc6204bis for PCP related text, we will consider
this request from you as well.

Thanks,

Hemant

From: [email-masked] [mailto:[email-masked]] On Behalf
Of Teemu Savolainen
Sent: Friday, February 17, 2012 3:43 AM
To: [email-masked]
Subject: [v6ops] PD-exclude was approved by the IESG -> should be
includedinto 6204bis

Hi v6ops,

Best regards,

Teemu

FYI: ---

ID Tracker URL:
http://datatracker.ietf.org/doc/draft-ietf-dhc-pd-exclude/

---

From: "STARK, BARBARA H" <[email-masked]>
Date: Fri, 24 Feb 2012 17:00:27 +0000

I have a question as to whether this needs to be a MUST/SHALL or can it be a SHOULD.
In my mind, the answer to this depends on how operators who intend to use PD-exclude will treat CE routers that do not support PD-exclude.
Will they refuse to offer IA_PD (so the non-PD-exclude-supporting CE router is useless for attachment to that access network), or will they offer IA_PD and either also offer IA_NA (from a different prefix) or let the CE router operate in "unnumbered mode"?
If there are numerous operators who intend to use PD-exclude and won't support non-PD-exclude CE routers, then I agree it's a MUST/SHALL. If these networks will also provide support for non-PD-exclude CE routers, then I think SHOULD would be reasonable.
Barbara

Hi v6ops,

Best regards,

Teemu

FYI: ---

---

From: jouni korhonen <[email-masked]>
Date: Tue, 28 Feb 2012 10:49:38 +0200

Barbara,

On Feb 24, 2012, at 7:00 PM, STARK, BARBARA H wrote:

> Will they refuse to offer IA_PD (so the non-PD-exclude-supporting CE router is useless for attachment to that access network), or will they offer IA_PD and either also offer IA_NA (from a different prefix) or let the CE router operate in “unnumbered mode”?

I cannot speak on behalf of others but from 3GPP networks point
of view, unnumbered mode and/or using IA_NA are not options since
the system architecture does not support either of those.

If the CE router does not support pd-exclude and still, against
3GPP specifications, attempts prefix delegation the outcome is
undefined. The 3GPP specs say today "The UE shall include
OPTION_PD_EXCLUDE option code in an OPTION_ORO option.." etc.

3GPP specs also mandate pd-exclude for a delegating router (GGSN/PGW)
"Prefix exclusion procedures shall follow draft-ietf-.." However,
the delegating router could always neglect OPTION_PD_EXCLUDE
since draft-ietf-dhc-pd-exclude gives you that possibility. Still,
the delegating router shall guarantee the delegated prefix and the
cellular "WAN link" prefix aggregation requirement (this is kind
of hard requirement). How it is then done is vendor specific.

> If there are numerous operators who intend to use PD-exclude and won’t support non-PD-exclude CE routers, then I agree it’s a MUST/SHALL. If these networks will also provide support for non-PD-exclude CE routers, then I think SHOULD would be reasonable.

For a CE router that is never going to use e.g. 3GPP WAN link, having
to implement pd-exclude is unnecessary. In that sense I could agree
on SHOULD. If the CE router has a chance for e.g. 3GPP WAN link, then
it is MUST. Which language choice is more safe?

- Jouni

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Anupam Kapoor <[email-masked]>
Date: Tue, 28 Feb 2012 16:20:09 +0530

korhonen> Barbara,
 korhonen> On Feb 24, 2012, at 7:00 PM, STARK, BARBARA H wrote:

 >> In my mind, the answer to this depends on how operators who intend to
 >> use PD-exclude will treat CE routers that do not support PD-exclude.
 >> Will they refuse to offer IA_PD (so the non-PD-exclude-supporting CE
 >> router is useless for attachment to that access network), or will they
 >> offer IA_PD and either also offer IA_NA (from a different prefix) or
 >> let the CE router operate in “unnumbered mode”?

 korhonen> I cannot speak on behalf of others but from 3GPP networks point
 korhonen> of view, unnumbered mode and/or using IA_NA are not options since
 korhonen> the system architecture does not support either of those.

,----
|  korhonen> If the CE router does not support pd-exclude and still, against
|  korhonen> 3GPP specifications, attempts prefix delegation the outcome is
|  korhonen> undefined. The 3GPP specs say today "The UE shall include
|  korhonen> OPTION_PD_EXCLUDE option code in an OPTION_ORO option.." etc.
`----
here are the relevant lines from sec:5.3.1.2.6 of 23.401 (ver:10.6.0)
      
      ,----
      | If the UE had indicated that it supports prefix exclusion and the
      | prefix to be delegated to the UE includes the /64 prefix that was
      | allocated to the PDN Connection, the PDN GW shall  
      | utilise the prefix exclusion feature as specified for DHCPv6 Prefix
      | Delegation in draft-ietf-dhc-pd-exclude-00 [70] 
      `----
from which it seems (to me at least) that ue *may* support
prefix-exclusion i.e. it is not mandatory for the ue to send
'PD-EXCLUDE' if supports prefix-delegation.

kind regards
anupam

---

From: jouni korhonen <[email-masked]>
Date: Tue, 28 Feb 2012 13:45:45 +0200

> 'PD-EXCLUDE' if supports prefix-delegation.

Hmm.. you could actually be right with that interpretation :) That
would then mean SHOULD is appropriate. 

- Jouni