Subject: [v6ops] draft-liu-v6ops-ula-usage-analysis-02

From: Brian E Carpenter <[email-masked]>
Date: Fri, 23 Mar 2012 16:18:45 +1300

Hi,

I think this draft is a considerable improvement on the -00 version.
It still needs some work on the English, but I think the main points
are covered now and the work should continue.

However, there is clearly a complication, which is that this document
needs to be aligned with whatever consensus appears in homenet about
ULAs, and with whatever consensus appears in 6man about RFC3484bis.

In particular, homenet is hitting the problem of what happens when
multiple ULA prefixes show up automatically in the same network. That
may not be recommended practice, but it seems very likely to happen,
and raises routing and address-selection questions.

I think the various WG Chairs need to agree how the discussion should
be managed, because it might get complicated with three WGs involved
(or four, if you count 6renum).

Regards
   Brian

---

From: Fred Baker <[email-masked]>
Date: Fri, 23 Mar 2012 04:37:54 +0100

On Mar 23, 2012, at 4:18 AM, Brian E Carpenter wrote:

> In particular, homenet is hitting the problem of what happens when multiple ULA prefixes show up automatically in the same network. That may not be recommended practice, but it seems very likely to happen, and raises routing and address-selection questions.

Personally, I think that having each router generate a /48 ULA prefix and use it without a conversation with its neighboring routers is a pretty silly concept, and what is happening in homenet is the obvious outcome of that. The problem is indeed tractable. A ULA generated in that way has one of two purposes: it is supposed to be the prefix from which all of the routers in a domain derive their prefixes, or it is a temporary use that will not survive the reason that it was created (probably to configure a residential router, which will then be configured with an address from upstream using DHCP-PD). Making one for a temporary purpose and keeping it forever in every router in the home just isn't very smart - for exactly the reasons you point to.

---

From: "Liubing (Leo)" <[email-masked]>
Date: Fri, 23 Mar 2012 05:31:02 +0000

Hi, Brian

There comes comments finally :-) Thanks for your concern about the draft.  

I've noticed the discussion in 6man and homenet, which is more in-depth technical issue while the ULA usage draft is more general use cases. But I think it is exactly valuable input and consideration to the ULA draft for the further step.  

I am also confused about the relationship between the discussion in various WGs and the ULA draft.
We should cover all the specific issues in the draft, or just limit the discussion within each WG while the draft only focus on general use cases？

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Brian E Carpenter
> Sent: Friday, March 23, 2012 11:19 AM
> To: IPv6 Operations
> Subject: [v6ops] draft-liu-v6ops-ula-usage-analysis-02
> 
> Hi,
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: "Liubing (Leo)" <[email-masked]>
Date: Fri, 23 Mar 2012 05:52:02 +0000

Hi, Fred

Inline.

> Fred Baker
> Sent: Friday, March 23, 2012 11:38 AM
> To: Brian E Carpenter
> Cc: IPv6 Operations
> Subject: Re: [v6ops] draft-liu-v6ops-ula-usage-analysis-02
> 
> 
> > In particular, homenet is hitting the problem of what happens when multiple
> ULA prefixes show up automatically in the same network. That may not be
> recommended practice, but it seems very likely to happen, and raises routing
> and address-selection questions.
> 
> Personally, I think that having each router generate a /48 ULA prefix and use it
> without a conversation with its neighboring routers is a pretty silly concept,
> and what is happening in homenet is the obvious outcome of that. 

[Bing] I'm a little confused about the assumption "without a conversation", aren't there some drafts in homenet WG to address the routing issue? Pardon me for my unfamiliar with the homenet discussions. 

> The problem is indeed tractable. A ULA generated in that way has one of two purposes: it is
> supposed to be the prefix from which all of the routers in a domain derive their
> prefixes, or it is a temporary use that will not survive the reason that it was
> created (probably to configure a residential router, which will then be
> configured with an address from upstream using DHCP-PD). Making one for a
> temporary purpose and keeping it forever in every router in the home just isn't
> very smart - for exactly the reasons you point to.

[Bing] I just read Anders Brandt's thread in homenet WG, "[homenet] Routing between hosts in ULA subnets". I think it is very clear explanation in multiple ULA prefixes requirement.

---

From: "George, Wes" <[email-masked]>
Date: Sat, 24 Mar 2012 08:58:22 -0400

A comment of my own:

3.1, Regarding: "Generally, this draft doesn't consider the ULA+NAT a good model of
   IPv6 deployment in normal cases. When thinking about ULA, we should
   eliminate the misunderstanding that ULA means the IPv6 version of
   rfc1918 deployment model."

I would clarify this by saying "...the IPv6 version of using RFC1918 + NAT [with RFC reference for NAT44/NAPT] as a means to provide hosts with private addresses with a means of accessing hosts beyond the local network."
Strictly speaking, the RFC1918 deployment model as defined in 1918 itself does not include NAT, and is actually a reasonable equivalent to ULA.
You could probably even go on to discuss the fact that since it will be common to have hosts with multiple IPv6 addresses, the expected solution for cases where hosts with ULA need to interact with hosts beyond the ULA scope is to provide them with a global-scope address in addition to any ULA.

Thanks,

Wes George

> Sent: Thursday, March 22, 2012 11:19 PM
> To: IPv6 Operations

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: "Liubing (Leo)" <[email-masked]>
Date: Sun, 25 Mar 2012 07:23:46 +0000

Hi, Wes

Thanks for the comment.

> Strictly speaking, the RFC1918 deployment model as defined in 1918 itself does not include NAT, and is actually a reasonable equivalent to ULA.

[Bing] Yes, this is a more accurate description, I'll update the draft. 
ULA is equivalent to 1918 from the perspective of independent addr allocation. But since 1918 is always used binding with NAT, some people may treat ULA as the same manner. We should eliminate the misunderstanding.

> You could probably even go on to discuss the fact that since it will be common to have hosts with multiple IPv6 addresses, the expected solution for cases where hosts with ULA need to interact with…

[Bing] That is exactly what we argued in the draft. But ULA+PA has explict controversial, I thind it is an important issue need to be discussed in the WG.

________________________________________
发件人: [email-masked] [[email-masked]] 代表 George, Wes [[email-masked]]
发送时间: 2012年3月24日 20:58
到: Brian E Carpenter; IPv6 Operations
主题: Re: [v6ops] draft-liu-v6ops-ula-usage-analysis-02

A comment of my own:

Thanks,

Wes George