Subject: [v6ops] new draft: draft-ma-v6ops-terminal-test

From: <[email-masked]>
Date: Mon, 5 Mar 2012 06:55:01 -0800 (PST)

A new draft has been posted, at http://tools.ietf.org/html/draft-ma-v6ops-terminal-test. Please take a look at it and comment.

---

From: "George, Wes" <[email-masked]>
Date: Wed, 7 Mar 2012 15:47:38 -0500

The format of the draft is making it difficult to identify the point that it is trying to make.
The fact that you did some IPv6 testing and that some devices didn't work as expected is not a surprise, and should not be a focus for the draft, nor should your methodology.

If I'm reading this properly, what you're saying is that there are some hosts that do some "strange" things with DNS and DHCP (like continuing to ask for an A record once it has received a AAAA and initiated a connection using IPv6). However, that may or may not be interesting to IETF.

If the observed behavior was seen on some hosts/applications, but not all, chances are quite good that it's just a poor implementation, open a bug with the implementer. We don't typically do "name and shame" documents here that point out a failure with a specific implementation, and even then, this one doesn't actually name names, meaning that it's impossible to lean on said implementer for a fix via public humiliation.

If the observed behavior was seen on all hosts/applications, then it's a question of whether this is expected behavior or not based on the existing documented standards, and if not, what fix action needs to be taken.

Unless you can point to a specific portion of the existing standards that the host is implementing properly but are creating undesired consequences, either because they are unclear, incomplete, or because there's an unforeseen problem, there's no action for IETF to take to resolve it.

If there is a scaling issue (too many DNS queries), explain that clearly, including what steps can be taken either operationally or at a protocol level to fix it. This again gives the IETF a problem to solve, rather than this simply being a test report.

Thanks,

Wes George

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Monday, March 05, 2012 9:55 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [v6ops] new draft: draft-ma-v6ops-terminal-test
>
>
> A new draft has been posted, at http://tools.ietf.org/html/draft-ma-v6ops-
> terminal-test. Please take a look at it and comment.
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.