Subject: [v6ops] FW: New Version Notification for draft-vyncke-ipv6-traffic-in-p2p-networks-01.txt

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Fri, 2 Mar 2012 13:21:47 +0100

Updated version with more recent statistics about BitTorrent peers using or not IPv6. For a more graphical version:
http://www.vyncke.org/ipv6status/p2p.php

-éric

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: vendredi 2 mars 2012 13:18
To: Eric Vyncke (evyncke)
Cc: [email-masked]
Subject: New Version Notification fordraft-vyncke-ipv6-traffic-in-p2p-networks-01.txt

A new version of I-D, draft-vyncke-ipv6-traffic-in-p2p-networks-01.txt has been successfully submitted by Eric Vyncke and posted to the IETF repository.

Filename:	 draft-vyncke-ipv6-traffic-in-p2p-networks
Revision:	 01
Title:		 Measuring IPv6 Traffic in BitTorrent Networks
Creation date:	 2012-03-02
WG ID:		 Individual Submission
Number of pages: 12

Abstract:
   This document is a follow-up of a University thesis which aims to
   measure the evolution over time of IPv6 traffic and to analyze the
   geographical distribution of IPv6 nodes.  The first measurements were
   done during the Summer 2009 using a specific-purpose program which
   connects to the BitTorrent peer-to-peer network and this document
   adds measurements done with the same program but in October 2011 and
   February 2012.

   The study was made in Peer-to-Peer (P2P) networks because they are
   responsible for a big part of Internet traffic and because their
   structure and functioning permit a rapid discovery of a large number
   of nodes from all over the world.  In addition, the P2P users are
   more likely to be interested by IPv6 as IPv6 does not have the same
   NAT problems as IPv4.

The IETF Secretariat

---

From: John Mann <[email-masked]>
Date: Mon, 5 Mar 2012 13:48:27 +1100

Hi,

---
The measurements were done in two periods:
---
Three, or perhaps four periods.

---

   o  May 2009 to July 2009: 5,000,000 peers were discovered but we were
      only able to to establish a BitTorrent connection with 1,500,000
      peers;

   o  1 day in October 2009: 100,000 peers were discovered;

...
---
Are the IPv6 stats based on the total number of peers discovered, or on the
peers that you were able to establish connections to?
If "establish connections to", then what were the numbers for the
subsequent tests?

s/Chine/China/

I also wonder whether the choice of torrents effected which peers and which
countries were detected.
For example, a torrent swarm for a particular language/type of software or
movie may mostly be of interest to people in particular countries.
Or if a tracker inside China was only used mostly by users inside that
country, you may not get to know about those torrents or users.

Thanks,
    John

On 2 March 2012 23:21, Eric Vyncke (evyncke) <[email-masked]> wrote:

> Updated version with more recent statistics about BitTorrent peers using
> or not IPv6. For a more graphical version:
> Subject: New Version Notification
> fordraft-vyncke-ipv6-traffic-in-p2p-networks-01.txt
>
> A new version of I-D, draft-vyncke-ipv6-traffic-in-p2p-networks-01.txt has
> been successfully submitted by Eric Vyncke and posted to the IETF
> repository.
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: "Eric Vyncke (evyncke)" <[email-masked]>
Date: Mon, 5 Mar 2012 07:56:03 +0100

John,

Thanks for your comments (I will fix the typos).

There is indeed a bias linked to which torrents the application tries to download. This is the reason why it changes of torrents every 15 minutes (10 torrents in parallel), so, in the course of 2 or 3 days, this makes about 2000-3000 different torrents. The source of those torrents is thepiratebay.com which is probably the source of a big bias there.

Also, BitTorrent is not used everywhere as in some countries it appears that there are other P2P.

BTW, if there is another source / compilation of torrents, then I am glad to add it to the next run in addition to the piratebay

The count is the number of discovered peers.

Regards

-éric

From: John Mann [mailto:[email-masked]] 
Sent: lundi 5 mars 2012 03:48
To: Eric Vyncke (evyncke)
Cc: [email-masked]
Subject: Re: [v6ops] FW: New Version Notification for draft-vyncke-ipv6-traffic-in-p2p-networks-01.txt

Hi,

---

---

...
---
Are the IPv6 stats based on the total number of peers discovered, or on the peers that you were able to establish connections to?
If "establish connections to", then what were the numbers for the subsequent tests?

s/Chine/China/

I also wonder whether the choice of torrents effected which peers and which countries were detected.
For example, a torrent swarm for a particular language/type of software or movie may mostly be of interest to people in particular countries.
Or if a tracker inside China was only used mostly by users inside that country, you may not get to know about those torrents or users.

Thanks,
    John

	
	-éric
	
	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]]
	Sent: vendredi 2 mars 2012 13:18
	To: Eric Vyncke (evyncke)
	Cc: [email-masked]
	Subject: New Version Notification fordraft-vyncke-ipv6-traffic-in-p2p-networks-01.txt

	
	Abstract:

	
	
	The IETF Secretariat