Subject: Re: [v6ops] NAT64 performance comparisons

From: Brian E Carpenter <[email-masked]>
Date: Tue, 13 Mar 2012 13:42:47 +1300

The official handle for this is http://hdl.handle.net/2292/13586

   Brian

On 2012-02-15 09:02, Brian E Carpenter wrote:
> On the subject of NAT64, I'v just filed a tech report on some work
> done by Se-young Yu under my supervision. It will get an official
> library handle soon, but here is an ad hoc URL to be going on with:
> 
> http://www.cs.auckland.ac.nz/~brian/IPv4-IPv6coexistenceTechnique-TR.pdf
>

---

From: Fred Baker <[email-masked]>
Date: Mon, 12 Mar 2012 17:51:21 -0700

Hmm. It appears to have tested exactly one implementation and reported results for the algorithms. It says that stateful NAT64 is better than NAT-PT, which I might have expected, but appears to have not tested the stateless mode.

It seems like you would need to test more than one implementation before your could generalize to a statement about the class of implementations...

On Mar 12, 2012, at 5:42 PM, Brian E Carpenter wrote:

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 13 Mar 2012 14:18:10 +1300

> Hmm. It appears to have tested exactly one implementation and reported results for the algorithms. It says that stateful NAT64 is better than NAT-PT, which I might have expected, but appears to hav…

Yes.

> It seems like you would need to test more than one implementation before your could generalize to a statement about the class of implementations...

Of course. That's more or less what the conclusion says.

   Brian

---

From: GangChen <[email-masked]>
Date: Tue, 13 Mar 2012 16:16:24 +0800

Hello Brian,

1/ Regarding

"we expected both NAT mechanisms to be more efficient
than the HTTP proxy, since it has to rebuild every packet it
receives from each node, executing full TCP processing as well as
some application layer copying."

just wondering this statement also could apply to "NAT64 vs 6-to-4
load balancer" according to your expectation?

2/ Does the testing involve some fragmentation consideration?

3/I assume all testing context is based on software coding. I guess it
could show different behavious if the code is integrated in chip sets.

Many thanks

Gang

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 14 Mar 2012 09:59:02 +1300

Hi Gang,

> load balancer" according to your expectation?

I'm not sure what method of load balancing you mean, but clearly
any method that involves layer 7 processing is at least as slow
as an HTTP proxy.

> 2/ Does the testing involve some fragmentation consideration?

No. Fragmentation destroys performance anyway, and should clearly
be avoided if possible.

> could show different behavious if the code is integrated in chip sets.

Absolutely. Please read the remarks in the Conclusion about this.

   Brian