Subject: [v6ops] FW: PCP (RE: draft-ietf-v6ops-6204bis WGLC)

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Wed, 14 Mar 2012 14:42:16 -0500

Folks,

This is some change that Med has asked to make to the PCP text in rfc6204bis.   Please provide comments.  Cc to some PCP and DS-Lite individuals as well.

Thanks,

Hemant

From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, March 14, 2012 3:11 AM
To: Hemant Singh (shemant)
Cc: JACQUENET Christian OLNC/NAD/TIP
Subject: RE: PCP (RE: [v6ops] draft-ietf-v6ops-6204bis WGLC)

Re-,

Please see inline.

Cheers,

Med

________________________________

	De : Hemant Singh (shemant) [mailto:[email-masked]] 
	Envoyé : mardi 13 mars 2012 18:11
	À : BOUCADAIR Mohamed OLNC/NAD/TIP; Hemant Singh (shemant)
	Cc : JACQUENET Christian OLNC/NAD/TIP
	Objet : RE: PCP (RE: [v6ops] draft-ietf-v6ops-6204bis WGLC)

	Med,

	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]] 
	Sent: Tuesday, March 13, 2012 11:32 AM
	To: Hemant Singh (shemant)
	Cc: JACQUENET Christian OLNC/NAD/TIP
	Subject: PCP (RE: [v6ops] draft-ietf-v6ops-6204bis WGLC)

	>Please see below a text proposal to solve the comment from O. Troan. If you want me to send this e-mail in the v6ops ML, I can do.

	>NEW:

	>   The WAN interface of the CE router SHOULD support an IPv4 PCP client

	>   as specified in [I-D.ietf-pcp-base] for use by applications on the CE

	>   Router.  This document takes no position on whether such

	>   functionality is enabled by default or mechanisms by which users

	>   would configure the functionality.

	Note above that the text says "IPv4 PCP client".  
	[Med] I kept that text from the draft as I understood it as: "PCP client to control a NAT44". You can safely replace "IPv4 PCP client" with "PCP client". 

	 Now I am confused by the text below that is referring to "native IPv6"?  We all were expecting IPv4 PCP use case and thus if you can explain what is the IPv6 PCP use case?  
	[Med] For DS-Lite we have two alternatives for PCP deployment:

	(1) send PCP messages over the DS-Lite tunnel: PCP over UDP over IPv4 over IPv6.

	(2) send PCP messages using native IPv6:  PCP over UDP over IPv6. For this to work: the PCP client must use the same IPv6 address as B4 when issuing PCP requests. 

	For the plain IPv6 mode, the PCP server discovery method as defined in the base PCP spec is broken:

	* base spec says: use any configured pcp server, if none use the default router.

	* for the plain IPv6 ds-lite mode: the procedure should be "use any configured pcp server, if none use the AFTR."

	Please let me know if it is more clear. 

	 The rest of the text below looks good to me.

	Thanks and cheers back,

	Hemant

	>      The PCP client SHOULD follow the procedure specified in Section

	>      8.1 of [I-D.ietf-pcp-base] to discover its PCP server.  In DS-Lite

	>      context, if PCP messages are exchanged using native IPv6 (i.e.,

	>      IPv4-in-IPv6 is not used) and no PCP server is configured, the PCP

	>      client MUST use the address of the AFTR as its PCP server.

	>      Handling PCP requests from PCP clients in the LAN side of the CE

	>      Router is out of scope.

---

From: Wuyts Carl <[email-masked]>
Date: Thu, 15 Mar 2012 08:00:21 +0100

Looks ok to me
Regs
carl

From: [email-masked] [mailto:[email-masked]] On Behalf Of Hemant Singh (shemant)
Sent: woensdag 14 maart 2012 20:42
To: [email-masked]
Cc: Alain Durand; Dan Wang (danwan); Dave Thaler
Subject: [v6ops] FW: PCP (RE: draft-ietf-v6ops-6204bis WGLC)

Folks,

Thanks,

Hemant

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]

Re-,

Please see inline.

Cheers,
Med

Med,

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Tuesday, March 13, 2012 11:32 AM
To: Hemant Singh (shemant)
Cc: JACQUENET Christian OLNC/NAD/TIP
Subject: PCP (RE: [v6ops] draft-ietf-v6ops-6204bis WGLC)

Thanks and cheers back,

Hemant

---

From: Hans Liu <[email-masked]>
Date: Thu, 15 Mar 2012 18:31:35 +0800

I'm ok with it.

Thanks,
Hans

On Thu, Mar 15, 2012 at 3:42 AM, Hemant Singh (shemant)
<[email-masked]> wrote:
> Folks,
>
>
>
> This is some change that Med has asked to make to the PCP text in
> rfc6204bis.   Please provide comments.  Cc to some PCP and DS-Lite
> individuals as well.
>
>
>
> Thanks,
>
>
>
> Hemant
>
>
>
>>Please see below a text proposal to solve the comment from O. Troan. If you
>> want me to send this e-mail in the v6ops ML, I can do.
>
>
>
>
>
>>NEW:
>
>>
>
> Note above that the text says "IPv4 PCP client”.
> [Med] I kept that text from the draft as I understood it as: "PCP client to
> control a NAT44". You can safely replace "IPv4 PCP client" with "PCP
> client".
>
>
>
>  Now I am confused by the text below that is referring to “native IPv6”?  We
> all were expecting IPv4 PCP use case and thus if you can explain what is the
> IPv6 PCP use case?
> (2) send PCP messages using native IPv6:  PCP over UDP over IPv6. For this
> to work: the PCP client must use the same IPv6 address as B4 when issuing
> PCP requests.
>
>
>
> * for the plain IPv6 ds-lite mode: the procedure should be "use any
> configured pcp server, if none use the AFTR."
>
>
>
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

-- 
Instead of following the fashion, we lead it through.

---

From: Francis Dupont <[email-masked]>
Date: Thu, 15 Mar 2012 23:59:49 +0100

>  rfc6204bis.   Please provide comments.  Cc to some PCP and DS-Lite

=> I have still a concern about a recommendation for PCP when we need
only the functionality, PCP is only one of the protocols which can
provide it.

>  	From: [email-masked]
>
>  	>NEW:
>  
>  	>   The WAN interface of the CE router SHOULD support an IPv4
>  	>   PCP client as specified in [I-D.ietf-pcp-base] for use by
>  	>   applications on the CE Router.  This document takes no
>  	>   position on whether such functionality is enabled by
>  	>   default or mechanisms by which users would configure the
>  	>   functionality.
>  

=> as it is in a SHOULD body you can't keep it so loose.

>  
>  	 Now I am confused by the text below that is referring to
>           "native IPv6"?  We all were expecting IPv4 PCP use case and
>           thus if you can explain what is the IPv6 PCP use case?

=> I can't see where this level of details will go (*), IMHO if you
want to keep a SHOULD for PCP (and I am strongly opposed to this) you
need to cite the base spec, the ds-lite application and the server
discovery documents.

Regards

[email-masked]

PS (*): I am confused about the structure of these messages so
I can't say what is a comment for the list or a proposed text
for the I-D. And I am not happy with this for a WGLC.

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Thu, 15 Mar 2012 18:44:56 -0500

Francis

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, March 15, 2012 7:00 PM
To: Hemant Singh (shemant)
Cc: [email-masked]; Alain Durand; Dan Wang (danwan); Dave Thaler
Subject: Re: [v6ops] FW: PCP (RE: draft-ietf-v6ops-6204bis WGLC) 

>=> as it is in a SHOULD body you can't keep it so loose.

Could you please provide tighter text?

>discovery documents.

Pcp-base is cited.  Please point us to documents for ds-lite application
and the server discovery.  Since you had trouble reading the new PCP
text because the text was combined with review comments, I have shown
the new text for PCP in rfc6204bis below.   Please review. 

   The WAN interface of the CE router SHOULD support a PCP client

   Router is out of scope.

Thanks much for the review.

Hemant

---

From: Tim Chown <[email-masked]>
Date: Fri, 16 Mar 2012 07:03:56 +0000

> only the functionality, PCP is only one of the protocols which can

This is the current position in the homenet architecture text, i.e. if "Simple Security" is in use then a signalling protocol is needed, but as yet no specific mechanism is recommended. 

There is likely to be some discussion of this in Paris.

Tim

---

From: <[email-masked]>
Date: Fri, 16 Mar 2012 08:24:40 +0100

Hi Francis,

The current text specifies the client counterpart of REQ#10 http://tools.ietf.org/html/draft-ietf-behave-lsn-requirements-05.

Which other protocols you want to include?

Cheers,
Med

>-----Message d'origine-----
>De : [email-masked] [mailto:[email-masked]] De 
>la part de Francis Dupont
>Envoyé : vendredi 16 mars 2012 00:00
>À : Hemant Singh (shemant)
>Cc : [email-masked]; Alain Durand; Dan Wang (danwan); Dave Thaler
>Objet : Re: [v6ops] FW: PCP (RE: draft-ietf-v6ops-6204bis WGLC)
>

---

From: Francis Dupont <[email-masked]>
Date: Fri, 16 Mar 2012 22:47:15 +0100

>     The WAN interface of the CE router SHOULD support a PCP client

=> I am still strongly opposed to this SHOULD for PCP.
For the other comments I'll consider this is nevertheless kept.

>     8.1 of [I-D.ietf-pcp-base] to discover its PCP server.

=> I am not convinced 8.1 is enough but if the PCP WG doesn't propose
something better for a CPE we could keep this.

>     In DS-Lite context, if PCP messages are exchanged using native
>     IPv6 (i.e., IPv4-in-IPv6 is not used) and no PCP server is
>     configured, the PCP client MUST use the address of the AFTR as
>     its PCP server.

=> it is bad, I propose:

>     In DS-Lite context, the procedure of [I-D.dupont-pcp-dslite] MUST
>     be applied.

>     Handling PCP requests from PCP clients in the LAN side of the CE

=> again there is no reason to restrict this to PCP: we should describe
the function we want and give PCP (or better PCP and UPnP IGD) as
examples of protocols providing it.

Regards

---

From: Francis Dupont <[email-masked]>
Date: Fri, 16 Mar 2012 23:04:33 +0100

In your previous mail you wrote:

> The current text specifies the client counterpart of REQ#10
> http://tools.ietf.org/html/draft-ietf-behave-lsn-requirements-05.

<flame on>

=> ah, a requirement from the WG which documents from
are clearly ignored in the real world (:-)?

<flame off>

>  Which other protocols you want to include?

=> UPnP IGD as another example (and please cite the v2 spec)

Regards

---

From: james woodyatt <[email-masked]>
Date: Fri, 16 Mar 2012 15:07:19 -0700

On Mar 16, 2012, at 15:04 , Francis Dupont <[email-masked]> wrote:
> 
> UPnP IGD as another example (and please cite the v2 spec)

We can't cite that spec as a normative reference.  Only as an *informative* reference.

--
james woodyatt <[email-masked]>
member of technical staff, core os networking

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Fri, 16 Mar 2012 18:43:48 -0500

Francis,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, March 16, 2012 5:47 PM
To: Hemant Singh (shemant)
Cc: [email-masked]; Alain Durand; Dan Wang (danwan); Dave Thaler
Subject: Re: [v6ops] FW: PCP (RE: draft-ietf-v6ops-6204bis WGLC) 

>     In DS-Lite context, the procedure of [I-D.dupont-pcp-dslite] MUST

The IPv6 CE router document can only add a technology in RFC form and
the above document is not an RFC.  In rare exceptions the rfc6204bis
accepts a draft but the draft should be in the IESG.  The above document
is not in the IESG either.

Thus we will have to settle for the text already proposed.  Also, I am
very sorry, I have a hard time reading your email because I do not
understand the delimiters for what is old vs. new text.  I will try
again carefully and see if I can reply further.

Thanks and regards,

Hemant

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Fri, 16 Mar 2012 18:46:51 -0500

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of james woodyatt
Sent: Friday, March 16, 2012 6:07 PM
To: IPv6 Ops WG
Subject: Re: [v6ops] FW: PCP (RE: draft-ietf-v6ops-6204bis WGLC)

> We can't cite that spec as a normative reference.  Only as an
*informative* reference.

Sorry, we only agreed to limited PCP requirement to add to the IPv6 CE
router document.  UPnP is a new requirement that is hard to add during
the LastCall of the document.  Could we consider UPnP for rfc6204ter?

Thanks,

Hemant

---

From: Francis Dupont <[email-masked]>
Date: Sat, 17 Mar 2012 14:55:17 +0100

>  We can't cite that spec as a normative reference.  Only as an *informative* reference.

=> example implies informative reference (so we should agree)

Thanks

---

From: Francis Dupont <[email-masked]>
Date: Sat, 17 Mar 2012 15:06:36 +0100

>  is not in the IESG either.

=> I understand your concern but if the PCP is referenced only as an
example (cf homenet-arch, with UPnP IGD) then:
 - it can go to informative references
 - only the base-spec should be cited
so it solves the problem and even more.

>  again carefully and see if I can reply further.

=> perhaps my MUA config junked again: old text is supposed to get
">  " before, and I manually add "=> " before the text I type.

Regards

---

From: Francis Dupont <[email-masked]>
Date: Sat, 17 Mar 2012 15:10:46 +0100

>  the LastCall of the document.  Could we consider UPnP for rfc6204ter?

=> you didn't understand: I don't want a requirement for UPnP but
a requirement for the *function* with PCP and UPnP IGD as example
of protocols providing the function.
Quoting draft-ietf-homenet-arch-02.txt as suggested by Tim:

   ... Applications or hosts
   wanting to accept inbound connections in networks that are compliant
   with the architecture presented in this document would then need to
   signal that desire through a protocol such as UPnP or PCP.

so what we need is just a similar text explaining what we want and
giving examples about how to get it.

Regards

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Sat, 17 Mar 2012 09:26:13 -0500

Francis,

Could you please provide text.  Can you please also work with Med on the
text for PCP and send one final text that both of you hash out.

Thanks and regards,

Hemant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Saturday, March 17, 2012 10:11 AM
To: Hemant Singh (shemant)
Cc: james woodyatt; IPv6 Ops WG
Subject: Re: [v6ops] FW: PCP (RE: draft-ietf-v6ops-6204bis WGLC) 

Regards

---

From: <[email-masked]>
Date: Mon, 19 Mar 2012 08:44:46 +0100

Hi Francis,

Please see inline.

Cheers,
Med 

>Envoyé : vendredi 16 mars 2012 22:47

Med: The requirement is coherent with the requriement in the server's side specified in draft-behave-lsn-*. 

>something better for a CPE we could keep this.

Med: This is the better we can do.

>>     configured, the PCP client MUST use the address of the AFTR as

Med: The text is generic on purpose and it applies to both PCP encapsulation mode and IPv6 plain mode. Selecting between these two modes is deployment-specific. I don't see a reason to cite your draft here. 

>examples of protocols providing it.

Med: Including PCP client in the LAN side would require having a PCP proxy in the CPE. Since the PCP WG didn't much progress in that spec, I vote for keeping this out of scope.

---

From: Francis Dupont <[email-masked]>
Date: Mon, 19 Mar 2012 09:16:33 +0100

In your previous mail you wrote:

>  Med: The requirement is coherent with the requriement in the
>  server's side specified in draft-behave-lsn-*.

=> the v6ops spec is supposed to be used in the real world
so has more constraints than draft-behave*.

> Med: The text is generic on purpose and it applies to both PCP
> encapsulation mode and IPv6 plain mode. Selecting between these two
> modes is deployment-specific. I don't see a reason to cite your
> draft here.

=> for me it looks like an attempt to overrule a choice which is in
the scope of the PCP WG and this WG only.
Note without a particular requirement for PCP none of the details
about how to use PCP is needed.

Regards

---

From: Dave Thaler <[email-masked]>
Date: Sun, 25 Mar 2012 16:49:48 +0000

> Sent: Monday, March 19, 2012 9:17 AM
> To: [email-masked]
> Cc: Hemant Singh (shemant); [email-masked]; Alain Durand; Dan Wang
> (danwan); Dave Thaler
> => the v6ops spec is supposed to be used in the real world so has more
> constraints than draft-behave*.
> 
> > modes is deployment-specific. I don't see a reason to cite your draft
> > here.
> 
> => for me it looks like an attempt to overrule a choice which is in the scope of
> the PCP WG and this WG only.
> Note without a particular requirement for PCP none of the details about how
> to use PCP is needed.

To add to that, I don't believe it is appropriate for 6204bis to make statements 
about how to use PCP that are not in a normative reference.   As MED mentioned,
PCP proxy is not a normative reference so cannot be required in this iteration.
Similarly I don't believe discussion of how to use PCP with DS-Lite is appropriate
in 6204bis itself either.   It should only state what normative references are
required and leave details on how they work to the normative references.

-Dave

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Sun, 25 Mar 2012 12:18:45 -0500

Dave,

-----Original Message-----
From: Dave Thaler [mailto:[email-masked]] 
Sent: Sunday, March 25, 2012 12:50 PM
To: Hemant Singh (shemant); [email-masked]
Cc: Alain Durand; Dan Wang (danwan)
Subject: RE: [v6ops] FW: PCP (RE: draft-ietf-v6ops-6204bis WGLC) 

>required and leave details on how they work to the normative
references.

Appreciate the comments.  I mostly agree with you.  There is one caveat
in that rfc6204bis is specifying requirements for a single device in the
IPv6 CE Router and thus rfc6204bis has some flexibility to tighten the
rules specified in a protocol that is being used in the requirement.
Since you have a slide to be presented in the PCP session tomorrow, we
can wait and see the outcome of that discussion.  The rfc6204bis v6ops
presentation may also move to Thursday.  For reference, the current PCP
text in rfc6204bis is included below.

W-6:  The WAN interface of the CE router SHOULD support a PCP client

         as specified in [I-D.ietf-pcp-base] for use by applications on

         the CE Router.  The PCP client SHOULD follow the procedure

         specified in Section 8.1 of [I-D.ietf-pcp-base] to discover its

         PCP server.  This document takes no position on whether such

         functionality is enabled by default or mechanisms by which

         users would configure the functionality.  Handling PCP requests

         from PCP clients in the LAN side of the CE Router is out of

         scope.

   W-7:  In DS-Lite context, if PCP messages are exchanged using native

         its PCP server.

Thanks,

Hemant