Subject: [v6ops] draft-ietf-intarea-ipv6-required

From: Fred Baker <[email-masked]>
Date: Thu, 15 Mar 2012 17:04:46 -0700

http://tools.ietf.org/html/draft-ietf-intarea-ipv6-required
  "IPv6 Support Required for all IP-capable Nodes", Lee Howard, Chris
  Donley, Wesley George, Chris Donley, 8-Dec-11

George raised this question on v6ops a tad over a year ago, but I wonder if there is a sense of the community that we should forward to intarea now. Do me a favor if your would; read the draft and post a a comment on it. Up/down is good; if you don't support it, saying why not so I can summarize to the Internet Area folks would be helpful.

Chris Donley must have had a really major part in this draft...

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Thu, 15 Mar 2012 19:38:54 -0500

Snipped from the document is the text below that I have a comment on.

[While transition technologies and other means to extend the lifespan

of IPv4 do exist, nearly all of them come with tradeoffs that prevent

them from being optimal long-term solutions when compared with

deployment of IP version 6 (IPv6) as a means to allow continued

growth on the Internet.]

Some folks will have an exactly opposite view from what is said above.
IPv4 may exist for a long time and thus IPv6 hosts will need to
communicate with IPv4 hosts and one will need transition mechanism and
the deployment is still optimal.  Thus the whole text above can be
removed or the text will thrash for discussion.

Further, the documents cites RFC 1812 but the title of RFC 1812 clearly
mentions "IP version 4 Routers".  So isn't RFC 1812 disqualified to be
in this document that is trying to find RFCs that have IP specific text
that needs qualification by v4 or v6?  That leaves only one RFC in RFC
1122 to cite in the document.  It would be good to collect more RFCs to
list.  Lastly, for IPv6 the IETF wrote the ipv6 node reqs RFC which is
the goto document for IPv6.  From the IPv6 node reqs document one
reaches all IPv6 specifications and then one does not go to any IPv4
IETF specification.  If one does, then some new features have to get
into the ipv6 node reqs document. 

Most of the text in the third paragraph of the Introduction section is
not much use.  It works much better to go directly to each device vendor
and request strongly for IPv6 support including any public shame in the
IETF.  There is enough public-domain free IPv6 code around that most
devices could start with. I'd recommend some of that code for specific
devices.  That's how stuff gets done. 

Regards,

Hemant

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Fred Baker (fred)
Sent: Thursday, March 15, 2012 8:05 PM
To: v6ops v6ops WG
Subject: [v6ops] draft-ietf-intarea-ipv6-required

George raised this question on v6ops a tad over a year ago, but I wonder
if there is a sense of the community that we should forward to intarea
now. Do me a favor if your would; read the draft and post a a comment on
it. Up/down is good; if you don't support it, saying why not so I can
summarize to the Internet Area folks would be helpful.

_______________________________________________

v6ops mailing list

[email-masked]

https://www.ietf.org/mailman/listinfo/v6ops

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 16 Mar 2012 13:49:25 +1300

> deployment of IP version 6 (IPv6) as a means to allow continued

The problem is what it has been for many years - we should always
say either 'coexistence' or 'interworking' to describe a technology;
transition is not a technology.

> IPv4 may exist for a long time 

which implies coexistence technology

> and thus IPv6 hosts will need to
> communicate with IPv4 hosts 

which implies interworking technology.

I think the text above could be revised to make this distinction
and to observe that interworking technology inevitably has
negative impact on users.

Apart from that, I support the document.

    Brian

and one will need transition mechanism and
> ------------------------------------------------------------------------
>

---

From: "George, Wes" <[email-masked]>
Date: Fri, 16 Mar 2012 10:01:50 -0400

Folks, the referenced draft has long since passed Last Call and is in the RFC editor's queue. It is currently in AUTH-48 status awaiting the AD's determination as to whether it will be a BCP or a PS. (There was apparently some confusion because the draft changed status between revisions. Despite what the datatracker says, the authors believe that the last guidance was for it to be a BCP).
http://datatracker.ietf.org/doc/draft-ietf-intarea-ipv6-required/
I do not believe that the wording nits below warrant changes at this stage, and am disinclined to do anything about them.

I believe that the draft that Fred intended to point you to is
http://tools.ietf.org/html/draft-george-ipv6-support-01
since this one is being discussed in INT-Area in Paris and we are certainly open to comments from v6ops as well.

The draft names are similar, so I understand how there might have been confusion. Hopefully this clears it up.

Thanks,

Wes George

From: [email-masked] [mailto:[email-masked]] On Behalf Of Hemant Singh (shemant)
Sent: Thursday, March 15, 2012 8:39 PM
To: Fred Baker (fred); v6ops v6ops WG
Subject: Re: [v6ops] draft-ietf-intarea-ipv6-required

growth on the Internet.]

Some folks will have an exactly opposite view from what is said above.  IPv4 may exist for a long time and thus IPv6 hosts will need to communicate with IPv4 hosts and one will need transition mechanism and the deployment is still optimal.  Thus the whole text above can be removed or the text will thrash for discussion.

Further, the documents cites RFC 1812 but the title of RFC 1812 clearly mentions "IP version 4 Routers".  So isn't RFC 1812 disqualified to be in this document that is trying to find RFCs that have IP specific text that needs qualification by v4 or v6?  That leaves only one RFC in RFC 1122 to cite in the document.  It would be good to collect more RFCs to list.  Lastly, for IPv6 the IETF wrote the ipv6 node reqs RFC which is the goto document for IPv6.  From the IPv6 node reqs document one reaches all IPv6 specifications and then one does not go to any IPv4 IETF specification.  If one does, then some new features have to get into the ipv6 node reqs document.

Most of the text in the third paragraph of the Introduction section is not much use.  It works much better to go directly to each device vendor and request strongly for IPv6 support including any public shame in the IETF.  There is enough public-domain free IPv6 code around that most devices could start with. I'd recommend some of that code for specific devices.  That's how stuff gets done.

Regards,

Hemant

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Fred Baker (fred)
Sent: Thursday, March 15, 2012 8:05 PM
To: v6ops v6ops WG
Subject: [v6ops] draft-ietf-intarea-ipv6-required

v6ops mailing list

[email-masked]<mailto:[email-masked]>

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Fred Baker <[email-masked]>
Date: Fri, 16 Mar 2012 08:25:07 -0700

Thanks. Yes, I went looking for draft-george-support-ipv6, and for some reason didn't find it - perhaps because the tag I had reference a -02. My error.

On Mar 16, 2012, at 7:01 AM, George, Wes wrote:

> Folks, the referenced draft has long since passed Last Call and is in the RFC editor’s queue. It is currently in AUTH-48 status awaiting the AD’s determination as to whether it will be a BCP or a PS. (There was apparently some confusion because the draft changed status between revisions. Despite what the datatracker says, the authors believe that the last guidance was for it to be a BCP).
> Further, the documents cites RFC 1812 but the title of RFC 1812 clearly mentions “IP version 4 Routers”.  So isn’t RFC 1812 disqualified to be in this document that is trying to find RFCs that have IP specific text that needs qualification by v4 or v6?  That leaves only one RFC in RFC 1122 to cite in the document.  It would be good to collect more RFCs to list.  Lastly, for IPv6 the IETF wrote the ipv6 node reqs RFC which is the goto document for IPv6.  From the IPv6 node reqs document one reaches all IPv6 specifications and then one does not go to any IPv4 IETF specification.  If one does, then some new features have to get into the ipv6 node reqs document.
>  
> Most of the text in the third paragraph of the Introduction section is not much use.  It works much better to go directly to each device vendor and request strongly for IPv6 support including any public shame in the IETF.  There is enough public-domain free IPv6 code around that most devices could start with. I’d recommend some of that code for specific devices.  That’s how stuff gets done.
>  
> Regards,
>  
> Hemant
>  
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Fred Baker (fred)