Subject: [v6ops] new draft: draft-townsley-v6ops-6rd-sunsetting

From: <[email-masked]>
Date: Sat, 17 Mar 2012 06:55:00 -0700 (PDT)

A new draft has been posted, at http://tools.ietf.org/html/draft-townsley-v6ops-6rd-sunsetting. Please take a look at it and comment.

---

From: Joel jaeggli <[email-masked]>
Date: Sat, 17 Mar 2012 16:43:07 -0700

I'd like to see it take a stand that being able to renumber is a highly
desirable property of cpe devices employing transitional mechanisms. I
don't think the prefix size selected for a 6rd deployment should compel
you to continue using that prefix size at a later date.

On 3/17/12 06:55 , [email-masked] wrote:
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops
>

---

From: Brian E Carpenter <[email-masked]>
Date: Sun, 18 Mar 2012 13:09:39 +1300

> you to continue using that prefix size at a later date.

Agreed. In a multihomed scenario or a renumbering scenario, you may
have multiple prefixes with different lengths at the same time. This
is mentioned in RFC 5887 and in draft-ietf-6renum-gap-analysis.
6rd must not constrain any non-6rd prefix length.

    Brian

---

From: Mark Townsley <[email-masked]>
Date: Sat, 24 Mar 2012 00:04:56 +0100

> A new draft has been posted, at http://tools.ietf.org/html/draft-townsley-v6ops-6rd-sunsetting. Please take a look at it and comment.

It's actually not a new draft, it's an "old" one, posted during the IETF meeting in Taipei last November. After our admittedly tardy posting, the Chairs asked me to pull together a presentation on it, which I was happy to do though the time was quite rushed if I recall. I think the meeting-based conversation on this one started but did not finish.

In any case, since then Ole and I worked out a draft that incorporates the 6rd sunsetting issue together with the related (yet "inverted") issue that ds-lite has. This is described in draft-townsley-troan-ipv6-ce-transitioning-02.

As mentioned in my other mail, 6204-bis is skirting this issue in what I continue to assert will end up as dangerous to both technologies should 6204-bis become the reference for inclusion of 6rd or ds-lite into retail CPE hardware.

Chairs: Alexandre from Free *may* be available Monday (and only Monday) for presentation or Q&A on 6rd-sunsetting if you can squeeze it in as the last presentation (I only know this as CIsco is trying to arrange our "host lunch presentation" on Monday to include him and others to discuss the upcoming v6world launch, so he would have to be here at noon for that anyway - perhaps we can talk him into coming at 11). As the largest 6rd (and IPv6) operator in the world, it might be worth making time for… In particular as generally he and his team does not have time to contribute directly to IETF activities, even if they are certainly contributing to IETF running code. 

Thanks,

- Mark

---

From: Fred Baker <[email-masked]>
Date: Sat, 24 Mar 2012 00:23:29 +0100

Well, we have had 182 messages on the topic since IETF 82. It fits that criterion.

I have a problem in that Monday's agenda is pretty full. Let's discuss Monday during the agenda bash, and we may move a discussion to Thursday. I'll be looking for a volunteer; with my luck, I'll move someone that has a dead short conflict if I pick at random.

---

From: Mark Townsley <[email-masked]>
Date: Sat, 24 Mar 2012 08:44:30 +0100

> I have a problem in that Monday's agenda is pretty full. Let's discuss Monday during the agenda bash, and we may move a discussion to Thursday. I'll be looking for a volunteer; with my luck, I'll m…

That's fair enough. 

FWIW, I do recall us requesting a slot for draft-townsley-troan-ipv6-ce-transitioning a while back (via email to the chairs), but perhaps it got lost as we didn't put "v6ops" in the name. As we don't match the regular expression in Henrik's tools for v6ops, it could have easily been overlooked and I didn't review the agenda myself until yesterday evening. 

- Mark