Subject: Re: [v6ops] Some questions on draft-yang-v6ops-fast6

From: [email-masked]
Date: Sun, 1 Apr 2012 20:25:46 +0800 (CST)

Hi, Fred:

1) Please provide a succinct problem statement for your draft. What problem/issue is this draft discussing? What operational problems does the proposal address in real life networks?

// When we made series trials in the real life network in the last two years, we found there are many problems arose in the practice and Native dual stack sounds like a suitable method for our network migration. The reasons why other kinds of transition technologies are not very suitable for our network, such as 4over6, 6over4, are briefly listed in the Introduction in this draft and detailed explained in “draft-yang-v6ops-FAST6-tool-selection-01”.

However, in order to make a quick response to address exhaustion, native dual stack has to cooperate with address sharing technology. We made a trial in real life network using “native dual stack+ carrier grade NAT” and  we find there is mixed routing problem in the network. In the initial stage, the CGNs have to be distributed in the Network Edge (such as BNG) since the large amount of IPv4 traffic (according to the prediction data for our network ). In this case, private IPv4 routing and public IPv4 routing will coexist in the network.
The proposal, FAST6 addresses this problems described above in real life network through establishing a private-in-public IPv4 tunnel between FTS and FTN to isolate the routings in network.In practice , the tunnel between FTS and FTN is usually a tunnel between BNG and CR. So it can solve the mixed routing problem in network.

2) Where does this draft or presentation fits into v6ops' current charter (http://datatracker.ietf.org/wg/v6ops/charter/)? Citing specific a section(s) of the charter is preferable.

We list the provisions in chart this draft fit into as below:

(1)   The IPv6 Operations Working Group (v6ops) develops guidelines for the operation of a shared IPv4/IPv6 Internet.

(2)  The main focus of the v6ops WG is to look at the immediate deployment issues. FAST6 is designed for very initial step of deployment.

(3)  Solicit input from network operators and users to identify operational issues with the IPv4/IPv6 Internet, and determine solutions or workarounds to those issues. FAST6 have describe the operation problem we meet in practice and give the solution.

3) Who is this draft's audience?

Although FAST6 is designed with our own network experience, it is suitable for many other operators. The audiences are network operators whose public address space is very limited and will be exhausted in very short recently which means they have no time to reform their network to native IPv6 in specified short time. They may have to use carrier grade NAT to deal the emergent situation, FAST6 can info them some operation problems in real life network and the solution.

4) Have any operators expressed interest in this draft or its problem space, either via review or other discussion?
China Telecom express strong interest in this draft. We are eagerly hoping the other operators’ response in the draft.
5) Is this draft pursuing discussion in any other WGs? If so, please list them here, along with rationale for the interaction with multiple WGs in parallel.
We only post it in v6ops WG and didn’t have discussion in other WGs yet.

6) Is any protocol work being recommended in the draft?
There is no change of any protocol in this draft.

===== 回复前原始邮件 =====

发件人：[email-masked]
日期：2012/03/31 20:45:01
收件人：[email-masked]
抄送：[email-masked]
主题：Some questions on draft-yang-v6ops-fast6

Let me ask some questions. This is not intended to put you off or offend, but to help the chairs in understanding where the draft fits in the big scheme of things.

1) Please provide a succinct problem statement for your draft. What problem/issue is this draft discussing? What operational problems does the proposal address in real life networks?

2) Where does this draft or presentation fits into v6ops' current charter (http://datatracker.ietf.org/wg/v6ops/charter/)? Citing specific a section(s) of the charter is preferable.

3) Who is this draft's audience?

4) Have any operators expressed interest in this draft or its problem space, either via review or other discussion?

5) Is this draft pursuing discussion in any other WGs? If so, please list them here, along with rationale for the interaction with multiple WGs in parallel.

6) Is any protocol work being recommended in the draft?

the criteria the WG asked me to apply for new work or presentation slots are:
- recent or recently updated draft
- within charter
- results in constructive discussion on the mailing list

I need for you to provoke discussion on the list. You may respond to my opening email to do so if it's helpful.

---

From: [email-masked]
Date: Sun, 1 Apr 2012 20:35:15 +0800 (CST)

Hi, Fred:

I forget to mention, for your fisrt question "Please provide a succinct problem statement for your draft. What problem/issue is this draft discussing? What operational", we will verify our second version with more intuitive description.

===== 回复前原始邮件 =====

发件人：[email-masked]
日期：2012/03/31 20:45:01