Subject: [v6ops] [Technical Errata Reported] RFC6204 (3175)

From: RFC Errata System <[email-masked]>
Date: Wed, 4 Apr 2012 07:24:29 -0700 (PDT)

The following errata report has been submitted for RFC6204,
"Basic Requirements for IPv6 Customer Edge Routers".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6204&eid=3175

--------------------------------------
Type: Technical
Reported by: Sathyanarayana Venkataramanappa <[email-masked]>

Section: 4.2

Original Text
-------------
WPD-3:  The IPv6 CE router MUST be prepared to accept a delegated
           prefix size different from what is given in the hint.  If the
           delegated prefix is too small to address all of its
           interfaces, the IPv6 CE router SHOULD log a system management
           error.

Corrected Text
--------------
WPD-3:  The IPv6 CE router MUST be prepared to accept a delegated
           prefix size different from what is given in the hint.  If the
           delegated prefix is too small to address all of its
           interfaces or delegated prefix size is greater than /64, the 
           IPv6 CE router SHOULD log a system management
           error.

Notes
-----
Stateless Address Auto configuration uses 64 bit long EUI-64. If Delegated prefix size obtained on the wan side is greater than /64. This Prefix cannot be used on Lan side nodes to create SLAAC address using EUI-64

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6204 (draft-ietf-v6ops-ipv6-cpe-router-09)
--------------------------------------
Title               : Basic Requirements for IPv6 Customer Edge Routers
Publication Date    : April 2011
Author(s)           : H. Singh, W. Beebee, C. Donley, B. Stark, O. Troan, Ed.
Category            : INFORMATIONAL
Source              : IPv6 Operations
Area                : Operations and Management
Stream              : IETF
Verifying Party     : IESG

---

From: Wes Beebee <[email-masked]>
Date: Wed, 04 Apr 2012 13:11:06 -0400

Given that part of "addressing all of its interfaces" implies handing out
prefixes on those interfaces from which SLAAC addresses will be constructed,
the "greater than /64" is already implied in the original WPD-3.  Do we need
to make this implication explicit?

- Wes

On 4/4/12 10:24 AM, "[email-masked]" <[email-masked]>
wrote:

> Stateless Address Auto configuration uses 64 bit long EUI-64. If Delegated
> prefix size obtained on the wan side is greater than /64. This Prefix cannot
> be used on Lan side nodes to create SLAAC address using EUI-64
> 
> Instructions:
> -------------