Subject: [v6ops] 6204bis draft 09 - http://tools.ietf.org/html/draft-ietf-v6ops-6204bis-09

From: Joel jaeggli <[email-masked]>
Date: Sat, 19 May 2012 21:11:36 -0700

In response to comments recieved during the 6204bis  draft wglc and
subsequent discsussion among the authors, draft 09 was produced.

http://tools.ietf.org/html/draft-ietf-v6ops-6204bis-09

diffs between the two are here:

http://tools.ietf.org/rfcdiff?url2=draft-ietf-v6ops-6204bis-09.txt

please review by tue 5/22, this is the version that I plan on generating
the document shepherds review from. It strikes me as unlikley that the
current discussion on mtu/mss adjustment is going to produce a
sustainable consensus and we should therefore consider where or whether
or where to expose that problem in a document.

Minor niggles can be corrected in auth-48, larger problems should not.

thanks
joel

---

From: Cameron Byrne <[email-masked]>
Date: Sun, 20 May 2012 05:50:04 -0700

> or where to expose that problem in a document.

I still strongly believe the mtu issue needs to be acknowledged here. It
does not need to be solved here.

CB

> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: Randy Bush <[email-masked]>
Date: Sun, 20 May 2012 22:05:08 +0900

> I still strongly believe the mtu issue needs to be acknowledged
> here. It does not need to be solved here.

this draft sans at least a warning would be grievously bad engineering.

randy

---

From: Ole Trøan <[email-masked]>
Date: Mon, 21 May 2012 09:49:54 +0200

Joel,

> or where to expose that problem in a document.

I-D.ietf-dhc-dhcpv6-stateful-issues should be a normative reference.

cheers,
Ole

---

From: Rémi Després <[email-masked]>
Date: Mon, 21 May 2012 11:05:33 +0200

Hi Joel,

2012-05-20  06:11, Joel Jaeggli :
...
>  It strikes me as unlikley that the

The fact that there is no consensus on how to deal with an identified operational problem justifies IETF to tackle the subject.

Suggestion: v6ops asks for a work item to be created on fragmentation issues, e.g. in Intarea.
Subject could include considerations on:
- IPv6 AND IPv4
- ICMP PTB and firewalls
- RA advertised MTUs
- Transmit MTUs and DF settings in hosts
 . in TCP AND UDP 
 . for on-link AND off-link destinations
- MSS rewrites

Any alternative way to make progress would be welcome, provided documenting an IETF view on these issues isn't further deferred.

Regards,
RD

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Mon, 21 May 2012 09:05:21 -0500

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ole Trøan
Sent: Monday, May 21, 2012 3:50 AM
To: Joel jaeggli
Cc: IPv6 Ops WG
Subject: Re: [v6ops] 6204bis draft 09 -http://tools.ietf.org/html/draft-ietf-v6ops-6204bis-09

>I-D.ietf-dhc-dhcpv6-stateful-issues should be a normative reference.

When do we think the above document can be sent to the IESG by the DHC WG?  Rfc6204bis is sensitive to any delays for publication if a normative reference does not become an RFC around the time of publication for rfc6204bis.

Thanks,

Hemant

---

From: "Bernie Volz (volz)" <[email-masked]>
Date: Mon, 21 May 2012 09:44:59 -0500

Can we request that the DHC WG chairs to start a DHC WG last-call on the document? There has been no real discussion of it so far on the mailing list; perhaps this is one way to trigger that discussion? It would be nice to move this document along!!

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hemant Singh (shemant)
Sent: Monday, May 21, 2012 10:05 AM
To: Ole Trøan; Joel jaeggli
Cc: dhcwg; IPv6 Ops WG
Subject: Re: [v6ops] 6204bis draft 09-http://tools.ietf.org/html/draft-ietf-v6ops-6204bis-09

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ole Trøan
Sent: Monday, May 21, 2012 3:50 AM
To: Joel jaeggli
Cc: IPv6 Ops WG
Subject: Re: [v6ops] 6204bis draft 09 -http://tools.ietf.org/html/draft-ietf-v6ops-6204bis-09

Thanks,

Hemant

---

From: "Hemant Singh (shemant)" <[email-masked]>
Date: Mon, 21 May 2012 14:53:23 -0500

Thanks, Bernie!

Hemant

-----Original Message-----
From: Bernie Volz (volz) 
Sent: Monday, May 21, 2012 10:45 AM
To: [email-masked]
Cc: IPv6 Ops WG; Hemant Singh (shemant); Ole Trøan; Joel jaeggli
Subject: RE: [v6ops] 6204bis draft 09-http://tools.ietf.org/html/draft-ietf-v6ops-6204bis-09

- Bernie

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Hemant Singh (shemant)
Sent: Monday, May 21, 2012 10:05 AM
To: Ole Trøan; Joel jaeggli
Cc: dhcwg; IPv6 Ops WG
Subject: Re: [v6ops] 6204bis draft 09-http://tools.ietf.org/html/draft-ietf-v6ops-6204bis-09

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ole Trøan
Sent: Monday, May 21, 2012 3:50 AM
To: Joel jaeggli
Cc: IPv6 Ops WG
Subject: Re: [v6ops] 6204bis draft 09 -http://tools.ietf.org/html/draft-ietf-v6ops-6204bis-09

Thanks,

Hemant

---

From: Randy Bush <[email-masked]>
Date: Tue, 22 May 2012 05:31:24 +0900

>>  It strikes me as unlikley that the current discussion on mtu/mss
>> adjustment is going to produce a sustainable consensus and we should
>> therefore consider where or whether or where to expose that problem
>> in a document.
> The fact that there is no consensus on how to deal with an identified
> operational problem justifies IETF to tackle the subject.

if there is no consensus on how to deal with it does not mean that we
should not warn that there is a very large operational speed bump.  it
would be irresponsible not to do so.

randy

---

From: Vízdal Aleš <[email-masked]>
Date: Wed, 23 May 2012 11:49:14 +0200

Hello,

I would like to propose a small wording change to increase the clarity of L-2
in order to make sure that in case of multiple prefixes delegated to a CER
a /64 from each of its delegated prefixes is assigned to each of its LAN interfaces.

L-2:   The IPv6 CE router MUST assign a separate /64 from *each of* its
          delegated prefix(es) (and ULA prefix if configured to provide
          ULA addressing) for each of its LAN interfaces.

WPD-8: the I-D.ietf-dhc-pd-exclude has recently been issued as an RFC6603

Cheers,
Ales

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Joel
> jaeggli
> Sent: Sunday, May 20, 2012 6:12 AM
> To: IPv6 Ops WG
> Subject: [v6ops] 6204bis draft 09 - http://tools.ietf.org/html/draft-ietf-v6ops-
> 6204bis-09
>