Subject: Re: [v6ops] draft-ietf-v6ops-ra-guard-implementation WGLC

From: Fernando Gont <[email-masked]>
Date: Thu, 03 May 2012 03:48:10 -0300

Hi, Nick,

On 04/22/2012 07:25 PM, Nick Hilliard wrote:
> reading back over this, I wonder would it be useful to make a
> recommendation to vendors to implement some form of logging for dropped
> packets so that operators can choose to have visibility into this problem
> on their networks.  Silently dropping packets is all very well, but many
> operators like to feel that if a packet is dropped, they should know about it.

Regarding your suggestion to log dropped packets, do you have any
proposed text to address it?

May be I could simply add this
"and this event SHOULD be logged (e.g., a counter could be incremented
reflecting the packet drop)."

to each rule that recommends to drop the packet?

Thanks!

Best regards,
-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Nick Hilliard <[email-masked]>
Date: Thu, 03 May 2012 12:22:27 +0100

> proposed text to address it?

yes, that would probably help.

I'd drop the word "silently" from paragraphs 3.1, 3.2 and 3.3, because that
implies no logging.

After paragraph 3.4, insert before "In order to protect current ...":

--
If a packet is dropped due to this filtering mechanism, then this packet
drop event SHOULD be logged.   The logging mechanism SHOULD include a drop
counter dedicated to RA-Guard packet drops.
--

Nick

---

From: Fernando Gont <[email-masked]>
Date: Thu, 03 May 2012 21:02:07 -0300

> I'd drop the word "silently" from paragraphs 3.1, 3.2 and 3.3, because that

By "paragraphs" you mean the bullets corresponding to the filtering
rules, right?

> After paragraph 3.4, insert before "In order to protect current ...":

Great. Will apply thi.

Thanks!

Best regards,

---

From: David Farmer <[email-masked]>
Date: Thu, 03 May 2012 20:05:29 -0500

I support this draft, it provides important and useful advice to 
RA-Guard implementers and the IPv6 operations community.

On 4/22/12 13:00 CDT, Fred Baker wrote:
> This is to initiate a two week working group last call of
> draft-ietf-v6ops-ra-guard-implementation. Please read it now. If you
> find nits (spelling errors, minor suggested wording changes, etc),
> comment to the authors; if you find greater issues, such as disagreeing
> with a statement or finding additional issues that need to be addressed,
> please post your comments to the list.
>
> We are looking specifically for comments on the importance of the
> document as well as its content. If you have read the document and
> believe it to be of operational utility, that is also an important
> comment to make.

-- 
===============================================
David Farmer               Email:[email-masked]
Networking & Telecommunication Services
Office of Information Technology
University of Minnesota	
2218 University Ave SE	    Phone: 612-626-0815
Minneapolis, MN 55414-3029   Cell: 612-812-9952
===============================================

---

From: Nick Hilliard <[email-masked]>
Date: Fri, 04 May 2012 15:12:02 +0100

> By "paragraphs" you mean the bullets corresponding to the filtering

yes.

Nick