Subject: [v6ops] I-D Action: draft-ietf-v6ops-ra-guard-implementation-03.txt

From: [email-masked]
Date: Fri, 11 May 2012 11:30:01 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the IPv6 Operations Working Group of the IETF.

	Title           : Implementation Advice for IPv6 Router Advertisement Guard (RA-Guard)
	Author(s)       : Fernando Gont
	Filename        : draft-ietf-v6ops-ra-guard-implementation-03.txt
	Pages           : 18
	Date            : 2012-05-11

   The IPv6 Router Advertisement Guard (RA-Guard) mechanism is commonly
   employed to mitigate attack vectors based on forged ICMPv6 Router
   Advertisement messages.  Many existing IPv6 deployments rely on RA-
   Guard as the first line of defense against the aforementioned attack
   vectors.  However, some implementations of RA-Guard have been found
   to be prone to circumvention by employing IPv6 Extension Headers.
   This document describes the evasion techniques that affect the
   aforementioned implementations, and provides advice on the
   implementation of RA-Guard, such that the RA-Guard evasion vectors
   are eliminated.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-v6ops-ra-guard-implementation-03.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

This Internet-Draft can be retrieved at:
ftp://ftp.ietf.org/internet-drafts/draft-ietf-v6ops-ra-guard-implementation-03.txt

The IETF datatracker page for this Internet-Draft is:
https://datatracker.ietf.org/doc/draft-ietf-v6ops-ra-guard-implementation/

---

From: Fernando Gont <[email-masked]>
Date: Fri, 11 May 2012 16:00:04 -0300

Folks (Bjoern, James & Nick),

COuld youuuble-check/confirm that this version addresses the issues you
raised during the WGLC?

Thanks!

Best regards,
Fernando

On 05/11/2012 03:30 PM, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories. This draft is a work item of the IPv6 Operations Working
> Group of the IETF.
> 
> Title           : Implementation Advice for IPv6 Router Advertisement
> Guard (RA-Guard) Author(s)       : Fernando Gont Filename        :
> draft-ietf-v6ops-ra-guard-implementation-03.txt Pages           : 18 
> Date            : 2012-05-11
> 
>  _______________________________________________ v6ops mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/v6ops
> 

-- 
Fernando Gont
SI6 Networks
e-mail: [email-masked]
PGP Fingerprint: 6666 31C6 D484 63B2 8FB1 E3C4 AE25 0D55 1D4E 7492

---

From: Nick Hilliard <[email-masked]>
Date: Mon, 14 May 2012 17:53:43 +0100

> COuld youuuble-check/confirm that this version addresses the issues you

yep, looks good to me.

Nick

-- 
Network Ability Ltd. | Chief Technical Officer | Tel: +353 1 6169698
3 Westland Square    | INEX - Internet Neutral | Fax: +353 1 6041981
Dublin 2, Ireland    | Exchange Association    | Email: [email-masked]

---

From: "Bjoern A. Zeeb" <[email-masked]>
Date: Tue, 15 May 2012 06:27:04 +0000

On 11. May 2012, at 19:00 , Fernando Gont wrote:

Hi Fernando,

> COuld youuuble-check/confirm that this version addresses the issues you

I had done previously and just double checked.  I am fine with the current
version.  I am expecting this to help a lot.  Thanks a lot for the update!

Regards,
Bjoern

-- 
Bjoern A. Zeeb                                 You have to have visions!
   It does not matter how good you are. It matters what good you do!