Subject: Re: [v6ops] draft-ietf-v6ops-464xlat

From: Rémi Després <[email-masked]>
Date: Fri, 1 Jun 2012 09:51:17 +0200

Masataka-san,

 2012-05-29 21:13, jouni korhonen:
...
>  I do not think the text needs to explicitly state
> that the dedicated prefix model is for wireline service.

Same view.

> Just saying
> it applies for any service that utilizes DHCPv6-PD should suffice.

In my understanding:
- the Dedicated IPv6 prefix model (BTW still too imprecisely defined IMHO), can work with any way to advertise the chosen 4X4XLAT prefix. DHCPv6-PD can be for this a possibility, but still incompletely specified AFAIK if several prefixes are delegated.
- Wireline services that support DHCPv6-PD (which is typical) don't need to use the Dedicated prefix model to use 464XLAT. 

Regards,
RD

> 
> - Jouni
> 
>> 
>> This text is completely splitted by service applicability (moblie
>> and wireline). This is hard to cause some confusions in audiences
>> of 464XLAT document.
>> 
>> We really understood your thoughts, we can save operation and
>> deployment cost for IPv4 long-life support by using dedicated IPv6
>> prefix.
>> 
>> This is a antinomy between dedicated IPv6 prefix is required and
>> not required. We understood this. So we are thinking that we
>> would like to describe the 2 models.
>> 
>> 
>> Kind Regards,
>> Masataka MAWATARI
>> 
>> 
>> * On Sat, 19 May 2012 09:32:33 +0200
>> * Admin <[email-masked]> wrote:
>> 
>>> Masanobu-san,
>>> 
>>> Thank you for the explanation below.
>>> Formally, you are right: RFC6145 doesn't cover the case where there is only one IPv4 address on the IPv4 side, and where therefore a fixed IPv6 address, non IPv4 translated, can be used.
>>> 
>>> OTOH, RFC 6052 says, about Stateless translation "Both IPv4-translatable IPv6 addresses and IPv4-converted IPv6 addresses SHOULD use the same prefix". Using different IPv6 prefixes for customer-side and Internbet-side IPv4 addresses would introduce an exception to this rule, with the need to explain.
>>> 
>>> The IANA EUI-64 interface ID remains IMHO worth using, at least when CLAT nodes contain NAT44s.
>>> 
>>> Regards,
>>> RD
>> 
>> _______________________________________________
>> v6ops mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/v6ops
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops

---

From: MAWATARI Masataka <[email-masked]>
Date: Mon, 04 Jun 2012 09:46:55 +0900

Dear Remi-san and all,

Thank you very much for your responding.

We understood your thoughts.

We will revise 464XLAT document by clarifying texts about some sections
(overview, architecture, applicability, etc.) based on your helpful
comments.

We are thinking that no NAT44 model on edge model is one of the uniqueness.

Kind Regards,
Masataka MAWATARI

* On Fri, 1 Jun 2012 09:51:17 +0200
* Remi Despres <[email-masked]> wrote:

> ..

---

From: MAWATARI Masataka <[email-masked]>
Date: Mon, 04 Jun 2012 09:50:52 +0900

Dear Jouni-san,

Thank you very much for your comments.

As we responded earlier, we will revise for the better document.
Please wait next.

Kind Regards,
Masataka MAWATARI

* On Tue, 29 May 2012 22:13:29 +0300
* jouni korhonen <[email-masked]> wrote:

> Hi,
> 
> One comment below.
> 
> On May 29, 2012, at 7:50 AM, MAWATARI Masataka wrote:
> 
> > Dear Remi-san and all,
> > 
> > 
> > We appreciate your every comments about 464XLAT.
> > 
> > We will add that the CLAT on 464XLAT architecture does not comply
> > with "Both IPv4-translatable IPv6 addresses and IPv4-converted IPv6
> > addresses SHOULD use the same prefix." that is described on Section
> > 3.3. in RFC 6052.
> > 
> > And about document's category, we do not care about the document's
> > category as we have told once. The reason that we changed category
> > from Informational to BCP is due to v6ops chairs' suggestion. If
> > v6ops chairs say a request to change from BCP to Informational, we
> > will defer to that.
> > 
> > In case of keeping present category, although we don't know whether
> > you are going to like or not, we would like to propose you.
> > 
> > What do you think about splitting text of "no dedicated IPv6 prefix
> > model by using NAT44 with IANA's EUI-64 ID" for mobile service (3G,
> > LTE, etc.) that does not utilize DHCPv6-PD yet and "dedicated IPv6
> > prefix model" for wireline service that utilize DHCPv6-PD as a
> > convenient function.
> 
> For the latter I do not think the text needs to explicitly state
> that the dedicated prefix model is for wireline service. Just saying