Subject: [v6ops] New draft: draft-matthews-v6ops-design-guidelines-00.txt

From: Philip Matthews <[email-masked]>
Date: Fri, 29 Jun 2012 14:14:58 -0400

(Looks like my first attempt didn't make it for some reason, so I am resending. My apologies if you receive two copies.)

I have submitted a draft entitled "Design Guidelines for IPv6 Networks". The intent is to present some of the common design choices that come up when designing IPv6 networks, and document the pros and cons of the various possible solutions. These are questions like "Should I do eBGP peering with globals or link-locals?" that come up from time-to-time on mailing lists or *NOG presentations. The goal is to document them in one place, give fairly thorough discussion, and present a best-practice (if we can come to some agreement). 

The document is looking at both IPv6-only networks and mixed IPv4/IPv6 networks.  That is, a number of questions have to do with how IPv4 and IPv6 should or should not be mixed in a network.

The current version is very much a work-in-progress, with content in some areas, but TBDs in other areas.  Currently, I have put in content around point-to-point links, static routing, and eBGP routing. 

I have gotten some interesting feedback on a preliminary version from a couple of people, but want to see what others say before doing more work on the document.

I would be interested in hearing comment on both the general idea of the document, as well as comments on the current discussion areas and new discussion areas.

- Philip

Begin forwarded message:

> From: [email-masked]
> Date: June 29, 2012 9:46:43 EDT
> To: [email-masked]
> Subject: New Version Notification for draft-matthews-v6ops-design-guidelines-00.txt
> 
> 
> A new version of I-D, draft-matthews-v6ops-design-guidelines-00.txt
> has been successfully submitted by Philip Matthews and posted to the
> IETF repository.
> 
> Filename:	 draft-matthews-v6ops-design-guidelines
> Revision:	 00
> Title:		 Design Guidelines for IPv6 Networks
> Creation date:	 2012-06-29
> WG ID:		 Individual Submission
> Number of pages: 10
> URL:             http://www.ietf.org/internet-drafts/draft-matthews-v6ops-design-guidelines-00.txt
> Status:          http://datatracker.ietf.org/doc/draft-matthews-v6ops-design-guidelines
> Htmlized:        http://tools.ietf.org/html/draft-matthews-v6ops-design-guidelines-00
> 
> 
> Abstract:
>   This document presents advice on the design choices that arise when
>   designing IPv6 networks (both dual-stack and IPv6-only).  The
>   intended audience is someone designing an IPv6 network who is
>   knowledgeable about best current practices around IPv4 network
>   design, and wishes to learn the corresponding practices for IPv6.
> 
> 
> 
> 
> The IETF Secretariat
>

---

From: Randy Bush <[email-masked]>
Date: Fri, 29 Jun 2012 14:38:59 -1000

>> Htmlized:        http://tools.ietf.org/html/draft-matthews-v6ops-design-guidelines-00

i read this document prepared to laugh and/or puke.  i was pleasantly
surprised.  this is generally quite good advice without getting
religious, and a darned good start.  congrats!

randy

---

From: Tina TSOU <[email-masked]>
Date: Sat, 30 Jun 2012 01:20:09 +0000

8.  OSPF

   (TBD)

I used basic OSPFv3 functionalities in IPv6 at my enterprise. Nothing special was found.

Tina
@ 2001:db8:1:ffff:e8e2:7822:9d12:e12e

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Randy Bush
> Sent: Friday, June 29, 2012 5:39 PM
> To: Philip Matthews
> Cc: IETF v6ops list
> Subject: Re: [v6ops] New draft: draft-matthews-v6ops-design-guidelines-
> 00.txt
> 
> _______________________________________________
> v6ops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/v6ops